Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Native VLAN Verständnisproblem

Frage Netzwerke Netzwerkgrundlagen

Mitglied: cz3kit

cz3kit (Level 1) - Jetzt verbinden

08.04.2012, aktualisiert 18.10.2012, 21479 Aufrufe, 14 Kommentare

Hallo zusammen, ich lerne gerade für mein Abitur, dass in 2 Wochen ist. Ich lerne gerade zum Thema VLAN und bin beim Native VLAN angekommen.

Ich hab ein Problem zu verstehen wozu ein Native VLAN gut ist. Ich sitze hier seit längerer Zeit mit dem Packet Tracer von Cisco und versuche den Sinn eines Native VLANs zu verstehen. Ich würde aber zuerst Fragen ob meine Information zum Native VLAN an sich richtig ist.

Ein Native VLAN wird verwendet, um Paketen, die keinem VLAN zugeordnet werden können, eine Möglichkeit zu geben, über den Trunk Link transportiert zu werden. Das Paket wird dem Native VLAN zu geordnet, wird aber ungetagged über den Trunk versendet. Außerdem soll es Rückwärtskompatibilität gewährleisten.

Ist das soweit richtig?

Nun zu meiner zweiten Frage. Ich habe mir ein kleines Netzwerk im Packet Tracer nachgebaut. Dort habe ich 3 Switche, zwischen diesen ist ein Trunk mit dem Native VLAN 99, und 4 PC. Zwei der PCs gehören zu einem VLAN. Diese habe ich an einen Access Port angeschlossen, der zum VLAN 20 gehört. Als ich mir die Pakete genauer angesehen habe, habe ich gesehen, dass diese getagged waren, was ja auch so sein soll.
Die anderen zwei PCs habe ich einfach an die Switche angeschlossen. Genau wie bei den anderen zwei, habe ich auch mir hier die Pakete genauer angesehen und musste feststellen, dass diese ebenfalls getagged waren. Als ich die Access Port zum VLAN 99 hinzugefügt habe, waren die Pakete ungetagged.

Meine Frage ist jetzt: Welchen Sinn hat es, wenn ich über einen Trunk ungetaggte Pakete verschicke, obwohl die Switch Ports einem VLAN angehören?

Ein großes Danke im Vorraus und noch frohe Ostern

cz3kit
Mitglied: danielfr
08.04.2012 um 20:21 Uhr
Hi, so wie ich das immer verstanden habe ist das für Geräte, die eben nicht getaggten Paketen umgehen können oder nicht entsprechend konfiguriert sind. Die gehören dann zum native VLAN und werden dann eben auch über den Trunk Port mit gesendet, da ja auch an einem weiteren Switch Geräte in ebendiesem VLAN sein können.
Falls ich das jetzt nicht richtig gepeilt habe beschreibe das Problem doch mal etwas genauer, evtl. mit einem Screenshot und den Config Files.
Genauer auch:
https://learningnetwork.cisco.com/thread/7582
http://en.wikipedia.org/wiki/IEEE_802.1Q#Trunk_ports_and_the_native_VLA ...
Gruß
Bitte warten ..
Mitglied: cz3kit
08.04.2012 um 21:23 Uhr
Hi, danke schonmal für die Antwort. Ich habe hier nochmal ein Bild rangehängt.

PC 1 kann PC 3 pingen.
PC 2 kann PC 4 pingen.
Also alles wunderbar. Das Paket von PC 2 und PC 4 ist nach 802.1Q getagged und das von PC 1 und PC 3 ist nicht getagged.
Warum es getagged ist, verstehe ich ja noch, aber ich kann nicht nachvollziehen, warum das von PC 1 und PC 3 ungetagged bleibt.

Kann man den einen Port in den Trunk Mode versetzen, wenn der gegenüberliegende Switch VLANs nicht unterstützt?

Irgendwie kann ich das nicht ganz nachvollziehen, warum es ungetagged bleibt.

Wenn du mir das erklären könntest, wäre ich dir sehr dankbar.

Grüße

cz3kit


Hier das Bild: http://s1.directupload.net/file/d/2854/oxz4ffaz_png.htm
Bitte warten ..
Mitglied: danielfr
08.04.2012 um 21:39 Uhr
Benutze besser die administrator.de Bilderfunktion, so ist das etwas nervig.
Warum ist VLAN 99 nativ?
Schick mal das Config File von Switch 1.
edit: warum es nicht getagged ist steht übrigens in einem der Links
Bitte warten ..
Mitglied: cz3kit
08.04.2012 um 21:53 Uhr
Zitat von danielfr:
Benutze besser die administrator.de Bilderfunktion, so ist das etwas nervig.
Ups, sorry.
Warum ist VLAN 99 nativ?
Das ist jetzt nur ein Beispiel. Ich hätte genauso gut 20 oder 50 nehmen können. Oder möchtest du dich auf etwas spezielles beziehen?
Schick mal das Config File von Switch 1.
Hier die Config

Current configuration : 1167 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 99
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

edit: warum es nicht getagged ist steht übrigens in einem der Links
Echt? Hab ich das jetzt überlesen? Ich schau nochmal in die Links rein.
Bitte warten ..
Mitglied: danielfr
08.04.2012 um 22:18 Uhr
Normalerweise ist Vlan 1 auf den Ciscos das native VLan. Die Pakete werden halt nicht getagged, weil Du das so konfiguiert hast, mit:
switchport trunk native vlan 99
Und diese Pakete werden dann halt auch untagged übers Trunk geschickt... das ist eigentlich schon alles. Ich würde da keinen tieferen Sinn drin sehen, bei VLans sollte man imho immer die tagged Variante wählen, in dem Buch das ich über CCNA habe (CCNA Study Guide v. Todd Lammle) wird das nicht einmal näher erläutert, und ich hatte dazu auch keine Frage in der Prüfung .
Bitte warten ..
Mitglied: cz3kit
08.04.2012 um 22:25 Uhr
Oke, dann werde ich mich damit abfinden... Schade, ich finds aber einfach immer geil, den Sinn dahinter zu verstehen :P

Ich danke dir für deine Hilfe, hast mir damit auf jeden Fall weitergeholfen.

Schönen Abend noch
Bitte warten ..
Mitglied: danielfr
08.04.2012 um 22:30 Uhr
Naja, ein Sinn kann sein irgendeinen Billigswitch an das native "VLan" anzuschliessen, damit der auch mit den anderen Switchen kommunizieren kann. Wie gesagt, VLan1 ist ja normalerweise auch nativ.
cu
Bitte warten ..
Mitglied: MrNetman
09.04.2012 um 02:26 Uhr
Na, klar hat es einen Sinn ungetaggte Pakete anzunehmen.

Stell dir vor du musst schnell einen Switch austauschen. Der ist noch nicht komplett konfiguriert. Ohne diese Funktion kann man den aus dem Netz nicht erreichen und nicht fertig konfigurieren.
Außerdem werden einige Protokolle VLAN-mäßig getrennt ver- und bearbeitet. STP, RSTP und CDP.
Oder es werden Ports von Telefon und PC gemeinsam genutzt. Der PC bekommt die ungetaggten und das Telefon die getaggten Pakete.

Gruß
Netman
Bitte warten ..
Mitglied: cz3kit
09.04.2012 um 13:54 Uhr
Danke, die Erklärung ist gut. Damit wird meine Frage gut erklärt.

Danke
Bitte warten ..
Mitglied: aqui
09.04.2012 um 15:00 Uhr
Sehr sehr fortschrittliche Schule wo LAN Netzwerk Infrastruktur und VLANs ein Abitur Thema ist...Respekt ! In der Regel nehmen heutige Lehrer bei solchen Themen ja eher Reissaus weil sie davon keinen Schimmer haben....
Als Abiturient hat man ja eigentlich auch zu recherchieren gelernt. Der VLAN Standard wird im IEEE Dokument 802.1q beschrieben:
http://de.wikipedia.org/wiki/IEEE_802.1q
An diesen weltweiten Standard müssen sich also alle Hersteller halten. Der .1q Standard schreibt vor das ungetaggte Pakete ohne ein führende VLAN ID im Ethernet Header an einem Trunk Port ins default VLAN geforwardet werden. Dort hättest du also die ganz genaue Erklärung für das Verhalten.
Es halten sich aber (wie so oft) nicht alle Hersteller an diese Norm, da, wenn man das IEEE .1q Papier etwas liberaler auslegt, das auch nur eine Empfehlung ist und keinen strikte Vorschrift.
Andere Hersteller wie Brocade, Juniper usw. forwarden generell nichts ungetaggtes auf Trunk Ports ohne eine entsprechende Konfiguration auf den Geräten.
Es gibt also sehr wohl erhebliche Unterschiede in der Handhabung der 802.1q Norm, was du allerdings als bekennender Cisco Knecht, der nur diese Welt derzeit kennt, nicht sehen kannst ohne Geräte anderer Hersteller.
"Native VLAN" bezeichnet also immer Traffic ohne eine identifizierende VLAN ID, also gewissermassen nackten Ethernet Traffic, den man in einem VLAN Umfeld nicht genau einem VLAN zuordnen kann.
Da nicht in allen Szenarien man untagged Traffic im default VLAN haben will, kann man mit dem "native VLAN" Kommando, das bei anderen Herstellern "dual mode x" usw. heisst in ein entsprechendes VLAN forwarden.
Es wird zudem auch benutzt für globale Kommunikation der STP, MSTP oder auch PV(R)STP Prozess. Auch GVRP nutzt das native VLAN zum Propagieren von dynamischen VLAN Informationen in einem Netz unter anderem. Nimm einen Wireshark Sniffer und trace es mal mit, dann siehst du es schwarz auf weiss !
Nichts anderes steckt dahinter !
Fazit: Dokumentationen lesen und einmal über den Hersteller Tellerrand schauen um den Wissenshorizont zu erweitern ! Nichts anderes hast du doch die letzten Jahre auch gemacht, oder ??


Wenns das denn war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: cz3kit
09.04.2012 um 15:25 Uhr
Zitat von aqui:
Sehr sehr fortschrittliche Schule wo LAN Netzwerk Infrastruktur und VLANs ein Abitur Thema ist...Respekt ! In der Regel nehmen
heutige Lehrer bei solchen Themen ja eher Reissaus weil sie davon keinen Schimmer haben....
Joa, neben dem Abitur auch noch eine schulische Ausbildung.
Als Abiturient hat man ja eigentlich auch zu recherchieren gelernt. Der VLAN Standard wird im IEEE Dokument 802.1q beschrieben:
http://de.wikipedia.org/wiki/IEEE_802.1q
An diesen weltweiten Standard müssen sich also alle Hersteller halten. Der .1q Standard schreibt vor das ungetaggte Pakete
ohne ein führende VLAN ID im Ethernet Header an einem Trunk Port ins default VLAN geforwardet werden. Dort hättest du
also die ganz genaue Erklärung für das Verhalten.
Es halten sich aber (wie so oft) nicht alle Hersteller an diese Norm, da, wenn man das IEEE .1q Papier etwas liberaler auslegt,
das auch nur eine Empfehlung ist und keinen strikte Vorschrift.
Andere Hersteller wie Brocade, Juniper usw. forwarden generell nichts ungetaggtes auf Trunk Ports ohne eine entsprechende
Konfiguration auf den Geräten.
Es gibt also sehr wohl erhebliche Unterschiede in der Handhabung der 802.1q Norm, was du allerdings als bekennender Cisco Knecht,
der nur diese Welt derzeit kennt, nicht sehen kannst ohne Geräte anderer Hersteller.
Leider.... Ich wünsche mir ja manchmal im Packet Tracer noch andere Geräte, damit man sich das mal ansehen kann, aber naja...
"Native VLAN" bezeichnet also immer Traffic ohne eine identifizierende VLAN ID, also gewissermassen nackten Ethernet
Traffic, den man in einem VLAN Umfeld nicht genau einem VLAN zuordnen kann.
Da nicht in allen Szenarien man untagged Traffic im default VLAN haben will, kann man mit dem "native VLAN" Kommando,
das bei anderen Herstellern "dual mode x" usw. heisst in ein entsprechendes VLAN forwarden.
Es wird zudem auch benutzt für globale Kommunikation der STP, MSTP oder auch PV(R)STP Prozess. Auch GVRP nutzt das native
VLAN zum Propagieren von dynamischen VLAN Informationen in einem Netz unter anderem. Nimm einen Wireshark Sniffer und trace es mal
mit, dann siehst du es schwarz auf weiss !
Nichts anderes steckt dahinter !
Fazit: Dokumentationen lesen und einmal über den Hersteller Tellerrand schauen um den Wissenshorizont zu erweitern ! Nichts
anderes hast du doch die letzten Jahre auch gemacht, oder ??
Ist manchmal leiter gesagt, als getan als Schüler. In den Dokus kann vieles stehen, aber so ein Gerät zu haben ist doch schon was tolles :P


Wenns das denn war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !


Ich danke dir für deine Ausführliche Beschreibung.
Bitte warten ..
Mitglied: aqui
10.04.2012, aktualisiert 18.10.2012
.. ."aber so ein Gerät zu haben ist doch schon was tolles" Bei eBay kann man für kleines Geld sowas "schiessen". Oder mal bei Firmen oder Systemhäusern fragen wenn die Hardware verschrotten.
Kleine Geräte wie ein Mikrotik 750 usw. bietet sowas schon für simple 30 Euro und das noch mit allen erdenklichen Routing Protokollen also die komplette WAN Welt auch noch zur Switchwelt dazu !! Mit einen billigen Cisco SG-200-8 hast du dann schon ein kleines Mini Labor wo man selber mal stecken, messen und experimentieren kann.
http://www.administrator.de/wissen/mikrotik-rb750-quick-review-124700.h ...
Es ist also nicht nur "toll" solche HW zu haben sondern auch ganz einfach und auch noch mit Schüler Taschengeld zu realisieren wie du am Mikrotik sehen kannst.
Tools wie Quagga für Linux und OpenWRT komplettieren das dann für ein "Schüler Labor" mit Mini Etat.
Das ist allemal besser als so ein theoretischer Mist mit "Packet Tracer" und anderen Hersteller proprietären Produkten. Da wird man nur (gewollt) betriebsblind und der Zweck solcher Tools ist klar...wie man ansatzweise bei dir ja schon sehen kann. Mit dem richtigen "Netzwerk" Leben hat das nichts zu tun.
Der Physikunterricht wird ja auch nicht nur von BMW mit Filmen ohne jegliche Hands on und Hardware gemacht bei euch...oder ?!
Selbstinitiative, selber was machen und über den Tellerrand schauen ist also angesagt... gerade bei einer Schule !!
Weisst du als angehender Abiturient ja sicher selber am besten....?!
Bitte warten ..
Mitglied: cz3kit
10.04.2012, aktualisiert 18.10.2012
Zitat von aqui:
.. ."aber so ein Gerät zu haben ist doch schon was tolles" Bei eBay kann man für kleines Geld sowas
"schiessen". Oder mal bei Firmen oder Systemhäusern fragen wenn die Hardware verschrotten.
Kleine Geräte wie ein Mikrotik 750 usw. bietet sowas schon für simple 30 Euro und das noch mit allen erdenklichen
Routing Protokollen also die komplette WAN Welt auch noch zur Switchwelt dazu !! Mit einen billigen Cisco SG-200-8 hast du dann
schon ein kleines Mini Labor wo man selber mal stecken, messen und experimentieren kann.
http://www.administrator.de/wissen/mikrotik-rb750-quick-review-124700.h ...
Danke für den Link, ich wusste far nicht das es sowas gibt und das auch noch zu solchen Preisen. Cool, damit kann ich echt was anstellen
Es ist also nicht nur "toll" solche HW zu haben sondern auch ganz einfach und auch noch mit Schüler Taschengeld zu
realisieren wie du am Mikrotik sehen kannst.
Tools wie Quagga für Linux und OpenWRT komplettieren das dann für ein "Schüler Labor" mit Mini Etat.
Das ist allemal besser als so ein theoretischer Mist mit "Packet Tracer" und anderen Hersteller proprietären
Produkten. Da wird man nur (gewollt) betriebsblind und der Zweck solcher Tools ist klar...wie man ansatzweise bei dir ja schon
sehen kann. Mit dem richtigen "Netzwerk" Leben hat das nichts zu tun.
Der Physikunterricht wird ja auch nicht nur von BMW mit Filmen ohne jegliche Hands on und Hardware gemacht bei euch...oder ?!
Selbstinitiative, selber was machen und über den Tellerrand schauen ist also angesagt... gerade bei einer Schule !!
Weisst du als angehender Abiturient ja sicher selber am besten....?!
Physik ist bei uns nur ein Grundkurs, also nichts großes. Aber da man an unserer Schule das CCNA erwerben kann, gibt es auch ein Labor, jedoch mit Cisco Switchen ausgestattet. Aber es ist nun mal eine Schule und da kann man nicht einfach rein, das sind so die Probleme die damit einhergehen. Dieses Mikrotik gefällt mir, das werde ich mir mal genauer ansehen Aber erst nach dem Abi, in einer Woche gehts los...

Danke
Bitte warten ..
Mitglied: aqui
10.04.2012 um 13:18 Uhr
.. ."ich wusste far nicht das es sowas gibt und das auch noch zu solchen Preisen.." Da kannst du mal sehen was die Cisco SW (gewollt) anrichtet !!
.. ."da man an unserer Schule das CCNA erwerben kann" ...klar damit du nachher im Beruf oder Uni auch immer das richtige Produkt kaufst, denn bringen tut einem das im Endeffekt nix !
Du hast vermutlich jetzt das Prinzip was hinter solcher SW steht nun verstanden.... ?!
Wehret den Anfängen.... Also dann mal los mit dem Mikrotik..... Für knifflige Fragen dazu gibts ja Administrator.de
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Linux Netzwerk
OpenVPN, zwei OpenWRT Router verbinden und VLAN durchs VPN leiten (6)

Frage von sharbich zum Thema Linux Netzwerk ...

Switche und Hubs
gelöst VLAN fähiger VPN Router gesucht (33)

Frage von Leo-le zum Thema Switche und Hubs ...

Hardware
Banana Pi M2 Ultra: Bastelrechner bietet native SATA-Unterstützung

Link von runasservice zum Thema Hardware ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...