Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

NET USE LPTx unter W7 geht nicht?

Frage Microsoft

Mitglied: mgr049

mgr049 (Level 1) - Jetzt verbinden

04.02.2010 um 15:43 Uhr, 6313 Aufrufe, 2 Kommentare

Hallo zusammen,

ich scheitere seit Tagen an der Aufgabe, unter W7-Prof mit aktivierter UAC als Halb-Admin (Mitglied der Administratoren-Gruppe) per "print /D:LPTx datei" etwas auf einem Netzwerkdrucker auszugeben. Der Drucker ist unter dem Namen \\computername\druckername geshared. Das Share soll mit "net use LPTx \\computername\druckername" zugewiesen werden. Das Kommando wird abgewiesen mit der Meldung "Systemfehler 5 aufgetreten, Zugriff verweigert", auch wenn es in der erweiterten Form "net use LPTx \\computername\druckername admipasswort /U:Administrator" eingegeben wird. Unter XP hat das alles noch funktioniert...

Das Net-Use-Kommando wird akzeptiert, wenn man es von einer Kommandozeile aus aufruft, die z.B. per "runas /savecred /U:Administrator cmd" gestartet wurde. Dann ist LPTx allerdings nur für den User Administrator verfügbar, nicht aber für den Halb-Admin, der das Runas-Kommando abgesetzt hat. Daran ändert sich nichts, wenn unter HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System der Wert EnableLinkedConnections auf 1 gesetzt wird.

Unter Vista soll "net use LPTx ..." prinzipiell nicht funktioniert haben, aber Vista habe ich übersprungen. Weiß jemand, ob das Problem nach W7 portiert wurde oder ob es eine Umgehungsmöglichkeit gibt, die in Batch-Prozeduren eingebaut werden kann, ohne UAC abzuschalten?

mfg mgr
Mitglied: oagkbln
04.02.2010 um 16:45 Uhr
hallo,

ich hatte ein ähnliches problem und habe mir am ende damit behelfen müssen einen printerserver einzusetzen. net use lptx \\rechner\drucker von w7 auf einen unter w7 freigegebenen drucker und die nutzung in programmen auf lptx führte nur bei einer warenwirtschaft nicht zum gewünschten erfolg, jegliche andere "uralt software" lief anstandslos. also kann ich damit aussagen, dass net use lpt unter w7 auch bei eigeschalteter uac funktioniert, selbst sowas simples wie dir c:\ >lpt1:



ich habe dann mal im hintergrund einen processmonitor aus den sysinternals laufen lassen und stellte fest., dass es sich offenbar um ein problem in der wws handelte. "name not found" und infolge dessen auch kein ausdruck.

unter vista gab es einige probleme mit lpt1 wenn du kein "volladmin" warst, unter w7 ist das problem eigentlich behoben. aber du kannst ja zu sicherheit lpt2 bis lptx nehmen.

sind die rechner denn in der gleichen workgroup/domain/heimnetz und wie sind die berechtigungen auf den drucjer gesetzt ?

gruß o
Bitte warten ..
Mitglied: mgr049
04.02.2010 um 17:52 Uhr
Hallo oagkbln, ich muss leider zugeben, dass ich im Titel der Frage nicht LPTx hätte schreiben dürfen

Ich bin nicht auf die Idee gekommen, dass - obwohl kein lokaler Drucker angeschlossen ist - LPT1 sich anders verhalten könnte als LPT2. Ist aber so, mit LPT2 tritt das Problem nicht auf. Mit LPT2 ist es auch egal, ob UAC an ist oder aus, NET USE funktioniert ohne Angabe von Userid/Passwort, und nun die Krönung: man muss nicht mal Halb-Admin sein, es reichen auch normale User-Rechte.

Nur der Vollständigkeit halber: es handelt sich um eine kleine Arbeitsgruppe, alles mit festen IP-Adressen, Druckerberechtigung "jeder darf alles".

Vielen Dank für die schnelle Hilfe, ich setze den Beitrag auf "gelöst". mfg mgr
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

VB for Applications
VB.net Combobox databinding langsam (4)

Frage von ForgottenRealm zum Thema VB for Applications ...

Weiterbildung
Cebit 2017 - Geht ihr hin ? (7)

Frage von AveiroCR7 zum Thema Weiterbildung ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(3)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Off Topic
gelöst Fachzeitschriften als E-Book oder hardcoded? (11)

Frage von KowaKowalski zum Thema Off Topic ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...