Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

NET USE während shutdown?

Frage Microsoft Windows Netzwerk

Mitglied: Ministry

Ministry (Level 1) - Jetzt verbinden

04.06.2010 um 10:22 Uhr, 6230 Aufrufe, 16 Kommentare

Hallo, ich versuche ein Backup-Script während des Shutdowns auf einem XP-Client einzusetzen.

Das Script läuft manuell ausgeführt einwandfrei, jedoch kann ich scheinbar keine Netzlaufwerke während des Shutdowns anlegen?
Über die Gruppenrichtlinien als Shutdown-Script eingesetzt funktioniert
01.
net use X: \\IP\Freigabe /user:Benutzer pwd /persistent:no
scheinbar nicht.
Gibt es generell keinen Zugriff mehr auf das Netzwerk beim Shutdown, oder liegt mein Fehler wo anders?

Danke im Vorraus.
Mitglied: ebfrb1
04.06.2010 um 10:31 Uhr
Das Skript so wie es da steht sollte funktionieren....Wie lautet denn das gesamte Skript für das Backup? Vlt liegt ja da der Fehler?

Problem könnte sein, dass beim Shutdown die Netzwerkverbindung mit als erstes getrennt wird...dann ist natürlich kein net use mehr möglich...

man müsste das skript mal sehen...
Bitte warten ..
Mitglied: Karo
04.06.2010 um 10:31 Uhr
hmm, ich sehe jetzt zwar den Sinn dieser Aktion nicht so ganz, gerade weil Du Persistent:NO angibst.
Das bedeutet, das dieses LW nur einmalig verbunden wird. Bei YES wird es immer verbunden.

Karo
Bitte warten ..
Mitglied: Ministry
04.06.2010 um 10:47 Uhr
Das Problem liegt in jedem Fall in der Verbindung des Netzlaufwerks.
Weiter oben wird nur Datum und Wochentag ermittelt und ein paar Variablen festgelegt.
Nach dem NET USE:
01.
net use X: \\IP\Freigabe /user:Benutzer pwd /persistent:no 
02.
if %errorlevel% EQU 0 ( 
03.
>C:\BLog.txt echo Netzlaufwerk verbunden 
04.
) else ( 
05.
>C:\Blog.txt echo Verbindung zum NAS fehlgeschlagen 
06.
exit /b 
07.
)
Edit: Und weiter komme ich auch nicht.
Bitte warten ..
Mitglied: Ministry
04.06.2010 um 10:50 Uhr
Persistent:no ist doch absicht.
Das Laufwerk wird für das backup verbunden und direkt hinterher wieder getrennt.
Der User soll ja keine Zugriff auf das Laufwerk haben, ausser wenn er den rechner runter fährt.

P.S. kann man nur jedem einzelnd antworten?
Bitte warten ..
Mitglied: ebfrb1
04.06.2010 um 11:02 Uhr
versuch mal das skript als logoff skript zu verwenden und binde am ende den shutdown befehl ein. ich denke das sollte funktionieren...es liegt meines erachtens an der trennung der netzwerkverbindung.
Bitte warten ..
Mitglied: Karo
04.06.2010 um 11:04 Uhr
Warum machst Du überhaupt ne Netzwerkverbindung wenn der User das LW nicht sehen soll. Du kannst doch auch direkt auf die Freigabe schreiben.

Wenn es darum geht, dass Du beim Abmelden geänderte Daten sichern willst, dann gibt es das wundervolle ROBOCOPY, das in den neueren Versionen eine Monitorfunktion besitzt, die nach vordefinierten Schaltern Änderungen erkennt und kopiert.

Ansonsten zu Deiner Batch:
>C:\BLog.txt echo Netzlaufwerk verbunden
bedeutet Du willst denn Text 'Netzlaufwerk verbunden' nach C:\BLog.txt schreiben?
Das sollte dann aber so aussehen
echo Netzlaufwerk verbunden >C:\BLog.txt

Karo
Bitte warten ..
Mitglied: Karo
04.06.2010 um 11:06 Uhr
hm, Du willst also ein Shutdown im Shutdown machen?
Bitte warten ..
Mitglied: Ministry
04.06.2010 um 11:37 Uhr
Als logoff-Script funktioniert es.
Jetzt hab ich das aber natürlich bei jedem Benutzerwechsel.
Ist nur die Frage, kann man überhaupt auf das Netzwerk zugreifen, während des Shutdowns?
Ein Ping scheint zu gehen, ansonsten?
Bitte warten ..
Mitglied: Ministry
04.06.2010 um 11:42 Uhr
Wie schreibe ich denn direkt auf eine passwortgeschützte Freigabe...ohne dass ich zuerst ein Netzlaufwerk verbinde?

Und meine Umleitung in die Textdatei funktioniert .
Die Reihenfolge ist egal. Ich finds leichter zu lesen so, da der "text" ja in der länge öfters variiert.
Bitte warten ..
Mitglied: Karo
04.06.2010 um 11:54 Uhr
Sorry, falsch ausgedrückt. Hätte heissen sollen: Du kannst auch ein NET USE direkt auf die Freigabe machen ohne LW also
net use \\IP\Freigabe /user:Benutzer pwd /persistent:no
Versuch es mal damit

Ja ich weiss das das mit dem Pipe so geht. Allerdings hatte ich da mal Ärger mit. War irgendwas in Verbbindung mit ner VBS. Darum gehe ich immer den Standard.
Bitte warten ..
Mitglied: Karo
04.06.2010 um 11:58 Uhr
Eigentlich ist es per Definition nicht möglich. Den während des Abmeldens werden spezifische Dienste runtergefahren. TCPIP Connection ist eines der letzten. Darum geht der Ping. Den Effekt siehst Du z.B. auch, wenn Du Shutdown machst, und versuchst den Explorer zu öffnen.
Wenn Du es wirklich nicht per User machen willst würde ich mir an Deiner Stelle wiklich mal Robocopy anschauen.

Karo
Bitte warten ..
Mitglied: Ministry
04.06.2010 um 13:31 Uhr
Funktioniert.
Allerdings (scheinbar logischerweise) nicht beim Shutdown.
Ich denke, ich werde damit leben müssen, dass bei logoff zu machen.
Inkrementelles Backup dauert zum Glück nicht sooo lang.
Am längsten dauert es immer noch, die Filelist zu erstellen. ;)

Bei Gelegenheit guck ich mir dann auch nochmal robocopy an.
Bitte warten ..
Mitglied: DerWoWusste
04.06.2010 um 17:48 Uhr
Hi.
Wie schreibe ich denn direkt auf eine passwortgeschützte Freigabe...ohne dass ich zuerst ein Netzlaufwerk verbinde?
Ein Shutdownskript ist in der Lage auf dem Netzwerk zu handeln (@Karo: Die Definition, die Gegenteiliges behauptet, würde ich gerne mal sehen ;) und zwar als Konto System (=Domänencomputer-Mitglied=Computername$)
Du kannst auf der Freigabe beispielsweise Ändernzugriff für die Gruppe Domänencomputer geben und die Sache läuft.

Nebenbei: Du schreibst:
Der User soll ja keine Zugriff auf das Laufwerk haben, ausser wenn er den rechner runter fährt.
Wenn Du ein LW unter Angabe eines Benutzernamens außerhalb der Usersession verbindest (nämlich beim Shutdown, welcher nach der Abmeldung aller User erfolgt), so hat kein Benutzer darauf Zugriff, ein Trennen ist unnötig.
Bitte warten ..
Mitglied: Karo
04.06.2010 um 18:05 Uhr
Hi,
mit der Aussage hast Du schon Recht, aber man sollte auch das dahinter lesen. Denn wenn das System runtergefahren wird, wird ab einem gewissen Punkt die Session gekillt. Und wo keine Brücke, da kein Übergang Insofern ist vielleicht der Begriff 'Definition' von mir nicht korrekt gewählt. Zudem habe ich selbst von Microsofties die Aussage mit Logoff-Skripten vorsichtig zu hantieren um Abbrüche zu verhindern.
Gleich allen Domänen-Computern den Zugriff zuzulassen ist sicherlich eine Lösung, aber vielleicht nicht so gewollt. Hier fehlt die eine oder andere kleine Info. Aber wir kommen schon alle irgendwie ans Ziel

Karo
Bitte warten ..
Mitglied: DerWoWusste
07.06.2010 um 09:54 Uhr
Moin Karo.
Denn wenn das System runtergefahren wird, wird ab einem gewissen Punkt die Session gekillt.
Das stimmt, nur darf man nicht die Usersession mit der generellen Netzwerkverfügbarkeit verwechseln, die ist bis zum Schluss da, siehe http://blogs.technet.com/b/richard_macdonald/archive/2007/03/26/706879. ...
Nämlich bis es heißt "Windows is shutting down..." - dann erst werden die Dienste gestoppt, die benötigt werden. Ebenso darf ein Shutdownskript beliebig lange dauern, soweit ich weiß. Ich will nicht sagen, dass MS Dir Mist erzählt hat, aber vielleicht war es missverständlich.
Bitte warten ..
Mitglied: mad-manne
18.09.2012 um 15:02 Uhr
Hallo und sorry, dass ich dieses alte Thema hervorkrame ... aber viel habe ich zu diesem Thema nicht gefunden, als ich gestern und heute fast 10 Stunden zu diesem Thema gegoogelt und rumprobiert habe ... umsomehr will ich dann doch mein Lösung loswerden

Nach diversen Tests komme ich nun nämlich zu folgendem Ergebniss:
Der "net use"-Befehl verhält sich offenbar innerhalb eines Shutdown-Skripts nicht exakt so, wie in einem Logoff-Skript bzw. beim Testen während des "normalen" Betriebs!
Dazu hatte ich per GPO erlaubt, dass meine Shutdown/Logoff-Skripte zu sehen sind und dort dann noch "Haltepunkte" eingebaut um überhaupt Zeit zu haben um zu sehen, wo das Problem liegt ...

Unter anderem habe ich zwischendurch einfach mal das Kennwort weggelassen um es dann interaktiv eingeben zu müssen: und siehe da, dann klappte die Verbindung.

Da dies natürlich kein gangbarer Weg ist, habe ich weiter und weiter getestet. Offenbar muss man nur die Syntax des net use-Befehls so ändern, dass das Kennwort das letzte ist, was in der Befehlszeile steht ... dann klappt es auch bei einem Shutdown-Skript!

So sieht das bei mir jetzt aus:
net use \\servername\sharename /persistent:no /user:username password
Da ich in robocopy den direkten Pfad eintrage nutze ich gar keinen Laufwerskbuchstaben, aber es geht auch mit einem LW-Buchstaben!

Ich hoffe irgendjemand kann mit dieser Info was anfangen ...
Gruss,
Manne.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows 7
Net use Befehl -Eingabe ungültig nach System-Neustart (8)

Frage von lderigo zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...