Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Net use auf W2K8 Server

Frage Microsoft Windows Server

Mitglied: lotus

lotus (Level 1) - Jetzt verbinden

16.09.2009 um 10:49 Uhr, 7464 Aufrufe, 8 Kommentare

Wo leg ich den script an?

hallo Admins

ich habe 1 Server und ein NAS.
Muss vom NAS auf den Server ein Netzlaufwerk verbinden mit net use.
Frage: Wo lege ich den script an?

Unter gpedit.msc Compterkonfiguration/Windows-Einstellungen/Scripts/Starten
oder
Unter gpedit.msc Benutzerkonfiguration/Windows-Einstellungen/Scripts/Anmelden

Das ganze sieht so aus:

Computerkonfiguration:
C:\Windows\System32\GroupPolicy\Machine\Scripts\Startup
oder
Benutzerkonfiguration:
C:\Windows\System32\GroupPolicy\User\Scripts\Logon

script:
net use L: \\IP\test Kennwort /user:User /persistent:no

Kann mir da jemand den Unterschied vielleicht noch erklären? Nach meiner logik sage ich doch bei Computerkonfiguration einfach:" Wenn die Maschiene startet dann soll sich das Netzlaufwerk verbinden es ist gleich wer sich anmeldet. Bei einem Server ist eh der Admin.


Gruss und Danke

lotus
Mitglied: runcmd
16.09.2009 um 12:03 Uhr
hallo,

deine logik passt.

Computerkonfiguration:
C:\Windows\System32\GroupPolicy\Machine\Scripts\Startup
= script wird ausgeführt, wenn maschine hochfährt

Benutzerkonfiguration:
C:\Windows\System32\GroupPolicy\User\Scripts\Logon
=skript wird ausgeführt, wenn jemand sich anmeldet

grüße
Bitte warten ..
Mitglied: lotus
16.09.2009 um 17:34 Uhr
hallo

ja das ist gut.

Das Problem ist nur das der batch über die Computerkonfiguration nicht geht. Die Netzlaufwerke werden zwar angezeigt sind aber alle getrennt. Ich habe auch spezifisch gesagt man soll zuerst auf das Netzwerk warten bevor die scripts laufen aber das macht das System scheinbar nicht.

Gruss
lotus
Bitte warten ..
Mitglied: 60730
16.09.2009 um 17:44 Uhr
Servus,

deine Logik passt zwar, hat aber eine Lücke...

Wenn der Computer das Laufwerk mappt - sieht das gemappte Laufwerk?

Rischdisch - der Computer und nicht der User, der evtl. irgendwann davor sitzt.

Ergo - braucht ein Script/Job das Laufwerk - beim Computer eintragen
Brauchts der User, der eigentlich nie vorm Server sitzen sollte - dann der User.

Gruß
Bitte warten ..
Mitglied: runcmd
16.09.2009 um 18:24 Uhr
sorry dr.house,

leider kann ich nur fühlen was du gemeint hast, semantisch verstehen nicht so ganz. du hast wohl ganz recht, meldet man sich nachträglich an, "sieht" man die laufwerke nicht, der "besitzer" der verbunden laufwerke ist wohl "system".

lotus,
woher weisst du, dass du in deinem skript die laufwerke nicht ansprechen kannst,? versuchst du was zu kopieren ? warum müssen die laufwerke eigentlich schon vorher verbunden sein, dh. noch bevor sich ein anwender anmeldet? vielleicht kannst du etwas genauer berichten, was du eigentlich vor hast...
Bitte warten ..
Mitglied: lotus
17.09.2009 um 19:22 Uhr
hallo zusammen

Es ist so!
Da ich ein NAS im Netzwerk habe und ich diese Freigaben einfach auf den Server legen will damit diese Stadard auf dem Server sind wen ich mich als Administrator anmelde habe ich gedacht: Da diese ja niemand braucht ausser der Admin werde ich den script dementsprechend unter Computerkonfiguration machen.
Dies geht jedoch nicht denn die Laufwerke werden im System zwar angezeigt aber als getrennt.
Habe die Option aktiviert die sagt "Immer auf das Netzwerk warten das hilft damit man jegliche Ausführung der scripts unterbinden kann bis das Netzwerk steht.
Denkste! Es scheint dass, das System nicht auf das Netzwerk wartet und die scripts einfach ausführt was natürlich dann zu dieser Ursache führt.
Ich kann es nicht beweisen momentan aber ich denke das ich richtig liege. Denn wenn ich den script manuell ausführe dann geht das ohne Problem, auch wenn ich pber die Bentzerkonfig gehe geht das.

Versteht mich richtig, das Problem ist gelöst nur nimmt es mich wunder wieso das nicht unter der Computer konfig. und wenn es doch gehen sollte dann wie?
Der normale Weg ist unter dem Profil des User einfach ein login script zu machen und dann hätte er ja alles was er braucht.
mfg
Bitte warten ..
Mitglied: lotus
17.09.2009 um 19:28 Uhr
hallo TimoBeil

nehmen wir dann einmal an ich bin ein Typ dem die Microsoft RDP Verbindung nicht gefällt und ich mich mit z.B. mit VNC au den Server bewegen möchte was dann?
Sicher, der admin ist sowieso angemeldet und ich sehe die Laufwerke aber.. es muss doch einen Weg geben das der Rechner unabhängig vom User diese Laufwerke mappt... oder!?

Gruss
und Danke.
Bitte warten ..
Mitglied: runcmd
18.09.2009 um 09:44 Uhr
dein vnc/rdp hinkt.

wenn ich dich nun richtig verstehe:

egal welcher user sich anmeldet, die freigabe sollen zu sehen sein, weil das system sie vorher gemapped hat?

da ist die antwort zum glueck mal klar:

nein, so geht das nicht.

es fühlt sich so an, als wenn du einfach nur ein problem mit der sichtweise hast. da dein problem ja gelöst ist, kannst du ja auch mal nen haken dran machen.

grüße
Bitte warten ..
Mitglied: 60730
18.09.2009 um 18:50 Uhr
Zitat von lotus:
hallo TimoBeil

nehmen wir dann einmal an ich bin ein Typ dem die Microsoft RDP Verbindung nicht gefällt und ich mich mit z.B. mit VNC au den Server bewegen möchte was dann?
Servus,
Kennst Du den Spruch "Jacke wie Hose?"

Sicher, der admin ist sowieso angemeldet

Autsch Am Server ist grundsätzlich niemand angemeldet..

und ich sehe die Laufwerke aber.. es muss doch einen Weg geben das der Rechner unabhängig vom User diese Laufwerke mappt... oder!?

Ich sags mal so:

  • ein Laufwerksmapping mache ich grundsätzlich nur mit einem Script.
  • Ob ich in dem Script nun "nur" ein Laufwerk mappe oder nach dem mappen auch gleich via Robo oder xyzcopy das "backup" mache und danach das Laufwerk wieder dismounte
  • Und das ganze Script dann per AT / schtasks unter einem gewissen User / der dann auch mal Adminrechte / nicht unbedingt Domainadminrechte haben darf

Das ist dann wiederum nicht Jacke wie Hose.

Wobei ich ehrlicherweise nicht wirklich verstehe -warum ein Domainadmin das machen sollen muß, wenn das NAS nicht in der Domain ist.
(wäre das Nas in der Domain reichte sicherlich auch ein \\nasname -\\NASIP\freigabe)


Gruss
und Danke.

zurück
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows 7
Net use Befehl -Eingabe ungültig nach System-Neustart (8)

Frage von lderigo zum Thema Windows 7 ...

Tipps & Tricks
Netztrennung (Firma, Gast) und Datenumzug von File-Server auf NAS (2)

Frage von Daniel776 zum Thema Tipps & Tricks ...

Windows Server
Installation Windows Nano Server für Hyper-V

Link von Mvinogradac zum Thema Windows Server ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (30)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...