Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netgear WGT624 und FTP-Problem

Frage Internet

Mitglied: passat28

passat28 (Level 1) - Jetzt verbinden

11.02.2007, aktualisiert 14.02.2007, 5506 Aufrufe, 3 Kommentare

Hallo Gemeinde,
Ich bekomme den ftp-Zugang nicht zum Laufen.
Konfiguration : DSL von t-..., Modem von t-..., WGT264, Buffalo-Linkststion.

In den einstellungen : Portweiterleitung f. ftp auf die IP-Nr. der LS mit port 20-21 aktiviert.
HW-Version : V3H1
Firmware : V1.1.125_1.1.1GR

ftp auf der LS klappt, da test im LAN mit interner IP-Nr. erfolgreich.
ftp von "draußen" über www.web2ftp mit meiner exterenen IP-Nr. klappt nicht.
Null Reaktion

Ich hoffe, daß ich alles wichtige geschildert habe.

Achja : einen Switch zwischen Router und Linkstation gibt es auch noch.

Hat jemand eine Idee oder selber schon mal das Problem gelöst.
Auch ein kontakt zu jemendem der dies laufen hat wäre sinnvoll.

Gruß
Mitglied: aqui
12.02.2007 um 00:42 Uhr
Das Problem ist ein Client. Bei einer normalen FTP Session wird ein willkuerlicher Daten Port gewaehlt, den deine Firewall nicht durchlaesst.
Wenn du den Client allerdings auf Passive FTP stellst sollte das klappen. Sogut wie alle FTP Implementationen in den Browsern machen passive FTP (jedenfalls bei Firefox). Damit kannst du die Funktion mal testen. Einfach im URL Feld>
ftp://username:password@ftp.server.addresse eingeben

Infos zu passive FTP und dem NAT Problem findest du hier:
http://www.ncftp.com/ncftpd/doc/misc/ftp_and_firewalls.html
Bitte warten ..
Mitglied: passat28
13.02.2007 um 00:22 Uhr
Hallo,
ich dachte 20 ist der Kommandoport und 21 der datenport.
Und das wäre fix.
Nun denn - muß ich passsives ftp im router einstellen ?
Ich habe nichts dort gefunden.
Übrigens : ch habe nur Portforwarding für 20 und 21 auf die LS eingestellt.
Kien anderer Dienst unjd auch kein Porttriggering.

Gruß
Bitte warten ..
Mitglied: aqui
14.02.2007 um 01:25 Uhr
Hier:
http://www.astalavista.ch/index.php?section=docsys&cmd=details& ...
Kannst du die Details zum Verbindungsaufbau nochmal nachlesen. Das Problem bei active FTP ist das der Server dem Client sagt auf welchem Port er die Verbindung aufbaut und das wird im NAT des Routers verdreht.
Bei Passive FTP initiiert der Client diese Session und das Problem existiert nicht.
Im Router wird der Passive Mode nicht eingestellt sondern NUR im FTP Client. Diesen muss man VOR dem Verbindungsaufbau auf PASSIVE setzen. Viele Clients wie WinFTP etc. supporten das.
Testen kannst du das wie gesagt mit dem Browser Firefox o.ä. Diese Clients sind fast immer passive (jedenfalls der Firefox) per Default.
Leider kannst du damit erstmal nur runterladen testen. Wenn das aber geht geht Upload auch mit dem entsprechenden Client.
Also einfach mal mit ftp://<deine FTP Adresse> versuchen eine Verbindung zu machen. Das sollte klappen.
Bitte warten ..
Ähnliche Inhalte
Java
Problem bei Java und FTP (1)

Frage von Marlon1 zum Thema Java ...

Batch & Shell
gelöst FTP und bach script I Problem von nicht komplett geladener Files (9)

Frage von drscoop zum Thema Batch & Shell ...

Router & Routing
gelöst Cisco-HP-Netgear (3)

Frage von homermg zum Thema Router & Routing ...

Windows Server
Portierung IIS6 Virtuelle FTP Verzeichnisse nach IIS8 FTP (1)

Frage von flop zum Thema Windows Server ...

Neue Wissensbeiträge
Humor (lol)

Wohnt jemand in Belgien und kann nicht mehr ruhig ausschlafen?

(3)

Information von LordGurke zum Thema Humor (lol) ...

Sicherheits-Tools

Trendmicro OSCE und das Fall Creators Update Win10 RS3

(3)

Information von Henere zum Thema Sicherheits-Tools ...

Microsoft Office

Text in Zahlen umwandeln

Tipp von logische zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Microsoft Office
ICH BIN AM ENDE MEINES IT-WISSENS ANGELANGT!!!! (38)

Frage von 134537 zum Thema Microsoft Office ...

Windows Server
Gruppenrichtlinie greift nicht zu! (24)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (21)

Frage von sunics zum Thema Hosting & Housing ...