Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzlaufwerk verbindet manchmal auf falschen Pfad.

Frage Microsoft Windows Netzwerk

Mitglied: Jonnyblue

Jonnyblue (Level 1) - Jetzt verbinden

04.07.2007, aktualisiert 14.08.2007, 8753 Aufrufe, 15 Kommentare

Hallo,
ich habe hier folgendes Problem:
In nicht logischen Abständen und ohne logische Veränderung wird bei diversen Usern ab und zu das "persönliche Laufwerk" falsch verbunden.

Ich habe hier einen Fileserver mit einer denke ich normalen Ordnerstruktur.

\\server\public\ (Alle user haben Lesezugriff)
\\server\basis$\ (Alle user haben Lesezugriff
\\server\basis$\%username%\ (Jeder User hat Lese-/Schreibzugriff auf sein Verzeichnis)

Jedem User wird im ADS sein Verzeichnis (\\server\basis$\%username%\) als Netzlaufwerk H: zugewiesen.
Das funktioniert auch in 99% aller Fälle einwandfrei.

Ab und zu kommt es jedoch vor, dass nach der Anmeldung H: nicht mit " ;\\server\basis$\%username%\ " sondern nur auf " ;\\server\basis$\verbunden wird und der User dann die ganze Liste aller User sieht. Ein Zugriff auf den Ordner des Users ist aber dann schon normal möglich., nur eben wird H: nicht direkt damit verbunden. Wenn man das Netzlaufwerk dann von Hand neu verbindet funktioniert alles wieder auf unbestimmte Zeit, auch über Neustarts hinweg.
Macht man nichts dagegen, bleibt H: weiterhin mit " ;\\server\basis$\" verbunden ebenfalls über Neustarts hinweg.

Ich werde aus dem Problem einfach nicht schlau, vor allem gibt es keine logische Struktur. Das Problem tritt auch gleichfalls bei Domänenadmins und normalen Usern auf.

Vielleicht hat ja jemand eine Idee, ich wäre auf jeden Fall sehr dankbar!
Mitglied: Xaero1982
04.07.2007 um 13:53 Uhr
Also so eine komische Konstallation habe ich noch nie gesehen.

Netzlaufwerke für User werden nicht via \\server$\%Username% vergeben oder was auch immer das da zu heißen haut ? sondern via

\\server\%username%$

Damit wird gewährleistet, dass der Ordner versteckt ist.

Zusätzlich müssen die Freigabe und NTFS Berechtigungen gesetzt werden.

Wie sieht denn deine Batch? aus? Posten!
Bitte warten ..
Mitglied: Jonnyblue
04.07.2007 um 15:59 Uhr
Sorry hatte mir vorher im Original die Formatierung zerschossen, daher die falschen Pfade.
Jetzt habe ich den Originalpost aktualisiert.
Bitte warten ..
Mitglied: LittleHolly
04.07.2007 um 16:09 Uhr
Hallo,

wenn Du möchtest das ein Laufwerk immer auf den selben Buchstaben verbunden werden soll, dann gib den Laufwerksbuchstaben doch beim Log-In-Script einfach mit.

Schaue Dir mal in der Windows-Hilfe den Befehl NET USE an, der wirkt Wunder.

Du solltest aber vorher alle Verbindungen trennen, da sie sich, bei eine doppelten Vergabe überlagern und Du nur die letzte Verbindung auf den gleich Laufwerksbuchstaben sehen kannst. Netter Fehler und immerwieder gern gemacht.

Viel Glück
Bitte warten ..
Mitglied: Jonnyblue
04.07.2007 um 16:27 Uhr
Das ganze ist kein Loginscript oder so, das ist eine Option im Windows 2003 Server Active Directory, dort kann man jedem User ein Netzlaufwerk mitgeben (in dem Fall H:\ auf \\server\basis$\%username%\)
Dann wird, wenn das Profil geladen wird automatisch das Laufwerk verbunden.

Und das funktioniert ja auch wie es soll, nur wirklich ganz selten verbindet das Laufwerk nicht wie im ADS angegeben auf \\server\basis$\%username%\ sondern nur auf \\server\basis$\ und das völlig willkürlich.

Beispiel: Max Müller
User: mueller-m
Laufwerk H: \\server\basis$\mueller-m\
Bitte warten ..
Mitglied: geTuemII
04.07.2007 um 16:53 Uhr
Wenn der User-Basisordner aus der Userkonfig des AD Probleme macht, solltest du Einträge in den Ereignisprotokollen des DC oder der lokalen Maschine haben. Tritt dein Problem gleichzeitig mit irgendwelchen anderen Netzwerkproblemen (Profil konnte nicht geladen werden oder so) auf?

geTuemII
Bitte warten ..
Mitglied: Jonnyblue
04.07.2007 um 19:15 Uhr
Das ist ja das krasse, die Ereignisprotokolle geben nichts her, es ist nichts besonderes feststellbar wenn das Problem auftritt die Protokolle sind wie immer...

Ich werde aus dem Sachverhalt nicht schlau. Es gibt keinerlei Anzeichen, dass etwas schief gelaufen ist wenn das Netzlaufwerk falsch gemappt wird...
Bitte warten ..
Mitglied: Xaero1982
05.07.2007 um 08:16 Uhr
s.o.

Eine Laufwerksfreigabe als Homelaufwerk wird so nicht realisiert

\\server\basis$\%username%\

sondern

\\server\basis\%username%$\

Im AD im Userprofil wählst du dann den Laufwerksbuchstaben aus und als pfad kommt \\server\%username%$\

Wir benutzen das hier so bei über 200 Leuten und es geht problemlos.
Bitte warten ..
Mitglied: Jonnyblue
05.07.2007 um 09:47 Uhr
Hey, schon klar. Leider lässt sich die bestehende Strucktur nur schlecht ändern.

Wir nutzen das hier für über 1000 Clients und an sich funktioniert das auch (seit Jahren) Problemlos hier, bis auf das genannte Problem. Ich könnte mir eigentlich nur vorstellen, dass irgendwie die Ordnerrechte nicht schnellgenug gesetzt werden und deshalb für das Laufwerk ein verbinden auf den direkten Pfad (\\server\basis$\%username%\) aufgrund fehlender Benutzerrechte nicht schafft und danach sich dann auf den übergeordneten Ordner auf den alle Benutzer rechte haben (\\server\basis$\) verbindet.

Eine Umstellung auf eine andere Ordnerstruktur würde viel aufwand bedeuten und so hätte ich lieber eine andere möglichkeit, falls noch jemand eine Idee hat wäre ich echt dankbar!

Danke schonmal für die Anregungen!
Bitte warten ..
Mitglied: Xaero1982
05.07.2007 um 10:56 Uhr
Naja so schwer ist das gar nicht

01.
' Modify User Profile Properties 
02.
 
03.
' Windows Server 2003 : Yes 
04.
' Windows XP : Yes 
05.
' Windows 2000 : Yes 
06.
' Windows NT 4.0 : Yes 
07.
' Windows 98 : Yes 
08.
 
09.
 
10.
Set objUser = GetObject _ 
11.
  ("LDAP://cn=myerken,ou=management,dc=fabrikam,dc=com") 
12.
  
13.
objUser.Put "homeDirectory", "\\sea-dc-01\HomeFolders\myerken" 
14.
objUser.Put "homeDrive", "H:" 
15.
objUser.SetInfo
Bitte erst in einer Testumgebung prüfen....Keine Garantie keine Haftung

LDAP://servername/ CN=Users,ou=organisationunit,dc=domäne,dc=zweiter teil des domänennamens nach dem punkt

pfade entsprechend anspassen

01.
objUser.Put "homeDirectory", "\\server\basis\%username%$" 
02.
objUser.Put "homeDrive", "H:" 
03.
objUser.SetInfo
wie gesagt vorher testen dazu z.B. bei CN=einen benutzer angeben
Bitte warten ..
Mitglied: Jonnyblue
05.07.2007 um 15:23 Uhr
Okay, ich werde das mal meinen Kollegen vorschlagen, was die davon halten.

Danke auf jeden Fall mal für die Hilfe!
Bitte warten ..
Mitglied: Xaero1982
05.07.2007 um 18:45 Uhr
Kein Problem. Wenn du noch fragen hast nur zu.

Zu deinem Problem aber noch mal : Noch nie gehabt. Die Homelaufwerke klappen immer problemlos im AD!
Bitte warten ..
Mitglied: pgmende
14.08.2007 um 08:47 Uhr
@Jonnyblue:

Hast Du das Problem bereits lösen können?

Stehe vor genau dem gleichen Problem, Win-XP-Prof-Clients (mit SP2) melden sich an einer Win2000-Domäne (AD) an.
Und selten kommt es vor, daß "NUR" auf das übergeordnete Basisverzeichnis gemappt wird.
Meldet sich der User ab und wieder an, behebt dies das Problem nicht immer, was aber immer funktioniert:
- Trennen des falsch verbundenen Laufwerks, dabei
kommt eine Rückfrage, weil angeblich Dateien offen wären - weiß nur nicht, welche!
- Neuanmelden des Users, dann wird richtig verbunden.

Was die Ordnerstruktur angeht: Wir setzen was ähnliches ein SERVER - BASIS$ - %USERNAME%
Die Win2000-Clients machten NIE Probleme dabei, die XP-Cients auch nur manchmal...

Wenn jemand einen Tip für mich hat - irgendwelche Ansatzpunkte, was ich noch überprüfen/umstellen/ändern könnte - bitte melden!

Gruß,
Andreas
Bitte warten ..
Mitglied: Jonnyblue
14.08.2007 um 15:23 Uhr
Hey pgmende,
scheint bei uns beiden das selbe Problem zu sein... Ebenfalls war bei uns bis zur Umstellung auf XP kein Problem mit der Ordnerstruktur auf dem Filer... Du umstellung auf eine andere Struktur ist bei uns aber momentan zweitrangig und auch vorerst nicht gewünscht. D.h. eine Problemlösung wäre toll aber dafür werden wir vorerst nicht die komplette Struktur auf dem Filer umbauen.

Deshalb einzige Lösung:

Ordnerstruktur von "server -> basis$ -> %username%" auf "server -> basis -> %username%$" ändern. So wie oben erklärt...
Könnte mir gut vorstellen das es so dann funktioniert.

Über weitere anregungen bin ich aber auch dankbar!
Bitte warten ..
Mitglied: pgmende
14.08.2007 um 15:34 Uhr
Hi,

was mir noch eingefallen ist:

Das Home-Verzeichnis wird für den User ja in den Benutzer-Einstellungen definiert.

Bei uns liegen die Benutzer-Verzeichnis momentan noch auf mehreren Servern, aber:
Falls bei Dir die User alle den selben Server benutzen, nimm doch die Homepath-Einstellung raus und mappe über ein Loginscript der Gruppenrichtlinie das Homeverzeichnis.

Gruß,
Andreas
Bitte warten ..
Mitglied: Jonnyblue
14.08.2007 um 15:53 Uhr
Hmm wäre eigentlich eine Idee die man mal testen könnte...

Werd ich dann nach meinem Urlaub in 2 Wochen denk ich mal testen!
Bitte warten ..
Ähnliche Inhalte
Windows 7
Manchmal kommt: "Der Pfad ist nicht verfügbar" beim Netzlaufwerk
Frage von PampersjoeWindows 76 Kommentare

Hallo zusammen, leider sind wir irgendwie "leicht" =) ratlos Wir haben einen Mitarbeiter mit Windows 7 64bit. Er hat ...

Windows Netzwerk
Netzlaufwerk verbindet nicht über VPN
gelöst Frage von spufi77Windows Netzwerk5 Kommentare

Hallo zusammen, meine Systemvoraussetzungen: FritzBox 7390, DNS eingetragen, integriertes NAS auf USB Stick, ein weiteres (echtes) NAS als "Exposed ...

Windows 8
Microsoft Surface Pro Windows 8 Netzlaufwerk verbindet sich mit falschem Namen
Frage von THEcRiteKWindows 82 Kommentare

Hallo Comm, seit geraumer Zeit habe ich auf einem Surface Pro der ersten Generation ein seltsames Problem. Es sind ...

Cloud-Dienste
Onedrive per Netzlaufwerk falsche Größe
Frage von bastian42Cloud-Dienste4 Kommentare

Hallo, ich habe bei onedrive 1 TB. Wenn ich mir das Laufwerk unter Windows 7 oder 8.1 als Netzlaufwerk ...

Neue Wissensbeiträge
Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 10 MinutenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 14 StundenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 18 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 18 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte14 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...