Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerk wird langsam bis zum Stillstand

Frage Microsoft Windows Netzwerk

Mitglied: killer101

killer101 (Level 1) - Jetzt verbinden

21.07.2008, aktualisiert 21:36 Uhr, 3643 Aufrufe, 6 Kommentare

Hallo!

Kleine Einleitung :

Wir betreiben ein Workgroup Netzwerk mit ca. 100 Clients. Ok, die Meisten werden jetzt die Hände über dem Kopf zusammenschlagen und sich fragen was das soll. Da sollte man doch besser auf eine Domänennetzwerk setzen. Stimmt, aber das hat verschiedene interne Gründe. Davon abgesehen läuft ja auch alles wunderbar. Der Wartungs- und Administrationsaufwand ist gering.

Folgendes Problem habe ich :

Ein Windows 2000 Server soll durch neue Hardware ersetzt werden. Dieser dient als File und Datenbankserver. Dieses funktioniert, da der Datenbankserver recht resourcenschonend ist (Advantage Database Server). Auf der alten Hardware läuft alles und die Auslastung ist auch nichts besonderes. Die Hardware ist jetzt aber schon etwas in die Jahre gekommen und soll ersetzt werden.

Der neue Server ist ein Dual-Quadcore Xeon mit einem Intel Board. Das Systemlaufwerk ist ein SATA Raid 1 (Megaraid) und die Daten liegen auf einem SCSI Raid 5 System mit ICP Controller. Die Software und Konfiguration entspricht dem alten Server, bis auf die Treiber für die neue Hardware natürlich.

Das Netzwerk ist Fast Ethernet mit mehreren Cisco Caralyst 2950 Switches. Die Clients sind hauptsächlich W2k Rechner und einige wenige XP Rechner.

Wenn ich jetzt den neuen Server ans Netz hänge, läuft der einige Zeit völlig problemlos. Dann merkt man die ersten Geschwindigkeitsaussetzer in der Datenbankapplikation und beim browsen von gemappten Laufwerken. Das schaukelt sich innerhalb von ca. 30 Minuten bis zum kompletten Netzwerkstillstand hoch. Vorher kann der Server aber auch drei Stunden einwandfrei funktionieren. Auf dem Server selbst brauchen Programme dann auch ewig bis sie starten. Die CPU-Last dümpelt so bei 3 - 5% rum. Das Ereignisprotokoll gibt auch nichts her, genauso wenig wie die Logs der Cisco-Switches. Da ist alles im grünen Bereich. Das Phänomen tritt übrigens offensichtlich nur dann auf, wenn die Mitarbeiter auf dem Server arbeiten. Wenn ich den Server am Wochenende tausche und das Gerät mit Arbeit belaste, stört der sich überhaupt nicht dran und funktioniert problemlos.

Es mag sein das es nur ein simpler Konfigurationsfehler ist, aber leider gehen mir die Ideen aus.

Wäre dankbar wenn jemand noch einen Tip hätte, worauf man sich mal stürzen könnte.

Habe mich auch schon stundenlang durch alle möglichen Foren gearbeitet. Die Erkenntnis war die, dass die meisten dieser Fälle als ungelöste Beiträge ihr Dasein fristen.

Mir würde es ja schon reichen, wenn ich den Fehler im nicht-produktiv Betrieb reproduzieren könnte. Dann hätte der Server schon verloren. Leider gelingt mir das nicht. Und den gesamten Betrieb als Versuchkannichen einzuspannen stößt irgendwann auf Unverständnis.
Mitglied: education
21.07.2008 um 20:52 Uhr
ist QOS an den Server aktiv?

hat vielleicht ein Client die "Server" funktion in netzwerk übernommen und hat jetzt das sagen wer was macht?
Bitte warten ..
Mitglied: Antos
21.07.2008 um 21:03 Uhr
Hi killer101,

hört sich so an als würde der Ramspeicher voll laufen so dass das System dann anfängt auf die Festplatte auszulagern.Hasst du die Auslagerungsdatei (pagefile) in irgend einer Form angepasst? Die Datenbank kenne ich jetzt nicht aber vielleicht hasst du da den Möglichkeit Ramspeicher zuzuweisen.
Oder evtl. ein Virenscanner im Einsatz (Clientseitig-Serverseitig) der dir die Performance frisst?

Mit freundlichen Grüßen,
Antos
Bitte warten ..
Mitglied: killer101
21.07.2008 um 21:17 Uhr
QOS in Bezug auf was genau? Bei den Netzwerkkarten? Die neuen Netzwerkkarten haben so einige Funktionen, bei denen laut Intel hier und da schon mal Probleme auftauchen. Allerdings passte bis jetzt kein Szenario. Aber vielleicht hat das alte Windows Probleme mit den Offload Funktionen. Bis auf die Powermanagement Sachen habe ich alle Einstellungen an der Netzwerkkartenhardware erst mal beim Standard belassen.

Die "Server" Funktion übernommen? Ist da die Masterbrowser Thematik gemeint? Diese Funktion hat ein anderer W2k Server im Netz.
Bitte warten ..
Mitglied: killer101
21.07.2008 um 21:24 Uhr
Dem Speicher geht es auch gut. Das System hat 4GB, das Betriebssystem sieht aber durch Bios Einstellugen nur 3GB. Das ist so gewollt, da die 4GB Grenze ja auch nur Probleme macht. Die Datenbank kümmert sich selbstständig um den Speicher und hat zu Crashzeiten auch nur 900MB im Zugriff. Das hat sie sonst auch.

Virenscanner laufen sowohl auf dem Server, wie auch auf den Clients. Am Server sind alle kritischen Sachen (Datenbank-Files usw.) vom Scannen ausgeschlossen. Die Clients kann man wahrscheinlich vernachlässigen, es funktioniert ja mit dem alten Server auch.

Am Pagefile habe ich nichts gemacht, ist so wie es Windows geschaffen hat!
Bitte warten ..
Mitglied: 60897
21.07.2008 um 21:25 Uhr
Ich hab' da auch noch etwas Senf zum dazugeben,

hallo auch!

Der Beschreibung und dem Ablauf zufolge würde ich darauf tippen, dass die verfügbaren TCP-Verbindungen knapp und überschritten werden, wobei das allerdings normalerweise in der Ereignisanzeige zu lesen sein sollte.

Was für eine Ausgabe bekommst Du, wenn Du kurz vor dem Exitus in der Kommandozeile mal nach netstat (Optionen nach Wunsch) fragst? Ich hatte bei einer Verwaltungssoftware für ThinClients mal ein vergleichbares Problem, da war es die SQL-Datenbank selbst, die Verbindugen gesammelt hat bis zum geht-nicht-mehr. Lösung war eine neue Programmversion. Lass es an der Zusammenstellung oder Installationsreihenfolge von Patches liegen...

Bonkers
Bitte warten ..
Mitglied: killer101
21.07.2008 um 21:36 Uhr
Nach netstat habe ich nicht geschaut! Ok, wäre vielleicht ratsam gewesen. Die Ereignisanzeige mäkelt da nichts in der Richtung an.

Die Programmversion des Datenbankservers ist aktuell und macht auf der alten Hardware keine Probleme.

Tja, die leidigen Patches vom M$. Das ist auch so ein Thema. Vor Jahren hatte der berüchtigte KB...066 den Datenbankserver mal ins Trudeln gebracht. Da war auch alles langsam, aber direkt! Nach Deinstallation war alles wieder im Lot. Diesen und noch zwei, drei andere Patches habe ich auf dem neuen Server natürlich weggelassen. Da sich der Server über einen hausinternen WSUS aktualisiert, habe ich die vorgeschlagene Reihenfolge so hingenommen.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Hyper-V
gelöst Win Server 2012 und Hyper V gleich Netzwerk extrem langsam (20)

Frage von Edaseins zum Thema Hyper-V ...

LAN, WAN, Wireless
Neuplanung Netzwerk mit VLAN, VOIP, Gästenetz (2)

Frage von GKKKAT zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Windows Netzwerk
USB-Gerät ins Netzwerk (Domäne) einbinden (4)

Frage von griss0r zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...