Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerk Linux und Windows gemainsame Verbindung :-)

Frage Linux

Mitglied: Lalo

Lalo (Level 2) - Jetzt verbinden

26.11.2006, aktualisiert 11.12.2006, 5980 Aufrufe, 23 Kommentare

Hallo!!
Ich benutze eine ISDN verbindung (dsl gibt es nicht).
Die Eumex Modem hat mehrere PC Anschlusse, aber ich kann es nicht benutzen..... , das will nicht klappen.

Ich habe 2 Rechner 1x Win 2000 damit habe ich keine Verbindung Problemme.., und Linux.
Ich möchte gerne die "gemeinsame Internet zugang einrichten".

Wer könnte mir hier ein paar Tipps geben?

Die PC sind mit Netgear Switch Verbunden. Die Verbindung ist noch nicht Angerichtet......

vielen Dank im Vorraus für Ihre mühe.

Lalo
Mitglied: nimrod2k
26.11.2006 um 11:46 Uhr
Hi!

Am einfachsten ist es, du besorgst dir einen ISDN Router incl. Modem (gibts schon für 70 Euro, z.b. DLink 304). Damit kannst du dann problemlos mehrere Rechner ins LAN bringen.

Oder du richtest einen deinen Rechner als Router ein. Dazu muss dieser dann aber die ganze laufen, was du evtl. wegen der Stromrechnung nicht unbedingt in Kauf nehmen möchtest....

Gruß
nimrod2k
Bitte warten ..
Mitglied: Lalo
26.11.2006 um 12:47 Uhr
ich habe ein Modem-Router...... Eumex mit USB anschlüssen. Damit komme ich nicht klar.
Linux auch nicht

Lalo
Bitte warten ..
Mitglied: nimrod2k
26.11.2006 um 14:44 Uhr
Hat der Router keine RJ45 Schnittstelle?
Am einfachsten ist ein Router auf Ethernetbasis. Der ist dann auch per Hub/Switch noch beliebig erweiterbar. Und dein Linux macht damitz auch keine Zicken.

Ist deutlich einfacher einzurichten als über USB.

Gruß
nimrod2k
Bitte warten ..
Mitglied: aqui
26.11.2006 um 16:31 Uhr
Die Eumex Anlage funktioniert wie ein USB ISDN Modem. Ob es für Linux Treiber gibt müsste man mal recherchieren. Wahrscheinlich funktionieren damit die normalen Modemtreiber.
Es gibt aber einen einfacheren Workaround ohne erstmal suchen zu müssen:
Du installierts die entsprechenden Treiber auf deiner Windows Maschine, so das die problemlos über das Eumex Modem via ISDN ins Internet kommt. An diesem Adapter aktivierst du die Windows "Internetverbindungsfreigabe".
Nun kannst du mit allen Maschinen die am Ethnernet angeschlossen sind automatisch ins Internet. Das klappt aber wie gesagt nur wenn der Windows PC eine aktive ISDN Verbindung aufgebaut hat bzw. überhaupt angeschaltet ist.
Natürlich kann man das auch automatisieren, aber da es bei ISDN keinerlei Flat Rate gibt kann das gefährlich werden sollte einer der Rechner permanent daten ins Interne schicken. Das können irgenwelche Keepalives für Update Server sein oder Naming Broadcasts oder was auch immer. Diese würden dir dann unbemerkt bei einer automatisierten Verbindung erheblich Kosten verursachen...

Die einfachste Lösung wäre aber wie oben schon vorgeschlagen einen ISDN Router zu beschaffen. Sowas (Cisco 700er, 800er oder 2500er o.ä.) gibt es zuhauf bei eBay für kleines Geld. (In Zeiten von DSL will keiner mehr ISDN )
Das erspart dir letztlich die Frickelei mit dem Modem und du bist unabhängig von deinen PCs mit der Internetverbindung.
Bitte warten ..
Mitglied: Lalo
26.11.2006 um 21:00 Uhr
es gibt immer noch Orte mitte in Europa wo NUR ISDN funktioniert, oder ANALog .
UMTS,DSL sind Fremde Wörte.

Für der Eumex sind tatsächlich irgenwelche Treiber...... aber es will nich klappen.

ISDM Modem mit RJ45...... das ist mein Traum.

und das ist Cisco 803 oder 804

Vielen Dank Jung und Mädels


Lalo
Bitte warten ..
Mitglied: aqui
28.11.2006 um 01:17 Uhr
Ja, der Cisco 700er, 800er, 1700er oder auch ein 2500er sind genau das was du suchen solltest auf eBay. Damit lässt sich problemlos sowas realisieren ! Zyxcel hat m.E. auch noch einen ISDN Router im Produktportfolio....
Bitte warten ..
Mitglied: 2795
28.11.2006 um 10:44 Uhr
Hi,

um nochmal auf deine anfängliche Frage einzugehen - eine alternative wäre natürlich
auf einen deiner Win-PC's einen Proxy-Server einzurichten z.B. "Jana2".
Dann übernimmt der Proxy das Öffnen der Verbindung, wenn dein Linux mal
raus muss.

kerl
Bitte warten ..
Mitglied: Lalo
01.12.2006 um 12:21 Uhr
CISCo ist (ein scheiss)^5.

vor mir Liegt ein 803.

zum resseten brauche ich special resset Programm von Cisco.... und weil ich kein Vertrag mit Cisco habe.....
bekomme ich keins.

Mein erstes und letztes Cisco router?

ist das tatsächlich so? oder habe ich der Mann falsch Verstanden?
Bitte warten ..
Mitglied: aqui
01.12.2006 um 13:56 Uhr
Ruhig bleiben....
Natürlich brauchst du KEIN Programm und auch keinen Vertrag !!

Es kommt darauf an ob du auf die Kommando Oberfläche kommst. Du schliesst das blaue Konsolkabel an den Router und an die serielle Schnittstelle deines PC an.
Dann lädst du ein Terminalprogramm wie TeraTerm (http://hp.vector.co.jp/authors/VA002416/teraterm.html) oder benutzt das Windows eigenen Hyperterm (Unter Zubehör->Kommunikation) Die Schnittstellen Einstellungen sind : 9600 Baud, keine Parity, 8 Bit 1 Stopbit und KEINE Flusskontrolle !

Wenn du das dranhast und den Router einschaltest siehst du seine Bootmeldung und du landest an einem Prompt der eine spitze Klammer hat > hier gibst du jetzt "ena" ein und kannst das System konfigurieren !
Hat allerdings jemand ein Passwort drauf das du nicht kennst hast du erstmal Pech aber auch das lässt sich lösen

Hier:
http://www.cisco.com/en/US/products/hw/routers/ps380/products_configura ...

steht genau wie man es macht und das unbekannte Passwort löscht. Ist recht einfach und die Standardprozedur bei allen Cisco Routern. Nur die Config Register Settings unterscheiden sich etwas....
Damit sollte das klappen deinen 803 wieder "nackig" zu machen !

Eine laufende ISDN Konfiguration des 803ers für den Zugang auf T-Online mit DHCP Server im LAN sieht dann so aus: Hast du einen anderen Provider musst du die Zugangsdaten ggf. ändern.
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname Router
!
enable secret geheim
enable password geheim
!
clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
no ip subnet-zero
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool 0
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 194.25.2.129
!
isdn switch-type basic-net3
!
interface Ethernet0
description Lokales Ethernet
ip address 192.168.1.254 255.255.255.0
ip access-group 102 in
ip nat inside
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
no cdp enable
!
interface Dialer1
description ISDN Waehlverbindung 64kB zu T-Online
bandwidth 64
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 118
dialer string 0191011
dialer hold-queue 15
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username 00056785813351012345678#0001 password <T-Online Passwort>
ppp timeout idle 118
!
ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 deny udp any range netbios-ns netbios-ss any
access-list 102 deny tcp any eq 139 any
access-list 102 permit icmp 192.168.1.0 0.0.0.255 any
access-list 102 permit ip any any
dialer-list 1 protocol ip permit
!

Router#


Der T-Online Username setzt sich zusammen aus:
<Anschlusskennung><T-OnlineNr.>#<Mitbenutzer>
Bitte warten ..
Mitglied: Lalo
01.12.2006 um 20:14 Uhr
ich habes Pech. Passwort ist drin.

Was ist eine Breaktaste :-S

Zitat:
Step 1 If break is enabled, go to Step 2. If break is disabled, turn the router off ( O ), wait 5 seconds, and turn it on ( | ) again. Within 60 seconds, press the Break key. The terminal displays the ROM monitor prompt. Go to Step 3.

Note Some terminal keyboards have a key labeled Break. If your keyboard does not have a Break key, see the documentation that came with the terminal for instructions on how to send a break.


Step 2 Press break. The terminal displays the following prompt:....

Break ist da (Alz+B)

Kampf geht weiter.....

M bytes of flash on board (4M from flash card)



Press RETURN to get started!


00:00:23: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
*Mar 1 00:00:25.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0,
changed state to up
*Mar 1 00:00:27.859: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, ch
anged state to down
*Mar 1 00:00:27.867: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, ch
anged state to down
*Mar 1 00:00:31.331: %SYS-5-CONFIG_I: Configured from memory by console
*Mar 1 00:00:31.583: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C800 Software (C800-Y6-MW), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Fri 21-Jun-02 11:25 by ccai
*Mar 1 00:00:31.679: %SNMP-5-COLDSTART: SNMP agent on host ND73134 is undergoin
g a cold start
*Mar 1 00:00:32.851: %LINK-3-UPDOWN: Interface BRI0, changed state to up


...... :-S
Bitte warten ..
Mitglied: aqui
02.12.2006 um 15:46 Uhr
Das Break Signal sendet man bei Hyperterm durch Drücken von <ctrl-c> oder der "Pause/Unterbr" Taste.
Bei TeraTerm ist es ALT-B
Bitte warten ..
Mitglied: Lalo
02.12.2006 um 17:57 Uhr
ja. Trotzdem komme ich nich weiter......

wie bekomme ich nicht-
privilegierten Modus????


ok keine fragen mehr

der Weg war nicht so einfach. Befehle die auf Cisci seite geschrieben sind habe ich nicht auf dem Router.
Schliesslich habe ich break gemacht , set ios sowie startup auf standart werte gesetzt und jetzt bin ich drin

Mein eindruk alte klump. :->
Bitte warten ..
Mitglied: aqui
04.12.2006 um 13:18 Uhr
OK, dann nur noch die Konfig von oben mit deinen ISDN und LAN Daten eingeben( das geht mit "conf t" nachdem man "ena" eingegeben hat !) und dann sollte dein ISDN Verbindung klappen !
Bitte warten ..
Mitglied: Lalo
05.12.2006 um 17:29 Uhr
...... ich brauche für die Telephongeräte Adapter.......
Wie heissen die Adapter? Passen die von Fritzbox ????

Lalo
Bitte warten ..
Mitglied: aqui
07.12.2006 um 13:26 Uhr
Ooops...wie, was ??? Was für Telefongeräte ???
Für den Router brauchst du keinen Adapter. Wenn du einen ISDN Anschluss hast, dann hast du von der T-Com (oder deiner Telefongesellschaft der Wahl) einen sog. NT (Network Terminator) bekommen. Der hängt irgendwo wo die Telefonleitung ins Haus kommt an der Wand (grauer Kasten). Dort sind unten 2 RJ-45 Buchsen. An eine schliesst du deinen ISDN Router an (mit der Routerbuchse die "ISDN" beschriftet ist) und an der anderen hast du dein Telefon oder die Telefonanlage.
Für den Router benötigst du keinerlei Adapter, der funktioniert direkt am ISDN Anschluss !
Bitte warten ..
Mitglied: Lalo
08.12.2006 um 17:18 Uhr
Router hat auch 2 eeeee Telefon buchsen.
Bitte warten ..
Mitglied: aqui
08.12.2006 um 23:41 Uhr
Die kannst du schlicht ignorieren wenn du den Router NUR als ISDN Router benutzen willst.
Ansonsten kann der Router noch nebenbei als ISDN - Analog Wandler arbeiten und würde dort wenn man es denn unbedinngt möchte auch noch 2 Telefone bedienen oder ein Telefon und ein Fax oder....
Wie gesagt, lass die Anschlüsse leer wenn du nur die Routerfunktion benötigst !
Bitte warten ..
Mitglied: Lalo
09.12.2006 um 20:11 Uhr
kampf geht weiter........ jetzt immer noch mit >ena<

schau mal:

show Show current or saved boot environment.
upload Load image or configuration data into RAM.
undelete Undelete file-name (maximum of 8 deletes & undeletes).
boot# disable
boot> ena
boot# disable
boot> ena<
ena<: failed, "command not found"
boot> ena <
<: failed, "invalid argument"
boot>



hehehe die "andere Funktionen " sind sehr interessnt
Bitte warten ..
Mitglied: aqui
10.12.2006 um 13:24 Uhr
Oha, du bist im Bootloader !!! Das sagt eindeutig der Prompt "boot>" da darfst du NICHT landen drin nach einem Kaltstart, denn damit funktioniert der Router NICHT !!!

Ist das der Fall hast du vergessen das Konfig Register wieder auf seinen ursprünglichen Wert zu setzen damit der Router wieder normal startet !!!
Kommandos wie "ena" oder sowas helfen dir da natürlich nicht richtig weiter, da du NICHT auf der normalen Konfigurationsoberfläche des Routers bist !!! Du kannst im Bootloader das Konfig register wieder richtig setzen mit:

boot> ena
boot# confreg 0x100
boot# reset (oder Kaltstart mit Strom aus Strom an)

Danach sollte der Router normal wieder hochkommen. Tut er das nicht kannst du statt 0x100 einmal 0x2100 als Konfreg versuchen.

Das sollte dann klappen !!! Funktioniert das solltest du mit:

Router> ena
Router #
Router # wri erase

reload
Den Router von seiner ursprünglichen Konfig befreien also diese löschen. Dann kaltstarten und dann kannst du die Konfig von open ganz einfach mit Cut and Past über die terminaloberfläche eingeben !!
Bitte warten ..
Mitglied: Lalo
10.12.2006 um 13:42 Uhr
joo. Probiere ich heute noch aus vielen Dank!!

die software:
http://www.cisco.com/pcgi-bin/tablebuild.pl/faststep

ist nicht wirklich hilfreich....? hast damit erfahrung?
Bitte warten ..
Mitglied: Lalo
10.12.2006 um 13:42 Uhr
joo. Probiere ich heute noch aus vielen Dank!!


TinyROM version 1.4(1)
19:37 11/07/00
Copyright (c) 1998-2000 by cisco Systems, Inc.
All rights reserved.

POST ............ OK. 4MB DRAM, 8MB Flash.

Configured boot failed, attempting fallback boot.

Booting "c800-y6-mw.122-8.T5.bin" ...,
Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706



Cisco Internetwork Operating System Software
IOS (tm) C800 Software (C800-Y6-MW), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Fri 21-Jun-02 11:25 by ccai
Image text-base: 0x000F5000, data-base: 0x0077F000

Cisco C803 (MPC850) processor (revision 1) with 44156K bytes of virtual memory.
Processor board ID JAD06450FE8 (1157150771)
CPU part number 0x2101
Rate ISDN software, Version 1.1.
2 POTS Ports
1 Ethernet/IEEE 802.3 interface(s)
1 ISDN Basic Rate interface(s)
4M bytes of physical memory (DRAM)
8K bytes of non-volatile configuration memory
8M bytes of flash on board (4M from flash card)



Press RETURN to get started!


00:00:24: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
*Mar 1 00:00:25.776: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0,
changed state to up
*Mar 1 00:00:28.476: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, ch
anged state to down
*Mar 1 00:00:28.484: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, ch
anged state to down
*Mar 1 00:00:31.948: %SYS-5-CONFIG_I: Configured from memory by console
*Mar 1 00:00:32.200: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C800 Software (C800-Y6-MW), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Fri 21-Jun-02 11:25 by ccai
*Mar 1 00:00:32.300: %SNMP-5-COLDSTART: SNMP agent on host ND73134 is undergoin
g a cold start
*Mar 1 00:00:33.468: %LINK-3-UPDOWN: Interface BRI0, changed state to up



Alm. Brand - Hjemme Router - ND73134





User Access Verification
Bitte warten ..
Mitglied: Lalo
10.12.2006 um 13:42 Uhr
es folgt :

boot# disable
boot> ena
boot# confreg 0x100
confreg: failed, "command not found"
boot#
Bitte warten ..
Mitglied: aqui
11.12.2006 um 20:14 Uhr
Mmmmhhh, das ist verwirrend...
Die Bootmeldung sieht eigentlich korrekt aus als ob der Router sauber hochkommt und das auch mit korrektem Config register..
Allerdings beginnt der spannende teil genau nach dem "User Access Verification"

Kammt da ein Passwort prompt ???
Eigentlich sieht auch der Prompt soweit ganz richtig aus. Es kann sein das jemand das System "boot" genannt hat, wie gesagt das kann man nicht sehen da es nach der Aufforderung:
User Access Verification.... kommt.

Kommt allerdings danach der Prompt, versuche mal folgendes:

boot# Hier am Prompt eingeben: "conf t" (ohne "" !) <return>
Wenn jetzt ein "boot(config)#" als Prompt erscheint ist keine änderung des Konfig Registers erforderlich !!!
Mit <ctrl z> kommst du da wieder raus und müsstest wieder "boot#" sehen. Ist das der Fall gibst du mal ein:
"write era" <return> (<return> ist die Eingabetaste )
Danach ist die alte Konfig gelöscht. Nun machst du den Router mal stromlos und bootest ihn neu. Er sollte jetzt mit einer nackten Konfig hochkommen und dich menügeführt nach ein paar Grundparametern fragen....
Vergiss "Faststep" das Programm macht alles noch schlimmer !!!
Du musst nur die ISDN Konfig von oben mit deinen Zugangsdaten Zeile für Zeile in den Router übertragen...
Das geht nach dem Kommando "conf t" im Konfig Modus.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerke
Clientmanagement für Linux + Windows (3)

Frage von janne-s zum Thema Netzwerke ...

Monitoring
System Monitoring für Windows, Linux (5)

Frage von manuelw zum Thema Monitoring ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...