Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerk plötzlich sehr (extrem) langsam - Server2008R2

Frage Microsoft Windows Server

Mitglied: miscmike

miscmike (Level 1) - Jetzt verbinden

22.12.2013 um 16:44 Uhr, 5816 Aufrufe, 17 Kommentare, 2 Danke

Hallo zusammen !

Vor meiner eigentlichen Frage wünsche ich allen hier erstmal eine frohe Weihnachtszeit !

Diese habe ich mir grade etwas madig gemacht.
Ich versuche mal das Problem möglichst detailliert zu beschreiben :

Beim Kunden steht (u.a.) seit ca. 2 Jahren ein leistungsstarker Server (2 x 6core XEON, 64GB RAM, Adaptec-SAS-RAID, 4 x Gigabit-LAN)
Betriebssystem ist Windows Server 2008R2 mit den jeweils aktuellsten Updates.
Security : Kaspersky KES 10 Business Select

Rollen : DC, DHCP,DNS,Hyper-V, DFS

Es existeri an einem zweiten Standort ein weiterer DC.
Zwischen beiden wird via DFS diverses Datenmaterial synchronisiert.

Bisher gab es keine Probleme, das System war schnell und zuverlässig.

Nun fiel vor 3 Tagen der Router (Gateway 192.168.100.1) aus, womit auch die Verbindung zum entfernten DC unterbrochen war.

Einen Tag später habe ich den Router (AVM Voip Gateway 5188) ersetzt gegen eine Fritz!Box 7390 mit aktuellem OS 6.01.
Die Internetverbindung ist manuell mit fester IP-Adresse, die interne Adresse ist wieder die 100.1 , Internetzugang, Updates etc funktionieren.
Die Verbindung zum entfernten DC ist auch da (Verzeichnisse sind z.B. zu sehen und Dateien zu kopieren..)

Man könnte glauben, alles ist wieder schön.. Falsch gedacht.

Wenn man vom Server eine Datei kopieren will oder eine hinschickt (vom Client via Explorer) dauert das ewig.
Beispielsweise wird für eine 500kb Pdf ca. 4 min benötigt, den Versuch mit einer 200MB Zip-Datei habe ich frustriert abgebrochen.

Parallel dazu kann man den Server so gut wie nicht mehr bedienen, Mausklicks reagieren wenn überhaupt teilweise erst nach Minuten.
Das gleiche passiert auch bei Laden von Programmen auf Clients. Probiert habe ich das mit Win7, XP und auch Server 2008 Clients.

Es ist via Taskmanager keine CPU-Last zu erkennen, der Netzwerk-Durchsatz (Gigabit) liegt bei 0,0x%.

Breche ich den Kopievorgang ab, dauert es kurz, dann kann ich am Server wieder etwas machen.

Entweder bin ich betriebsblind oder doof - mir fehlen mittlerweile die Ideen, wo ich hier ansetzen könnte.

Liebe Admins - um das Weihnachtsfest nicht ganz zu versauen bitte ich Euch um Hilfe !

Viele Grüße
Der Mike
Mitglied: wiesi200
22.12.2013 um 17:11 Uhr
Hallo,

Erst mal per zugriff über IP die gleichen Probleme?
Schon mal direkt auf //server-ip/c$ kopiert?

Und so nen schweren Server an ne Fritzbox hängen
Bitte warten ..
Mitglied: certifiedit.net
22.12.2013 um 17:20 Uhr
Schliesse mich Wiesi an.

Der Server ist
a) Oversized, aber darum geht es nicht
b) falsch konfiguriert: (AD neben Hyper-V)
c) nicht richtig abgesichert -> FritzBox.

Ich vermute die Ports sind auf 100M konfiguriert oder irgendwas an der Nic Konfig stimmt nicht. Alternativ: Platten bereits gecheckt? Was sagt die HW? iDrac, IPMI, etc pp.
Bitte warten ..
Mitglied: aqui
22.12.2013, aktualisiert um 17:27 Uhr
Und täglich grüßt das Murmeltier:
http://www.administrator.de/contentid/225044
Betreibst du ein redundantes LAN sprich ist Spanning Tree bei dir ein Thema ??
Bitte warten ..
Mitglied: Cthluhu
22.12.2013, aktualisiert um 18:09 Uhr
Hi
Zitat von miscmike:
Entweder bin ich betriebsblind oder doof - mir fehlen mittlerweile die Ideen, wo ich hier ansetzen könnte.
Zuerst ma in den Logfiles schauen. Nämlich:
  • Virenscanner (kommt gar nicht so selten vor, dass dieser Amok läuft)
  • am Server
  • am Client
  • am Switch/Router
  • Läuft die DFS Synchronisation auf Hochtouren und blockiert bremst den Rest (ok, CPU und Netzwerkauslastung sind gering, aber das Dateisystem kann am Limit sein)?

Dann mal separat Geschwindigkeiten Testen und zwar:
  • HDD (z.B. mit HD tune)
  • Dateisystem (große Dateien kopieren, nicht übers netz sondern von einer Platte im Server auf eine andere, bzw innerhalb einer Platte)
  • Netzwerkdurchsatz (iperf oder netio)

Zitat von aqui:
http://www.administrator.de/contentid/225044
Betreibst du ein redundantes LAN sprich ist Spanning Tree bei dir ein Thema ??
Das ist durchaus auch ein Thema, auch wenn er keines betreibt. Sollten die Switche im Netz nix von Spanning Tree verstehen (oder deaktiviert haben) kann es durchaus sein, dass durch (kurzzeitiges) stecken einer Schleife mi den Patchkabeln die Switche außer tritt gebracht werden. Ein Neustart des Switche (nach auflösen der eventuell noch vorhandenen Schleife) sollte das Problem aber aus der Welt schaffen.

Mit freundlichen Grüßen

Cthluhu
Bitte warten ..
Mitglied: Dobby
23.12.2013 um 00:26 Uhr
Hallo,

Und so nen schweren Server an ne Fritzbox hängen
Dem schließe ich mich mal an, das ist wohl nicht "best Practice" und in einem
Unternehmen würde ich immer zwei Routingpunkte in einem Netzwerk bevorzugen wollen
einen "vorne" am WAN Interface einen Router oder eine Firewall und einen auf einem Layer3
Switch.

Der Server ist
a) Oversized, aber darum geht es nicht
Gibt es leider nicht!
1. Unterdimensioniert - nichts läuft "rund"
2. Richtig dimensioniert - alles läuft wie es soll, aber eben meist ohne Reserve
3. Überdimensioniert oder "oversized" ist wie Punkt 2, hält aber länger und hat noch Reserven!

c) nicht richtig abgesichert -> FritzBox.
Sehe ich auch so

Ich vermute die Ports sind auf 100M konfiguriert oder irgendwas an der Nic Konfig stimmt nicht.
Fast getroffen, wenn die FB 7390 neu ist, also nicht gebraucht gekauft wurde, sind nämlich alle
LAN Ports auf 100 MBit/s eingestellt, das kann man aber ändern in den Energiesparoptionen der FB.

Das AVM Voip Gateway 5188 durch einen Fritz!Box 7390 zu ersetzen ist auch so eine Sache.
Also ich lehne mich jetzt mal weit aus dem Fenster, aber das AMV VOIP 5188 Gateway halte ich
absolut um ganze "Ecken" für leistungsfähiger, eventuell liegt es auch daran.


@miscmike
- Check doch mal die LAN Ports der neuen FB 7390
- Überlege Dir einfach mal ob man die FB 5188 nicht gegen ein gleich starkes Gateway,
und sei es drum einen Router/Firewall mit DMZ Funktion zu kaufen und zusätzlich eine
TK Anlage, hätte ersetzen sollen.
- Einen Cisco Switch aus der SG-200 oder SG-300 Serie nicht das Netzwerk richtig bereichern würde.

Auch wenn es viele Admins so machen ich würde auch nicht einen Server direkt an den Router bzw.
die Firewall hängen wollen, sondern immer einen Switch dazwischen stellen wollen.
DMZ = Layer2
LAN = Layer3

Gruß
Dobby
Bitte warten ..
Mitglied: certifiedit.net
23.12.2013 um 00:57 Uhr
Hallo dobby,

es gibt noch Zwischenstufen zwischen gut dimensioniert (mit Puffer) und oversized.
2 HexaCores mit den Werten müssen schon genutzt werden. Wenn ich mir bedenke, wo und was ich bei 1x Cores noch Puffer hätte (DualSocketSysteme)

Zu den 100M Ports: Genau das meinte ich. Energiesparen usw.
Zu den Leistungsdaten an sich -Größe des NW etc hat er ja nichts genannt, bleibt also nur raten.

LG
Bitte warten ..
Mitglied: Dobby
23.12.2013 um 01:39 Uhr
es gibt noch Zwischenstufen zwischen gut dimensioniert (mit Puffer) und oversized.
Eigentlich hast Du ja recht, ich wollte Dir auch nicht zu nahe treten, aber ich finde es
besser so herum als wenn ich mir hier immer den genau anders herum gelagerten Teil
ansehen muss, also Server mit 2 GB RAM, auf einem DUAL Core PC Prozzi und SATA
Festplatten die schön günstig waren und einen RAID Controller der gar keiner ist und einem
Netzteil vom letzten Aldi PC und als Sicherung noch eine USB Festplatte und wenn es ein
Luxus Backup ist sind zwei USB Festplatten mit im Spiel.

Dann lieber 2 x Intel Xeon E5-2690 und xyz GB ECC/REG mit einem Adaptec 6805 und wenn
mal etwas mehr Arbeit ansteht macht der Server das eben gleich mit "links" noch neben bei mit.

Gruß
Dobby
Bitte warten ..
Mitglied: miscmike
23.12.2013 um 09:14 Uhr
Oha - die vielen "Nachtschichter" haben ganze Arbeit geleistet. Vielen Dank vorerst für Eure Mühe.

Zur Erklärung (ich wollte keinen Riesenroman schreiben) :


Die FritzBox hängt zwischen Switch (managebarer Gigabitswitch von Netgear) und Router von dem ortsansässigen Monopolisten, der hier die
Zugänge zur Verfügung stellt. Die Ports sind natürlich auf 1000 gestellt.

Es stimmt, das 5188 finde ich für solche Zwecke deutlich besser - lief ja bisher auch damit. Dummerweise hat AVM die Produktion eingestellt, weil man
der Meinung ist, die Fritzboxen können das auch (naja).

Zweck der Fritzbox ist lediglich folgender : 1. Routing von Internetanfragen nach draußen , 2. zur Verfügung stellen von VPN Verbindungen für eine Niederlassung sowie
mobile Mitarbeiter. Bisher war das alles super.

Absicherung ist vorhanden - div. Firewalls sowie Kaspersky Business Security im gesamten Netz

Wenn ich Dateien von Server A nach Server B oder umgekehrt kopiere, beide Server an einem Switch hängen - ist doch die Fritzbox außen vor ?
Oder sehe ich das falsch ? Denn selbst bei diesem Vorgang schläft dem Server die Fresse ein )

Ich bin ziemlich sicher, dass das vor dem Ausfall des 5188 nicht so war.

Nochmal die Reihenfolge : 1. alles i.O, 2. Ausfall des 5188, 3. 1,5 Tage ohne Router gelaufen (natürlich ohne Außenverbindung), 4. Fritzbox mit gleicher IP-Adresse, VPN Verbindungen und allen anderen Funktionen abgeschaltet.

Ich weiß, Fritzboxen in Unternehmen sind nicht gern gesehen, aber für diese Funktionen glaube ich ausreichend. Außerdem war die am schnellsten zu beschaffen.

Kurz zum Thema Dimensionierung :

Das (lokale) Netz besteht aus dem genannten Server (mit 5 VMs), einem Backup-Server, einem Citrix-Xenserver (mit 15 VMs), sowie 10 Clients und ein paar Druckern.
Der Server ist deshalb so dimensioniert, da er eben auch bei Verwendung der VMs nicht gleich aufgibt. Das hat bisher auch immer gut funktioniert.

@wiesi200 : Ja, kopieren über die administrative Freigabe hat denselben Bremseffekt - wobei stop, es war \\servername\e$ , über die IP teste ich gleich mal....

Die anderen Tests kann ich auch noch machen, wenngleich ich ein Netzwerkproblem vermute, welches vorher nicht da war...

Viele Grüße

Der Mike
Bitte warten ..
Mitglied: wiesi200
23.12.2013 um 09:22 Uhr
Es gibt aber auch noch andere Hersteller außer AVM die Router Herstellen.
Bitte warten ..
Mitglied: Dobby
23.12.2013 um 09:34 Uhr
Wenn ich Dateien von Server A nach Server B oder umgekehrt kopiere, beide Server an einem Switch hängen -
ist doch die Fritzbox außen vor ?
Ja genau das meinte ich damit auch als ich von zwei Routingpunkten im Netzwerk sprach, zumindest wenn es ein Layer3
Switch ist, der selber routet und nicht ein Layer2 Switch der von der Fritz!Box mit versorgt werden muss.

Oder sehe ich das falsch ?
Nein

Denn selbst bei diesem Vorgang schläft dem Server die Fresse ein
Ich täte den auch nicht direkt an einem Router anschließen wollen, sondern dann einen Switch dazwischen packen.
Ich würde an Deiner Stelle einmal in das Menü der AVM Fritz!Box und dann dort ganz gezielt in die Ernergiesparoptionen
und nach den Ports gucken wollen ob die auch wirklich auf 1 GBit/s laufen und nicht nur auf 100 MBit/s.

Ich weiß, Fritzboxen in Unternehmen sind nicht gern gesehen, aber für diese Funktionen glaube ich ausreichend.
Außerdem war die am schnellsten zu beschaffen.
Na dann beschwere Dich bitte auch nicht, dann läuft ja alles.

Gruß
Dobby
Bitte warten ..
Mitglied: miscmike
23.12.2013 um 09:41 Uhr
Ääähm - ich hatte grade doch beschrieben, das die Ports alle auf 1000MBit/s eingestellt sind (sind nur zwei belegt, einer in Richtung Router, einer in Richtung Switch)
Und die Server hängen NICHT direkt an der Fritzbox sondern am Switch.

Ganz so der Anfänger bin ich nun auch nicht.

Ich beschwere mich nicht, sondern suche Gedankenansätze, die zur Lösung führen.

Ich fahre übrigens nachher mal rüber zum Kunden, um Vor Ort mal ein paar Tests zu machen ...

VG

Mike
Bitte warten ..
Mitglied: Dobby
23.12.2013 um 10:13 Uhr
Ääähm - ich hatte grade doch beschrieben, das die Ports alle auf 1000MBit/s eingestellt sind
(sind nur zwei belegt, einer in Richtung Router, einer in Richtung Switch)
oh wie peinlich den habe ich dann wohl mal gepflegt überlesen, der geht dann an mein Konto.

Und die Server hängen NICHT direkt an der Fritzbox sondern am Switch.
Jo würde ich zumindest immer so machen wollen, macht ja auch jeder wie er will

Ganz so der Anfänger bin ich nun auch nicht.
Habe ich auch nicht behauptet! Auch nicht angespielt.

Ich beschwere mich nicht, sondern suche Gedankenansätze, die zur Lösung führen.
Hier ging es um die FB von AVM die eine AVM Lösung (5188) hat ca. ~499 € gekostet
und wird nun durch eine 200 € Lösung ersetzt, daher mein Einwand.

Ärgere Dich nicht darüber, geschrieben ist eben nicht gesprochen und hinter jeden Satz ein
Smily finde ich in unserem Alter eher weniger hilfreich.

Gruß
Dobby
Bitte warten ..
Mitglied: miscmike
23.12.2013 um 12:44 Uhr
Hi D.o.b.b.y ,

war ja auch nicht böse gemeint - und Smilies sind manchmal nicht so übel

So, zum aktuellen Stand : MURPHY hat wieder zugeschlagen - alles was geht, geht auch schief..

Ich war grad beim Kunden. Beim Öffnen der Tür zum Serverraum hat es mich fast umgehauen - so viele rote LEDs an Servern hat man selten..
Es waren so ca. 50°C drin, die Klimaanlage ist ausgefallen, Metallteile (Gehäuse, Schrank usw.) konnte man zwar noch anfassen, allerdings war es sehr
sehr heiß.

Der Switch hat sich mit sich selbst beschäftigt - deshalb sind wohl auch keine Meldungen über Temperaturen "nach außen" gedrungen.

Workaraound : Alles aus (ging ja eh nix mehr), Tür auf, Klimaanlage auf volle Pulle Turbo gestellt, nach ca. 2 Stunden Switche und Server wieder hochgefahren.

Ich würde jetzt noch nicht behaupten, dass das die Lösung war - man weiß ja nie, was jetzt alles "zerkocht" wurde, aber im Moment sieht es ganz gut aus.


... daran denkt ja auch keiner ... und leider kam beim Kunden vor Ort keiner auf die Idee, mal die Tür aufzumachen...

Viele Gruße

Mike
Bitte warten ..
Mitglied: wiesi200
23.12.2013 um 12:55 Uhr
Zerbraten tut es da nicht mehr viel. Die Server Takten einfach runter.
Was die Geschwindigkeit erklären würde.

Das sollte sich dann sehr schnell wieder beruhigen.
Bitte warten ..
Mitglied: miscmike
23.12.2013 um 12:58 Uhr
Die Server ja - aber Switche ????? Die konntest Du nicht wirklich anfassen und mit dem Lüfterstrom hätte ein Fön echte Konkurrenz gehabt.

Ich bin grad remote drauf - da ist momentan alles normal..
Bitte warten ..
Mitglied: certifiedit.net
23.12.2013 um 13:36 Uhr
Also doch die Hardware - hast du auf dem Server denn kein remote Management drin? (wäre ein bisschen schade bei den Specs - siehe oversized).

LG
Bitte warten ..
Mitglied: miscmike
23.12.2013 um 13:38 Uhr
Habs doch grad geschrieben - die Verbindungen zur Außenwelt waren auch am kochen (Murphys Gesetz), deshalb habe ich nix erfahren.
Hab jetzt die ganzen Meldungen im Block "nachgereicht" bekommen.....
VG
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Hyper-V
gelöst Win Server 2012 und Hyper V gleich Netzwerk extrem langsam (20)

Frage von Edaseins zum Thema Hyper-V ...

Vmware
gelöst Server 2008 R2 in VMware (ESX-Farm) extrem langsam (10)

Frage von YotYot zum Thema Vmware ...

Windows Update
gelöst WSUS-Downloads im LAN extrem langsam seit Win-10-Anniversary-Update 1607 (1)

Frage von departure69 zum Thema Windows Update ...

Windows 10
FTP ist extrem langsam (3)

Frage von grka zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...