Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkabbrüche bei Netgear Switches

Frage Netzwerke

Mitglied: Netzwerkkobold

Netzwerkkobold (Level 1) - Jetzt verbinden

12.05.2010 um 10:39 Uhr, 5471 Aufrufe, 11 Kommentare

Hallo zusammen,

wir haben ein sehr merkwürdiges Problem in unserem Netzwerk. Zunächst möchte ich erstmal kurz den Netzaufbau beschreiben:

Wir haben insgesamt 9 Netgear-Switches (FSM7250RS, 48-Port), wobei immer 3 von ihnen als Stack konfiguriert sind und für die Netzwerkanbindung eines Gebäudeteils zuständig sind. Port 49 und Port 50 sind LWL-Ports und sind innerhalb des Stacks als Port-Trunk konfiguriert (Sprich Trunk 1 = Gerät A Port 49 + Gerät B Port 49 + Gerät C Port 49), d.h. es gibt pro Stack 2 Port-Trunks. Die 2 LWL-Ports sind zusätzlich als Spanning Tree Ports konfiguriert, sodass Port-Trunk 2 bei einem Ausfall der Leitungen von Port-Trunk 1 die komplette Arbeit übernehmen kann.
Die Netgear-Stacks sind via LWL an Nortel-Stacks angebunden (je Stack 3 Ports als Port-Trunk konfiguriert).

Jetzt haben wir folgendes Problem:

In 2 Gebäudeteilen ist der entsprechende Stack manchmal nicht pingbar, arbeitet aber weiter. Jetzt hatten wir letztens das Problem, dass alle Clients die an einem Switch hingen über langsame Netzwerkverbindungen klagten. Der entsprechende Switch wurde eingesendet und umgetauscht. Der neue Switch zeigt aber genau die selben Probleme... Jetzt haben wir die redundanten Leitungen aus allen 50er Ports des Problem-Stacks herausgezogen und die Netzwerkverbindung funktioniert ohne Probleme! Ein ähnliches Problem hatten wir mit einem anderen Stack in einem anderen Gebäudeteil, allerdings hat dieser bei einstecken der redundanten Leitungen gleich das gesamte Netzwerk lahm gelegt.

Wir schätzen, dass es etwas mit dem STP zu tun hat, da es ohne die redundanten Leitungen ja funktioniert. Allerdings ist es merkwürdig, dass nur 2 Stacks von 3 diese Probleme aufweisen, obwohl alle 9 Switches die gleiche Konfig+Firmware haben.

Über Denkanstöße oder Lösungsvorschläge würde ich mich sehr freuen

Vielen Dank und LG,
Netzwerkkobold.
Mitglied: dog
12.05.2010 um 10:41 Uhr
Bei Netgear würde ich das unter Kategorie "normal" einordnen.
Wirklich gegenprüfen kannst du das auch nur mit Geräten anderer Hersteller.
Bitte warten ..
Mitglied: SamvanRatt
12.05.2010 um 11:23 Uhr
Hi
habt ihr bei den Netgear (wir nutzen die im Autarken Netz umfeld, da einfach billiger als unsere Nortel/Enterasys Standards) Failover oder LoadBalancing genutzt; bei ersterem sollte das nicht vorkommen, bei letzterem kenne ich es auch von anderen Marken, die dabei sind in die Lukrative Firmenwelt zu sehen.
Du mußt dich auch damit abfinden das ein 1k EUR Switch/Router (wir haben die 7324 in Benutzung) nicht mit einem Nortel Pathway für 100k mithalten kann, obwohl beide die selbe I/O Konnektivität mit bringt. Bei meinen Cabletrons SSR8000 (auf denen ich gelernt habe nachdem mit Cisco Schluß war) waren Redundanz und 24/7, NoDowntime auch groß dabei) gehört nur ein Befehl dazu eine Redundanz zu legen (damals war noch nichts mit Konfig GUIs), aber welcher Art (Failover, MulitlevelFailover, LoadBalance mit Least Queue, Round Robin, Miniqueue, ....) und was darüber gehen soll ist nicht ganz so banal.
Mit Enterasys/Foundry Networks/Extreme habe ich beste Erfahrung gemacht wenn man nicht das Geld für mehr hat. Immerhin stehen bei einem Netzwerkausfall auch schnell mal viele Leute untätig rum was dem Geld gegenüber steht (wie beim Backup)
Gruß
Sam
Bitte warten ..
Mitglied: aqui
12.05.2010 um 11:44 Uhr
Die weitere Frage ist noch WELCHE Art von Spanning Tree ihr einsetzt ??? Man kann wohl davon ausgehen das die Billigheimer NetGear nur simples olles 802.3d STP können und das auch nur als global STP Prozess.
Macht ihr nun Per VLAN STP oder MSTP auf den Nortel kracht es natürlich sofort mit den Symptomen die du oben schilderst.
Leider warst du ja nicht in der Lage diese Informationen zu liefern oder einmal einen Log Auszug aus den Nortels oder NetGears bzwgl. des STP Verhaltens.
So bleibt einem bei der oberflächlichen Schilderung ohne Fakten leider mal wieder nur das_hier für eine mögliche Lösung
Es ist aber davon auszugehen das dies, wie immer, eine STP Fehlkonfiguration ist, vermutlich aus Unkenntnis einer richtigen und durchgängigen STP oder RSTP Konfiguration mit den beteiligten Herstellern !!
Bitte warten ..
Mitglied: dog
12.05.2010 um 11:59 Uhr
Du mußt dich auch damit abfinden das ein 1k EUR Switch/Router (wir haben die 7324 in Benutzung) nicht mit einem Nortel Pathway für 100k mithalten kann

Wir wollen mal die Kirche im Dorf lassen
Ich (und viele andere auch) würde einen 1k€ Switch nicht mal als Core-Switch genehmigt bekommen...

Und wer Netgear benutzt der hat sicher auch kein RZ mit 99,9999% Uptime SLAs
Bitte warten ..
Mitglied: SamvanRatt
12.05.2010 um 12:11 Uhr
Hi dog
das ist schon klar. Die guten Switches liefern aber wenigstens gute Logs und verhindern oft solche Fehlkonfigs (was nicht heißt das man ein IOS nicht die schönsten toten Repeater bauen kann). Beim NG habe ich solche Fehler eben mit LoadBalance aufbauen können OHNE einen Fehler für die Paketverluste zu sehen (da frägt man sich dann auch wofür man einen managebaren L3 Switch vor sich hat).
Gruß
Sam
Bitte warten ..
Mitglied: aqui
12.05.2010 um 12:14 Uhr
@Sam
... ."das man ein IOS nicht die schönsten toten Repeater bauen kann".. Das Rätsel dieses kryptischen Satzes musst du nochmal auflösen ?!
Bitte warten ..
Mitglied: Netzwerkkobold
12.05.2010 um 13:36 Uhr
Hallo,

Entschuldigung, dass ich nicht alle Daten gepostet habe.
Hier sind die restlichen Daten:

Auf beiden Seiten (Netgear und Nortel) wird das Rapid Spanning Tree Protocol (IEEE 802.1w) verwendet. Auf den Netgear Geräten lässt sich nicht viel mehr einstellen, außer der Art des STP und auf welchen Ports es läuft.
Das Error-Log der Netgears ist nicht sehr aussagekräftig (EVENT> bootos.c 280 87FFFE00) und enthält auch keine Datums/Uhrzeitanzeige. Das Trap-Log besagt nur, dass die Ports für das STP geändert wurden (48 days 13:29:15--Spanning Tree Topology Change Initiated: 0, Interface(u/s/p): 0/1/1 , Unit: 1 | 48 days 13:29:15--Spanning Tree Topology Change: 0, Unit: 1).

Das Log der Nortels zeigt nur in dem Zeitraum der Probleme an "Link UP/DOWN" für die konfigurierten Ports (Link Up Trap for Unit/Port: 2 / 18).

VG
Bitte warten ..
Mitglied: aqui
12.05.2010 um 18:30 Uhr
  • Benutzt ihr VLANs ?
  • Wenn ja ist auf den Nortel Switches "Per VLAN STP" konfiguriert. Also ein separater RSTP Prozess pro VLAN ??
Hier mal im PVST Test zu Cisco ..
http://www.nortel.com/products/02/bstk/switches/collateral/0304_tolly.p ...
Diese Antwort schuldest du uns noch... !!
Bitte warten ..
Mitglied: SamvanRatt
12.05.2010 um 21:44 Uhr
Hi aqui
Ein Router/Repeater der nicht weiter repeatet sondern nur zurück echot sollte damit gemeint sein.
Das simpelste was mir dazu einfällt wäre ein SplitHorizon auf sein Eingangsinterface oder ein ReversePoisoning auf das Ausgabeinterface. (Ciscos) IOS12.1 (das letzte worauf ich meine Scheine gemacht habe) fängt das nicht ab; allerdings da kommt das Thema Logs wieder hervor: Bei Billiggeräten ist meist ein schlechtes bis gar kein Log vorhanden, während man sich bei den besseren von veryverbose bis zu extraquiet alles haben kann, wodurch eine geführte Fehlersuche wesentlich vereinfacht wird, siehe den Post unter mir. Bei "meinen" SSR8000 (das waren wohl die hochwertigsten Geräte meiner Netztech Laufbahn) wurde vor Übernahme der Regel auch das syntaktische Zusammenspiel überprüft und Probleme angezeigt, ähnlich einem Precompiler. Vor 12 Jahren war das schon was. Mittlerweile ist im IOS ja auch ein GUI Frontend drinnen.
Gruß
Sam
Bitte warten ..
Mitglied: Netzwerkkobold
17.05.2010 um 09:06 Uhr
Hallo,

nein VLANs benutzen wir nicht für STP.

VG.
Bitte warten ..
Mitglied: aqui
20.05.2010 um 12:36 Uhr
OK, dann wäre in jedem Fall wichtig zu wissen ob die Nortels PVST machen oder nicht. Normalerweise machen sie es auch wenn du nur ein einziges VLAN hast (das default VLAN) auf den Nortels.
Damit wären sie dann inkompatibel zu den NetGears und das wäre eine plausible Erklärung für das o.a. Verhalten.
Vermutlich können die NetGear Billigteile wie alle diese Billigheimer nur ein simples Global Single Spanning Tree und kein PVST ! Entsprechend musst du auch die Nortels dann so einstellen in der STP Konfig.
Solange du aber zu den STP Einstellungen/Konfigs an den Nortels und den NetGears nichts konkretes sagst kann man die Frage bzw. das Problem nicht sicher identifizieren ohne raten zu müssen.
Ggf. hilft eine Spanning Tree Debugging auf den Nortels...dann siehst du es auch sofort !
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst HP Switches - Frage zu Spanning Tree bzw. Loop Back Protection (12)

Frage von chfran zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Netgear N150 als Repeater für das Hitron CVE 30360 (2)

Frage von spexx zum Thema Router & Routing ...

Switche und Hubs
gelöst Frage zu SFP+ Einschub für Cisco SG-500X Switches (4)

Frage von the-datzl zum Thema Switche und Hubs ...

Router & Routing
gelöst Cisco-HP-Netgear (3)

Frage von homermg zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...