Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkausfälle eingrenzen, aber wie?

Frage Microsoft Windows Netzwerk

Mitglied: Xpactor

Xpactor (Level 1) - Jetzt verbinden

15.10.2009, aktualisiert 18.10.2012, 9165 Aufrufe, 16 Kommentare

Hallo zusammen,

Ich bin auf der Suche nach einer Methodik Netzwerkausfälle einzugrenzen...

Bis jetzt habe ich Nagios in betriebgenommen. Erkenntnis: ein WLAN Router fällt immer vorher heraus...



Problembeschreibung

In unserem Firmennetz haben wir teilweise Ausfälle, diese gestallten sich so, das der DC, sowie Exchange und TS für die Mitarbeiter nicht mehr erreichbar sind, ca. 20 Minuten lang, danach ist alles wieder okay.
Die Ausfälle kommen nicht periodisch vor, es kann sein, dass 2-3 Wochen alles gut geht und dann, in einer Woche alle 1-2 Tage Ausfälle vorkommen. Es sind auch keine besonderen Ereignisse (Reinigungskraft, Externe Mitarbeiter, Backups, oder Ähnliches) zur Zeit der Ausfälle geplant bzw. im Haus.


Bisher unternommene Massnahmen

Nagios

Nun habe ich als erste Massnahme Nagios in berieb genommen, damit ich das Netzwerk überwachen kann.
Dort ist mir aufgefallen das ein WLAN AP (WAP200) immer vor dem Netzwerkausfall ausfällt.

Neue WLAN AP

In unserem Netzwerk habe ich in letzter Zeit zwei WAP200 WLAN APs von Linksys in betrieb genommen.


Konfiguration

WLAN
WAP200-1

  • Mode: AP
  • Verschlüsselung: WAP2/PSK
  • SSID: Netz1

WAP200-2
  • Mode: AP
  • Verschlüsselung: WAP2/PSK
  • SSID: Netz2

Netzwerk

192.168.27.x/32 Netz

Meine Rechner :

  • Windows Server 2008 als DC, DHCP, DNS
  • Windows Server 2008 mit Exchangeserver 2007 (Virtuell auf DC)
  • Windows Server 2008 mit TS (Virtuell auf DC)
  • 20 Clients (XP Pro)
  • ca. 20 VMs (Verschiedene Windows Versionen (2003 Server, XP Pro, Suse)
  • ca. 10 Entwicklungsserver (Verschiedene Windows Versionen (2003 Server, XP Pro, Suse)


Fragestellung

  • Kann es an diesem einen WLAN AP liegen das das Netzwerk nicht richtig funktioniert? Oder meint ihr es ist eine Fehlkonfiguration?
  • Nagios ist ja ein praktisches Tool zu analysieren, jedoch findet es keine Fehler... Gibt es ein Tool welches das Netzwerk nach Fehlkonfigurationen Scannt?

Ich wäre für jegliche Hilfestellungen und Ideen Dankbar.

Danke schon im Voraus,

Grüsse Mat
Mitglied: Iwan
15.10.2009 um 11:20 Uhr
Hallo,

ich finde es gut, das die Formatierungshilfe so ausgiebig nutzt. Allerdings solltest du den Text noch mal Korrektur lesen, aber das nur am Rande.
Wenn die Möglichkeit besteht und den Verdacht hast, das dieser eine AP für die Ausfälle zuständig ist, dann tausch ihn doch mal aus.
Wie sieht es denn mit anderen LAN-Komponenten aus oder besteht eure Netzwerkstruktur nur aus diesen beiden APs?
Bitte warten ..
Mitglied: Houben
15.10.2009 um 11:46 Uhr
Hallo,

schau doch mal mit Wireshark nach, ob du viele Broadcasts im Netz hast.
Bitte warten ..
Mitglied: Xpactor
15.10.2009 um 12:00 Uhr
Danke erstmal für die schnelle Antwort.

Es ist so, das wir in einer langwierigen Migrationsphase von Windows Server 2003 auf Windows 2008 Server sind. Vor der Umstellung lief das Netzwerk problemlos. Wir haben uns zur Umstellung entschieden, weil der alte DC schon lange am Anschlag lief.
In dieser Migrationsphase wurde der DC neu aufgesetzt auf einem neuen Server mit Windows 2008. Es wurden ebenfalls die meisten Switches ersetzt. Da wäre noch zu erwähnen, dass der alte DC immer noch steht, kann es evtl. auch an dem liegen, das ich 2 DCs im Netz habe mit verschiedenen Domains?

Den WLAN AP habe ich zwar schon mehrmals für 2-3 Tage vom Netz genommen, ich hatte zwar in dieser Zeit keine Ausfälle, jedoch kann das auch nur Zufall sein, dass in dieser Zeit das Netzwerk Problemlos lief. Da ich den Ausfall nicht genau eingrenzen kann, auch Zeitlich nicht, will ich nicht einfach so einen neuen AP einkaufen, bevor ich nicht genau weiss, das dieser den Ausfall auslöst.
Bitte warten ..
Mitglied: Woolfsmann
15.10.2009 um 14:47 Uhr
Hi,

du schreibst das Ihr auch die Switche getauscht habt.

Was sind das für neue Switche, und habt Ihr Spanning-tree Portfast aktiv?

Ich kann man an ein ähnliches Probelm erinnern, ist schon ein bisschen her damals war es ein Loop im Netz. Der auch immer nur Zeitweise zu ausfällen geführt hat.


gruß
Woolfsmann
Bitte warten ..
Mitglied: Xpactor
15.10.2009 um 15:03 Uhr
Einerseits wurden die Switche in den Büroräumen gewechselt. Andererseits ein 16 Port Switch gengen einen 24 Port Switch, alle Switche sind unmanaged.

Wo kann ich das mit dem Spanning-tree Portfast überprüfen?

Jedoch hätte beim verkabeln ein Fehler passieren können, also Loops auf den Swich. Werde gleich noch alle Switche durchgehen.

@ Houben:

Bin gerade noch am Wireshark Studieren... werde mich melden sobald ich mehr weiss.
Bitte warten ..
Mitglied: aqui
15.10.2009 um 15:24 Uhr
Deine Beschreibung ist ziemlich oberflächlich, denn du zählst mit sinnloser Formatierung (von den zig Dreckfuhlern mal ganz abgesehen die man hätte mit einem Klick auf "Bearbeiten" korrigiert) nur die Komponenten auf die im Netz vorhanden sind. Nicht aber die Infrastruktur selber.
Aus was besteht denn dein Netz ??
Aus einem einzigen billigen Taiwan Switch vom Blödmarkt...??
Oder einem redundanten Netzwerk wie sowas hier:
cbd02541153fdaf4376026b03fd512a5-switchnetz - Klicke auf das Bild, um es zu vergrößern
Folglich kann man also nur raten ob es Redundanzprotokolle, der Switch, die Netzwerkkarte(n), das Kabel, die Dosen.... oder oder oder ist ?
Wo soll man mit deiner Beschreibung anfangen und aufhören.
Nagios ist da mehr ein dilletantischer Versuch... wenn der die ausgefallene Dienste zeigt weisst du ja nur das sie weg sind. Ob das an einem falsch gecrimpten Kabel liegt oder an einem Switch der kollabiert ist an Broadcast Stürmen oder Loops, oder am kaputten Netzteil vom Server siehst du ja noch lange nicht.....
Dafür brauchst du dann eher eine Kristallkugel denn ein Nagios ! Mit Wireshark und einem konsequenten Switchcheck bist du eher besser beraten, denn die Infrastruktur sollte dein erster Schritt sein um hier KEINE Fehler zu haben....alles ander sind immer Folgefehler davon, logisch !!
Bitte warten ..
Mitglied: Woolfsmann
15.10.2009 um 15:26 Uhr
Wenn die Switche unmanaged sind kannst du auch kein Spanning-tree einstellen. Da must du in den Unterlagen der Switche gucken ob die das vielleicht mitbringen. Geh ich aber mal nicht von aus.

Guck dir die Switche an ob du was findest, wenn nicht könnte Houben's Tipp auch gut Helfen.

gruß
Bitte warten ..
Mitglied: Xpactor
15.10.2009 um 17:34 Uhr
Da ich leider ein dilettant bin, was Netzwerke angeht, kann ich keine Grafik wie die obenstehende liefern.
Jedoch kann ich zusammentragen was im Netzwerk steht und hoffen das man damit was anfangen kann.

b13766b79d5fa189b93c3eb3d570179b-network - Klicke auf das Bild, um es zu vergrößern

Mir ist auch bewusst das die Grundlage stimmen muss, damit man was Bauen kann. Es führen keine Kabel auf Switches zurück. Ebenfalls habe ich den WLAN AP heute abgehängt, hatte wieder Ausfälle im Netz, somit kann der WLAN AP ausgeschlossen werden.

Folgendes konnte ich beobachten:

  • Wenn ich wärend dem Ausfall auf dem DC die Netzwerkbrücke (2 Netzwerkkarten zusammengeschlossen) deaktiviere, den DHCP und DNS neustarte und die Netzwerkbrücke wieder aktiviere, geht es wieder.
Bitte warten ..
Mitglied: aqui
15.10.2009, aktualisiert 18.10.2012
Warum ist es eigentlich so schwer KEINE externen Grafik Links zu benutzen ???
Adminstrator.de hat eine Funktion zum Uploaden von Bildern !!!

(Ursprungsthread oben mit "Bearbeiten" editieren, Bild hinzufügen anklicken, Bild hochladen, auf den URL mit einem Rechtsklick "alles markieren", nochmal und "Kopieren", Bild URL dann in die Antwort hier pasten.
Was ist daran so schwer..... ?? Wenns an sowas schon hapert, wie soll das denn erst beim Troubleshooting werden zu dem o.a. Problem ??!! )


Würg...wozu denn ein Netzwerkbrücke ??? Das ist dein Ursprungsproblem !!!
Wie man sowas richtig macht steht hier:

http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Setz das genau so um und dann bist du garantiert auf einen Schlag alle deine Probleme los !
Mit einer Netzwerkbrücke ganz bestimmt NICHT !
Bitte warten ..
Mitglied: 2hard4you
15.10.2009 um 22:42 Uhr
Moin,

also die Verbindungsausfälle beseitigt es sicher nicht - aber warum nimmst Du nen W2k8 als VM in nen W2k8, nur um TS zu spielen - datt kann der auch direkt

Gruß

24
Bitte warten ..
Mitglied: Xpactor
17.10.2009 um 10:47 Uhr
Hallo aqui

Danke für den Hinweis mit dem Bild.

Die Netzwerkbrücke ist nicht dazu da 2 Netze zusammenzuführen, sonden die Netzwerkkarten zu "bündeln", also das ich 2 Netzwerkkarten habe, die auf eine IP hören. Weiss nicht ob dies der richtige Ansatz ist. Ich weiss aber zur Zeit keinen anderen, bzw. besseren.
Bitte warten ..
Mitglied: aqui
17.10.2009, aktualisiert 18.10.2012
@Xpactor
Also ein NIC Teaming...richtig ??

Hast du dann alles berücksichtigt was hier steht:
http://www.administrator.de/forum/motherboard-mit-2-onboard-lan-anschl% ...
http://www.administrator.de/forum/traffic-am-server-auf-2-nics-verteile ...
http://www.administrator.de/forum/kann-man-einen-server-zur-performaces ...
http://www.administrator.de/forum/bonding-mit-broadcom-slb-117829.html
http://www.administrator.de/forum/link-aggregation-frage-zur-hash-confi ...

Vermutlich machst du da einen groben Fehler was schon deine Beschreibung ganz schwer vermuten lässt !!
Eine Netzwerkbrücke ist kein Teaming oder eine Link Aggreagtion was du anstrebst !!
Wie gesagt eine Link Bündelung (Link Aggregation) heisst "Teaming" bei MS und muss zwingend auch auf der Switchseite konfiguriert werden !! Passiert das nicht, passiert das was in deinem Netz passiert, nämlich temporäre Loops und ein Ausfall des gesamten Netzwerks !
Lies dir die o.a. Threads genau durch und dann weisst du warum !! Das dort diskutierte sollten auch Laien verstehen !

Was du machst ist vollkommen falsch, vermutlich durch Unkenntniss der Verfahren und Protokolle, und führt bei dir im Netz zu temporären Loops die das Netz kollabieren lassen...
Ein typischer Fehler von Netzwerk Laien die nicht verstanndan haben was Bündelung, Teaming oder Link Aggregation ist, im Vergleich zu einer Netzwerkbrücke.
Das eine hat mit dem anderen rein gar nichts zu tun wie dir die o.a. Threads ja hoffentlich schnell klarmachen werden !!
Bitte warten ..
Mitglied: Xpactor
19.10.2009 um 10:37 Uhr
Du hast recht, ich gehe da einen völlig falschen weg.

Ich wollte ein Teaming einrichten, eichfach mit dem Gedanken die Performance zu erhöhen. Dies habe ich wie jadefalke (Traffic am Server auf 2 NICs verteilen) beschreibt, mit Markieren der NICs und "Verbindungen zusammenführen"...

Nun hatte ich am Samstag noch die Broadcom Treiber der NICs installiert. Damit ich im BACS (Broadcom Advanced Control Suit 3) ein Teaming einrichten kann, jedoch funktioniert danach im Netzwerk noch weniger als jetzt!

Ich hatte das folgende Problem:

Wenn ich auf einer VM den server anpingen wollte, sagte er mit die Adresse kann nicht gefunden werden, zeigt jedoch auf sich selbst! Beispiel:

ping 192.168.27.1
Antwort: 192.168.27.4 konnte nicht gefunden werden.

Ich habe nun wieder auf die MS "Netzwerkbrücke" umgestellt, da dies wenigstens einigermasen funktionier.

Da erhalte ich folgende IP Configuration.

01.
C:\>ipconfig /all 
02.
 
03.
Windows-IP-Konfiguration 
04.
 
05.
   Hostname  . . . . . . . . . . . . : SERVER01 
06.
   Primäres DNS-Suffix . . . . . . . : Domain.local 
07.
   Knotentyp . . . . . . . . . . . . : Hybrid 
08.
   IP-Routing aktiviert  . . . . . . : Nein 
09.
   WINS-Proxy aktiviert  . . . . . . : Nein 
10.
   DNS-Suffixsuchliste . . . . . . . : Domain.local 
11.
 
12.
Ethernet-Adapter Netzwerkbrücke: 
13.
 
14.
   Verbindungsspezifisches DNS-Suffix: 
15.
   Beschreibung. . . . . . . . . . . : MAC Bridge Miniport 
16.
   Physikalische Adresse . . . . . . : 02-1E-C9-CD-05-F7 
17.
   DHCP aktiviert. . . . . . . . . . : Nein 
18.
   Autokonfiguration aktiviert . . . : Ja 
19.
   IPv4-Adresse  . . . . . . . . . . : 192.168.27.1(Bevorzugt) 
20.
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0 
21.
   Standardgateway . . . . . . . . . : 192.168.27.2 
22.
   DNS-Server  . . . . . . . . . . . : 127.0.0.1 
23.
                                       81.221.250.10 
24.
   NetBIOS über TCP/IP . . . . . . . : Aktiviert 
25.
 
26.
Tunneladapter Local Area Connection* 8: 
27.
 
28.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
29.
   Verbindungsspezifisches DNS-Suffix: 
30.
   Beschreibung. . . . . . . . . . . : Microsoft ISATAP Adapter 
31.
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0 
32.
   DHCP aktiviert. . . . . . . . . . : Nein 
33.
   Autokonfiguration aktiviert . . . : Ja 
34.
 
35.
Tunneladapter Local Area Connection* 9: 
36.
 
37.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
38.
   Verbindungsspezifisches DNS-Suffix: 
39.
   Beschreibung. . . . . . . . . . . : Microsoft ISATAP Adapter #2 
40.
   Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0 
41.
   DHCP aktiviert. . . . . . . . . . : Nein 
42.
   Autokonfiguration aktiviert . . . : Ja 
43.
 
44.
Tunneladapter Local Area Connection* 11: 
45.
 
46.
   Medienstatus. . . . . . . . . . . : Medium getrennt 
47.
   Verbindungsspezifisches DNS-Suffix: 
48.
   Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface 
49.
   Physikalische Adresse . . . . . . : 02-00-54-55-4E-01 
50.
   DHCP aktiviert. . . . . . . . . . : Nein 
51.
   Autokonfiguration aktiviert . . . : Ja
Habe ich das richtig verstanden, dass für ein Teaming ein managed Switch zwingend erforderlich ist?
Bzw. Sollte ich einfach über eine NIC gehen... sprich, die 2. deaktivieren?

Ausserdem habe ich am Samstag noch entdeckt das auf dem alten DC, welcher immer noch im eigenen Netz (192.168.1.x) steht der DNS noch aktiv ist. Diesen habe ich nun daektiviert.
Bitte warten ..
Mitglied: aqui
19.10.2009 um 15:41 Uhr
Ja, eine Konfiguration des Switches auf dem die ge"Teamten" Links enden ist zwingend erforderlich damit es sauber funktioniert.
Das steht ja nun zuhauf auch in den o.a. Threads wenn du sie liest !
Die Funktion heisst 802.3ad, LACP oder wird oft auch "Trunking" genannt. Die ersten beiden Begriffe sind die technisch korrekten !
Ein managebarer Switch ist dafür zwingende Voraussetzung, denn du musst das ja auf den Switch Links konfigurieren !! (Wie sollte das bei einem doofen, ungemanagten Switch denn auch funktionieren der dieses Feature nicht supportet ?)
Mit doofen Switches vom Blödmarkt vom Grabbeltisch ist es definitiv NICHT zu machen.

Eine HP Konfiguration kannst du z.B. hier sehen:
Switch# conf t
Switch(config)# int eth 1-2, 5-6 lacp active
Switch(config)# wr m
Switch(config)# end

Das Kommando erzeugt einen 4fach gebündelten Link auf den Switchports 1 und 2 und 5 und 6 !
Bei anderen Herstellen geht das ähnlich oder über ein Web Konfig Interface mit Haken !

Deine o.a. Konfig hat immer noch die für dich tödliche Netzwerkbrücke aktiviert. Die muss definitiv raus, sonst werden deine Probleme nicht weniger !
Klar das auch ein richtiges Teaming auf Serverseite fehlschlägt wenn du den Switch nicht auf der anderen Seite konfigurierst !!
Auch das funktioniert definitiv NICHT !! Nur mit einem entsprechenden Switch der LACP / 802.3ad supportet !!
Bitte warten ..
Mitglied: Xpactor
19.10.2009 um 16:27 Uhr
Sehr gut, oder eben nicht

Da wäre eine warnung von Windows noch schön! (aber eben)
Ich nehme die Brücke heute abend mal raus und werde die Lage weiterhin beobachten.
Ich hoffe, damit ist die Sache weg von Tisch!

Danke vielmals für die Hilfestellung!!! Wäre ohne euch nie darauf gekommen.
Bitte warten ..
Mitglied: Xpactor
27.10.2009 um 09:02 Uhr
Das Netzwerk funktionier wieder einwandfrei.

Danke nochmals vielmals für die Hilfestellungen.

Gruss Mat
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...