Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkbrücke mit 2 x Cisco WRVS4400N V2

Frage Netzwerke Router & Routing

Mitglied: UncleSam

UncleSam (Level 1) - Jetzt verbinden

07.09.2009, aktualisiert 18.10.2012, 6862 Aufrufe, 5 Kommentare

Problem bei der Verbindung eines PCs über ein getrenntes Netzwerk in ein zweites Netzwerk.

Hallo zusammen!

Folgendes Problem stellt sich.

Ich habe für unser Geschäft (2 große Fotostudios) Router angeschafft, da die alten Server ihren Dienst verweigert haben und ausgemustert wurden.
Wir sitzen hauptsächlich in Studio 1, welches aus ca. 25 angeschlossenen Macs / PCs besteht, die ihre IP's dynamisch bis auf ein paar Ausnahmen (Fileserver, Netzwerkdrucker, etc) per DHCP zugeteilt bekommen.
Das Ganze ist ein Class A-Netz.

Der Router hat die IP 10.1.1.1 / 24 (255.255.255.0) und verteilt die IPs folgend an die Clients.

In Studio 2 gibt es lediglich einen angeschlossenen Mac und einen PC in der nebenanliegenden Wohnung des Chefs, die ihre IPs ebenfalls dynamisch von einem zweiten Router erhalten. ( 10.1.2.1 /24)
Da das Studio 2 für Mietkunden gedacht ist, darf keine direkte Verbindung zu Studio 1 bestehen, da sonst eingemietete Kunden u.U. auf das Netzwerk in Studio 1 zugreifen könnten.

Beide Router in beiden Studios sind jeweils an einem HP 2524 Switch angeschlossen, die über eine LWL-Leitung verbunden sind.
Diese wurde vor Abschaffung der alten Server genutzt, um nachts Backups vom Server in Studio1 auf den Server in Studio 2 zu fahren.

Diese Verbindung soll nun genutzt werden, um von einem PC aus der Wohnung des Chefs über das Netzwerk in Studio 2 -> LWL -> nach Studio 1 zugreifen zu können.
Sprich: Der besagte PC bekommt eine feste IP und soll über Router in Studio 2 das Netzwerk in Studio 1 zugreifen können.

Die Router in beiden Studios sind bau- und typgleich. Cisco WRVS4400N V2.

Wenn ich nun eine statische Route von Netz 2 zu Netz 1 einstelle, bspw:

Source: IP: 10.1.2.55 /24
Destination: IP: 10.1.1.0 /24

erreiche ich keine Verbindung. Klar, wegen der unterschiedlichen Netze.

Ich fragte mich, ob es nicht möglich wäre, dem Router in Studio 2 die DHCP-Funktion zu nehmen und ihn quasi nur als Gateway einzusetzen.
Router 1 soll dann die IPs für beide Netze zur Verfügung stellen.
Das würde bedeuten, dass alle per LAN oder WLAN angeschlossenen Clients in beiden Studios von ein und dem selben Router IP's zugeteilt bekämen.

Nun habe ich aber keinerlei Erfolg, eine Verbindung für den besagten PC herzustellen, noch IPs vom Router in Studio 1 nach Studio 2 zuzuteilen.


Es wäre nett, wenn ich ein paar Anregungen oder Tipps zur Konfiguration bekäme.
Mitglied: dog
07.09.2009 um 23:24 Uhr
Das Ganze ist ein Class A-Netz.

Vergiss das mal ganz schnell.
Es gibt nur noch CIDR und du hast da ein paar /24er Netze.

Ich würde das Problem anders löten.
Die 2524s sind managebare Switches.
Das heißt du kannst ganz einfach ein paar tagged VLANs über das Glasfaser-Kabel ziehen.
Den Port an dem der PC des Chefs hängt beschaltest du dann einfach untagged mit dem VLAN an dem auch die PCs in Studio 1 sind.
So ist der PC effektiv im selben Netz.

fca0b5b5a0c2ebf591feb776122ba911-layout - Klicke auf das Bild, um es zu vergrößern

Grüße

Max
Bitte warten ..
Mitglied: aqui
08.09.2009, aktualisiert 18.10.2012
Der Witz schlechthin ist ja: "...Da das Studio 2 für Mietkunden gedacht ist, darf keine direkte Verbindung zu Studio 1 bestehen, da sonst eingemietete Kunden u.U. auf das Netzwerk in Studio 1 zugreifen könnten...."

Und gleich im nächsten Satz steht dann: "...jeweils an einem HP 2524 Switch angeschlossen, die über eine LWL-Leitung verbunden sind..."

Frage: Wie passt das denn zusammen ?? Mit der LWL Leitung sind beide Netze verbunden und alle Rechner sind offen für jedermann...inklusive aller Mietkunden oder wer sich auch immer an die Switches anschliesst.
Das ist also Unsinn was du da schreibst in Bezug auf die Trennung der Netze, denn da kann jeder auf jeden zugreifen.

Was du als allererstes machen musst ist die Netze zu trennen mit 2 VLANs und diese VLANs über einen tagged Link auf beide Switche zu bringen, genau so wie dog es oben beschrieben hat !!

Dann verbindest du die beiden VLANs mit einer kleinen kostenlosen Firewall wie hier im Tutorial beschrieben:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Als Billigversion geht auch ein DSL Router ohne Modem mit der DMZ des kleinen Mannes:
http://www.heise.de/netze/DMZ-selbst-gebaut--/artikel/78397

Noch einfacher ist aber in der Tat die Lösung von dog:
  • 2 VLANs einrichten
  • Switches und VLANs über eine tagged Link verbinden
  • Dem VLAN von Studio 1 das nun auch aus dem Switch in Studio 2 ist weist du einen (oder mehr) Ports für den Studio PC zu.
  • Dem VLAN in Studio 2 weist du den Rest der Ports zu

Damit können nun die PCs die zu euch gehören problemlos über den LWL Link und Router/Internet in Studio 1 arbeiten.
Der Rest Mietkunden ist davon vollkommen isoliert, da separates VLAN, und arbeitet über den Router in Studio 2.
Beide Netze solltest du so lassen, denn du benutzt zwar einen Class A Adresse aber mit einem separaten Class C (24 Bit) Subnetting.
Da du 2 unterschiedliche Netze betreibst ist das auch gut so das die sauber getrennt bleiben !!

Nähers zum Thema VLANs findest du hier:
http://www.heise.de/netze/VLAN-Virtuelles-LAN--/artikel/77832
Bitte warten ..
Mitglied: UncleSam
08.09.2009 um 12:14 Uhr
Vielen Dank für die Antworten!

Es ist mir klar, dass es sich bei 10.x.x.x /24 um kein echtes Class-A Netz handelt sondern ein Class-A in Class-C Größe.

dogs Variante ist so in dieser Form auch eingerichtet, inklusive der tagged VLANs.

Das Problem ist nur, dass ich keinerlei Verbindung zum Netzwerk in Studio 1 herstellen kann.
Der Client-PC, der verbunden werden soll, ist folgendermaßen konfiguriert:

IP: 10.1.2.2
SNM: 255.255.255.0
Gateway: 10.1.1.1

Allerdings erreiche ich den Router in Studio 1 per ping-Befehl nicht.
Eine Traceroute endet nach Router 2 (10.1.2.1) im nichts.

Muss ich zusätzlich ein statisches Routing vom Client-PC (10.1.2.2) nach 10.1.1.0
im Router 2 eintragen und / oder muss dieser Router sich ebenfalls im selben VLAN wie der Client-PC befinden?

Habe mehrere Möglichkeiten durchprobiert, leider mit mäßigem Erfolg.


Vielen Dank und beste Grüße
Bitte warten ..
Mitglied: dog
09.09.2009 um 00:59 Uhr
Also mal ganz langsam:

Die Konfiguration des HP-Switches in Studio 1:

01.
interface 25 
02.
	name "Downlink Studio 2" 
03.
exit 
04.
 
05.
interface 24 
06.
	name "DSL Router" 
07.
exit 
08.
 
09.
interface 23 
10.
	name "Router Studio 1 WAN" 
11.
exit 
12.
 
13.
interface 22 
14.
	name "Router Studio 1 LAN" 
15.
exit 
16.
 
17.
vlan 101 
18.
	name "vStudio 1" 
19.
	untagged 1-22 
20.
	tagged 25 
21.
exit 
22.
 
23.
vlan 7 
24.
	name "vRouter Transfer" 
25.
	untagged 23-24 
26.
	tagged 25 
27.
exit
Und die vom HP-Switch in Studio 2:

01.
interface 25 
02.
	name "Uplink Studio 1" 
03.
exit 
04.
 
05.
interface 24 
06.
	name "Router Studio 2 WAN" 
07.
exit 
08.
 
09.
interface 23 
10.
	name "Router Studio 2 LAN" 
11.
exit 
12.
 
13.
interface 1 
14.
	name "PC Chef" 
15.
exit 
16.
 
17.
vlan 101 
18.
	name "vStudio 1" 
19.
	untagged 1 
20.
	tagged 25 
21.
exit 
22.
 
23.
vlan 102 
24.
	name "vStudio 2" 
25.
	untagged 2-23 
26.
exit 
27.
 
28.
vlan 7 
29.
	name "vRouter Transfer" 
30.
	untagged 24 
31.
	tagged 25 
32.
exit
Dies entspricht meiner Grafik oben, davon ausgehend, dass:

- Port 25 bei beiden Switches der LWL-Port ist
- Der Chef am zweiten Switch auf Port 1 steckt
- An Switch 1 Port 24 ein dritter Router steckt, der die DSL-Verbindung herstellt
- Die beiden anderen Router jeweils im NAT-Modus an Switch1/Port23 und Switch2/Port24 mit ihrem WAN-Interface stecken
- Und an Switch1/Port22 und Switch2/Port23 mit ihrem LAN-Interface

Du hast damit drei getrennte Netzwerke, wobei die beiden Studios nicht untereinander kommunizieren können.

Grüße

Max
Bitte warten ..
Mitglied: UncleSam
09.09.2009 um 10:58 Uhr
Klasse Hilfe!

Vielen Dank, Dog.. es funktioniert!
Ich hatte einige Dreher in den Tagged/Untagged Ports.


Grüße aus Stuttgart,
UncleSam
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 8
gelöst Active Directory Default User.v2 Profile - Windows 8.1 Apps Error (4)

Frage von adm2015 zum Thema Windows 8 ...

Voice over IP
Cisco 2600xm SIP Trunk autentifizieren

Frage von Herbrich19 zum Thema Voice over IP ...

LAN, WAN, Wireless
gelöst Cisco Aironet Radio-Settings (6)

Frage von swisstom zum Thema LAN, WAN, Wireless ...

SAN, NAS, DAS
gelöst Cisco LAG-LACP an Synology RS3614xs+ Bonding Bandbreite zu niedrig (20)

Frage von Ex0r2k16 zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...