Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkdurchsatz Windows Server2012 R2 unterschiedlich

Frage Netzwerke LAN, WAN, Wireless

Mitglied: netzwerk

netzwerk (Level 1) - Jetzt verbinden

14.11.2014, aktualisiert 13:10 Uhr, 706 Aufrufe, 3 Kommentare

Hallo,

ich habe hier ein (zumindest für mich) merkwürdiges Phänomen und vielleicht hat der ein oder andere hier ja noch eine Idee, woran es liegen könnte...

Das Problem ist, dass die Netzwerkübertragung unterschiedlich ist, je nachdem, welche Maschine die Übertragung anstösst!

Das Testszenario ist wie folgt:
Zwei physikalische Server, identische Hardware (Dual XEON, 32GB RAM, SSD RAID 10), 4* Gigabit LAN mit statischer Link-Aggregation.
Ein Server läuft mit 2008R2 und der andere mit 2012R2 (Terminalserver). Wenn nun Daten von einem zum anderen Server übertragen werden, passiert folgendes:
2816a4f1ad5ab7c271f551a6ef53d379 - Klicke auf das Bild, um es zu vergrößern
Das ist der LAN Durchsatz, wenn ein 4GB File wie folgt kopiert wird:
1. (rot) vom 2008R2 Server zum 2012R2 Server - per Explorer auf dem 2008er Server angestossen
2. (gelb) vom 2012R2 Server zum 2008R2 Server - per Explorer auf dem 2008er Server angestossen
3. (rot) vom 2008R2 Server zum 2012R2 Server - per Explorer auf dem 2012er Server angestossen
4. (gelb) vom 2012R2 Server zum 2008R2 Server - per Explorer auf dem 2012er Server angestossen

1. und 2. zeigen, dass netzwerktechnisch alles OK ist, volle 1GBit/s sowohl bei lesen wie auch schreiben.
Wenn das ganze aber vom 2012er Server aus angestossen wird, bricht die Leistung stark ein, wie 3. und 4. zeigen!
HDD/RAID-Subsystem und CPU scheiden hier sicherlicherlich als Ursache aus.

Ich habe dann mit einer dritten Maschine (virtuelles Windows 8.1) quergecheckt...
...zunächst die Performance zwischen 8.1 VM und 2008R2 Server:
2d07d3346e16e6c5be3a6666fceb417b - Klicke auf das Bild, um es zu vergrößern
Und dann zwischen 8.1VM und 2012R2 Server:
ba74c5a8c9a4a4f99bbb12ebf7cb5399 - Klicke auf das Bild, um es zu vergrößern
Dass hier die Performance beim schreiben auf die VM einbricht liegt am HDD-System in der VM.
Aber: Identische Werte, egal auf welcher Maschine man die Übertragung anstösst! So sollte es sein.

Hat jemand vielleicht einen Tipp, wo das Problem ursächlich zu suchen ist?
Warum tritt das Problem nur zwischen 2008R2 und 2012R2 auf, wenn vom 2012er Server angestossen?
Die Messungen sind reproduzierbar und unabhängig von der Filegröße.
Beim schreiben auf den 2012er Server nutzt er nur knapp 2/3 der 1GBit Leitung aus.

Bin für jeden Tipp dankbar!!

Vielen Dank

Ein verzweifelnder Netzwerker...
Mitglied: DerWoWusste
14.11.2014, aktualisiert um 13:21 Uhr
Hi.

Du machst einen Kardinalfehler: Du benchmarkst ein Netzwerkproblem mittels Dateitransfers. Benchmarke es ausschließlich über die Netzwerkkarte mit geeigneten Tools. So werden dann Festplattenperformance und Virenscanner als Ursache wirklich ausgeschlossen.

Nimm http://www.ars.de/ars/ars.nsf/docs/netio
Bitte warten ..
Mitglied: netzwerk
14.11.2014 um 14:03 Uhr
Hallo DerWoWusste,

Danke für den Hinweis, gesagt, getan. NETIO zeigt identische Werte um 100-110MB/s für "alle 4 Möglichkeiten".
Aber das bringt mich jetzt leider nicht wirklich weiter ... das Problem bleibt ja auf "normaler Applikationsebene" bestehen.
Virenscanner gibt es nicht und die 100MB/s schaffen die SSDs auf beiden Systemen mehr als locker, was ja auch 1. und 2. im oberen Bild belegen...
Bitte warten ..
Mitglied: DerWoWusste
14.11.2014 um 14:10 Uhr
Teste bitte noch einmal Deine Explorertests mit 2 leeren 2012 R2 untereinander in einer VM. Nur 2012 R2 mit Update 1 installieren, und sonst nichts.
Mein Verdacht wäre eine seltsame Software, die auf den 2012ern drauf ist, ist die Ursache.
Bitte warten ..
Ähnliche Inhalte
Drucker und Scanner
gelöst Lokale Drucker auf Server2012 R (5)

Frage von Robtschick zum Thema Drucker und Scanner ...

Windows Server
Server2012 R2 Radius Richtlinien bestimmten Clients zuordnen (6)

Frage von MichaelW84 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Windows Server 2008 R2 Platte spiegeln - unterschiedliche Platten? (2)

Frage von imacer zum Thema Festplatten, SSD, Raid ...

Microsoft
gelöst Windows Server R2-Version (6)

Frage von MiSt zum Thema Microsoft ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (13)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Webentwicklung ...

Microsoft Office
gelöst Office 365 Pro Domäne einrichten OHNE Webseite (9)

Frage von thklemm zum Thema Microsoft Office ...

Voice over IP
48 Port VOIP Switch mit POE gesucht (8)

Frage von brutzler zum Thema Voice over IP ...