Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkeinstellungen für Virtual Box

Frage Netzwerke

Mitglied: 17867

17867 (Level 1)

09.08.2009, aktualisiert 14:45 Uhr, 17003 Aufrufe, 3 Kommentare

Wirthost: Windows Vista
VirtualBox: Windows 7

möchte die Netzwerkumgebung einrichten

Hallo,

ich möchte ein Netzwerk aufbauen und meinen Wirthost Vista mit der Virtual Box (Windos7) verbinden. In der Netzwerkumgebung sehe ich nur meinen Laptop aber nicht die Virtual Box. Kann sie auch nicht anpingen. Wie müssen meine Netzwerkeinstellungen aussehen???

Hier mein ipconfig /all vom Wirthost:

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : Jome-Laptop
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : fritz.box

Ethernet-Adapter LAN-Verbindung 6:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : TeamViewer VPN Adapter
Physikalische Adresse . . . . . . : 00-FF-BE-50-C6-76
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja

Ethernet-Adapter LAN-Verbindung 5:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
Physikalische Adresse . . . . . . : 08-00-27-00-0C-A7
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::b013:f1c2:bb4b:d7b5%17(Bevorzugt)
IPv4-Adresse (Auto. Konfiguration): 169.254.215.181(Vorläufig)
Subnetzmaske . . . . . . . . . . : 255.255.0.0
Standardgateway . . . . . . . . . :
DNS-Server . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung:

Verbindungsspezifisches DNS-Suffix: fritz.box
Beschreibung. . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter

Physikalische Adresse . . . . . . : 00-21-63-56-33-75
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::d4d3:9b76:3e1:ef8a%11(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 192.168.178.54(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Lease erhalten. . . . . . . . . . : Sonntag, 9. August 2009 14:19:04
Lease läuft ab. . . . . . . . . . : Mittwoch, 19. August 2009 14:19:07
Standardgateway . . . . . . . . . : 192.168.178.1
DHCP-Server . . . . . . . . . . . : 192.168.178.1
DNS-Server . . . . . . . . . . . : 192.168.178.1
NetBIOS über TCP/IP . . . . . . . : Aktiviert


UND HIER MEINE ipconfig /all der Virtual Box:
DHCP Enabled: yes
Autoconfiguration enabled: yes
Link-local IPv6 Addres: fe80::ada8:bf84:68d0:b51e%11 (Preferred address)
IPv4 Address: 10.0.2.15 (Preffered)
Subnet MAsk: 255.255.255.0
Default Gateway: 10.0.2.2
DHCP Server: 10.0.2.2
DHCPv6 IAID: 235405351
DHCPv6 Client DUID: 00-01-00-01-11-FE-42-6F-08-00-27-79-A8-26
DNS Servers: 192.168.178.1
NetBios over TCP/IP: enabled
Mitglied: aqui
09.08.2009 um 15:52 Uhr
In der Virtual Box aktivierst du in den Einstellungen unter Netzwerkden Netzadapter-1 und aktivierst ihn als Bridged Adapter.

Danach sind alle Komponenten in einem Netz und du kannst der VM entweder eine IP von der FB vergeben lassen oder eine statische IP außerhalb der DHCP Range der FB konfigurieren.
Such dir das für dich passende raus..

Derzeit ist das bei dir ein sinnloses Kuddelmuddel von IP Adressen. Dein aktivierter Hostadapter ist mit einer APIPA Adresse (169.254.x.y) versehen weil er vermutlich in der Virtual Box nicht im Bridge Modus ist sondern Host Modus.
Dem Host hast du aber selber auf dem Adapter eine 10.0.2.15er IP vergeben.
Logischerweise können die ja niemals so zusammenkommen, das weiss jeder Laie, da die IP Netze verschieden sind.
Also entweder du setzt den Adapter auf Bridged Adapter und vergibst allen eine IP aus dem 192.168.178.0 /24 Netz was das sinnvollste wäre, da mit du alles mit allem erreichen kannst,
Ober wenn deine VM vollkommen isoliert sein soll und nur über den VB Host erreichbar sein kann dann vergibst du auf der VB Maschine auf dem Netzadapter statt der derzeitigen 169.254.x.y (steht vermutlich auf DHCP und findet keinen Server !) z.B. die 10.0.2.200 /24.

So wird ein Schuh draus und nicht mit der aktuellen Frickelei...
Bitte warten ..
Mitglied: 17867
09.08.2009 um 16:37 Uhr
Meine NEtzwerkseinstellungen auf demREchner sehen so aus:
- drahtlosnetzwerkverbindung aktiv 192.168.178.26
- lan verbindung 5 aktiviert (virtual host-only-adapter) keine ip.kann auch nichts einstellen alles grau hinterlegt

habe wlan und lan verbindung5 angeklickt und verbindung überbrückt:
STATUS der Netzwerkbrücke:
-192.168.178.26
-gateway,dhcp und dns 192.168.178.1

Meine Netzwerkeinstellungen in der VMBOX sehen nun so aus:
Netzwerk
Adapter 2:
PCnet-FAST III (Netzwerkbrücke, MAC Bridge Miniport)

Wenn ich die VMBOX starte und ipconfig eingebe kommt folgendes raus:
ip address 192.168.178.102
subnet mask 255.255.255.0
standardgateway 192.168.178.1
habe also keine inetverbindung

kann aber nun per remote desktop auf meine vmbox zugreifen und habe nun netzwerkzugang bzw. vmbox und rechner finden sich gegenseitig...nur kommeich mit der vmbox nicht ins inet?????
Bitte warten ..
Mitglied: aqui
10.08.2009 um 17:35 Uhr
Das sieht doch aber gut aus ! Der Hostadapter in der VB hat dann die Adressen:

ip address 192.168.178.102
subnet mask 255.255.255.0
standardgateway 192.168.178.1

Das sind ja IPs aus dem richtigen Netz, nämlich deinem lokalen Netz !
Kannst du den Router 192.168.178.1 aus der VM pingen ???

Was sagt ein ipconfig des Betriebsystems in der VM ?? Dort müssten ja auch diese IPs zu sehen sein aus deinem lokalen Netz.

Ein Ping von allen Komponten auf den Router muss klappen. Ohne das musst du erstmal gar nicht weitermachen !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Virtualisierung
gelöst QEMU KVM - VMware Workstation - Oracle Virtual Box - Was denkt ihr? (17)

Frage von twoDarkMessiah zum Thema Virtualisierung ...

Windows Update
Windows Update funktioniert nicht in Virtual Box (7)

Frage von donfigo zum Thema Windows Update ...

Router & Routing
Neue Top Level Domain .box bringt manche Netze durcheinander (1)

Link von magicteddy zum Thema Router & Routing ...

Router & Routing
Neue Top Level Domain .box bringt manche Fritzbox-Netze durcheinander (3)

Link von mikrotik zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...