Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkgeschwindigkeit geht in den Keller

Frage Netzwerke

Mitglied: szimmer

szimmer (Level 1) - Jetzt verbinden

26.09.2006, aktualisiert 09.01.2007, 9295 Aufrufe, 6 Kommentare

Hallo,

wir betreiben ein Netzwerk mit Windows 2000 Server und 6 Clients. Auf allen Clients läuft das OS Windows 2000 und die selben Programme, eine Warenwirtschaft welche auf Pervasive SQL 9 aufsetzt, Tobit Infocenter von Tobit V8+ und eine SQL Teiledatenbank welche den MS SQL Server verwendet.

Ich hatte im Sommer eine zeitlang einen Netgear MR814v2 als WLAN Access Point eingerichtet um mit dem Notebook Wireless auf's Netz zu zugreifen. Nachdem ich diesen Router am Switch abgezogen hatte wurden alle Clients extrem langsam und zwar expliziet in der Warenwirtschaftssoftware sowie in Office Dokumenten welche vom Server geöffnet werden.

Ein hier ansässiger EDV Betreuer beurteilte dies als DNS Problem und wollte mir sofort einen neuen Server verkaufen. Ich glaubte jedoch nicht an ein DNS Problem und habe mich aus diesem Grund entschieden den Server neu einzurichten. Dies habe ich nun vor zwei Wochen auch endlich getan. Wir haben den Windows 2000 Server neuinstalliert und auch einen neuen Domänennamen ausgewählt. Leider musste ich nach der Neuinstallation feststellen das sich an unserem Geschwindigkeitsproblem nichts verbessert hatte.

Einige Tage darauf stellte ich fest das 3 der 6 Clients, wenn der Client aus dem Vertrieb nicht im Netz war, genau so schnell liefen wie früher. Nun habe ich mein Notebook wie einen Client eingerichtet und was soll ich sagen, wenn die 6 Clients laufen ist nur mein Notebook schnell, der Rest hinkt. Schalten wir den Client im Vertrieb ab so laufen 3 Clients und mein Notebook schnell.

Ich ging also davon aus das die Fehlerquelle der Client im Vertrieb ist und habe diesen über's Wochenende neuinstalliert. Am Sonntag Abend lief dieser super schnell und ich dachte das Problem sei gelöst. Leider nicht. Läuft dieser Client jetzt alleine im Netz ist er super schnell doch so bald die anderen laufen wird er wieder brechend langsam. Der Rest wie gehabt.

Nun frage ich mich ernsthaft wo das Problem liegt. Am Server kann es nicht liegen da Neue Clients wie mein Notebook immer sehr schnell arbeiten die alten scheinen in Abhängikeit voneinander langsam zu werden. Kann mir hier vielleicht jemand einen Lösungsansatz anbieten?

Vielen Dank, Szimmer
Mitglied: ulli1966
26.09.2006 um 18:58 Uhr
Hallo,

also - vor dem WLAN Experiment lief alles 100% ??
Und ausser den Access Point mal ins LAN hängen und wieder entfernen, wurde NICHTS geändert ?? ( schwöre

Dann solltest du auch in diesem Bereich suchen.

Ich würde erstmal den Switch aus und wieder einschalten.
Wer macht den DHCP und DNS? Ist da noch alles wie es muss?
Dann auf den Clients prüfen, ob die Netzwerkeinstellungen in Ordnung sind.

Was heißt "Netzwerk langsam "? Nur bei zugriffen auf den Server?
Oder auch zwischen den Clients?
Ist der Server ausgelastet?


Wichtig ist ganz systematisch an die Ursachenforschung zu gehen.
Nicht mehrere Dinge gleichzeitig ändern.
Zur Not protokolieren was man wie geprüft hat.
Und nicht sagen " das wird schon richtig sein". Prüfen ob es auch so ist.

Mehr kann ich dir im Moment auch nicht helfen.

Viel Spaß

Grüße Ulli
Bitte warten ..
Mitglied: szimmer
27.09.2006 um 08:27 Uhr
Morgen,

Vor dem WLAN Experiment lief alles 100% und im ms Bereich. Das kann ich dreifach beschwören

Das mit dem Switch habe ich versucht, habe ich sogar mal 10 min komplett ohne Strom gelassen um den Bauteilen die Möglichkeit einer Entladung zu ermöglichen.

Am DHCP und an der DNS hat sich damals nichts geändert, da dies der Server macht und der Router da gar nichts zu tun hatte. Nach der Neuinstallation vom Server ist DHCP und DNS 1A, zu mal der DHCP nur einen kleinen Adressbereich für die Notebooks hat. Der Rest hat feste IP Adressen im Bereich 192.168.6.x.

Die Netzwerkeinstellungen an jedem Client hab ich ebenfalls bereits geprüft und auch die TCP/IP Protokolle entfernt und neu hinzugefügt.

Das Netzwerk ist eigentlich nur beim Aufruf langsam d.h. Anmeldung und Dateibrowser sind fix, aber wenn ich eine Excel Datei öffnen möchte geht es 20 sec wo es früher nur ein Fingerschnippen gedauert hat. Das gleiche bei der Warenwirtschaft die per Tastenkurzbefehle gesteuert wird um schnell zu navigieren, da haben wir mittlerweile Wartezeiten wenn er die Vorschau für die Bestellung generiert welche früher nie der Fall waren.

Mir fehlt mittlerweile wirklich der Ansatz. Ich werde im Laufe des Tages mal mein Protokoll der bereits versuchten Dinge hier hinzufügen.

Vielen Dank für's erste.
Bitte warten ..
Mitglied: aqui
27.09.2006 um 23:17 Uhr
Ob es die Infrastruktur, sprich Switch etc. ist lässt sich sehr einfach testen mit einem Performancetool wie NetIO.

http://www.ars.de/ars/ars.nsf/docs/netio

Binaries runterladen und auf Client und Server in ein Verzeichnis kopieren und in der Eingabeaufforderung ausführen. Ohne Parameterr zeigt es die einfache Bedienung an. Dies Tool ermittelt den Durchsatz durch die Netzkomponenten bei unterschiedlichen Packetgrößen ohne eine Anwendungssoftware dazwischen. Damit lässt sich erstmal sicher sagen ob es an der Netzwerkhardware liegt oder nicht.
Alles andere ist Kaffeesatzlesen und Spekulieren.
Kann man dies sicher ausschliessen kann es nur die Anwendungssoftware selber sein oder andere Umstände.
Leider schreibst du nicht ob du einen konfigurierbaren Switch hast oder nicht. Aber auch ein konfigurierbarer Switch kann sich nicht selber durch externe Geräte auf "langsam" konfigurieren um das mal salopp zu sagen.
Meistens zeigt diese Problematik ein Negotiation problem auf. D.h. das Endgerätekarten nicht automatisch auf die Port Paramter wie half/full duplex und oder Geschwindigkeit negotiaten.
Die kann zu erheblichen Kollisionen am Port und damit zu einer erheblichen Performance Einschränkung kommen. Ein Reboot des Switches hilft da natürlich nicht !
Ist der Switch nicht gemanget kann man nur durch eine testweise statische Einstellung der Portparameter auf der NIC (Server und Client !) auf z.B. 100 Mbit, FullDup ein Erzwingen dieser Parameter erreichen.
Üble Kandidaten sind oft Ethernetkarten von 3Com durch deren proprietäre Erweiterung des Standards was viele Switches übel nehmen außerden von 3Com natürlich.
Ist der Switch managebar kann man diese Parameter auf den Switchports erzwingen. Ein managebarer Switch zeigt auch auf den Portstatistiken an wie hoch dort die Kollisionsrate ist.
Bitte warten ..
Mitglied: szimmer
28.09.2006 um 17:02 Uhr
Ich habe Net IO mal vom Server ausgeführt:

Ergebnisse:
01k - 11217 Kbyte/s tx - 10731 Kbyte/s rx
02k - 11089 Kbyte/s tx - 10934 Kbyte/s rx
04k - 10210 Kbyte/s tx - 11119 Kbyte/s rx
08k - 10040 Kbyte/s tx - 10794 Kbyte/s rx
16k - 10169 Kbyte/s tx - 11177 Kbyte/s rx
32k - 10412 Kbyte/s tx - 11187 Kbyte/s rx

Damit hat der Server wohl eine Sende und Empfangsleistung von ca. 80 - 88 MBit.

Die Auswertung der Clients poste ich später noch, da bin ich gerade dran.

Grüße, Szimmer
Bitte warten ..
Mitglied: szimmer
04.10.2006 um 09:00 Uhr
Sooo also die Auswertung der Clients liefert identische Ergebnisse... kein Netzproblem.

Ich hab nun alle langsamen Clients NEU aufgestezt, dabei ist mir folgendes aufgefallen:

Die Rechner sind richtig schnell unterwegs bis ich Microsoft Office installiert habe, danach
gehts wie vorher, nämlich schleppend langsam. Es muss also an Office liegen ?!?
Bitte warten ..
Mitglied: szimmer
09.01.2007 um 13:32 Uhr
Um die Lösung nun selbst zu veröffentlichen:

Es war die BDE der Agenda Software, welche das komplette Netzwerk ausgebremst hat. Lösung ist ein nicht veröffnetlichter Patch (Begründung Agenda: Da dies nur in 5% aller Netze vorkommt) den man bei Agenda im Forum nun auch downloaden kann. Nach dem patchen der Software habe ich nun seit einiger Zeit ein rasend schnelles Netz.

Grüße, szimmer
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
gelöst Active Directory CA öffentlich vertrauenswürdig machen, geht das? (2)

Frage von DeathangelCH zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...