Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkproblem - Fehler im Subnetz?

Frage Netzwerke Netzwerkmanagement

Mitglied: CriBer

CriBer (Level 1) - Jetzt verbinden

17.12.2012 um 13:06 Uhr, 2456 Aufrufe, 6 Kommentare

Hallo Leute,
wir haben seit einiger Zeit ein Problem mit unserem Netzwerk. Durch die wachsende Zahl an Netzwerkgeräten mussten wir unser Subnetz umstellen. Vorher hatten wir das Subnetz 192.168.21.0/24. Nun haben wir das Subnetz 192.168.20.0/22, also die IP-Adressen 192.168.20.1-192.168.23.254 verfügbar.

Nun kommt es zeitweise vor, dass Pings auf einzelne Rechner nicht funktionieren.
z.B. kann der Rechner 192.168.21.54 nicht die 192.168.21.1 anpingen. Der Ping auf 192.168.21.15 geht aber weiterhin durch. Das Routing zwischen den Switches ist gleich, da beide Zielrechner am selben Switch hängen.

Woher kann der Fehler in der Erreichbarkeit kommen?
Auch andere Geräte können den Server mit der IP 192.168.21.1 zeitweise nicht erreichen, alle anderen Rechner aber schon. Die Subnetzmasken sind bei allen Geräten entsprechend auf 255.255.252.0 (22) gestellt. Der Verbindungsfehler kommt ca. alle 5-30 Sekunden vor.

Danke im Voraus. Gruß,
Criber
Mitglied: Lochkartenstanzer
17.12.2012 um 14:39 Uhr
Moin,

  • ist die Erreichbarkeit bestimmter IP-Adressen druchgehend nicht gegeben, oder variiert diese? (mal erreichbar, mal nicht)
  • hast du mal mit einem netzwerkscanner (z.B. nmap) von diversen IP-Adressen aus das netz gescannt, ob und welche Systeme antworten?
  • Prüfe nochmal alle masken udn IP-Adressen auf Tippfehler. Passiert schneller als man denk, insbesodnere, daß man 255 statt 252 tippt.
  • Prüfe, ob irgendwelche Systeme sich die Maske autonatisch ziehen.
  • Prüfe, ob bei den DHCP-Servern alle einträge korrekt sind.

lks
Bitte warten ..
Mitglied: aqui
17.12.2012 um 16:12 Uhr
Der Einwand mit dem "Routing" ist irgendwie verwirrend, denn du schreibst nichts davon das du noch routetst im Netz.
Du hast lediglich einfach die Subnetzmaske angepasst und damit nur die Broadcast Doamin größer gemacht, was letztlich kein guter Schritt ist und weitere Probleme nach sich ziehen kann.
Besser wäre wirklich du hättest hier sauber zwischen den beiden Subnets geroutet was aber bei eldiglich Ändern der Subnetzmaske definitiv NICHT gemacht wird !
Du musst also folgendes klären:
  • Routest du in deinem Netzz wirklich oder machst du nur dummes und flaches Layer 2 Switching ?
  • Wenn du tatsächlich routest hast du wasserdicht geprüft das das Ändern der Subnetzmaske keine anderen Netze beeinflusst (Doppelvergabe der Netz, Überschneiden der Subnetze)
Desweiteren solltest du immer im Hinterkopf haben das einige Endgeräte mit CIDR Masken wie du sie jetzt einsetzt nicht umgehen können. Da du ein klassisches Class C Netzwerk verwendest kann das ebenfalls der Fall sein.
Besser wäre wirklich ein sauberes Routing...
Bitte warten ..
Mitglied: CriBer
19.12.2012 um 09:41 Uhr
Vielen Dank für die schnelle Antwort.

* ist die Erreichbarkeit bestimmter IP-Adressen druchgehend nicht gegeben, oder variiert diese? (mal erreichbar, mal nicht)
Es ist nur die IP 192.168.21.1 zeitweise nicht erreichbar. Die Verbindungsfehler kommen nur im WLAN vor und sind nur zeitweise vorhanden. Diesen wichtigen Punkt habe ich in der ursprünglichen Frage leider vergessen. Wir haben ein WLAN-Cluster für firmenweites WLAN zur mobilen Datenerfassung aufgebaut. Nur aus dem WLAN kommt der Verbindungsfehler zum Rechner mit der IP 192.168.21.1 vor. Alle anderen PCs und Server sind weiterhin erreichbar.
Die PCs im LAN können jeden Rechner beliebig anpingen und erreichen (ohne jeglichen Verbindungsabbruch).

* hast du mal mit einem netzwerkscanner (z.B. nmap) von diversen IP-Adressen aus das netz gescannt, ob und welche Systeme antworten?
Noch nicht, werde ich aber mal machen.

* Prüfe nochmal alle masken udn IP-Adressen auf Tippfehler. Passiert schneller als man denk, insbesodnere, daß man 255 statt 252 tippt.
Die Linux-Maschinen wurden alle per Shell-Konfigurationsskript mit statischen IP-Adressen versehen. Die Subnetzmasken sind also identisch und nach Kontrolle auch korrekt auf 255.255.252.0 gesetzt.

* Prüfe, ob irgendwelche Systeme sich die Maske autonatisch ziehen.
Welche Systeme sollten sich die Subnetzmaske automatisch ziehen? Wüsste jetzt nicht genau wo ich ansetzen soll.

* Prüfe, ob bei den DHCP-Servern alle einträge korrekt sind.
Die IP-Adressen in unserem Netzwerk sind alle statisch vergeben. Es ist kein DHCP im Einsatz.

Grüße,
Criber
Bitte warten ..
Mitglied: CriBer
19.12.2012 um 09:51 Uhr
Zitat von aqui:
  • Routest du in deinem Netzz wirklich oder machst du nur dummes und flaches Layer 2 Switching ?
Ich habe mich leider unglücklich ausgedrückt. Wir haben nur die Subnetzmaske angepasst und verlassen uns auf die Paketverwaltung der Switches.
Ich werde mir wohl mal ein Buch zum Thema bestellen und mich über die Feiertage tiefer einlesen. Ist wohl der sinnvollste Weg. Aber danke schon mal für eure Mühen!
Bitte warten ..
Mitglied: aqui
19.12.2012 um 16:21 Uhr
Ja das ist sicherlich sinnvoll, denn die technisch kontraproduktive Lösung der einfachen Vergrößerung der Collision Domain über das Vergrößern der Subnetzmaske ist die technisch allerschlechteste Lösung.
Strukturiertes VLAN Routing ist da erheblich besser und auch erheblich skalierbarer !!

Während du liest dann bitte
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Mitglied: Lochkartenstanzer
19.12.2012 um 16:45 Uhr
Zitat von CriBer:
Vielen Dank für die schnelle Antwort.

> * ist die Erreichbarkeit bestimmter IP-Adressen druchgehend nicht gegeben, oder variiert diese? (mal erreichbar, mal nicht)
Es ist nur die IP 192.168.21.1 zeitweise nicht erreichbar. Die Verbindungsfehler kommen nur im WLAN vor und sind nur zeitweise
vorhanden. Diesen wichtigen Punkt habe ich in der ursprünglichen Frage leider vergessen. Wir haben ein WLAN-Cluster für
firmenweites WLAN zur mobilen Datenerfassung aufgebaut. Nur aus dem WLAN kommt der Verbindungsfehler zum Rechner mit der IP
192.168.21.1 vor. Alle anderen PCs und Server sind weiterhin erreichbar.

Von mehreren oder nur von einzelnen Clients aus dem WLAN? es scheint mir eher ein funktechnisches als ein Netzwerk-Problem zu sein.


> * Prüfe, ob irgendwelche Systeme sich die Maske autonatisch ziehen.
Welche Systeme sollten sich die Subnetzmaske automatisch ziehen? Wüsste jetzt nicht genau wo ich ansetzen soll.

Es gibt Geräte mit verkorkster Firmware (oder Treiber), die aufgrund der IP-Adresse die Maske "erraten" (Class A/B/C) oder auch Geräte, die mit Netzmasken ungleich /8, /16 oder /24 falsch rechnen. Sollte heutzutage nicht mehr vorkommen, aber was wäre die Welt ohne die täglichen Bugs.

lks
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (26)

Frage von JayyyH zum Thema Switche und Hubs ...

Notebook & Zubehör
HP 8770W - LAN Netzwerkproblem (Aufbau, Geschwindigkeit) (5)

Frage von RiceManu zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...