Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkproblem mit Router oder Access Point. IP wird nicht richtig zugewiesen.

Frage Netzwerke

Mitglied: DrCox

DrCox (Level 1) - Jetzt verbinden

29.10.2006, aktualisiert 12.11.2006, 5247 Aufrufe, 20 Kommentare

Habe hier ein Problem, welches ich schon im Beitrag switche reagieren nicht angeschnitten haben.
Also ich bekomme keine Verbindung mehr zum Router. Die Verbindung ist durch 2 Access Points geregelt, die per Wireless-Lan an eine nahegelegene Uni mit dem Internet verbinden. Es handelt sich dabei um ein Studentenwohnheim.
Dazu muss ich noch sagen, dass der Router von Cisco ist und auch gleichzeitig als DHCP server arbeitet.
Ich komme von meiner Verbindung aus nicht mehr rein, allerdings von einer anderen Internetverbindung kann ich darauf zugreifen. Ich habe so bereits versucht den Router zu resetten. Allerdings hat das nicht funktioniert. Manuell habe ich dies auch schon gemacht. Auch ohne Erfolg.
Auf Telnetzugriffe reagieren übrigens auch die Switche nicht. Allerdings geht die Netzwerkfreigabe noch.
Mit was genau könnte dies zu tun haben? Die APs sind auch von Cisco (Aironet 1200). Sollte ich die APs vielleicht auch resetten, oder ist das nicht notwendig?
Was mir am Tag vor diesem Totalabsturz noch aufgefallen ist: Kurzfristig sind bei einem Switch etwa 10 Verbindungen ausgefallen. Kurze Zeit später gingen alle jedoch wieder. Am nächsten Morgen war der Zugriff auf den Router aber nicht mehr möglich und das Internet viel bei allen aus.
Mitglied: aqui
30.10.2006 um 10:05 Uhr
Das ist recht diffus was du da beschreibst so das eine dedailierte Hilfe schwer möglich ist. Angenommen dein Szenario sieht so aus:

(Internet)---Router---(CiscoAP)---WLAN-Bridge oder WDS---(CiscoAP)---Wohnheimnetz,Switch

ist es vorab erstmal zu wissen wie deine IP Adressen vergeben sind sonst kann man schwer sagen ob dein Ping, Telnet oder was auch immer vielleicht sinnlos ist.
Sieht das Szenario so aus wie oben, dann ist alles was hinter dem Ethernet des Internet Routers ist ein IP Netzwerk ! Alle Geräte sollten hier IP Adressen aus dem gleichen IP Netzwerkbereich haben mit einer identischen Subnetzmaske und natürlich auch einer einheitlichen Gateway Adresse die auf den Router zeigt !
Ist dem so MUSS ein Ping von allen Geräten mit allem und auch mit den PCs/Laptops in diesem Netz funktionieren, sofern eine evtl. Personal Firewall auf den PCs diesen Ping erlaubt (Im Zweifelsfall immer abschalten zum Test).
Bei Cisco Devices ist unbeding darauf zu achten ein enable Passwort und auch ein Telnet Passwort zu vergeben, andernfalls ist ein Telnet Zugriff im IOS nicht möglich bzw. wird aus Sicherheitsgründen unterdrückt ! Ping sollte aber immer klappen, sofern eine richtige IP Adresse vergeben ist und der Mangement Port im default VLAN ist beim Switch.

Nach den Schilderungen deiner Symprome ist zu vermuten, das es zu einem Ausfall der WLAN Strecke kommt. Das 10 Ports am Cisco Switch gleichermaßen defekt sein sollen und nach ein paar Stunden wieder gehen ist eigentlich höchst unwahrscheinlich.
Das man den Router bei Ausfall der WLAN Stecke nicht erreichen oder pingen kann ist natürlich dann auch normal....
Um die WLAN Strecke zu analysieren müsste man einmal wissen ob die ggf. im WDS Repeater Modus betrieben wird oder als dedizierte Ethernet Bridge arbeitet (Mit dem Cisco AP sind beide Modi möglich). Diese Strecke würde ich einem genaueren Test unterziehen...
Wie gesagt alles unter Vorbehalt, da deine Beschreibungen sehr sehr allgemein gehalten sind !!!
Bitte warten ..
Mitglied: DrCox
30.10.2006 um 12:15 Uhr
Ok, also das Problem ist, dass die Access Points von der Uni verwaltet werden. Diese habe ich schon zwecks Prüfung angeschrieben. Es gibt also 2 Access Points, die mittels Wlan-Bridge verbunden sind und das ist dann eben an den Router angeschlossen. Der Router fungiert gleichzeitig auch als DHCP-Server und verbindet zu den Switchen.

Deine Darstellung ist fast richtig. Nur der Router kommt erst nach dem AP.

Damit hat sich auf jeden Fall mal meine Frage gelöst, ob ich die IP des Access Points anpingen kann. Das sollte nicht möglich sein und geht nicht.

Das Problem liegt wohl in der Vergabe der Ip's. Es wird eine 250.250.0.0 Gateway, statt einer 250.250.250.0 Gw verwendet. Zudem hat er starke Probleme bei der IP-Zuweisung. Das dauert sehr lange. Die IP ist dann in einem anderen Wertebereich, als üblich.

Zudem habe ich noch versucht von extern auf den Router zuzugreifen. Das ging am Anfang auch. Im Netzwerk intern war dies aber überhaupt nicht möglich.
So habe ich versucht, dass ich den Router neu starte. Allerdings kam da immer eine Fehlermeldung, dass er keinen Zugriff auf den Host hat. Einmal scheinte es dann zu klappen. Allerdings hat das keine Veränderung gebracht.
Am Router leuchtet zudem nur ein Licht.
Da sollte laut Beschreibung auch etwas blinken.

Was mir noch aufgefallen ist: Am Tag zuvor war bei einem Port des Switches eine sehr schlechte Verbindung. Ich weiß allerdings nicht, was genau an dem Port angeschlossen war.
Es war ein Port an der Rückseite des Switches, der mit dem Router verbunden ist. Das war genau der Switch, der den Router mit den anderen Switchen verbindet. Könnte der Port vom Switch auch an einen Access Point führen?
Der Port war so gut wie tot und hat so gut wie keine Pakete übertragen.
Ein reset des Switches hat übrigens auch keine Wirkung gezeigt.
Der Router ist übrigens ein Cisco 1841.
Bitte warten ..
Mitglied: aqui
30.10.2006 um 16:15 Uhr
OK, das Szenario sieht dann so aus:

Campusnetz---(AP/Bridge)---WLAN---(AP/Bridge)---Cisco1841---(Heimnetz,Switch)

Das was du da geschrieben hast mit 250er Adressen kann irgendwie nicht stimmen oder du verwechselst da was.... 250er Adressen wären sehr ungewöhnlich und ich nehme an du meinst damit die Netzwerk Maske, richtig ??? Die lautet aber nicht 250.250.250.x (das wäre keine gültige Maske) sondern muss dann mintestens 255.255.250.x oder sowas haben wenn es eine "krumme" Maske ist. Da stimmt wieder was in deiner Beschreibung nicht.

Die WLAN Bridge arbeitet als Layer 2 Bridge, dort ist also ein IP Segment aus dem Campus Bereich in Verwendung auf das du wahrscheinlich keinen Zugriff hast.
Ich denke mal das die Uni Admins auf den Cisco "dichtgemacht" haben sofern der in ihrer Administrationshoheit steht. Ich hätte es jedenfalls gemacht wenn auf der anderen Seite ein Studi Wohnheim mit wilden Hackern ist
Das würde bedeuten kein Telnet, kein HTTP kein Ping oder was auch immer ist aus dem Wohnheim auf den Router möglich.
Der Cisco hat mit Sicherheit eine DHCP Konfig für das LAN Segment zum Wohnheim hin. Gemeinhin funktionieren diese Dienste auf einem Cisco völlig problemlos. Um das genauer analysieren zu können müsstest du mal die Konfig des Routers schicken. Damit ist euere IP Adressbereich durch die Cisco Admins ja sowieso festgelegt es sei denn jemand vergibt sich statische Adressen aus dem DHCP Bereich und schafft damit ein Tohuwabohu in der Adressvergabe.
Dadurch kannst du natürlich eine Doppelbelegung haben und nichts geht mehr. Um das zu beurteilen müsste man am Router mal sniffern...
Auch dem Router müssen wenigstens beide Kontroll LEDs für beide Ethernet Links einmal WLAN Bridge und einmal Wohnheim leuten und auch blinken bei Datentraffic !
Gleichwohl auf dem Switch der am Router angeschlossen ist. Auch hier leuchtet die Link LED zum Routerport und muss auch im Takt der Daten blinken. Das gilt übrigens auch für jeden Clientport des Switches an dem Endgeräte angeschlossen sind !!!
Das ist wenigstens mal ein grober Anhaltspunkt zur Funktion.
Wenn du nicht weisst was an schlecht funktionierenden Ports angeschlossen ist, ist eine Hilfe unmöglich.
Dafür muss man leider "wahrsagen" können..... Das ist aber sicher etwas für andere Foren !!!
Bitte warten ..
Mitglied: DrCox
30.10.2006 um 18:11 Uhr
Ja, ich meinte die Subnetmaske und diese hatte an 3. Stelle statt der 255 eine 250.

Danke an Aqui für deine gute Antwort.

Ich habe heute mit einem Techniker gesprochen und er meinte, dass der Router nicht ordentlich neu gestartet ist und sich da aufgehängt hat.

Er meinte, dass man das auch per Telefonsupport machen kann.

Kennt sich hier jemand mit Konsolenzugriffe auf Router aus? Würde mir hierzu gerne ein paar Kenntnisse aneignen. Also mit Windows macht man das mit Hilfe von Hyperterminal oder?
Bitte warten ..
Mitglied: DrCox
31.10.2006 um 11:38 Uhr
yourname#show ip int brie
Interface IP-Address OK? Method Status Prot
ocol
BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

FastEthernet0 unassigned YES NVRAM administratively down down

FastEthernet1 unassigned YES NVRAM administratively down down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

FastEthernet4 unassigned YES unset up down

FastEthernet5 unassigned YES unset up down

FastEthernet6 unassigned YES unset up down

FastEthernet7 unassigned YES unset up down

FastEthernet8 unassigned YES unset up down

FastEthernet9 unassigned YES unset up down

Vlan1 10.10.10.1 YES NVRAM up down



Also ich war auf der Konsole und irgendwie sind die Protokolle alle down.
Bitte warten ..
Mitglied: aqui
31.10.2006 um 22:16 Uhr
Ein Cisco Router der sich aufhängt beim Booten...höchst ungewöhnlich aber egal....

Ja deine Interfaces sind alle inaktiv obwohl besser ein "show int" gewesen wäre denn mit sho in ip siehts du nur den IP Status.
Das 1. und 2. Interface ist aber inaktiv, da darfst du nichts anschliessen, denn das ist übers Setup deaktiviert, dann wäre es kein Wunder das nix geht.
Bitte warten ..
Mitglied: DrCox
01.11.2006 um 14:46 Uhr
Versuche gerade die Configuration neu aufzusetzen.
kann man unter SDM das System neu aufsetzen, wenn man so eine Konfigurationsdatei hat?
Bitte warten ..
Mitglied: DrCox
01.11.2006 um 16:52 Uhr
Wie bekomme ich das hier weg?

ip dhcp pool sdm-pool
import all default-router 10.10.10.1
lease 0 2
Bitte warten ..
Mitglied: aqui
01.11.2006 um 17:07 Uhr
Was ist SDM ???
Immer ein "no" davor, das löscht die meisten Cisco Kommandos !

"no ip dhcp pool sdm-pool"
Bitte warten ..
Mitglied: DrCox
01.11.2006 um 19:23 Uhr
service device manager!

ist der webclient von cisco.

das mit no hab ich schon probiert. funktioniert aber nicht.
Bitte warten ..
Mitglied: aqui
01.11.2006 um 21:11 Uhr
SDM...igitt. Es kann sein das du erst die IP Pool Parameter löschen musst mit "no" bevor sich der Pool löschen lässt, da ist dann die Reihenfolge der Trick. Zur Not Konfig sichern, mit "wri era" plattmachen und die Konfig neu aufsetzen !
Bitte warten ..
Mitglied: DrCox
01.11.2006 um 21:38 Uhr
Ich habe hier ja noch eine alte Konfigurationsdatei. Kann ich die mit SDM irgendwie zurückdraufflashen?
was bedeutet wri era? Dann ist alles weg oder wie?

Den dhcp pool konnte ich bis jetzt noch immer nicht löschen. habs mit no und shutdown probiert.

Kann es sein, dass es nicht geht, weil in dem Netz noch ein anderer Router ist? Da ist nämlich einer und das hat schon zu einem DNS-Konflikt geführt.
Bitte warten ..
Mitglied: aqui
01.11.2006 um 21:46 Uhr
SDM Tipps kann ich dir nicht geben das kenn ich nicht ! "wri era" ist ein Command Line Kommando ! Das gilt auch für die "no" Kommandos, die müssen übers CLI eingegeben werden per Telnet oder Konsole !
Bitte warten ..
Mitglied: DrCox
02.11.2006 um 09:59 Uhr
Also der Befehl hat keine Auswirkung. In SDM wird dieser DNS-Pool auch gar nicht angezeigt. Hat sich also erledigt.

Was mich jetzt noch interessieren würde, da ich mich jetzt näher mit der Materie beschäftigt habe:

Kann man in der Konfiguration irgendwie steuern, dass gewisse Seiten gesperrt werden (zb Filesharing-Seiten)?

Und ist von Seiten des Routers eine Bandbreitenlimitierung möglich?
Bitte warten ..
Mitglied: aqui
02.11.2006 um 11:36 Uhr
Ja das klappt recht einfach über eine ACL. Man kann auf dem Ethernet Port eine "extended Access Liste" legen und alle Ports von Filesharing Protokollen sperren oder um das Filesharing nicht komplett zu unterbinden die maximale Bandbreite damit zu limitieren.
Ein reines URL Filtering ist mit einem Router nicht möglich, das geht nur über einen Web Proxy.
Das IOS Manual oder die Cisco Webseite hat diverse Beispielkonfiguratonen für so ein ACL Filter Szenario.
Bitte warten ..
Mitglied: DrCox
06.11.2006 um 09:50 Uhr
Das Problem ist schon wieder aufgetreten.
Selbes Problem. Der Router lässt sich überhaupt nicht mehr ansprechen.
Allerdings kann ich die IP noch manuell konfigurieren und so noch auf die Switche zugreifen.

Vielleicht sollte ich mein "stack" hier mal posten.
Bitte warten ..
Mitglied: DrCox
06.11.2006 um 12:27 Uhr
Ich habe die Protokolle wieder aktiviert. Da stand, dass sie down waren, wie beim letzten Mal.
Danach bin ich zurück in meine Wohnung und habe den Router durch die Internetverbindung zum Router neu starten wollen.
Das funktionierte allerdings wieder nicht. Hab es dann noch mal an der Konsole gemacht.
Woran kann das liegen?
Kann ich irgendetwas an der Konsole noch testen?
Und wie kann man die Konfiguration rauskopieren? Unter cmd kann man ja nichts markieren und über Hyper Terminal verzieht sich alles.
Also am besten Screenshots?
Bitte warten ..
Mitglied: aqui
07.11.2006 um 21:00 Uhr
Mmmmhhh, irgendwas unterbricht dir da immer die Verbindung. Ob es nun der Switch ist der am Router hängt oder der Router selber. Das der Router abstürzt ist eher selten.
Es gibt mehrere Wege das rauszubekommen. Ggf. solltest du für eine Zeit in der das reproduzierbar auftrat einmal NUR deinen PC allein am Router anschliessen und einen Dauerping auf einen Zielrechner über den Router laufen lassen.
Danach kannst du dann relativ sicher sagen ob der Router selber oder etwas anderes die Verbindung unterbricht. Danach solltest du dir den Switch ansehen. Vielleicht fährt einer aus dem Wohnheim auch DoS Attacken auf Router oder Server. Es gibt viele Troubleshooting Szenarien...da muss man nun mal systematisch suchen...
Bitte warten ..
Mitglied: DrCox
09.11.2006 um 10:39 Uhr
wie kann ich einen dauerping machen?
Mir ist aufgefallen, dass an dem Switch an dem der Router hängt an einem Port (26) keine Daten mehr über die Switch-Software anzeigt.

1 100 1 0 0 0 0 0
2 2 100 2 0 0 0 0 0
3 3 100 3 0 0 0 0 0
4 4 100 4 0 0 0 0 0
5 5 100 5 0 0 0 0 0
6 6 100 6 0 0 0 0 0
7 7 100 7 0 0 0 0 0
8 8 100 8 0 0 0 2 0
9 9 100 9 1 0 1651 443 0
10 10 100 10 0 0 0 0 0
11 11 100 11 0 0 0 0 0
12 12 100 12 0 0 0 0 0
13 13 100 13 0 0 0 0 0
14 14 100 14 0 0 0 0 0
15 15 100 15 0 0 0 0 0
16 16 100 16 0 0 0 0 0
17 17 100 17 0 0 0 0 0
18 18 100 18 0 0 0 0 0
19 19 100 19 0 0 22 691 0
20 20 100 20 0 0 0 0 0
21 21 100 21 0 0 0 0 0
22 22 100 22 0 0 0 0 0
23 23 100 23 0 0 0 2 0
24 24 100 24 0 0 0 0 0
25 25 1000 25 0 0 421 962 0
26 26 1000 26 0 0 2 0 0
63 DEFAULT_VLAN 0 DEFAULT_VLAN NA NA 0 0 0



Der Port führt allerdings zu einem anderen Switch auf dem dann doch wieder Daten im üblichen Maße ankommen.

Vielleicht hat hier aufgrund der Konfiguration noch jemand einen Vorschalg:


Current configuration : 4378 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec

!
hostname
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!


!
!
no ip domain lookup
ip domain name *
no ip ips deny-action ips-interface
ip ips notify SDEE
!

!
!

!
!
!
interface BRI0
no ip address
shutdown
!
interface FastEthernet0
ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
ip address
***
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1

!
ip classless
!
!
ip http server
ip http authentication local
ip http secure-server
no cdp run
!
!
!
!
control-plane
!
banner login ^C
^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
end
Bitte warten ..
Mitglied: aqui
12.11.2006 um 01:17 Uhr
Du solltest besser die next Hop Adresse von der Default Route im Post entfernen, denn dadurch weist man das du in Koblenz wohnst und euer next Hop Router ein Cisco 7202 ist

Die Konfig ist soweit ok. Wenn du nicht unbedingt die Web Oberfläche des Routers nutzt solltest du diese mit "no ip http" abschalten. Das ist oft ein Quell von Angriffen auf das System.
An der Router konfig liegt es nicht. Das der Switch an dem Port keine Statistiken anzeigt würde mir eher Bauchschmerzen bereiten. Auf alle Fälle solltest du den Router mal an einen anderen Switchport hängen !

Einen Dauerping unter Windows führst du aus mit "ping -t <IP Adresse>". Ping <return> zeigt die Syntax des Kommandos bei Windows.
Auf dem Cisco Router kannst du dazu das erweiterete Ping Menü nehmen indem du auch einfach "ping" und <return> eingibst. Danach kommst du in ein Menü und der Rest ist geführt. Bei Retries trägst du dann eine hohe Zahl ein.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
Zyxel Support, Zyxel W-Lan Access Point NWA1100-NH (2)

Erfahrungsbericht von ThomasBIT zum Thema Router & Routing ...

Router & Routing
gelöst Zugangsdaten Router bei All-Ip Anschluss (8)

Frage von Firewire zum Thema Router & Routing ...

LAN, WAN, Wireless
WLAN-Funkreichweite Access Point MikroTik (4)

Frage von teret4242 zum Thema LAN, WAN, Wireless ...

Router & Routing
Access Point konfigurieren (2)

Frage von accessp01nt zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...