Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkprobleme - Übertragungsrate der Netzwerkkarte?

Frage Netzwerke LAN, WAN, Wireless

Mitglied: fewe

fewe (Level 1) - Jetzt verbinden

10.05.2006, aktualisiert 11.05.2006, 7434 Aufrufe, 10 Kommentare

Hallo!

Wir haben ein Problem mit unserem Firmen-Netzwerk. Zugriffe auf den Datenbank-Server (Windows 2003 Server mit SQL-Server) dauern teilweise extrem langsam.

Unsere Ausstattung:

1 Switch Ovislink (16 Port)
2 Switch Allied Telesyn (je 16 Port)
1 Switch HP ProCurve 2626 (NEU)

ca. 45 PCs
ca. 5 Drucker mit Netzwerkschluss

Das Gebäude ist ca. 3 Jahre alt, ich gehe davon aus das die Verkabelung OK ist.

Mit dem managebaren HP ProCurve versuchen wir nun das Problem in den Griff zu bekommen. Der Windows 2003 Server ist am Gigabit-Slot vom HP ProCurve angeschlossen.

Meine Frage (n):

Ist es sinnvoll die Übertragungsrate/Dublexrate der PCs auf 100 Vollduplex (statt Auto) zu stellen? Ich habe gehört das der Automodus viel zusätzliche Netzwerklast erzeugt. Stimmt das?

In den einzelnen Büros sind tw. zuwenig Netzwerkdosen, daher mussten wir einige Hubs verwenden (D-Link Switch/Hub 4 Port). Kann es sein dass diese Hubs das Netzwerk lahm machen?


Vielen Dank für eure Antworten.
Lg
Werner
Mitglied: debpa
10.05.2006 um 09:39 Uhr
Hallo,

hast Du mal geschaut, ob es wirklich ein Netzwerkthema ist?
Ich habe die Erfahrung gemacht, dass es mitunter auch durchaus ein Nameserver Thema sein kann.

Was für eine Infrastruktur besteht denn? Windows Domäne? Ein Domänen Controller? Macht der DC auch den Nameserver? Ist beim DC nur 127.0.0.1 als Nameserver eingetragen und macht der DNS dann den Forward und ist bei allen Clients nur der DC als DNS drin oder ist hier etwas wildwuchs entstanden und Windows zickt herum, weil es Namen nicht aufgelöst bekommt?

Viele Grüße
Dirk
Bitte warten ..
Mitglied: VoSp
10.05.2006 um 10:01 Uhr
Hallo,

was sagt denn eine netio Durchsatzmessung von einem langsamen Cleint auf den Server.

Wieviele Hubs hast Du denn hinterineander geschaltet und wieviele PC's hängen an den HUB's. Das kann sehr wohl zu Problemem führen.

Betrifft das denn nur diesen Db Server oder auch andere Server an diesem switch?

Wie mein vorredner schon sagte muss es nicht die Netzperformance sein sondern kan andere Grüde haben. ist die Ereignisanzeige der Server und der Cients sauber?

Bis dann

VoSp
Bitte warten ..
Mitglied: sysad
10.05.2006 um 10:40 Uhr
Probier doch mal einen der langsamen Clients direkt an dem Switch, an dem der Server auch dran ist.

AUTO macht normalerweise keinen großen Overhead, weil das am Anfang ausgehandelt wird und dann läufts mit der Rate weiter. Was manchmal kummer macht ist Vollduplex. Falls es die Leitung ist, kannst mal mit Halbduplex und oder 10MB experimentieren.
Bitte warten ..
Mitglied: fewe
10.05.2006 um 10:43 Uhr
Danke für die Antworten!

Bei uns läuft noch ein Windows NT Server als DC, ohne Nameserver. Die Ereignisanzeigen sind bei Server als auch Clients sauber.

Unser Problem wurde erst in den letzten Monaten akut, als mehrere neue User dazukamen (ca. 15 neue Leute in den letzten 4 Monaten).

An den Hubs hängen tw. die Drucker mit Netzwerkkarte + PC, Zeiterfassungsterminals + PC und ca. 5 PCs im "Bürocontainer". Einige der Hubs wurden schon eliminiert, aber es trat keine spürbare Besserung ein.

Der File-Server (Windows NT) ist davon eigentlich nicht betroffen.

Wie kann man den Durchsatz am besten messen? Netspeed wurde im Forum schon einigemale genannt?

Danke.
lg
Werner
Bitte warten ..
Mitglied: VoSp
10.05.2006 um 11:02 Uhr
Alos ich nehm für durchsatzmessungen immer netio.

http://www.netfuse.de/techarea/netio/netio1.htm

Bis dann

VoSp
Bitte warten ..
Mitglied: aqui
10.05.2006 um 11:03 Uhr
Den realen Durchsatz kannst du mit dem Tool "Netio" messen:

http://www.wintotal.de/softw/index.php?rb=28&id=671

(Läuft auf DOS Ebene im Eingabefenster. Ein Aufruf ohne Parameter zeigt dir die einfache Syntax)
Ein Design mit Hubs und Switches ist generell nicht unproblematisch. In der Regel supporten Hubs kein Fullduplex und da fängt das Elend schon an. Alle Ports an denen Hubs hängen solltest du prüfen ob die richtig negotiated (ausgehandelt im Auto Modus) sind an den Switches. Stehen diese Ports auf Fullduplex solltest du sie manuell auf Halbduplex setzen. Die Problematik ist der Mischbetrieb mit zuviel Ports im Halbduplex Modus an einer Switchinfrastruktur. Der Server am Gigabit Port macht immer Fullduplex, da Gigabit nur im Fullduplex Modus spezifiziert ist. Der bekommt also gar nichts mit davon das deine Hubs nur HDX können und sendet und empfängt munter drauflos. An einem Hub kann aber immer nur EINER gleichzeitig hören oder senden. Im Fulldup Modus kann man aber senden und empfangen zur gleichen Zeit. Nun kannst du dir vorstellen was passiert bei Mischbetrieb. Sendet jemand am Hub darf ein Switch auf dem Ports nichts senden denn der ist ja im HDX Mode und muss zwischenpuffern. Je mehr HDX Ports du hast und je mehr Traffic du bekommst je großer muss dieser Puffer sein. Bei "Low Budget" Switches wie du sie einsetzt wird aber genau daran und an anderen Dingen wie CPU Performance etc. gespart um eben in diesem Preissegment dem Wettbewerb standhalten zu können.
Fazit ist: Ist der Puffer voll werden Packete verworfen und damit kommt es zu Retransmits auf der IP L4 Ebene oder es kommt zu Kollisionen auf den HDX Links zum Hub und damit rennt alles im 3ten Gang und das je mehr je größer der traffic ist...genau so wie du es siehst.
Als To Dos solltest du dir die Hub Links üder das switch Management (aktuelle Port Parameter) ansehen ob die richtig negotiated sind und die ggf. auf feste Parameter einstellen. Das gleiche gilt für die Switches untereinander sofern du dafür kein Glasfaser benutzt. Generell ist es aber besser die Hubs komplett durch Switches zu ersetzen um eine einheitliche Infrastruktur zu bekommen.
Der Tip von oben ist auch richtig die "lahmen" Clients mal direkt auf den HP zu hängen und zu checken ob das Phänomen verschwunden ist.
Danach solltest du malmit NETIO checken wie der LAN Durchsatz ist um einen verlässlichen Vergleichswert abhängig von der Packetgröße zu bekommen !
Nochwas: Der "Auto" Modus erzeugt keinerlei Netzwerktraffic, das ist Unsinn !
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 11:06 Uhr
@sysad:

"normalerweise" macht Auto- Sense keine Probleme, leider ist das nicht immer so.
Manche Switche können mit manchen Karten nicht so, wie es sein sollte.
Ich hatte mal ähnliche Probleme, die Lösung war, nur NIC's mit Intel- Chipsatz und Cisco Switches zu verwenden, alles auf 100/full (Serverbereich).
Es hilft nur testen oder messen. 3Com- Karten laufen meist besser mit Auto, Intel besser mit
100/full, usw., was aber wiederum vom eingesetzten Switch abhängig sein kann.
Im Serverbereich würde ich Auto- Sense nicht verwenden, da ich die Übertragungsqualität meines Netzes kennen sollte und daher festlegen kann, was passieren soll.
Auto erzeugt Overhead und ich sehe keinen Grund, feststehende Parameter durch eine Automatik verifizieren zu lassen.
Half Duplex und 10MBit würde ich nicht mal in Erwägung ziehen (ausser zum Verständnis bzw. zum Testen), denn dann könnte iman auch gleich überlegen, ob man zum Datentransport USB- Sticks ausgibt.

Gruß - Toni
Bitte warten ..
Mitglied: aqui
10.05.2006 um 11:22 Uhr
Meist liegt es nicht am Switch sondern an den Karten, deshalb ist es "relativ" egal ob Cisco, Foundry, HP oder wer auch immer, zumal alle diese Hersteller in diesem Preissegment keine eigenen Port ASICS mehr benutzen sondern Cusctom Chips von Broadcom oder Xilink etc. ProCurve und andere Low Budget Hersteller produzieren gar nicht mehr selber sondern lassen Barebones bei Accton (Taiwan) fertigen, die dann nur noch gelabelt werden.
Die Problematik sind die Karten, denn der Autonegotiation Standard ist nicht 100% ausdefiniert und man hat so den Herstellern Platz für proprietäre Erweiterungen gelassen.
Gerade aber 3Com ist einer der Vertreter der diese leidlich ausnutzt mit all den Konsequenzen. Denn gerade dieser Hersteller hat über die Jahre die meisten Probleme im Negotiation Umfeld ! (Außer natürlich mit Hubs und Switches aus seiner eigenen Produktion). Der Grund sind diese zusätzlichen Bits bzw. Infromationen im Negotiation Frame der Switches durcheinander bringt und die Parameter falsch einstellen lässt. Nimmt man billigste 5 Euro Realtek 8139 basierende Karten passiert das meist nicht, weil hier aus Preisgründen nur das allernötigste implementiert ist um dem Standard zu genügen....von anderen Nachteilen dieser Karten mal abgesehen.
Fazit: Generelle Aussagen geht oder geht nicht abhängig vom Hersteller lassen sich nicht machen ! Es wird immer Kombinationen von Karten Chips mit Port ASICS von Switches geben bei denen es zu Problemen kommt im Auto Modus.
Gekniffen sind dann meist nur die die noch nicht einmal managebare Switches haben, wo man mit statischen Parametern Abhilfe schaffen könnte.
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 11:28 Uhr
Korrekt, ich habs eben etwas "verblümter" ausgedrückt, um nicht einem Hersteller auf die Zehen zu treten.

Gruß - Toni
Bitte warten ..
Mitglied: fewe
11.05.2006 um 09:31 Uhr
Vielen Dank für eure Hilfe.

Wo kann man sich am besten schlau machen bezüglich der Fehler / Fehlermeldungen bei Switch-Ports? Was bedeuten die einzelnen Meldung bei managbaren Switches bzw. gibt es Fehler die besonders kritisch sind? Ich habe schon mal gegoogelt, aber keine wirklich brauchbaren Infos erhalten (ich weiß jetzt aber was die Abkürzungen bedeuten )

Z.B:
FCS Rx
Alignment Rx
Runts Rx
Giants Rx
Total Rx Errors
Drops Rx
Collisions Tx
Late Colln Tx
Excesseive Colln
Deferred Tx

Danke und lg
Werner
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Netzwerkprobleme Setupänderung (2)

Frage von mmovchin zum Thema DSL, VDSL ...

Server-Hardware
gelöst SFP+ Twinax vs Cat6 Netzwerkkarte (18)

Frage von Fenris14 zum Thema Server-Hardware ...

LAN, WAN, Wireless
Netzwerkprobleme mit Synology DMS 5.2 auf einem HP Proliant unter ESXI 5.5 (4)

Frage von Herbiems89 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...