Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkprobleme mit dem Denon X3100 AVR

Frage Netzwerke LAN, WAN, Wireless

Mitglied: MikeThomson

MikeThomson (Level 1) - Jetzt verbinden

04.01.2015 um 15:44 Uhr, 2414 Aufrufe, 4 Kommentare

Hallo zusammen,

kurz vorab ich komme eigentlich aus der E-Technik und habe bislang mit Netzwerken wenig zu tun. Jetzt stehe ich vor einem Problem welches mich etwas überfordert.

Wir haben hier ein Elektro-Bus-System (KNX) im Einsatz. Als Endgeräte werden normale PCs eingesetzt, auf der eine Software zur Gebäudesteuerung läuft. In der Software kann ich z.B. das Licht ein und ausschalten ... Als Schnittstelle zum KNX wird ein spezieller Server als closed-box eingesetzt. Dieser "übersetzt" die Kommandos und sendet diese auf den Elektro-Bus. Funktioniert perfekt.

Im Netzwerk ist auch ein Denon X3100 AVR eingebettet. Das Problem ist jetzt, dass wenn der Denon AVR ausgeschaltet wird frieren mir die PCs mit der Software zur Gebäudesteuerung ein. Sprich ich kann für 30 Sekunden nichts machen, danach läuft alles wieder normal.

Nach langer Recherche muss es mit Netzwerk zusammenhängen. Wenn ich das Netzwerkkabel aus dem Denon X3100 herausziehe habe ich kein einziges Problem. Stecke ich das Kabel wieder rein und schalte dann das Gerät aus hängen meine Clients wieder.

Ich vermute, dass der Denon X3100 mir irgendwas beim abschalten auf das Netzwerk schickt was dazu führt, dass das Netzwerk stockt. Die Probleme bestehen nur zum Zeitpunkt des Ausschalten des Denon's!

Hier bräuchte ich etwas Unterstützung! Wie finde ich den Fehler und wie kann ich das Problem dann beseitigen? Denn der Netzwerkanschluss ist zwingend erforderlich. Im Netzwerk ist ein Switch TP-Link TL-SG2424P verbaut.

Besten Dank und Gruß

Mike
Mitglied: StefanKittel
04.01.2015 um 16:41 Uhr
Hallo Mike,

da sind natürlich recht viele Fragezeichen, aber ich probiere mal mein Glück.

Frage: Was hat der X3100 mit dem KNX zu tun?
Du schreibst im Netzwerk eingebunden. Wird er durch das KNX gesteuert oder überwacht?

Das ganze klingt für mich weniger nach einem Netzwerkproblem, sondern nach einer schlecht programmierten Software im closed-boxed-server.
30 Sekunden hört sich verdächtig nach einem Timeout an.

Der Server überwacht regelmäßig ob alle Geräte noch da sind und antworten.
Nun antwortet der X3100 ja nicht mehr, da er ausgeschaltet wurde. Also wartet der Server 30 Sekunden ob der nicht doch noch antwortet.
Der Bug wäre hier, dass der Server in dieser Zeit keine Kommandos mehr annimmt.
Wenn das so wäre, wäre das aber sehr schlecht programmiert.

Alternativ kann es auch sein, dass der X3100 beim ausschalten noch ein Abmelde-Kommando an den Server senden.
Dieses könnte fehlerhaft sein und führt zu diesem "Schluckauf".

Vieleicht helfen Die diese Ansätze ja.

Viele Grüße

Stefan
Bitte warten ..
Mitglied: MikeThomson
04.01.2015, aktualisiert um 17:07 Uhr
Hallo Stefan,

dane für die Hilfe.

Der AVR hat erstmal nichts mit dem KNX zu tun. Einzig die Steckdose an dem der AVR hängt wird über das KNX-System gesteuert (Strom EIN/AUS). Ich habe das KNX System nur ins Spiel gebracht, da die Clients hängen sobald ich den AVR ausschalte und das passiert halt nur wenn das Netzwerkkabel im AVR gesteckt ist.

Eine andere Auswirkung im Netzwerk sehe ich nicht. Was nicht heißt das es diese nicht gibt.

Naja an dem closed-box Server kann ich nichts machen geschweige denn ändern. Fakt ist, dass das Problem im Moment nur in dieser Kombination auftritt. Da der Server nur über den KNX-Bus - ich will mal sagen - mit der Steckdose kommuniziert und nicht direkt mit dem AVR kommt hier keine Kommunikation zu stande. Einzig die Clients die ich zur Visualisierung nutze kommunizieren über das Netzwerk mit dem closed-boxed Server und an dem Netzwerk hängt eben auch der AVR mit dran. Aber auch eine direkte Kommunikation zwischen AVR und Clients dürfte es nicht geben. Zumindest ist hier nichts von mir eingerichtet. Eigentlich sollte der AVR nur auf die NAS und das Internet zugreifen.

Der Server überwacht regelmäßig ob alle Geräte noch da sind und antworten.
Genau das ist der Punkt. Diesr KNX-Server spricht nur mit den Geräte im KNX-Bus und mit den Visualisierungs-PCs im LAN. Er überwacht meiner Meinung nach keine anderen Geräte. Zumindest ist das nicht seine Aufgabe. Der Server ist ein GIRA Homeserver. Mmn. Marktführer was nicht heißen soll frei von Fehlern.

Alternativ kann es auch sein, dass der X3100 beim ausschalten noch ein Abmelde-Kommando an den Server senden.
Dieses könnte fehlerhaft sein und führt zu diesem "Schluckauf".
Sowas in der Art würde ich auch vermuten. Die Frage ist nur, wie bekomme ich jetzt raus ob der AVR beim ausschalten noch etwas sendet und wenn ja an wen?

Zweite Frage die sich mir da gerade aufdrängt. Kann ich dem AVR bzw. Switch nicht mitteilen, dass der Port an dem der AVR hängt nur mit dem Port der NAS oder alternativ mit dem Port des Routers für den Internetzugriff "reden" darf?

Gruß

Mike
Bitte warten ..
Mitglied: StefanKittel
04.01.2015 um 19:47 Uhr
Zitat von MikeThomson:
Zweite Frage die sich mir da gerade aufdrängt. Kann ich dem AVR bzw. Switch nicht mitteilen, dass der Port an dem der AVR
hängt nur mit dem Port der NAS oder alternativ mit dem Port des Routers für den Internetzugriff "reden" darf?

Hallo,
das hängt von dem Switch ab. Managed Switche können etwas was sich VLAN nennt.
http://de.wikipedia.org/wiki/Virtual_Local_Area_Network#Portbasierte_VL ...

Viele Grüße

Stefan
Bitte warten ..
Mitglied: MrNetman
05.01.2015 um 12:39 Uhr
Dein Denon X3100 Receiver kann sehr viel.
Unter anderem kann er auch Netzwerkdienste bereit stellen.
Netzwerkdienste werden als Broadcast bereit gestellt, Das höhren alle Endgeräte. (Stichwort gapless play)
Die KNX-Komponenten können vermutlich nichts oder gar wenig damit anfangen und reagieren deshalb so eigenartig.

Das Trennen der Netzwerke hilft definitiv.
Wenn die die PCs, Receiver und Lautsprecher in ein VLAN und das KNX Netzwerk ins ander legst, gibt es schon mal die Effekte nicht.
Aber welches der beiden Netzwerke muss ins Internet? Wenn das KNX Netzwerk keinen Internetanschluß benötig, dann ist es einfach. Dann wird das VLAN der PCs und des Receivers mit dem Router verbunden.
Ansonsten benötigst du einen etwas anderen Router (Multiport- oder VLAN-fähig) oder eben eine spezielle Konfiguration dazu.

Gruß
Netman
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
DSL, VDSL
Netzwerkprobleme Setupänderung (2)

Frage von mmovchin zum Thema DSL, VDSL ...

LAN, WAN, Wireless
Netzwerkprobleme mit Synology DMS 5.2 auf einem HP Proliant unter ESXI 5.5 (4)

Frage von Herbiems89 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...