Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Linux Suse

GELÖST

Netzwerkprobleme unter Suse 9.3

Mitglied: cleaner

cleaner (Level 1) - Jetzt verbinden

17.03.2006, aktualisiert 20.03.2006, 4800 Aufrufe, 8 Kommentare

Der Ping aus den vorhandenen Netzen funktioniert nur in eine Richtung .

Also wir haben eine kleine Domäne mit drei Routern und noch anderen Servern. Die Netze die wir nutzen sind einmal 172.1.10.1 ; 172.2.10.1 ; 172.3.10.1 . Das routing funktioniert wunderbar vom 3 ins 2 und dann ins 1 Netz . Aber wenn wir versuchen vom 2 oder 1 Netz ins 3 Netz zu pingen schreibt er uns den Fehler Zeitüberschreitung .
Mit dem Befehl tracert unter Windows nimmt er beim tracert 172.3.10.1 den weg über 172.2.10.1 dann 172.1.10.1 und dann geht er raus ins Nirvana .
Kann mir da einer einen Hinweis geben woran das liegen kann . Dadurch können wir auch keine Verbindung auf webmin zu Rechnern aufbauen die abwährts in anderen netzen sind.
Ich bin für jeden Rat dankbar.
Mitglied: Dani
17.03.2006 um 11:06 Uhr
Hi,
würde sagen, da fehlt ne Route im 172.2.x.x Netz.


Gruß
Dani
Bitte warten ..
Mitglied: cleaner
17.03.2006 um 11:34 Uhr
Aber ich kann doch gar keine Route eintragen wenn das interne Netz durch eine virtuelle . Netzwerkschnittstelle generiert wird . Und die Rechner kennen sich ja auch alle.
NIS funktioniert ja auch ohne Probleme. Ich kann mich auf einer Maschine im 3 netz anmelden obwohl die Profile auf einem Rechner liegen der im 1 Netz ist.
Bitte warten ..
Mitglied: Okies
17.03.2006 um 12:51 Uhr
Aber ich kann doch gar keine Route eintragen
wenn das interne Netz durch eine virtuelle .
Netzwerkschnittstelle generiert wird .

Warum nicht?

Und
die Rechner kennen sich ja auch alle.

'Kennen' und erreichen sind zwei Dinge...

Okay, erstmal, wollen die Rechner externe Netze erreichen? 172.1.10.0 ist _kein_ privates Netz, genau wie 172.2.x.x und 172.3.x.x. Privat wäre 172.16.x.x bis 172.31.x.x. Wenn Du diese Netze so nimmst, kannst Du nicht in die entsprechenden *wirklichen* Netze kommunizieren.

Als nächstes redest Du von Routern. Was für Router? Cisco, Juniper? Was für ein Protokoll? RIP, BGP, OSPF? Sorry, aber ich glaube die von Dir zur Verfügung gestellten Informationen reichen einfach nicht aus. Also, versuche nähere Auskünfte über Dein Netzwerk zu liefern, am besten mit Ausgaben von ifconfig, ip addr show und route -n.

Gruss, Oliver
Bitte warten ..
Mitglied: cleaner
17.03.2006 um 22:35 Uhr
Also um deine Frage zu beantworten nein die Rechner sollen kein externes Netz erreichen. Sie befinden sich nur im Intranet für diese Firma.
Die Router die ich erwähnte sind normale Rechner die mit Suse 9.3 bestückt sind und die nur als Router fungieren. Wo jeweils eine physikalische Netzwerkkarte drin ist und wo eine virtuelle Schnittstelle generiert wurde .

>ROUTER1 virtuell 172.1.10.1/16 eth0:1; physikalisch 192.168.75.100/24 eth0
>ROUTER2 virtuell 172.2.10.1/16 eth0:1; physikalisch 172.1.10.100/16 eth0
>ROUTER3 virtuell 172.3.10.1/16 eth0:1; physikalisch 172.2.10.100/16 eth0

Die virtuellen Schnittstellen sind als internes Netz in der Firewall diffiniert worden und die physikalischen als externes Netz. Es sind alle zu verfügung stehenden Dienste eingetragen die die Firewall durch lassen soll. Zusätzlich haben wir noch den Port 10000 für WEBMIN; 631 für CUPS damit Clients sich damit verbinden können; 139 für Ping anfrage.
Zur Zeit besteht das Problem das ROUTER3 den ROUTER1 und 2 anpingen kann und ROUTER2 den ROUTER1 anpingen kann aber ROUTER1 kann nicht ROUTER2 und 3 anpingen und ROUTER2 kann nicht den ROUTER3 anpingen. Nun ist die Frage was ist daran falsch und wie kann ich das ändern damit der ping auch beantwortet wird.
Dadurch vermute ich nämlich auch mal das die Clients aus dem 172.1.0.0 Netz auch nicht auf den CUPS zugreifen können. Weil die Clients aus dem 172.3.0.0 Netz können auf den CUPS zugreifen.
Ich hoffe diese Information reicht fürs erste einmal aus und das mir einer bei diesem Problem weiter helfen kann.

Danke im voraus Gruss Cleaner
Bitte warten ..
Mitglied: cleaner
17.03.2006 um 23:02 Uhr
Um auf deine Frage zu antworten nein die Rechner sollen kein externes Netz erreichen.
Sie sin nur im Intranet der Firma.
Die ROUTER sind einfache Rechner die als Router fungieren.

>ROUTER1 virtuell 172.1.10.1/16 eth0:1; physikalisch 192.168.75.100/24 eth0
>ROUTER2 virtuell 172.2.10.1/16 eth0:1; physikalisch 172.1.10.100/16 eth0
>ROUTER3 virtuell 172.3.10.1/16 eth0:1; physikalisch 172.2.10.100/16 eth0

In der Firewall wurde die virtuelle als internes Netz und die physikalische als externes Netz deklariert. Für das externe Netz wurden alle zu verfügung stehenden Dienste ausgewählt um diese auch durch zu lassen. Ebenso haben wir die PORTS 10000 für WEBMIN ; 139 für PING um Antwort zu bekommen ; 631 für CUPS damit die Clients aus allen Netzen über den CUPS drucken können.

Zur Zeit ist es so das ROUTER3 alle anpingen kann, ROUTER2 nur den ROUTER1 und ROUTER1 gar keinen von beiden.
ALso funktioniert das PINGEN nur in eine Richtung und die ist nach draussen zum 192.168.75.0 Netz.

Ich habe mal einer Windows Maschine die IP 172.2.10.51 gegeben den Befehl "tracert 172.3.10.1" eingegeben und als Antwort habe ich bekommen.

1: - 172.2.10.1
2: - 172.1.10.1
3: - 192.168.75.223 Das ist der Rechner der das Internet zu Verfügung stellt.
4: - dann kam ein extern stehender Router von netgear der aber nicht zum Projekt gehört das Tor zur Aussenwelt ist der 192.168.75.223
5: - der Provider

Ich hoffe diese Informationen sind etwas Aufschlussreicher und das mir jemand helfen kann.
Danke schon mal im voraus gruss Cleaner
Bitte warten ..
Mitglied: Okies
18.03.2006 um 13:20 Uhr
Also um deine Frage zu beantworten nein die
Rechner sollen kein externes Netz erreichen.
Sie befinden sich nur im Intranet für
diese Firma.

Okay, das klingt schon besser

>ROUTER1 virtuell 172.1.10.1/16 ; physikalisch 192.168.75.100/24
>ROUTER2 virtuell 172.2.10.1/16 ; physikalisch 172.1.10.100/16
>ROUTER3 virtuell 172.3.10.1/16 ; physikalisch 172.2.10.100/16

Das ist nicht so einfach. Ich denke mir, Du solltest mal auf allen Servern ein route -n machen, ein blaues Wunder?
Das Problem ist einfach das automatisch Routen gesetzt werden, z.B. wird ROUTER3 automatisch alles an das Netz 172.2.x.x über das Interface eth0 (Name okay?), also das physikalische, schicken wollen weil es eine entsprechende Adresse hat. Muß aber in diesem Falle über eth0:1 (Name okay?). So wird es auch für ROUTER2 aussehen, oder so ähnlich. Ich kann mir eigentlich nur denken das ROUTER1 in der Lage ist vernünftig zu kommunizieren.
Nicht einfach... am besten änderst Du die Adressen der physikalischen Karten in ROUTER2 und ROUTER3. Ist da auch ein anderes Netz wie z.B. irgendein 192.168.x.x'er möglich? Wäre besser.

Gruss, Oliver
Bitte warten ..
Mitglied: Okies
18.03.2006 um 14:25 Uhr
Wir werden mal versuchen das zu zerlegen, ich installieren meinen anderen Computer sowieso gerade neu, habe also ein Stündchen Zeit

Zur Zeit ist es so das ROUTER3 alle anpingen
kann, ROUTER2 nur den ROUTER1 und ROUTER1 gar
keinen von beiden.

Warum kann ROUTER3 das? Ich sage mal folgendes. ROUTER1 soll ROUTER2 oder ROUTER3 erreichen. Er wird wahrscheinlich keine Route zu denen haben und so probieren. Über die physikalische Adresse wird er dann ins Internet geschickt. ROUTER2 hat eine 172.1.x.x Adresse auf der physikalischen Karte, die wiederum ist physikalisch auch mit der virtuellen 172.1.10.1 verbunden. Bingo! ROUTER3 wird wahrscheinlich auf demselben Wege ROUTER1 und ROUTER2 finden.

ALso funktioniert das PINGEN nur in eine
Richtung und die ist nach draussen zum
192.168.75.0 Netz.

Defaultroute?

Ich habe mal einer Windows Maschine die IP
172.2.10.51 gegeben den Befehl "tracert
172.3.10.1" eingegeben und als Antwort
habe ich bekommen.

1: - 172.2.10.1
2: - 172.1.10.1
3: - 192.168.75.223 Das ist der Rechner der
das Internet zu Verfügung stellt.
4: - dann kam ein extern stehender Router
von netgear der aber nicht zum Projekt
gehört das Tor zur Aussenwelt ist der
192.168.75.223
5: - der Provider

Klar, ist eine externe Adresse,wird nach außen weitergegeben.

Bei SuSE würde ich evtl. mal dieses schicke YaST Tool verwenden, und in jedem Rechner die Eigenschaften der Netzwerkkarten aufrufen, da kannst Du irgendwo Einfluß auf's Routing nehmen. Du mußt jedem der drei Router mitteilen das er jeweils für die Netze 172.1.0.0, 172.2.0.0 und 172.3.0.0 die Richtung virtuelle Schnittstelle nimmt. Das könnte es dann schon gewesen sein. Dann mußt Du aber wohl auch die Defaultroute über die physikalische Schnittstelle laufen lassen. Dein internes, virtuelles Netz sollte dann fluppen, das externe ist immer noch nicht perfekt. Um das hinzubekommen ändere die 172er Adressen in andere. 172.5.x.x oder 192.168.x.x. Ganz egal, nix aus den internen Netzen 172.1.0.0 bis 172.3.0.0. Glaub mir, iss besser.

Viel Glück, Oliver
Bitte warten ..
Mitglied: cleaner
20.03.2006 um 15:34 Uhr
Ich danke dir erst einmal für deine Hilfe.
Das Problem ist jetz endgültig gelöst der Ausschlaggebende Punkt war das er den routed Dienst immer wieder ausgeschaltet hat und wir haben den einfach noch mal neu installiert und in Webmin gesagt das er den auch immer beim Systemstart mit ausführen soll und schon waren die Probleme behoben. Mit der vorhandenen konfiguration.

Gruss Cleaner
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
RDS Netzwerkprobleme
gelöst Frage von mcmaccaWindows Netzwerk3 Kommentare

Hallo mal wieder, ein vollständig konfigurierter Win 2012R2 RDS auf HyperV (max 5 User) macht Probleme. Die Verbindung bricht ...

Microsoft
DFS und Netzwerkprobleme
Frage von Herbi1984Microsoft1 Kommentar

Hallo zusammen, ich habe bei uns ein Problem, bei dem ich zurzeit nicht weiter komme. Bei jedem User wird ...

DSL, VDSL
Netzwerkprobleme Setupänderung
Frage von mmovchinDSL, VDSL2 Kommentare

Hallo Community! Mein Setup sieht wie folgt aus: APL DSL Business Anschluss mit fester IP => DSL Splitter => ...

Windows Server
Netzwerkprobleme Win2012R2
gelöst Frage von petereWindows Server3 Kommentare

Hallo, auf einem Windows 2012 Server habe ich HyperV laufen. Dieser virtualisiert u.A. einen Gast: Windows 2012 R2 Standard, ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall10 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS9 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...