Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkressourcen - verschiedene Freigaben auf dem gleichen Server

Frage Microsoft Windows XP

Mitglied: Leopold.Bloom

Leopold.Bloom (Level 1) - Jetzt verbinden

07.09.2012 um 11:50 Uhr, 4504 Aufrufe, 14 Kommentare

Hallo liebe Leute,


unter WinXP SP3

ich nutze mehrere Freigaben auf demselben Server und möchte die als Netzwerkressource einbinden. Der Server ist immer derselbe nur die Anmeldung nicht. Ich muss mich je nach Account mit einer Mailadresse und einem Passwort anmelden. Bei der ersten Freigabe funktioniert es - bei allen weiteren nicht - wenn ich die aufrufe bekomme ich die erste Freigabe geliefert.

Um es konkret zu machen.

Ich (bzw. meine Frau und ich) habe(n) bei der Telekom zwei Clouds (je eine) und wir teilen uns einen Rechner und nutzen das gleiche Profil. Wenn ich die Clouds als WebDav LW mappe klappt das ganz hervorragend. Aber ich habe nicht mehr genügend LW Buchstaben über und hätte es gerne als Netzwerkressource.

Ich habe eine Netzwerkressource angelegt.

die Freigabe heißt https://webdav.mediencenter.t-online.de. Dann wird nach einer Mailadresse und dem Passwort gefragt. Also UserA@beispiel.com und passwortA. Funktioniert. Ich komme auf den UserA Account.

Dann die zweite Netzwerkressource.

die Freigabe heißt wieder https://webdav.mediencenter.t-online.de . Dann wird nach einer Mailadresse und dem Passwort gefragt. Also UserB@beispiel.com und passwortB. Die Ressource wird angelegt. Aber ich komme nicht auf den UserB Account sondern auf den UserA Account.

In der Netzwerkumgebung habe ich die beiden Ressourcen. Sie enthalten jeweils einen lnk namens Target und sonst nichts. Die beiden target Dateien unterscheiden sich - sie enthalten den jeweiligen Ressourcennamen. Trotzdem zeigen sie offenbar auf die gleiche Ressource.

Das ist nicht das was ich möchte. Woran liegts? Kann man es ändern?

Sachdienliche Hinweise werden gern genommen. Vielen Dank für Euer Interesse.

LG

Leo





Mitglied: MrNetman
07.09.2012 um 12:18 Uhr
Hallo Leo,

unter gleichem Namen wird man wohl auch nur das selbe bekommen. Ist fast logisch.
Aber es gibt Tricks.
Dein Browser merkt sich einige Informationen. Wenn die erste klappt, wird die zweite nicht genutzt. (Ist dann aber nicht so elegant wie WebDAV). Zweiten Browser nutzen.
Der PC meldet sich auch entsprechend so an. Im LAN kann man das umgehen, indem man die gleiche Maschine mit unterschiedlichen Methoden verbindet: Einmal mit Namen und einmal mit der IP-Adresse. Dann kann man auf einer Maschine zwei unterschiedliche Benutzer mit unterschiedlichen Rechten auf ein und dem selben Server nutzen.
Die Telekom macht solche Dinge auch schon mal Benutzeraccount fest. T-online-Nummer und so. Dann gibt es für WEBDAVnur eine Resource.

Gruß
Netman
Bitte warten ..
Mitglied: DerWoWusste
07.09.2012 um 12:21 Uhr
Hi.

Versuch es bitte zum Test einmal über deren IP: 62.157.140.89
https://62.157.140.89
Bitte warten ..
Mitglied: Leopold.Bloom
10.09.2012 um 12:22 Uhr
Hallo MrNetman, hallo DerWoWusste,

vielen Dank für Euer Interesse und Eure Antworten. Seltsam genug. Über DNS und über IP macht es einen Unterschied. Obwohl ja der DNS Server den Namen nur in die IP umsetzt. Mit 2x IP geht es nicht, mit 2x DNS geht es auch nicht. Mit 1x IP und 1x DNS geht es. Das verstehe wer will. Und was mache ich, wenn mein Sohn auch noch einen Account will?

Eine kleine Lösung habe ich gefunden. Ich benutze ohnehin für Dateioperationen fast nur den Totalcommander. Für den gibt es ein WebDav Plugin und damit kann man eine Art virtuellen Pfad ohne LW Buchstaben erzeugen.

Aber ich habe auch bei T-Online noch mal nachgefragt. Die weisen mir ja auch aus Freigabe, Mailadresse und Passwort den richtigen Account zu. Von denen habe ich noch keine Antwort.Falls ich eine bekomme, die der Sache dienlich ist, werde ich sie hier posten.

LG aus HH

Leo
Bitte warten ..
Mitglied: DerWoWusste
10.09.2012 um 12:37 Uhr
Mit 2x IP geht es nicht, mit 2x DNS geht es auch nicht. Mit 1x IP und 1x DNS geht es. Das verstehe wer will.
Das war zu erwarten. Siehe http://support.microsoft.com/kb/938120
Dies beantwortet auch Deine Frage zu einem 3. Account: Du müsstest dann in die Hosts-Datei Aliases einfügen.
Bitte warten ..
Mitglied: Lochkartenstanzer
10.09.2012 um 12:44 Uhr
Moin,

Es ist kein wunder, wenn ein http/https-Server unterschiedlich reagiert je nachdem, ob man ihm eine IP oder einen Namen vorwirft. Die meisten http-Server heutzutage bieten mehrere Vrtuelle Server und je nachdem, was der Client anfragt wird dann unterschiedlich geantwortet. wenn man nun nur die IP benutzt, weiß der http-Server (nichts andres ist ein WebDAV-Server) unter umständen gar nicht, zu welchem Server er das zuordnen soll.


um das korrekt abzubilden muß man ggf. in der hosts-datei des Clients den Server mit der IP-Adresse eintragen und dann über den Servernamen anfragen.

lks
Bitte warten ..
Mitglied: Leopold.Bloom
10.09.2012 um 23:26 Uhr
Moin,

dann habe ich DNS doch nicht richtig verstanden. Ich dachte, dass der Name aufgelöst wird, bevor ich den Server erreiche. Im heimischen Netzwerk ist im Router der DNS. Wenn ich keinen Router habe, nutze ich den DNS vom Provider. Oder einen anderen. Wenn ich keinen DNS angegeben habe findet meine Botschaft ihr Ziel nicht, es sei denn, ich benutze eine IP zum Versand. Wenn ich einen anderen Rechner im Netzwerk anpinge löst der DNS den Namen auf und pingt mit der IP den anderen Rechner an. Der andere Rechner weiß nicht ob ich ihn über die IP oder einen Namen angesprochen habe. Das hat mit http nichts zu tun. Der Empfänger wird in jedem Fall über die IP angesprochen. So habe ich mir das immer vorgestellt. Aber anscheinend ist das falsch.

Wenn ich den MS Support Hinweis richtig verstehe scheitert es schon im eigenen Rechner. Eine Fehlermeldung wie da beschrieben habe ich allerdings nicht bekommen. Ob auf der anderen Seite ein Windows basierter Rechner steht weiß ich nicht - ich vermute eher nicht.

Aber nun zu dieser Hosts Datei. Ihr meint doch die Datei ohne Extension, die bei WinXP in Windows\System32\driver\etc\ liegt, oder? Was müsste ich da eintragen? Bisher steht da über den T-Online Webdav Server nichts drin. Da käme dann die IP des Servers und ein Name. Nächste Zeile wieder die IP und ein anderer Name und so fort? Bis ich ausreichend Aliase zusammenhabe? Oder wie muss ich mir das vorstellen? Da mache ich mir meinen eigenen kleinen DNS, der meine Namen auflöst? Die Aliase gaukeln meinem Rechner vor er würde unterschiedliche ferne Rechner ansprechen obwohl es die gleiche IP ist? Im Hinweis von MS steht, dass es so gewünscht ist. Für mich hört sich das immer noch seltsam an.

LG aus HH

Leo
Bitte warten ..
Mitglied: DerWoWusste
10.09.2012 um 23:46 Uhr
Moin.

Nochmal zusammenfassend: Ja, es scheitert nicht serverseitig, sondern schon bei Dir. Windows möchte zu einem Server nur eine Kombination von Benutzernamen und Kennwort zur Zeit zulassen - über die Hosts-Datei - ja, alles richtig wiedergegeben von Dir - kannst Du ihm vorgaukeln, dass es mehrere Rechner sind.
Bitte warten ..
Mitglied: Leopold.Bloom
11.09.2012 um 02:00 Uhr
Moin,

perfekt. Super. Es funktioniert. Die diversen Aliase kan man in eine Zeile schreiben. Und die host Datei wird vor dem DNS Server ausgewertet. Die Aliase dürfen allerdings kein @ enthalten. Jetzt sind alle WebDav Connects als Netzwerkressourcen hinterlegt. Die User und Passwörter kann man in den Windows Benutzerkonten hinterlegen, so dass man sich auch nicht jedesmal neu anmelden muss. Ich bin begeistert. Vielen Dank - Ihr habt mir sehr geholfen.

Eine neue Frage tut sich noch auf. Wenn ich meine Accounts über diese Netzwerkressourcen angezeigen lasse werden mir Leerzeichen in den Order- und Dateinamen mit %20 angezeigt. Offenbar ein anderer Code als in Windows üblich. Kann ich Windows dazu überreden bei diesen Ordnern den richtigen Code zu für die Darstellung zu wählen?

LG aus HH

Leo
Bitte warten ..
Mitglied: DerWoWusste
11.09.2012 um 09:26 Uhr
Jetzt sind alle WebDav Connects als Netzwerkressourcen hinterlegt.
Das verstehe ich noch.
Wenn ich meine Accounts über diese Netzwerkressourcen angezeigen lasse werden mir Leerzeichen in den Order- und Dateinamen mit %20 angezeigt.
Das leider nicht mehr - kannst Du näher beschreiben, wo das angezeigt wird?
Bitte warten ..
Mitglied: Lochkartenstanzer
11.09.2012, aktualisiert um 09:39 Uhr
Zitat von DerWoWusste:
> Jetzt sind alle WebDav Connects als Netzwerkressourcen hinterlegt.
Das verstehe ich noch.
> Wenn ich meine Accounts über diese Netzwerkressourcen angezeigen lasse werden mir Leerzeichen in den Order- und
Dateinamen mit %20 angezeigt.
Das leider nicht mehr - kannst Du näher beschreiben, wo das angezeigt wird?

Das ganze läuft über http. Da wird <space> (=char(0x20) oder =32dec) als %20 codiert. Nun ist der webDAV-Client zu dämlich das wieder in <space> (=Leerzeichen) zurückzuübersetzen und korrekt anzuzeigen. Da erscheint dann halt "%20" im Datei-/Ordnernamen.

lks
Bitte warten ..
Mitglied: Leopold.Bloom
11.09.2012, aktualisiert um 09:59 Uhr
Moin DerWoWusste,

tut mir leid wenn ich mich unklar ausgedrückt habe, ich war schon ziemlich müde und auch erstaunt, was da passiert. Meine WebDav Accounts erscheinen nun als Ordner in der Netzwerkumgebung. Wenn ich so einen Ordner mit dem Explorer oder dem TC öffne, wird mir das oberste Verzeichnis auf das ich Zugriff habe gelistet. Jetzt jeweils der richtige Account. Ich sehe dann also die Ordner und Dateien, die auf dem Account abgelegt sind. Genau wie ich die oberste Ebene sehe wenn ich den Account als LW mappe. Aber die Verbindung ist trotzdem "irgendwie anders". Wenn ein Ordnername Leerzeichen enthält werden die Leerzeichen als %20 dargestellt - vielleicht eine andere Zeichenkodierung. Dann steht da nicht "mein Ordner" sondern "mein %20Ordner". Umlaute werden allerdings normal dargestellt. Außerdem habe ich auf der ersten Ebene kein Schreibrecht. Ich kann weder eine Datei dahin kopieren noch einen Ordner anlegen. Ich bekomme aber auch keine Fehlermeldung wie "Permission denied" oder so. Es passiert nur nichts. In den darunter liegenden Ordnern kann ich schreiben. Wenn ich den Account gemappt habe, kann ich auch auf der obersten Ebene schreiben. Ich kann den Unterschied nicht einordnen. Wird da ein anderes Protokoll genutzt? Ich weiß auch nicht wo da was passiert. Ist das serverseitig oder auch auf meiner Seite?

LG

Leo
Bitte warten ..
Mitglied: Leopold.Bloom
11.09.2012 um 09:56 Uhr
Nachtrag

Wenn ich den Account gemappt habe, werden auch die Ordner und Dateinamen richtig dargestellt. Einen extra Webdav Client benutze ich nicht. Die Accounts sind als normale LW im Explorer bzw. TC zu sehen.

LG

Leo
Bitte warten ..
Mitglied: DerWoWusste
11.09.2012 um 10:15 Uhr
Keine Ahnung, warum Du mal schreiben kannst, mal nicht. Wegen %20 hat Dir Lochkartenstanzer was geschrieben.
Bitte warten ..
Mitglied: Leopold.Bloom
11.09.2012 um 11:41 Uhr
@DerWoWusste

Naja, notfalls kann ich ja alles eine Ordnerebene weiter nach oben schieben und auf Leerzeichen in Datei und Ordnernamen verzichten. Oder ich finde noch eine andere Lösung. Vielen Dankk jedenfalls.

@Lochkartenstanzer

Auch Dir vielen Dank.

Mir ist trotzdem nicht das unterschiedliche Verhalten klar. Der Explorer bzw. der Total Commander machen es richtig, wenn der Account als normales Laufwerk mit LW Buchstaben gemappt ist. Und sie machen es falsch, wenn ich mir den Account als Netzwerkressource anzeigen lasse. Ausserdem ist es so, dass bei der Verbindung über die Netzwerkressource das Zertifikat vom WebDav Server angemeckert wird. Das passiert nicht, wenn der Account als normales LW gemappt ist. Mir ist der Unterschied zwischen der Ansprache des Zielrechners über ein gemapptes LW und der Ansprache des Zielrechners über eine Netzwerkressource nicht klar. Offenbar passiert da ja etwas Unterschiedliches. Wenn ich im heimischen Netzwerk Netzwerkressourcen verwende ist das nicht so. Da ist es egal, ob ich den Zielrechner so oder so anspreche. Ich bekomme immer das gleiche Ergebnis und die gleichen Rechte. Da erscheint die Freigabe auf dem fernen Rechner auf meinem Rechner wie ein normaler lokaler Ordner - nur dass der Ordner eben in der Netzwerkumgebung liegt. Ich kann ihn auch wie einen normalen lokalen Ordner nutzen. Im Fall des T-Online WebDav Servers ist es anders. Da gibt es zwar auch den entsprechenden Ordner in der Netzwerkumgebung. Aber ich habe nicht die gleichen Rechte und nicht die gleiche Darstellung als ob ich den gleichen Account mappe.

Einer Netzwerkressource im lokalen Netzwerk kann ich per subst einen Laufwerksbuchstaben zuordnen. Das kann ich bei diesen Onlinenetzwerkressourcen nicht - da bekomme ich eine Fehlermeldung "Netzwerkpfad nicht gefunden". Eine Onlinenetzwerkressource unterscheidet sich offenbar grundsätzlich von einer Netzwerkressource im lokalen Netzwerk. Warum und worin? Das sind meine eigentlichen Fragen. Da bin ich vielleicht auch in der falschen Rubrik - vielleicht gehört das mehr in den Fachbereich Netzwerk und nicht zu WindowsXP und wäre einen neuen Thread wert. Je tiefer ich in dieses Thema einsteige, desto unklarer wird es mir.

LG

Leo
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (6)

Frage von Kroeger02 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...