Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerktimeout Arbeitsgruppe Windows XP

Frage Netzwerke

Mitglied: Serpico

Serpico (Level 1) - Jetzt verbinden

31.08.2009, aktualisiert 18.10.2012, 5823 Aufrufe, 10 Kommentare

Hallo,

ich betreue ein sehr kleines Netzwerk schon seit mehreren Jahren. Es sind nur 2 PC und diverse Plotter an den Netzwerkswitch (Level One 8 port) und ein 4 Port Switch-Router (ebenfalls Level One) angeschlossen und dies simpel in einer Arbeitsgruppe gehalten. Dieses Netzwerk lief seit Jahren wunderbar und stabil. Vor kurzer Zeit wurden die PC´s durch 2 neuere PC´s ersetzt.

Seitdem ist das Problem, das wenn eine Netzwerkverbindung hergestellt werden soll und er die vorhandenen Dateien auf dem HauptPC anzeigen soll, kommt es zu einem Timeout der 50 - 200 sek dauert. Danach sind alle Dateien und Ordner zu sehen und es lässt sich normal arbeiten. Danach kann ich die Freigabe schliessen und öffnen und es sind sofort alle Dateien zu sehen. Also beim ersten Mal kommt nur dieser Timeout, ist die Verbindung hergestellt funktioniert alles.

Wie kann es zu diesem Timeout kommen bzw. warum muss ich warten bis ich wirklich im Netzwerk arbeiten kann.?
- Treiber wurden komplett aktualisiert
- Netzwerkkarteneinstellungen durchprobiert (Autosense etc.)
- Windows Patches und Updates eingespielt.
- Beide PC wurden komplett neu mit XP Prof aufgesetzt
- Router/Switch Einstellungen gecheckt

Nochmal ich klicke auf die Netzwerkverknüpfung die auf dem Desktop liegt und will mir die Dateien anzeigen lassen die dort abgelegt sind. Ich muss lange warten bis das Fenster wirklich aktiv ist und ich dadrin arbeiten kann bzw. Dateien kopieren kann. Das ist nicht normal. Gibt es noch eine XP Einstellung die mir bisher verborgen blieb ???
Beim Googlen hat ich was gefunden einen Timeout der bei XP Dateifreigaben verwendet wird weil er irgendwas sucht (weiss leider nicht mehr 100% was genau), diese Einstellung per Registry habe ich auch vorgenommen und brachte kein Erfolg.
Ich denke zwar das der Timeout von der Hardware kommt und nicht per Software zu steuern ist aber es kann doch nicht sein das das normal ist.
Mitglied: aqui
01.09.2009, aktualisiert 18.10.2012
In solchen banalen Netzen basiert die Windows Namensauflösung auf einem UDP Broadcast im Netz bzw. der dynmaischen selktierung eines Master Browsers.
Wenn diese PC nun ausgeschaltet werden, muss dieser Selektionsprozess immer wieder von neuem angestossen werden und kann laut MS Knowledgebase bis zu 40 Minuten dauern.

In solcherlei Netzen ist es immer ratsam IP Adressen und Namenszuordnung wie deinem Haupt PC auf allen anderen PC statisch zu machen.
Damit unterbindest du auf Anhieb diese Wartezeiten und löst das Problem im Handumdrehen.

Diese statische Zuordnung findest du in der Datei lmhosts im Verzeichnis C:/windows/system32/drivers/etc/. Sie ist selbsterklärend wenn du sie editierst.
Wie du genau vorgehen musst erklärt dir dieser Thread hier:

http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...

Damit sollte das Problem sofort beseitigt sein !
Bitte warten ..
Mitglied: Serpico
02.09.2009 um 17:47 Uhr
vielen dank für die Antwort aber leider konnte dieser Lösungsweg das Problem nicht beseitigen.

Irgendwie hat ich das noch von Windows 98 in Erinnerung und dachte eigentlich wirklich das es das Problem beseitigen kann aber leider musste ich heute feststellen das es nicht hilft ^^.

Habe im Router die DHCP Funktion ausgeschaltet und auf den 2 Clienten statische Ip´s vergeben incl. gateway,dns u.s.w. ! Habe das die lmhosts Datei editiert und die Ip´s der PC´s eingetragen inkl. Namen.
PC aus und wieder an ....... immer noch das gleiche Problem ...... lange wartezeit bis erstmaliger Zugriff möglich..................warum war das auf den vorgänger pc´s nicht (definitiv keine andere Einstellung).
Bitte warten ..
Mitglied: aqui
02.09.2009 um 18:50 Uhr
Die lmhost ist eine Beispieldatei mit der Dateierweiterung .sam Die musst du erst in eine lmhost .nichts (keine Extension) kopieren, das sollte dir klar sein.
Du kannst sie auch in die Datei hosts ohne Extension kopieren. Windows akzeptiert beide Dateinamen hosts und lmhost

Ob sie dann sauber funktioniert, kannst du nach einen Reboot testen indem du einmal ping < name> eingibst um ein externes Gerät zu pingen mit seinem Namen.
Klappt das wurde auch die lmhosts erkannt.

Zur Sicherheit solltest du noch in den erweiterten Eigenschaften des TCP/IP Protokolls unter dem Karteireiter WINS den Haken setzen bei lmhosts Abfrage aktivieren !!
Bitte warten ..
Mitglied: 81825
02.09.2009 um 19:03 Uhr
Hi,
damit du mal eine Vorstellung davon bekommst, was so alles abläuft, kannst du dir den TechNet-Artikel mal antun. Vielleicht interessiert es dich.
http://www.microsoft.com/germany/technet/datenbank/articles/600987.mspx
Bitte warten ..
Mitglied: Serpico
03.09.2009 um 16:25 Uhr
Hallo, nochmal vielen Dank für die schnelle Antwort.

Es war ein bischen unglücklich geschrieben. Das lmhosts.sam ne Beispieldatei ist, war mir klar .
Um genau zu sein habe ich mit der hosts Datei (ohne Endung) gearbeitet.

Ping Name und ähnliches funktioniert
Nur der anfängliche Timeout bleibt ..............

bei WINS ist eigentlich standardmäßig Lmhost Abfrage der Haken gesetzt, wurde natürlich auch von mir überprüft.......
Bitte warten ..
Mitglied: Serpico
09.09.2009 um 18:34 Uhr
Hatte eigentlich gehofft hier noch wirklich hilfreiche Tips zu ergattern aber leider schaut das wohl doch nicht so gut aus.

Ich glaube auch fast des es kein Netzwerkproblem ist und somit hier vielleicht falsch ist. Per Ping ob über ip oder Namensauflösung, das Netzwerk steht und ist sofort ansprechbar, nur der Dateibrowser braucht einfach ewig bis die Netzwerkdateien dargestellt werden. Der Rechner ist Virusfrei, alle Prozesse bis auf die Windows eigenen wurden geblockt = keine Veränderungen, die Hardware wurde getestet mit diversen Profiprogrammen = keine Fehler.
Neuinstallation = keine Veränderung
Router gewechselt = keine Veränderung

es ist zum verzweifeln
Bitte warten ..
Mitglied: 81825
09.09.2009 um 21:38 Uhr
Trenne doch erst mal die Plotter vom Netz, so dass nur noch die beiden PCs am Switch hängen und versuche die Verbindung nur zum jeweiligen anderen PC herzustellen.
Bitte warten ..
Mitglied: Serpico
15.09.2009 um 18:54 Uhr
hatte heute endlich wieder die Möglichkeit diesem Problem zu widmen.

Habe mir einen neuen Speedport geschnappt, 2 neue Kabels und hab die beiden Problem PC`s in ein seperates Netz gestellt, natürlich mit festen IP´s und hosts Datei. Leider muss ich sagen das das Problem keine Veränderung zeigt.........
Also wieder was ausgeschlossen nur fällt mir kaum noch was ein

PC1 Netzwerkkarte : Intel 82567LM-3 Gigabit Network Connection. Erkennt 100mbit Duplex - umstellen bringt nix - vor 3 wochen noch neuester Treiber.

PC2 Netzwerkkarte : Atheros AR8121/8113/ 8114 PCI-E Ethernet Controller

Sind beides onBoard Karten eins von nem Intel Board (PQ45 oder so), das andere ist nen Asus P5Q.

Das Problem ist von beiden Rechnern aus, Netzwerk funktioniert sofort , nur der Dateibrowser macht bei Netzwerk die TimeOut tücken.

Wenn es an der Netzwerkkarte liegen sollte, mein ich fast es liegt an der Intel, im PC2 hatte ich mal eine andere Netzwerkkarte eingebaut aber das Problem blieb.
Mit freundlichen Grüßen
Bitte warten ..
Mitglied: aqui
19.09.2009, aktualisiert 18.10.2012
Wenn du die beiden PC untereinander pingen kannst hat es de facto NICHTS mit der Netzwerkkarte zu tun.
Wie bereits oben bemerkt alle relevanten ToDos zum Koppeln von Windows Rechnern stehen hier:
http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...

Die Selektierung eines Master Browsers in so einem Netz kann laut MS Knowledgebase bis zu 25 Minuten dauern.
Wenn du nun wechselseitig immer mal einen PC ausschaltest, dann geht das Spiel von vorne los.
Es ist also essentiell wichtig in so einen Banalnetz mit nur ein paar PCs das alle gegenseitigen Resourcen fest in die Datei hosts oder lmhosts eingetragen sind.
Ob die gelesen wird kannst du immer mit ping <name> ausprobieren.
Wenn das geht ist die aktiv.

Störer in so einem Konstrukt sind auch leider sehr oft überflüssige Personal Firewalls wie z.B. Zone Alarm um mal einen der schlimmsten Vertreter zu nennen !
Auch nach einer vermeintlichen Deinstallation treiben die immer noch ihr Unwesen. Ist so etwas mal auf den PCs draufgewesen oder noch aktiv solltest du also dringend auch mal in dieser Richtung suchen !!
Bitte warten ..
Mitglied: Serpico
22.09.2009 um 16:41 Uhr
Heute war ich nochmal in dem Netzwerk und konnte etwas seltsames feststellen wo ich jetzt definitiv keine Erklärung für finde .....................

Die Freigabe lautet \\PC1\Eigene Dateien\ , wenn ich diese Verknüpfung aufrufe kommt es zu diesem Timeout. In diesem Odner wiederum liegen mehrere Ordner mit weiteren Unterordnern und Dateien

Wenn ich jetzt eine Verknüpfung \\PC1\Eigene Dateien\Kunden aufrufe ---- siehe da dann existiert kein Timeout mehr ????????

Wieso sind Unterordner kein Problem während der Hauptordner zum Problem führt ?
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows XP
Kann man noch neue Notebooks für Windows XP kaufen ? (9)

Frage von DieterJansen zum Thema Windows XP ...

Windows Netzwerk
SMBv2 in Windows 7 - Windows XP - Windows Server 2003 Domäne deaktivieren (4)

Frage von Mario.Steinberg zum Thema Windows Netzwerk ...

Windows XP
gelöst Windows XP SP 3 System Clonen (19)

Frage von zeroblue2005 zum Thema Windows XP ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...