Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkverbindung langsam - wireshark-Capture unklar

Frage Netzwerke Netzwerkprotokolle

Mitglied: mt11341

mt11341 (Level 1) - Jetzt verbinden

13.01.2014 um 08:56 Uhr, 2564 Aufrufe, 10 Kommentare

Hallo zusammen,

ich öffne eine Datei (z.B. TEST.doc) mit einem Windows 7 (64 Bit)-Client (IP: 192.168.218.151) auf einer Freigabe auf einem Server (Server 2003) (IP: 192.168.218.204) im Netzwerk.
Das Öffnen dauert viel zu lang (ca. 3 Sekunden). Irgendetwas macht die Verbindung langsam. ich habe bereits alle möglichen Einstellungen geprüft (IP, DNS etc.). Nun habe ich wireshark bemüht und folgende unnormale Zeilen geben mir ein Rätsel auf:

No. Time Source Destination Protocol Length Info
145 2.31417300 192.168.218.204 192.168.218.151 SMB 630 Read AndX Response, FID: 0xc00b, 512 bytes
146 2.31435500 192.168.218.151 192.168.218.204 SMB 117 Read AndX Response, FID: 0xc00b, 2 bytes at offset 544
147 2.31460900 192.168.218.204 192.168.218.151 SMB 120 Read AndX Response, FID: 0xc00b, 2 bytes
148 2.31476600 192.168.218.151 192.168.218.204 SMB 117 Read AndX Response, FID: 0xc00b, 2 bytes at offset 574
...
12073 4.87261400 192.168.218.204 192.168.218.151 SMB 97 Read AndX Response, FID: 0xc00b
12074 4.87278700 192.168.218.151 192.168.218.204 SMB 99 Close Request, FID: 0xc00b
12075 4.87306900 192.168.218.204 192.168.218.151 SMB 93 Close Response, FID: 0xc00b

Die beiden letzten Zeilen wiederholen sich Inhaltlich danach tausendfach. Dadurch wohl auch die Verzögerung.
Kann mir jemand diese Zeilen erklären? Wieso dauert die Übertragung so lang?

Besten Dank im Voraus.
Mitglied: colinardo
13.01.2014, aktualisiert um 11:29 Uhr
Hallo mt11341,
hast du mal alle QoS Dienste auf deinen Geräten (Router, Switch, etc) in deinem Netzwerk deaktiviert. Vor allem aber auch den QoS-Paketplaner in den Eigenschaften der Netzwerkverbindung des Windows 7 Clients. Ist der Server 2003 die einzige Gegenstelle die so langsam reagiert, bzw. ist es anders herum Server 2003 => WIN7 genauso ?
Was du noch testen kannst ist das Autotuning in Windows 7 zu deaktivieren, das macht manchmal Probleme:
netsh interface tcp set global autotuning=disabled
wenn das keine Besserung bringt stellst du es so wieder zurück:
netsh interface tcp set global autotuning=normal
Normalerweise wird nach einem Read AndX Response der Servers ein Block an Daten übertragen, bevor ein erneuter Request des Client den nächsten Block vom Server anfordert, was hier nicht der Fall ist. Irgendwie können sich Client und Server nicht einigen bzw. eventuell gehen Pakete auf dem Weg verloren, so dass eine erneute Anfrage des Client über die Leitung geht. Überprüfe auch mal die MTU-Size in den Eigenschaften der Netzwerkkarte. Die sollte ja bei normalen LANs 1500 bytes betragen.

Grüße Uwe
Bitte warten ..
Mitglied: mt11341
13.01.2014 um 14:50 Uhr
Hallo Uwe,

QoS im Win7 habe ich auch schon abgeschalten.
Autotuning habe ich auch schon ausgeschalten.
MTU war 1500. Habe ich auch schon mit anderen Werten getestet.
Es geht zu einem anderen Server 2003 auch langsam. Aber zu einem Server 2008 gehts schnell und zu einem weiteren Server 2008 langsam.
Alle Server befinden sich hinter dem gleichen Switch.

Gruß
mt
Bitte warten ..
Mitglied: colinardo
13.01.2014, aktualisiert um 16:32 Uhr
  • Netzwerkkartentreiber aktuell ?
  • mal SMB2 auf Windows 7 deaktiviert / danach Neustart ?
  • Virenscanner (On-Acess-Scanner) deaktiviert ?
  • testweise IPv6 deaktiviert ?
  • Server mal an einen anderen Switchport geklemmt ?

Kannst du das PCAP File mal irgendwo hochladen, das wir mal reinschauen können?
Bitte warten ..
Mitglied: mt11341
14.01.2014 um 07:16 Uhr
Guten Morgen,

Zitat von colinardo:

  • Netzwerkkartentreiber aktuell ?
ja
* mal SMB2 auf Windows 7 deaktiviert / danach Neustart ?
ja, ohne Erfolg
* Virenscanner (On-Acess-Scanner) deaktiviert ?
ja, ohne Erfolg
* testweise IPv6 deaktiviert ?
ja, ohne Erfolg
* Server mal an einen anderen Switchport geklemmt ?
meine Vermutung, das es an der Hardware liegt. Das kann ich erst morgen testen.

Kannst du das PCAP File mal irgendwo hochladen, das wir mal reinschauen können?
Hier habe ich das PCAP-File hochgeladen.

So langsam gehen mir die Nerven durch

Gruß
mt
Bitte warten ..
Mitglied: colinardo
14.01.2014, aktualisiert um 12:45 Uhr
Hallo mt,
hab mir das PCAP-File mal angeschaut, und denke die Verzögerung hat mit dem Opportunistic File Locking des SMB-Protokolls zu tun. Mehr Info dazu findest du hier:
http://www.dataaccess.com/whitepapers/opportunlockingreadcaching.html

Grüße Uwe
Bitte warten ..
Mitglied: Dobby
15.01.2014 um 06:01 Uhr
Hallo,

eventuell hast Du die Datei im Explorer in der Vorschau und dann gilt sie mitunter auch schon "als in Benutzung"
und daher kommen diese Latenzen.

Gruß
Dobby
Bitte warten ..
Mitglied: mt11341
15.01.2014, aktualisiert um 08:08 Uhr
Hallo Uwe,
"Opportunistic File Locking" funktioniert nur mit SMB?
Ich habe SMB ausgeschalten - Problem besteht immernoch

Hallo D.o.b.b.y,
kurrios ist aber, dass der Zugriff auf einen anderen Server funktioniert oder in anderen Teilen (hinter anderen Switchen, nicht Subnetze) funktioniert es auch.


Gruß
mt
Bitte warten ..
Mitglied: colinardo
15.01.2014, aktualisiert um 09:01 Uhr
Ich habe SMB ausgeschalten - Problem besteht immernoch
Wie kommst du dann im Explorer auf die Datei ?? wenn du smb komplett abschaltest; wenn das überhaupt geht ...?!
Bitte warten ..
Mitglied: mt11341
15.01.2014 um 13:03 Uhr
Zitat von colinardo:
Wie kommst du dann im Explorer auf die Datei ?? wenn du smb komplett abschaltest; wenn das überhaupt geht ...?!

Ich habe nur SMBv2 ausgeschalten. Komplett abschalten geht auch, dann ist natürlich der Zugriff auf Freigaben nicht möglich.
Bitte warten ..
Mitglied: mt11341
28.01.2014 um 13:03 Uhr
Ich habe die vermutliche Ursache gefunden. Zumindest funktioniert danach ein schneller Zugriff auf Dateien ;)

Ich habe die Office-Dateiüberprüfung (Office File Validation) per regedit ausgeschalten und siehe da, es läuft.

Trotzdem ein Dankeschön an alle.
Bitte warten ..
Neuester Wissensbeitrag
DSL, VDSL

Telekom blockiert immer noch den Port 7547 in ihrem Netz

(3)

Erfahrungsbericht von joachim57 zum Thema DSL, VDSL ...

Ähnliche Inhalte
Windows Server
Server sehr langsam bei vielen kleinen Dateien (5)

Frage von MichiBLNN zum Thema Windows Server ...

Festplatten, SSD, Raid
Samsung SSD zu langsam (20)

Frage von Protected zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Kopiervorgang im Gigabit Heimnetzwerk mit 2 NICs langsam (20)

Frage von John.D zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...