Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Netzwerkzugriff aus VM Ubuntu

Frage Linux Samba

Mitglied: istike2

istike2 (Level 2) - Jetzt verbinden

04.11.2012, aktualisiert 15:43 Uhr, 3337 Aufrufe, 6 Kommentare

Hallo,


ich habe einen W7 64bit Host, worauf ein WMWARE Image läuft mit Ubuntu 11.04. Der Host hat die IP 10.2.1.20 /255.255.255.0/

Die VMs Adpater ist als NAT eingestellt. Internetzugang funktioniert. IP wird via DHCP verteilt.

Problem: Ich kann meine NAS (10.2.1.10) nicht als Windows-Share mounten. Ping geht. Egal wie ich versuchen 10.2.1.10/Studio einzubinden klappt es nicht.

Weiß jemand Rat?

Unter "Windows Netzwork" wird nichts gefunden. Fehlermeldung:

"Unable to mount location. Failed to retrieve share list from server".

Woran kann es liegen?

Anbei findet ihr noch ein Screenshot mit den IP-Einstellungen der VM.

69da607f05bef8d1d183bcfc8265e511 - Klicke auf das Bild, um es zu vergrößern

Danke für die Tipps.


Gr. I.



Mitglied: aqui
04.11.2012, aktualisiert um 15:31 Uhr
Na ja das ist ja logisch wenn man nur mal ein klein bisschen nachdenkt !!
Das NAT verhindert den Zugriff. Das ist genau der gleiche Effekt wie bei einem NAT Router.
Einzig Traffic der eine Eintrag in der NAT Session Table hat darf passieren. Traffic der keine aktive Session hat, also wie Traffic der von außen reinkommt, darf nicht passieren.
Näheres dazu kannst du auch hier nachlesen:
http://www.administrator.de/contentid/48713 --> "Alternative 2"
Es ist also höchst kontraproduktiv den Server in der VM im NAT Modus laufen zu lassen.
Wenn du den in den Bridged Modus versetzt sind alle deine Probleme auf Schlag gelöst ! Logisch ist das der Ubuntu dann natürlich auch eine IP aus dem lokalen IP Netz bekommt.
Willst du dennoch nicht auf NAT verzichten kannst du nur mit Port Forwarding arbeiten. Du musst also in die Port Forwarding der VmWare an dieser vNIC die Ports für SMB/CIFS Filesharing (TCP 445) auf die lokale IP hinter dem NAT NIC forwarden. Dann bekommt man es auch damit zum Laufen. Das wäre dann die umständliche Variante....
Nochein Tip: Ein Server sollte niemals eine dynamische IP per DHCP bekommen sondern immer eine feste, statische IP. Das gilt auch für Server in einer VM !
Bitte warten ..
Mitglied: istike2
04.11.2012, aktualisiert um 15:45 Uhr
Hi Aqui,

ich habe etwas missverständlich formuliert. Die NAS (Thecus N7700Pro) ist außerhalb der VM.

Ich versuche ihn aus der VM zu erreichern, weil ich einige USB-Festplatten unter W7 nicht mehr erreiche.

Als NAT kann ich Internet benutzen möchte aber auf die NAS zugreifen. Bridge habe ich auch probiert.

Anbei ist die Screenshot der Einstellungen.

502bbab27642a1b66c71b00b5a8d01e5 - Klicke auf das Bild, um es zu vergrößern

So habe ich nicht mal Izugang. Ich habe die Option "Replicate physical network connection state" nicht aktiviert.
Unter "Configure Adapters" sind beide Häkchen gesetzt.



I.
Bitte warten ..
Mitglied: aqui
04.11.2012, aktualisiert um 16:02 Uhr
Was ist ein "Izugang" ??
OK, gehen wir mal strategisch vor...
  • Ist jetzt der Bridged Mode aktiv ?
  • WICHTIG: Warum haben dein NAS und das Default Gateway der VM die gleiche IP Adresse ?? Zitat: "...meine NAS (10.2.1.10)" Screenshot oben: Default Route mit der gleichen IP !! Da stimmt also schon mal was nicht oder hast du sowas wie ne Fritzbox die einen USB Stick per SMB/CIFS freigeben kann ?? Du schreibst ja Thecus, was ja nicht routen kann also stimmt da schon mal generell was nicht !! Deshalb auch der dringende Tip das Router immer in der IP Adressierung nach "ganz oben" oder ganz unten" im Netz, also bei dir mit einer 24 Bit Class C Maske auf die .1 oder .254 gesetzt werden sollten ! Gerade um keine Überschneidungen im Hostbereich zu provozieren !!
  • Wenn du die IP Adressen korrigiert hast kannst du von der VM a: das NAS 10.2.1.10 anpingen und b: dann den Router mit welcher IP auch immer ? Dann c: eine nackte IP im Internet 193.99.144.85 (www.heise.de)
Wenn das klappt machen wir hier mal weiter !!
Bitte warten ..
Mitglied: istike2
04.11.2012 um 16:08 Uhr
Izugang ist Internetzugang.

Via Ping erreiche ich alle Netzwerkteilnehmen

Fritzbox: 10.1.2.1
Thecus LAN1: 10.1.2.210
Thecus LAN2: 10.2.1.10 (mein Ziel)

Bridge ist aktiv.

Der HOST hat Internetzugang durch den Thecus (IP-Freigabe) daher die identische IP. Der Thecus ist ja der "Router" zwischen den beiden Netzwerken. Es ist ja prinzipiell OK. Habe´s jetzt auch Internet und kann alles anpingen. Nur SMB scheint zu streiken.

Wenn ich via SMB etwas unter "Places" einbinde wird nach kennwort verlangt, das aber nie akzeptiert wird...

I.
Bitte warten ..
Mitglied: aqui
04.11.2012, aktualisiert um 16:20 Uhr
OK, ungewöhnlich ein NAS als Router zu betreiben aber warum nicht.
Gut weiter im Text der Fragen:
  • Macht der Thecus NAT (Adress Translation) ins Fritzbox Netzwerk ??
  • Wenn NEIN: Hast du eine statische Route auf der FB eingetragen ?? (Zielnetz: 10.2.1.0, Maske: 255.255.255.0 Gateway: 10.1.2.210)
Grundlagen zu solch einer Konstellation und deren Konfiguration findest du hier:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Gut, aber scheinbar schein das ja zu klappen wenn du auch DNS Namen wie www.heise.de von der VM anpingen kannst.
Damit wäre dann deine IP Adressierung im Netzwerk absolut sauber.
Der böse Buhmann kann dann nur noch der Thecus selber sein !
Vermutlich hat der eine Access Liste oder Firewall und lässt nur SMB/CIFS Zugriffe aus dem 10.1.2er IP Netz zu. Anders wäre das nicht zu erklären.
Der Thecus hate ein Logg !! Bist du auf die Idee gekommen mal im Logg nachzusehen ob dort entsprechende Einträge zu sehen sind ??
Bitte warten ..
Mitglied: istike2
04.11.2012 um 16:22 Uhr
Danke Aqui,

da alles sauber lief habe ich alle sonstige VM_Adapter deaktiviert, bereits erstellte Nertwerkverzeichnisse entfernt... Dann gabe es noch Probleme mit irgendwelchem Ring Keys....

Nach erneuten Versuchen war es dann OK. Warum auch ...

Danke nochmals.

I.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Vmware
Veeam für VM Ware Backup Fehler (1)

Frage von JoergN1968 zum Thema Vmware ...

Windows Server
Lizenzierung Windows Server + 2 x W7P VM (6)

Frage von Mozzie zum Thema Windows Server ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (10)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...