Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Trotz Netzwerkzugriff über webmin kein DNS oder kein Zugriff über Samba

Frage Linux Samba

Mitglied: mkapate

mkapate (Level 1) - Jetzt verbinden

26.04.2012 um 14:56 Uhr, 4967 Aufrufe, 10 Kommentare

Hallo alle zusammen,

ich habe folgendes Verständnissproblem:
ich installiere zum x - mal einen Ubuntu Server entweder 10.4 oder den 10.10 und bei beiden Varianten treten mir nicht ersichtliche Probleme auf. Bei der Installation die routine mäßig abläuft wird nach allen Möglichen Einstellungen gefragt und von mir auch beantwortet wie z.B. der Name des PC in diesem Fall einfach nur "Server" und davor "Samba-Server" die Installation läuft ohne Probleme durch bis zum Ende.
Jetzt will ich testen ob der Samba im Netz zu sehen ist nachdem ich die Freigaben über Webmin eingestellt habe aber leider ist nichts zu sehen
Das komische daran ist das ich über die Eingabe der IP Adresse und den Port 10000 auf webmin zugreifen kann aber nicht über "Server:10000", ich habe dann im Router kontrolliert ob der Samba dort gelistet ist. Die IP Adresse ist gelistet auch die Mac Adresse aber kein Name zu der IP in beiden Versionen 10.4 und 10.10 nicht. Nun denke ich mir das das irgendwie mit der Namensauflösung zu tun haben kann, aber um ganz sicher zu gehen habe ich die SuSe 11.0 auf einen andern PC parallel inst und dort ist zwar der Name hinter der IP zu sehen aber auch hier kein Zugriff über das Netzwerk auf dem Samba möglich. Keine Freigaben werden angezeigt. Alle Pings werden beantwortet alle Rechner befinden sich im gleichen Netzwerk 192.168.178.0/24 Arbeitsgruppe:WORKGRPUP
Also alles ganz Standard ohne Schnickschnack etc.
Über dem Terminal lade ich aus dem Internet die Pakete runter also funktioniert auch das Netzwerk in dem sich alle Rechner befinden! Warum ist denn keine Freigabe zu erkennen oder weshalb sehe ich die Rechner nicht im Netz?

Ich wäre echt dankbar wenn ich dahingehend einige gut Ratschläge bekommen könnte

Mit freundlichen Grüßen
Mitglied: michi1983
26.04.2012 um 15:34 Uhr
Hallo,

poste doch mal den Inhalt der smb.conf und die Ausgaben von
01.
cat /etc/network/interfaces
sowie von
01.
cat /etc/dhcp3/dhcpd.conf
Gruß
Bitte warten ..
Mitglied: catachan
26.04.2012 um 15:44 Uhr
Hi

Du brauchst einen DNS Server oder du musst den Server in die Hosts Datei der Clients eintragen.

LG
Bitte warten ..
Mitglied: mkapate
26.04.2012 um 15:45 Uhr
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.178.24
netmask 255.255.255.0
broadcast 192.168.178.255
network 192.168.178.0
gateway 192.168.178.1

dhcpd.conf existiert bei mir nicht nur dhclient.conf
Bitte warten ..
Mitglied: mkapate
26.04.2012 um 15:47 Uhr
Habe einen BIND DNS Server installiert um die Sache mit der Namensauflösung auszuschließen
Bitte warten ..
Mitglied: catachan
26.04.2012 um 15:51 Uhr
Zitat von mkapate:
Habe einen BIND DNS Server installiert um die Sache mit der Namensauflösung auszuschließen

Hast du ihn bzw die Zone richtig konfiguriert ? Installieren alleine löst dein Problem nicht
Bitte warten ..
Mitglied: mkapate
26.04.2012 um 15:58 Uhr
Gute Frage ich habe mich erstmal um den stink normalen Netzwerkzugriff gekümmert weil ich denke das ich erst diesen hinbekommen sollte um überhaupt den DNS Server betreiben zu können bzw. wenn ich ihn überhaupt nutzen muss was ich bezweifel. Später vieleicht als Teststrecke für andere Projekte
Bitte warten ..
Mitglied: Pjordorf
26.04.2012 um 19:28 Uhr
Hallo,

Zitat von mkapate:
weil ich denke das ich erst diesen hinbekommen sollte um überhaupt den DNS Server betreiben zu können bzw. wenn ich ihn überhaupt nutzen muss was ich bezweifel. Später vieleicht als Teststrecke für andere Projekte
Hehe. Was war zuerst da. Henne oder Ei. Für dich bedeutet dies das du entweder einen DNS Server Installierst und Konfigurierst damit du mit Namen arbeiten kannst oder du arbeitest nur mit der IP. Suche es dir aus, aber mecker nicht rum das deine Namensauflösung nicht geht wenn du die vorraussetzungen nicht schaffen willst. Es liegt in deinen x-mal geübten Ubuntu Installationshänden

Gruß,
Peter
Bitte warten ..
Mitglied: mkapate
27.04.2012 um 09:39 Uhr
Ok Peter du hast soweit recht und ich streite es nicht ab, aber wenn du meine Anfrage gelesen hast dann würde dir auffallen das ich NUR eine Freigabe des Samba Server aufbauen will und nur zur Fehleranalyse ein BIND DNS aufgesetzt habe was sich im nachhinein als unrelevant rausstellte da der gleiche Rechner sowieso schon nicht im Netz mit Namen zu sehen ist ergo das Problem liegt wohl in der Installation aber die habe ich ja schon x - mal gemacht und alles genau unter die Lupe genommen. Das sollte man als Informatiker schon auf Tasche haben, aber denoch besteht das Problem und daher meine Anfrage hier!!!

Zum Thema:
mir fiel noch etwas sehr korioses auf der Localhost hat ja bekanntlich 127.0.0.1 Eigenartigerweise sehe ich in der Webminsysteminformation folgenden Eintrag

System Hostname Server (127.0.1.1)
Betriebssystem Ubuntu Linux 10.10
Webmin Version 1.580
Systemzeit Fri Apr 27 09:32:33 2012
Kernel und CPU Linux 2.6.35-22-generic-pae auf i686
Prozessorinformation AMD Turion(tm) 64 X2 Mobile Technology TL-64, 2 cores
System Laufzeit 0 Stunde(n), 1 Minute(n)
Laufende Prozesse 131

Wie zum Geier nochmal kommt der Rechner auf 127.0.1.1 ??????????????????????????????

In der Netzwerkkonfiguration unter aktiven Schnitstellen steht

eth0 Ethernet 192.168.178.24 255.255.255.0 Aktiv
lo Loopback 127.0.0.1 255.0.0.0 Aktiv
wlan0 Wireless Ethernet Keine Adressen konfiguriert Keine Inaktiv

Also Leute der LINUX TUX FAN Gemeinde könntet IHR mir einen Rat geben??

Danke euch
Bitte warten ..
Mitglied: Pjordorf
27.04.2012 um 14:22 Uhr
Hallo,

Zitat von mkapate:
aber wenn du meine Anfrage gelesen hast
Ja, das habe ich. Und das sehr langsam um auch alles mitzubekommen und zu verstehen was du meinst Und da habe ich mich schon gefragt was du mit
Jetzt will ich testen ob der Samba im Netz zu sehen ist nachdem ich die Freigaben über Webmin eingestellt habe aber leider ist nichts zu sehen
genau meinst. Du willst eine also etwas sehen. Wo willst du etwas sehen? Was erwartest du zu sehen? Soll das Sehen von einen anderen PC mit OS ??? erfolgen oder auf den Lokalen PC mit deinem Ubuntu?


das ich NUR eine Freigabe des Samba Server aufbauen will
Nun, ich weiß nicht wie du nur eine Samba freigabe aufbauen willst ohne eine entsprechendes OS darunter zu haben. Hier dein Ubuntu Linux. Also hast du 2 Baustellen.

und nur zur Fehleranalyse ein BIND DNS aufgesetzt habe
Dir ist schon klar das ein BIND kein Werkzeug zur Fehlersuche darstellt, oder?

was sich im nachhinein als unrelevant rausstellte da der gleiche Rechner sowieso schon nicht im Netz mit Namen zu sehen ist
Jetzt kommen wir doch mal zu einer Frage. Wo (An welchem Rechner) gibts du welchen Namen (welcher Name soll aufgelöst werden) ein und wie soll dieser Name zu einer IP aufgelöst werden wenn es keine Server (Hier z.B. dein BIND) für Namensauflösung gibt? Und auch dein ursprungliches
Eingabe der IP Adresse und den Port 10000 auf webmin zugreifen kann aber nicht über "Server:10000"
deutet doch zu 100% auf Namensauflösung hin, oder siehst du das anders?

Und auch dein
ich habe dann im Router kontrolliert ob der Samba dort gelistet ist. Die IP Adresse ist gelistet auch die Mac Adresse aber kein Name zu der IP in beiden Versionen 10.4 und 10.10 nicht
deutet doch darauf hin das du von Namensauflösung nicht gerade was verstehst, oder? Beantworte dir doch mal die Frage, wie ein Router dort einen Name den er ja gar nicht von sich aus kennen kann, trotzdem anzeigen kann.

Und weiter mit deinem
Zugriff über das Netzwerk auf dem Samba möglich
du meinst hier bestimmt der Zugriff per Namen auf deine Freigaben und nicht der zugriff per IP auf dein Samba, oder? (weil per IP wird es doch gehen)

Und dann zum schluß deine direkte Frage
Warum ist denn keine Freigabe zu erkennen oder weshalb sehe ich die Rechner nicht im Netz?
Ja, wie können Rechner es ermöglichen damit du etwas sehen kannst? Hier insbesondere andere Rechner in einem Broadcast Netz.

ergo das Problem liegt wohl in der Installation
Eher nicht. (Wie sollten sonst alle anderen Linux Installationen dieser Welt sonst funktionieren?)

aber die habe ich ja schon x - mal gemacht
Auch einen Fehler kann man x-mal wiederholen

und alles genau unter die Lupe genommen.
Vielleicht ist deine Lupe kaputt?

Das sollte man als Informatiker schon auf Tasche haben
Jetzt wirds interessant

aber denoch besteht das Problem und daher meine Anfrage hier!!!
Jaja.

mir fiel noch etwas sehr korioses auf der Localhost hat ja bekanntlich 127.0.0.1
Ja.

System Hostname Server (127.0.1.1)
Wie zum Geier nochmal kommt der Rechner auf 127.0.1.1 ??????????????????????????????
Das sollte man als Informatiker schon auf Tasche haben sind deine eigenen Worte.

Also Leute der LINUX TUX FAN Gemeinde könntet IHR mir einen Rat geben??
Nein, mich kannst du nicht meinen denn ich arbeite eher selten mit Tux.

Aber auch ein sich eher selten mit Linux befassender informatiker findet deine Antwort zu deiner 127.0.1.1 Frage. (und versteht die auch)
http://wiki.ubuntuusers.de/hosts

Was passiert wenn du von einem anderen Rechner aus ein ping auf den "Server" per Name machst?
Was passiert wenn du von einem anderen Rechner aus ein Ping auf den "Server" per IP machst?

Und Begriffe wie Masterbrowser oder Netbios und Ports 137,138,139 oder auch WINS sind dir geläufig? Dann stellt sich noch die Frage was du in deiner Samba Konfiguration (diese smb.conf Textdatei) alles drin oder eben nicht drin stehen hast.

Gruß,
Peter

(Mein Samba Server tut genaus all das was bei dir nicht geht)
Bitte warten ..
Mitglied: aqui
27.04.2012 um 19:28 Uhr
@mkapate
Es ist doch logisch das Namen bei dir nicht aufgelöst werden können ! Der Router ist ja nur DNS Proxy und befragt den DNS des Providers.
Das der natürlich all deinen lokalen Bastel und Testserver namensseitig nicht kennt ohne registrierte Domain weiss heutezutage ja jeder Grundschüler...
Du musst also auf deinen Server per IP Adresse zugreifen mit Staret --> Ausführen --> //<ip_adresse> oder über den Datei Explorer mit Laufwerk verbinden und dann die IP Adresse eingeben.
Alternativ kannst du den Namen statisch in die hosts oder lmhosts Datei bei deinem Windows Rechner eintragen unter /windows/system32/etc/
Die Datei ist selbsterklärend wenn du sie mit den Notepad Editor editierst.
Wenn du das machst klappt es auch mit dem Namen...
Alternative ist wenn du einen DNS Server dort laufen lässt. Dann musst du aber auch die DNS IP nicht auf den Router sondern deinen lokalen Server einstellen und dort dann eine Weiterleitung auf den Router.
Eigentlich Overkill für ein Heimnetzwerk wo man mit statischen Einträgen problemlos klarkommt.
Machbar ist das aber auch. Davor solltest du dir aber dringenst ein paar Infos über das DNS System anlesen !!
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (7)

Frage von Kroeger02 zum Thema Netzwerke ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...