Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Neuer Router mit VPN (Cisco RV042) in einem Netzwerk mit Windows SBS2008 - Internet funktioniert nicht

Frage Netzwerke

Mitglied: wRudi69

wRudi69 (Level 1) - Jetzt verbinden

25.03.2012, aktualisiert 18.10.2012, 7192 Aufrufe, 26 Kommentare

Hallo,

ich habe ein kleines Firmennetzwerk mit einem Thomson Modem und Router in einem von meinem Provider UPC.
Dahinter hängt ein Windows Small Business Server 2008, welcher auch als Domaincontroller und DHCP Server aggiert, außerdem hängt dort ein Cisco Switch,
auf welchem die anderen Clients hängen.
Nun habe ich mir einen Cisco RV042 Router geholt um ein VPN einzurichten, allerdings habe ich schon beim einrichten des Internets Probleme.
Mein Netzwerk sieht nun wie folgt aus:

- Thomson Modem und Router (DHCP, Firewall usw ist deaktiviert)
- Cisco RV042
- SBS 2008
- Cisco Switch
- Client
- Client
- ...

Beim RV042 hab ich DHCP deaktivert, da der SBS ja als DHCP Server aggiert und stattdessen DHCP-Relay aktiviert.
Nun will die Verbindung zum Internet aber irgendwie nicht hinhauen, hab schon alle möglichen Einstellungen probiert,
aber ich bekomms einfach nicht hin.
Kann mir bitte jemand von euch helfen?

Danke

LG Alex
Mitglied: education
25.03.2012 um 11:11 Uhr
mehr infos wären nicht schlecht...

ip und subnet vom router.

welche ip und subnet hat der server,

welches gateway ist eingetragen.
Bitte warten ..
Mitglied: wRudi69
25.03.2012 um 11:15 Uhr
Hab ich irgendwie total vergessen...

Thomson IP: 192.168.0.1

Cisco
IP:192.168.0.20
Subnet: 255.255.255.0

SBS2008
IP: 192.168.0.2
Subnet: 255.255.255.0
Gateway: 192.168.0.1
Bitte warten ..
Mitglied: 104286
25.03.2012 um 12:43 Uhr
Hallo,

du musst die Netzwerknummern verändern. EIn Router weist die Wege zwischen Netzen.

Grüße
leo
Bitte warten ..
Mitglied: wRudi69
25.03.2012 um 12:52 Uhr
Hallo Leo,

danke für deine Antwort, kannst du mir das bitte etwas genauer erklären?
Ich hab den Router mal eben bei mir zu Hause getestet, fast das selbe Szenario, nur dass ich keinen SBS Server habe,
allerdings hab ich das selbe Thomson Modem und das aggiert bei mir als DHCP Server.
Hab den Router wieder umgestellt auf DHCP Relay und DHCP Server Adresse 192.168.0.1 (Thomson)
Nun bekommt der Rechner keine IP zugewiesen und ich erreiche den Thomson Router nicht mehr.
Wenn ich die Einstellungen allerdings manuell mache:
IP: 192.168.0.x
Subnetz: 255.255.255.0
Gateway: 192.168.0.20 (Cisco)
DNS: 192.168.0.20 (Cisco)

Dann funktioniert mein Internet, aber ich erreiche den Thomson Router ebenfalls nicht.
Bitte warten ..
Mitglied: danielfr
25.03.2012 um 13:15 Uhr
Im Handbuch ( http://www.connect802.com/download/cisco/VPN_Router_RV042_OperationsGui ... ) steht eigentlich die Konfiguration erklärt. Der Cisco-Router hat eine LAN und eine WAN Schnittstelle, eine davon hast Du nicht konfiguriert, zumindest schreibts Du davon nichts.
Du wirst bei dem Thomson das Subnetz umstellen müssen, da ja auch bei dem Cisco WAN und LAN logischerweise in unterschiedlichen Subnetzen liegen müssen.
Allso z.B.

[Thomson LAN: 192.168.1.1/24] ---- [WAN: 192.168.1.254/24 Cisco LAN: 192.168.0.1] ---- [Clients etc.]

So musst Du bei den Clients und dem Server nichts umkonfigurieren.

Damit solltest Du dann zumindest mal ins Internet kommen. Als Relay musst Du eigentlich gar nichts einrichten. Wenn Du daheim DHCP brauchst richte das halt erstmal auf dem Cisco ein und schalte es dann später wieder ab.
Bitte warten ..
Mitglied: 104286
25.03.2012 um 13:33 Uhr
Hast du folgenden Netzwerkaufbau?


internet ----------router(thomson)--------------------router(cisco)-----------------------------------------sbs oder pc


Falls ja, dann musst du erstmal verschiedene Netzwerknummern einstellen. Mit dem DHCP kannst du doch später weitermachen. Nimm erstmal statische Adressen. Ich habe es so verstanden, dass der Cisco-Router neu hinzugekommen ist und es vorher ging,

Mach ein IP-Netz zwischen SBS/PC und Cisco und eines zwischen Cisco und Thomson. Dann musst du den Thomson vom PC aus anpingen können. Für den Internetzugang vom SBS/PC musst du zum Schluss noch eine statische Route auf dem Thomson-Router einstellen.

Falls ich das dich falsch verstanden habe, dann tut es mir leid. Ich wollte dich nicht verwirren.

Viel Glück.
Bitte warten ..
Mitglied: wRudi69
25.03.2012 um 13:47 Uhr
Zitat von danielfr:
[Thomson LAN: 192.168.1.1/24] ---- [WAN: 192.168.1.254/24 Cisco LAN: 192.168.0.1] ---- [Clients etc.]

Wenn ich beim Cisco nen anderen IP-Bereich einstellen will, muss ich doch wieder den DHCP Server aktivieren, wollte ihn aber deaktiviert lassen, da es sonst wieder Probleme mit dem SBS gibt...

@leo
Ja genau so sieht mein Netzwerk aus, und du hast richtig verstanden, der Cisco Router ist neu und vorhin gings problemlos.
Werd das mal statisch probieren, den DHCP Server am Thomson soll ich auch deaktivieren?
Bitte warten ..
Mitglied: 104286
25.03.2012 um 14:01 Uhr
Man kann pro Netz einen DHCP-Server zur Verfügung stellen. DHCP-Relay ist eine Funktion, um mit einem DHCP-Server mehrere Netze zu versorgen.
Lass es doch zu erstmal weg und probiere das Ganze nur mal so, ohne DHCP. Dann hast du erstmal einen Stand, von dem du ausgehen kannst. Die anderen Einstellungen setzen dann darauf auf.

Wenn du den Cisco später als VPN-Server einsetzen willst, kommen sowieso noch mehr Einstellungen auf dich zu. Wenn du den Thomson-Router benötigst und ihn nicht als Modem laufen lassen kannst bzw. ihn nicht durch ein Modem ersetzen kannst.
Bitte warten ..
Mitglied: danielfr
25.03.2012, aktualisiert 18.10.2012
Zitat von wRudi69:
> Zitat von danielfr:
> [Thomson LAN: 192.168.1.1/24] ---- [WAN: 192.168.1.254/24 Cisco LAN: 192.168.0.1] ---- [Clients etc.]

Wenn ich beim Cisco nen anderen IP-Bereich einstellen will, muss ich doch wieder den DHCP Server aktivieren, wollte ihn aber
deaktiviert lassen, da es sonst wieder Probleme mit dem SBS gibt...
Aha, sagt wer? Ich habe doch gerade geschrieben, wie Du es passenderweise konfigurieren solltest, damit es eben keine Probleme gibt. Statische Routen musst Du nirgendwo einrichten, da der Cisco NAT macht.
Bei Verständnisproblemen hier noch was zum lesen,
Dein Szenario ist eine einfache Kopplung von zwei Routern:
http://www.heise.de/netze/artikel/DMZ-selbst-gebaut-221656.html
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
wie sie auch hier im Forum mehrfach nachgefragt und besprochen ist...
Viel Spass noch beim basteln.
Bitte warten ..
Mitglied: aqui
25.03.2012 um 15:06 Uhr
Erstmal sollte Rudi mal klären ob das Thompson Teil auch wirklich ein Modem ist bzw. im Modem Modus arbeitet !!
Modems haben KEINE IP Adresse und sind nur Medienwandler !!
Das Thompson Teil MUSS also wirklich als Modem arbeiten ! Auch wenn es eine IP Adresse hat zum Management MUSS diese sie unterscheiden von den anderen IP Adressen im Netz !
Jeder Grundschüler weiss das IP Netze einzigartig sein müssen und eben nicht doppelt vorkommen was ja oben der Fall war. Das gilt es zu vermeiden !
Thompson hört sich nach einem Kabel TV Modem an also NICHT DSL leider dazu auch keinerlei Infos
Ist dem so und das Kabel TV muss der Cisco Router auf DHCP Betrieb am WAN/Internet Port eingestellt werden.
Ferner muss dann das Kabelmodem zwingend einmal stromlos gemacht werden damit es die Mac Adresse des Routers neu lernt.
Ein immerwiederkehrender Klassiker hier bei Kabel TV Internet.
DHCP Relay hat nichts zu suchen auf dem Router !! Also abschalten. Du musst nur einfach DHCP ausschalten auf dem Cisco Router !
Achtung: nicht zu verwechseln mit dem DHCP Client Modus am WAN/Internet Port des Cisco Routers sofern das Thompson Teil ein Kabel TV Modem ist !!
Der bleibt natürlich bestehen !
(Ist es doch ein DSL Modem muss der Cisco Router auf PPPoE Modus gestellt werden !!)
So

b679e9ee4b6ef5bcf600a0361ecbf867 - Klicke auf das Bild, um es zu vergrößern

sähe dieses Popelnetz dann richtig aus !
Bitte warten ..
Mitglied: danielfr
25.03.2012 um 19:11 Uhr
Zitat von aqui:
Erstmal sollte Rudi mal klären ob das Thompson Teil auch wirklich ein Modem ist bzw. im Modem Modus arbeitet !!
Ich war davon ausgegangen das man "Thomson Modem und Router in einem" wörtlichen nehmen kann...
Na mal sehen, was noch dabei rauskommt.
Bitte warten ..
Mitglied: aqui
26.03.2012 um 11:09 Uhr
Na ja du kennst ja das Problem hier zu unterscheiden zwischen "Modem" und Router. Vielen Laien fällt das schwer.
Im Kabel TV Bereich bekommt man oft wirklich ein NUR Modem und genau keinen Router. Auch wenn das Modem eine IP Adresse hat ist diese einzig nur für die Konfiguration aber nie zum Routen weil ein NUR Modem das ja nicht kann wie wir alle wissen.
Also....mal sehen, was noch dabei rauskommt beim "Rudi".
Bitte warten ..
Mitglied: wRudi69
31.03.2012 um 16:43 Uhr
Hallo,

also mein Netzwerk sieht so aus, wie auf deiner Grafik.
Ja es ist ein Kabel TV Modem, ich werd schauen, dass ich die Modelbezeichnung bekomm und genauere Infos finde.
Hab das jetzt mal so eingestellt, wie du gesagt hast.
Der Cisco Router bekommt über den WAN Port auch ne IP und ne Adresse zum DNS Server, allerdings bekommt mein Rechner keine IP-Adresse,
im Cisco Router steht zwar mein Rechner mit 192.168.1.100 aber ich bekomme immer so eine komische IP: 169.254.178.xx
und kein Standardgateway sowie DNS Server.
Weiß einfach nicht woran das liegt.
Bitte warten ..
Mitglied: danielfr
31.03.2012 um 17:14 Uhr
Vermutlich ist jetzt nach dem ganzen rumgefummel der DHCP Server Dienst auf dem Windows Server nicht mehr aktiv. Überprüfe das mal als erstes.
Bitte warten ..
Mitglied: aqui
02.04.2012 um 10:09 Uhr
169.254.x.x ist eine APIPA Adresse die sich Winblows dynamisch vergibt wenn es keinen DHCP Server sieht: (Eingeschränkte Konnektivität)
http://de.wikipedia.org/wiki/Zeroconf

Kollege danielfr hat also Recht das an deinem PC selber etwas oberfaul ist wenn der Router ihm korrekt eine IP gibt was er ja anzeigt der PC sie aber nicht bekommt.
Achte also darauf das dort alles auf Automatisch beziehen steht in den TCP IP Einstellung auf der LAN Verbindung** !!!
Bitte warten ..
Mitglied: wRudi69
09.04.2012 um 11:31 Uhr
Hallo,

melde mich nun auch mal wieder.
Konnte das leider heute erst testen, nun funktioniet zumindest das Internet schonmal, nachdem ich den DHCP Server am SBS2008 umgestellt habe.
Leider bekomme ich (wie könnte es anders sein) den VPN Server nicht zum laufen.
Wollte testweise mal nen PPTP-Server starten, da da weniger zum konfigurieren ist.
Und zwar scheitert es schon beim Verbindungsaufbau, mein Client kann den Server nicht finden, also dieser antwortet nicht.
Hab im Thomson den Port 1723 auf den Cisco (192.168.0.20 - WAN) umgeleitet.
Muss ich noch was umstellen?
Danke schon mal für eure HIlfe!

Lg

//edit: Da macht entweder der Thomson oder der Cisco Probleme, denn über den HTTP Port 80 hab ich auch keinen Zugriff mehr.
Aber die Ports werden auf den Cisco weitergeleitet und von dort der gesamte Verkehr an den SBS2008.
Bitte warten ..
Mitglied: aqui
10.04.2012, aktualisiert 18.10.2012
Bevor wir hier weitermachen solltest du erstmal klären ober das Thompson Teil ein Router oder nur ein simples Modem ist ansonsten raten wir hier fröhlich weiter und können dir NICHT zielführend helfen.
Erkennen kannst du das indem du mal bei der IP Adressvergabe am Cisco Router nachsiehst ob der am WAN/Internet Port eine öffentliche IP Adresse bekommen hat !
Dort darf keinen RFC 1918 IP Adresse ( private IP ) vergeben sein !
Ist das der Fall und arbeitet der Thompson tatsächlich auch als Router hats du zwei kaskadierte NAT Router und musst logischerweise 2 mal ein Port Forwarding machen !!
PPTP besteht mitnichten nur aus TCP 1723 sondern noch aus dem GRE Protokoll !!
Lies also bei PPTP bitte zuallererst DAS hier !! Und da besonders DAS hier.... !!

Was zudem völlig absurd ist in deiner Konstellation ist die Tatsache, das du ja mit dem Cisco RV042 schon einen vollständigen VPN Router einsetzt der ja selber VPN Server (IPsec) spielen kann. (Zudem ist er auch noch ein Dual Port WAN Router !)
In sofern ist deine "Frickelei" mit Port Forwarding usw. völlig unverständlich und auch kontraproduktiv. Es sei denn du bist technischer Masochist der nach dem Motto "Warum einfach machen, wenn es umständlich auch geht..!" Verfahren handelt.
Mit einem kostenlosen VPN Client wie z.B. dem Shrew Client:
http://www.shrew.net/support/wiki/HowtoLinksys
oder auch Cisco / Linksys VPN Client direkt:
http://www.cisco.com/en/US/prod/routers/quick_vpn.html
Ist doch mit dem Router direkt problemlos mit 3 Mausklicks im Gui ein VPN Zugang eingerichtet ?? Das kann sogar ein völliger VPN Laie auf Anhieb !
Die Frage die sich hier stellt ist also wo dein wirkliches Problem liegt ??
Bitte warten ..
Mitglied: wRudi69
10.04.2012 um 17:20 Uhr
Hi,

also das Thomson Dings ist definitiv auch ein Router, hat WLAN integriert und weißt LAN-IPs zu (192.168.0.xx)
Das ich doppelt forwarden muss weiß ich (hab ich auch gemacht).
Und das die Konstellation dumm ist, ist mir auch klar, hab zwei Router hintereinander, aber das Problem ist, dass ich das Thomson Dings ja nicht ersetzen kann,
da ich ja sonst nicht mehr ins Netz komme und den "Router Modus" kann ich leider nicht komplett deaktivieren...
Bitte warten ..
Mitglied: wRudi69
12.04.2012 um 19:38 Uhr
Wenn ich die IP anpinge, bekomme ich eine Antwort, aber meine Anfragen werden einfach nicht an den Server weitergeleitet.
Weiß jetzt nicht wo es hängt, entweder am Thomson Router oder am Cisco, vermute aber eher am Cisco,
da ich am Thomson ja nicht viel einstellen kann.
Bitte warten ..
Mitglied: aqui
13.04.2012 um 10:07 Uhr
Bevor wir ins Eingemachte gehen:
  • WOHIN willst du dein VPN Tunnel aufbauen ?? Zum Cisco RV042 (der ist ja VPN Router !!) oder zum Server dahinter ??
  • WAS für ein VPN Protokoll willst du dafür verwenden ??
Von der Beantwortung dieser Kardinalsfragen hängt die weitere Konfig ab der Router !!
Bitte warten ..
Mitglied: wRudi69
13.04.2012 um 11:06 Uhr
Also den VPN Tunnel will ich zum Cisco aufbauen, damit ich von außen auf die Rechner zugreifen kann,
z.B. die Sql db am server...
Welches Protokoll ich verwenden will ist eine gute Frage, hab mich mal kurz eingelesen,
aber konnte mich nicht wirklich entscheiden.
Welches Protokoll wäre denn empfehlenswert?

Danke
Lg
Bitte warten ..
Mitglied: aqui
13.04.2012 um 11:51 Uhr
OK, dann sind die Fakten klar, denn der Cisco spricht nur IPsec im ESP Modus als VPN Protokoll.
IPsec besteht aus den folgenden Protokoll Komponenten:
UDP 500 IKE (Schlüsselhandling)
UDP 4500 (NAT Traversal sofern der RV042 das supportet)
ESP Protokoll (ESP ist ein eigenständiges IP Protokoll mit der Protokoll ID 50 was denn Tunnel mit den Produktivdaten realisiert)
http://de.wikipedia.org/wiki/IPsec#Encapsulating_Security_Payload_.28ES ...
Du musst für IPsec also mindestens 2 dieser Protokolle nämlich UDP 500 und ESP ins Port Forwarding eintragen:
UDP 500
ESP
Diese beiden Protokolle müssen per Port Forwarding auf die WAN IP Adresse des RV042 zeigen.
Damit sollte dann sofort problemlos der VPN Tunnel auf den RV042 zustande kommen ! Sei es mit dem Shrew Client oder Linksys Client.
Bitte warten ..
Mitglied: wRudi69
14.04.2012 um 07:38 Uhr
Hi,

danke ich werde mir das dann heute gleich anschauen.
Hab gestern mal beim Cisco ein Firmware Upgrade gemacht, da das mit dem forwarding ja nicht funktioniert hat und
er auch keine logs erstellt hat.
Nun funktioniert das mal problemlos, erreiche den Server und vor allem ich habe Logs.
Bitte warten ..
Mitglied: aqui
14.04.2012 um 14:40 Uhr
Wie... "erreiche den Server..."?? Also klappt das jetzt mit deinem VPN oder wie soll man diese Message verstehen ??
Bitte warten ..
Mitglied: danielfr
14.04.2012 um 23:51 Uhr
@aqui: Bin heute über ein Thomson TWG870UG gestolpert (da musste ich doch gleich an den Thread hier denken), das hat eine NAT Funktion, die etwas umständlich als Residental Gateway bezeichnet wird. Handbuch hier.
Bin mal gespannt, wann die diversen Problemchen behoben sind. Gruß
Bitte warten ..
Mitglied: aqui
23.04.2012 um 13:57 Uhr
@Rudi69
Wenns das denn nun war oder du kein Interesse mehr hast an einer Lösung bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
TP-Link Router VPN Verbindung Router Oberfläche nicht erreichbar (3)

Frage von D46505Pl zum Thema Router & Routing ...

Netzwerke
gelöst VPN Sichtbarkeit im Netzwerk nicht möglich (6)

Frage von serguni zum Thema Netzwerke ...

Windows Server
SBS2008 AD funktioniert nur im LAN mit bestimmter IP. wie ändern? (13)

Frage von tomeknfr zum Thema Windows Server ...

Windows 8
gelöst Update auf Windows 8.1 funktioniert nicht (11)

Frage von KMP1988 zum Thema Windows 8 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...