Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NtBackup: Sicherung eines Laufwerk

Frage Sicherheit Backup

Mitglied: Zeddy74

Zeddy74 (Level 1) - Jetzt verbinden

19.06.2013, aktualisiert 15:28 Uhr, 2483 Aufrufe, 12 Kommentare

Hallo an alle,

ich habe bei folgendem System:

Windows Server 2003 Standard Edition SP1

folgendes Problem:

Ich benutze die Windows Eigene Software (NTBackup) um eine wöchentliche Sicherung auf ein LTO Band durchzuführen.

Es werden vier Partitionen ( D:, E:, F:,G: ) und der System State gesichert.
Von den Festplatten soll nicht alles gesichert werden, sondern nur bestimmte Verzeichnisse. Demzufolge haben wir in der .BKS Datei einige excludes.

Nun haben wir eine zusätzliche Platte (iSCSI), die schon seit längerem an dem Server hängt. Da der Platz auf den anderen Platten etwas wenig geworden ist,
wollen wir die iSCSI-Platte ( I: ) für Daten nutzen und natürlich soll die auch gesichert werden.

Das funktioniert aber nicht. Das Backup fängt jeden Samstag um 3.30 Uhr an und wenn ich mir die Logs am Montag anschaue, steht bei dem Laufwerk I: z.B.:

Backup started on 15.06.2013 at 18:54.
Backup completed on 15.06.2013 at 18:54.
Directories: 0
Files: 0
Bytes: 0
Time: 15 seconds

Sprich NtBackup läuft in 15 Sekunden über die Platte und das wars. Keine Fehlermeldung, nichts. Auch der Platte sind aber ca. 25GB Daten, die zu sichern sind.

Hab mir das die letzten 3 Wochen angeschaut und keinen Hinweis gefunden, warum der dieses Laufwerk nicht sichert.

Hat jemand eine Idee an was das liegen könnte?


Viele Grüsse
Zoltan
Mitglied: Ravers
19.06.2013 um 16:08 Uhr
Hi,

lege zunächst mal ein Backupplan nur für i an und schaue, ob der durchläuft.
Mit welchen Schaltern startet ihr den NTBackup?

Ansonsten mal den Plan hier abbilden.

greetz
ravers
Bitte warten ..
Mitglied: Zeddy74
19.06.2013 um 16:29 Uhr
Hi,

die Schalter sind wie folgt:

C:\WINDOWS\system32\ntbackup.exe backup "@%BACKUP_SELECTION%" /v:no /r:no /rs:no /l:s /HC:on /SNAP:on /m normal /n "%BACKUPNAME%-Medium_%myDATE%_%myTIME%" /d "%BACKUPNAME%-Set_%myDATE%_%myTIME%" /j "%BACKUPNAME%-Job_%myDATE%_%myTIME%" /um /p "LTO Ultrium"

Das hatte ich auch vor, mal so ein Fall nur mit I: durchzuspielen, bin aber noch nicht dazu gekommen.
Das einzige was ich gemacht ist, über das GUI von ntbackup eine selection von I: (so wie wir es brauchen) zu machen und in eine Datei zu sichern. Das hat funktioniert.

Gruss
Zoltan
Bitte warten ..
Mitglied: Pjordorf
19.06.2013 um 19:57 Uhr
Hallo,

Zitat von Zeddy74:
%BACKUP_SELECTION%
Was steht dort drin? Dahinter sollte sich ja eine Dateiname.bks Datei mit den Inhalt von dem was gesichert werden soll befinden. Ersetze die mit den richtigen Pfad/Dateinamen. Du kannst dir die bks Dateien im Editor anschauen (Achtung: nicht Speichen aus dem Editor heraus). Änderungen sollten aber nur mit dem NTBackup gemacht werden da es nicht nur eine einfache Textdatei ist. Ohne diese Datei oder deren leeren Inhalt sind doch 15 Sekunden nicht schlecht, oder?

Beispiel bks Inhalt:
I:\ 
I:\ /exclude
welche funktioniert und trotzdem nichts sichert oder gar Fehler schmeißt.

Falls du die .bkf Datei doch mit dem Notepad bearbeiten willst dann beim Speichern acht geben. http://support.microsoft.com/kb/237310

Gruß,
Peter
Bitte warten ..
Mitglied: Zeddy74
20.06.2013 um 08:42 Uhr
Hallo Peter,

hinter %BACKUP_SELECTION% verbirgt sich die Datei system_builds_qs_releases.bks, und dort steht drin:

C:\
D:\
D:\Svn\ /Exclude
D:\Trac\ /Exclude
G:\Synchronize\
G:\Builds\ /Exclude
G:\Service\
G:\mvn_repos\
G:\NAC\
G:\NAC\standards\ /Exclude
G:\Releases\ /Exclude
G:\KM\
G:\DMS\
G:\QMSystem\
I:\backup\artifactory\artifactory\Weekly_Backup\
I:\backup\artifactory\teamcity7\
I:\backup\teamcity5\
I:\backup\jira\
SystemState

Hab gestern auch noch ein wenig rumgesucht und bin auch auf das Ergebnis mit dem Unicode gekommen.....
Ich werde mal die Selektion nochmal über NtBackup direkt (also GUI) erstellen und dann mal schauen, ob besser (überhaupt) läuft.

Gruss
Zoltan
Bitte warten ..
Mitglied: Pjordorf
20.06.2013 um 11:28 Uhr
Hallo,

Zitat von Zeddy74:
die Datei system_builds_qs_releases.bks, und dort steht drin:
Die Datei sieht ja so erstmal ok aus und wenn dann noch mit Unicode gespeichert sollte die auch laufen.

Gruß,
Peter
Bitte warten ..
Mitglied: Zeddy74
24.06.2013 um 08:44 Uhr
Guten Morgen zusammen,

so, nach meinen Versuchen letzte Woche und dem turnusmässigen Backup am Wochenende steht es fest, dass das Backup (zumindest von diesem I:-Laufwerk) wieder nicht durchgelaufen ist

Alles andere wurde normal erstellt. Es hat sich quasi nichts verändert.

Habt ihr noch irgendwelche Vorschläge ?


Guten Start in die Woche
Zoltan
Bitte warten ..
Mitglied: Pjordorf
24.06.2013 um 09:57 Uhr
Hallo,

Zitat von Zeddy74:
so, nach meinen Versuchen letzte Woche
Und? Verrätst du uns deine Versuchsergebisse oder meinst du wir sollen die uns selbst erarbeiten?

und dem turnusmässigen Backup am Wochenende steht es fest
Solange doch nichts geändert oder der Fehler gefunden wurde sollte sich hier an dem nicht Sichern von I: nichts ändern, oder meinst du etwa nicht?

dass das Backup (zumindest von diesem I:-Laufwerk) wieder nicht durchgelaufen ist
Dann wäre es doch nett von dir wenn du uns sagst was denn überhaupt klappt. Was steht im ereignissprotokoll drin? was steht im Sicherungsprotokoll drin? Sicherungsprotokoll eingestellt das Details geloggt werden (Vermutlich nicht)?

Es hat sich quasi nichts verändert.
Enttäuscht?

Habt ihr noch irgendwelche Vorschläge ?
Richte es korrekt ein. Beseitige die Fehler die eine Sicherung verhindern. Was willst du ohne Infos deinerseits jetzt hier Lesen?

Gruß,
Peter
Bitte warten ..
Mitglied: Zeddy74
24.06.2013 um 10:29 Uhr
Zitat von Pjordorf:
Hallo,

> Zitat von Zeddy74:
> so, nach meinen Versuchen letzte Woche
Und? Verrätst du uns deine Versuchsergebisse oder meinst du wir sollen die uns selbst erarbeiten?
Die Selection über NtBackup GUI zusammengestellt und darauf geachtet, dass es als UNICODE abgespeichert ist.

> und dem turnusmässigen Backup am Wochenende steht es fest
Solange doch nichts geändert oder der Fehler gefunden wurde sollte sich hier an dem nicht Sichern von I: nichts
ändern, oder meinst du etwa nicht?
Das ist ja mein Problem, wo soll ich anfangen zu suchen ?

> dass das Backup (zumindest von diesem I:-Laufwerk) wieder nicht durchgelaufen ist
Dann wäre es doch nett von dir wenn du uns sagst was denn überhaupt klappt. Was steht im ereignissprotokoll drin? was
steht im Sicherungsprotokoll drin? Sicherungsprotokoll eingestellt das Details geloggt werden (Vermutlich nicht)?
Alles andere (siehe oben, auszug aus der Selektion) wird richtig gesichert. Wie oben bereits geschrieben, läuft das Backup in 15 Sekunden über das I: und sichert nichts. Es gibt auch keine Fehlermeldung. Es kommen aber täglich neue Dateien/Verzeichnisse hinzu.

Hier der Auszug aus dem Logfile:
Backup (via shadow copy) of "I: iSCSI-2.6TB"
Backup set #4 on media #1
Backup description: "system_builds_qs_releases-Set_2013.06.22_ 3:30:00"
Media name: "system_builds_qs_releases-Medium_2013.06.22_ 3:30:00"

Backup Type: Normal

Backup started on 22.06.2013 at 19:57.
Backup completed on 22.06.2013 at 19:57.
Directories: 0
Files: 0
Bytes: 0
Time: 15 seconds
> Es hat sich quasi nichts verändert.
Enttäuscht?
Nicht wirklich, hätte mich eher gewundert, wenn es klappt.

> Habt ihr noch irgendwelche Vorschläge ?
Richte es korrekt ein. Beseitige die Fehler die eine Sicherung verhindern. Was willst du ohne Infos deinerseits jetzt hier
Lesen?
Welche Fehler? Soll ich das Laufwerk I: in K: umbenennen? Hat NtBackup etwas gegen den Buchstaben I:? Wenn ich doch keine Fehlermeldung habe und somit auch keinen Ansatzpunkt, kann ich den Fehler nicht beseitigen. Wie schon geschrieben, es ist genauso eingerichtet wie die anderen Laufwerke und die werden korrekt gesichert. Es ist eine einzige .cmd, die die Sicherung macht. Nur die Selektion des Laufwerk I: ist dazugekommen. Die Infos hab ich eigentlich ganz zu anfang schon gegeben, dachte ich. Wenn sich im Vergleich zu letzter Woche nichts geändert hat, ist diese Fehlerbeschreibung immer noch gültig.

Gruß,
Peter

Ich habe nicht erwartet, dass hier jemand seine Glaskugel auspackt und mir ganz genau sagt, daran liegt es. War der Meinung, dass es vielleicht ein bekanntes Problem ist und jemand auf anhieb sagen kann, das oder das könnte es sein.

Gruss
Zoltan
Bitte warten ..
Mitglied: Pjordorf
24.06.2013 um 11:27 Uhr
Hallo,

Zitat von Zeddy74:
Die Selection über NtBackup GUI zusammengestellt und darauf geachtet, dass es als UNICODE abgespeichert ist.
Das ist ja gut und schön wenn bei dir das Testen und Versuche mit verschiedenen Optionen der Datensicherung nur darin besteht eine neue bks Datei zu erstellen. Da hast du wahrhaftige gewaltige Versuche unternommen. @Ravers fragte dich ganz am anfang was denn ein Versuch ergibt dein Laufwerk I: alleine zu sichern. Deiner bisherige Antwort
Das hatte ich auch vor, mal so ein Fall nur mit I: durchzuspielen, bin aber noch nicht dazu gekommen
Und jetzt sollen wir wissen ob dein I: überhaupt gesichert werden kann?

Das ist ja mein Problem, wo soll ich anfangen zu suchen ?
Da wo die Protokolle anfangen?

Nicht wirklich, hätte mich eher gewundert, wenn es klappt.
Warum hätte dich das denn gewundert wenn es geklaptt hätte?

Welche Fehler?
Rechte?

Soll ich das Laufwerk I: in K: umbenennen?
Wenn du es möchtest. Wird aber an dein Problem wohl nichts änden.

Es ist eine einzige .cmd, die die Sicherung macht.
Und wird wie gestartet? Durch wen? Welche Laufwerke existieren dann mit welchen Rechten?

die Selektion des Laufwerk I: ist dazugekommen
Und ist wohl auch dein einziges iSCSI Target, oder?

Wer sichert wann, wo, welche Umgebung, welche Rechte auf Quelllaufwerke usw. geh das alles durch, dann findest du auch den Fehler.

PS. Du musst nicht erst bis zum Wochenden warten um eine Testsicherung machen zu können.

Ich habe nicht erwartet, dass hier jemand seine Glaskugel
Das müssen wir aber wenn du hier nichts an Informationen lieferst woraus sich dein Fehler ergeben könnte. Ansonsten bleibt als Antwort "Es kann alles mögliche sein".

War der Meinung, dass es vielleicht ein bekanntes Problem
Klar ist es ein Bekanntes Problem. Wenn ich mir deine Umgebung und Benutzer und Gruppen und iSCSI Targets und Batchdateien und Tasks so zusammenbaue wir es bei dir ist, werden ich den gleichen Fehler haben. Est hat aber wohl keiner deine genaue Umgebung bzw alle parameter Identisch mit deinen, weshalb es bei anderen ghet udn bei dir nicht.

Schließe Fehler aus. Was über bleibt ist dein Fehler.

Kann Laufwerk I: alleine gesichert werden? (wurde aber schon vor 5 Tagen gefragt)

Gruß,
Peter
Bitte warten ..
Mitglied: Zeddy74
24.06.2013 um 12:42 Uhr
Ja, sorry, das war mein Fehler, es nicht zu erwähnen. Ich habe letzte Woche eine manuelle Sicherung von dem Laufwerk (die selben Verzeichnisse wie in der Selektion) gemacht. Das hat funktioniert.

Ich könnte die ganze Umgebung hier mit allen Verknüpfungen und Zusammenhängen darstellen. Bis ich das aber gemacht habe, habe ich den Fehler/Problem selbst gefunden.
Ich habe in meinem nicht mehr so jugendlichen Leichtsinn gedacht, hier würde ich einige Ratschläge kriegen. Keiner kann auf anhieb das Problem lösen, dass ist mir schon klar. Es ging mir nur um denkanstösse. Man kann natürlich solche Antworten geben :Da hast du wahrhaftige gewaltige Versuche unternommen.: oder konstruktive. Ich muss ganz ehrlich gestehen, dass ich auf solche Art von sarkastischen Antworten verzichten kann.

So, dann werde mich mal das Problem selbst lösen, und falls jemand mal so was (oder ähnliches) hat, kann sich gerne bei mir melden. Ich werde jedenfalls mein Wissen gerne teilen, ohne die Fragen/Antworten der anderen Wort für Wort zu zerlegen und Angriffspunkte zu suchen.

Viele Grüsse
Zoltan
Bitte warten ..
Mitglied: Pjordorf
24.06.2013 um 13:18 Uhr
Hallo,

Zitat von Zeddy74:
es nicht zu erwähnen.
Für dich vielleicht unwichtig. Aber wir hier wissen nicht was du machst oder gemacht hast oder welche Erkenntnisse du inzwischen gefunden hast. Du willst eine Hilfe zu deinem Problem.

Ich habe letzte Woche eine manuelle Sicherung von dem Laufwerk (die selben Verzeichnisse wie in der Selektion) gemacht. Das hat funktioniert.
OK, also ist I: zu sichern. Gut. Wie hast du die Sicherung gemacht? manuell? Per Script? Per Task? Waren die Gebenheiten bei der Ausführung der Sicherung gleich (nicht den Inhalt der bks Datei, da reicht ein I:\ drin), also gleicher Benutzer, gleiche Umgebung? Ein Task ausgeführt ohne Anmeldung hat eine andere Umgebung und Rechte als ein Admin der am Server angemeldet irgend etws irgendwie testet. Verstehst du denn sinn der fragen jetzt?

Ich könnte die ganze Umgebung hier mit allen Verknüpfungen und Zusammenhängen darstellen
Brauchst du nicht. Du solltest nur bei dir daruaf achten das die stimmen un dkorrekt sidn um auch ein korrektes ergebniss zu erhalten. Es kann ohne weiteres sein das dein Sicherungslauf tatsächlich korrekt arbeitet. s.o.

Ich habe in meinem nicht mehr so jugendlichen Leichtsinn gedacht, hier würde ich einige Ratschläge kriegen.
Hast du auch. Damit müsste sich der Fehler (wenn es einer ist) finden lassen oder den Grund dafür ergründen lassen. Aber dazu brauchen wir dich und deine Sicht auf der Konsole und was da dann steht. Wir sehen dein Bildschirm hier nicht.

Man kann natürlich solche Antworten geben
Fülltext? Um eine Antwort ohne Inhalt länger aussehen zu lassen ohne wirklich was zu sagen bzw. Information preis zu geben? Was würdest du sagen wenn ich sage das ich am Wochende ca. 12 Stunden damit verbracht einen Server 2003 und sein NTBackup dazu zu kriegen etwas nicht zu Sichern obwohl er es soll um deinen Fehler nachzustellen?

ich auf solche Art von sarkastischen Antworten verzichten kann.
Liefer klare Fakten und lass uns nict immer in unsere milchige Glasmurmel schauen was bei dir dir Ursache sein könnte.

Gruß,
Peter
Bitte warten ..
Mitglied: Pjordorf
01.07.2013 um 19:06 Uhr
Hallo,

Zitat von Zeddy74:
> Was steht im ereignissprotokoll drin?
Bis heute keine Antwort von dir hierzu. Ich möchte fast Wetten (etwas was ich aber grundsätzlich nicht tue) das dort zu den genannten Zeiten wo dein Backup nicht dein I: sichert dort ein Event 24 und 35 von deinem VSS steht und zwar unter System.

Backup started on 22.06.2013 at 19:57.
Da sollte im Ereignissprotokoll unter System auch etwas zu stehen.

Gruß,
Peter
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Server 2012R2 HyperV Sicherung von Dateien (10)

Frage von smeclnt zum Thema Windows Server ...

Windows Server
SBS 2011 - Fehler bei Server-Sicherung (20)

Frage von Irolan zum Thema Windows Server ...

Netzwerkmanagement
gelöst Im Anmeldeskript ein Laufwerk mit einem anderen User und Pw mappen unsicher? (10)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...