Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NTFS Sicherheitsberechtigung nach Neuinstallation defekt ?

Frage Microsoft Windows Server

Mitglied: beowulf1980

beowulf1980 (Level 1) - Jetzt verbinden

23.05.2011, aktualisiert 14:28 Uhr, 4357 Aufrufe, 4 Kommentare

Hallo zusammen,

ich habe ein Problem mit einem File-Server. Der Server wollte nach einem Reboot einfach nicht mehr starten. Man kam noch nichtmal zu dem Auswahlpunkt für die Systemreparatur.

Also dachte ich mir da die Daten auf dem zweiten RAID liegen kann ich den Server ja einfach neu installieren.
Ich hab den Server dann händisch aus der Domäne geworfen ihn neu installiert mit demselben Namen und die Freigaben wieder eingerichtet. Die ACL's funktionieren auch noch alle eigentlich. Also User haben keine Probleme auf ihre Dateien zuzugreifen.

Nur die Administratoren nicht

Das Problem war schon nach der Neuinstallation das er mich nicht auf das Root-Verzeichnis der Festplatte lassen wollte. Ich komme über die administrative Freigabe auf alles dahinter drauf. Allerdings kommt vorher noch das Fenster das ich momentan keinen Zugriff habe und bestätigen muss dauerhaften Zugriff zu erhalten. Das muss ich jetzt bei jedem Ordner tun den es auf dem Server gibt.

Wenn ich danach in die ACL schaue sehe ich das mein User jetzt drinsteht und ich auch dran komme. Aber die Gruppe Administratoren hat ja auch Zugriff darauf. Und in der bin ich ja auch drin. Ich hab halt irgendwie das Gefühl das er die Zuordnung der Domänen-Admins zu den lokal-Admins nicht ganz hinbekommt.

Die Vererbung kann ich leider nicht benutzen, auf dem Server sind ca 300000 Ordner und etwa 8 Mio. Dateien. Alle speziell eingerichtet für die User. Wenn ich da von Root vererbe bin ich mehrere Wochen beschäftigt das wieder so einzurichten wie vorher.

Ich schätze mal das Problem liegt daran das ich den Server wieder gleich benannt habe und die lokale Administratoren-Gruppe eine andere SID hat als die vom alten Server.

Ich wüßte jetzt aber auch nicht wie ich das berichtigen kann ohne mir die komplette ACL-Struktur zu killen.

Hat jemand von euch da vielleicht ne Idee zu ?

Gruß
Beowulf
Mitglied: Lochkartenstanzer
24.05.2011 um 08:04 Uhr
Zitat von beowulf1980:
Hat jemand von euch da vielleicht ne Idee zu ?


Hast Du mal geschaut, welche Benutzer in der lokalen Admin-Gruppe sind?

Sind die Zugffsrechte für die Domänenadmins vergeben oder nur für die lokalen Admins?

Du könntest ggf. über die Shell die Zugriffsrechte für die Domänen-Admins hinzufügen.

lks
Bitte warten ..
Mitglied: beowulf1980
24.05.2011 um 10:13 Uhr
Hi,

ja in der lokalen Admin-Gruppe sind die Domänen-Admins drin.
Und vergeben waren die Rechte immer für die Lokal-Admins.

Auf die Root-Ebene hatte ich wieder Zugriff nachdem ich explizit für meinen Account auf der Rootebene ohne Unterordner den Zugriff wieder gesetzt habe. Und jetzt kommt halt bei jedem Ordner den ich anwähle die Meldung das ich keinen Zugriff und ob ich mir den geben will. Bestätige ich das wird halt mein Account in die ACL eingetragen und ab dann kann ich da auch wieder ran. Aber das ist bei so vielen Ordnern ja auch nicht Sinn der Sache und meine Kollegen haben dadurch auch noch keinen Zugriff.

Kommandozeile hatte ich auch schon gedacht aber dann müsste ich ja erstmal mit takeown alle Besitzrechte übernehmen für die paar Mio. Dateien. Das würde ich eigentlich gerne umgehen.

Kennst du denn ein Tool mit dem man in allen ACL's eine Gruppe austauschen kann ?

Gruß
Beowulf
Bitte warten ..
Mitglied: beowulf1980
26.06.2011 um 23:35 Uhr
Vielleicht liest das hier nochmal jemand der mir helfen kann.

Ich habe jetzt die Datenplatte gebackuped die Platte formatiert und alle Verzeichnisse ohne SIcherheitsberechtigung wiederhergestellt. Somit war die Platte wieder richtig eingestellt und alle Verzeichnisse hatten dieselben NTFS-Sicherheitseinstellungen. Damit war der Zugriff für alle Administratoren wiederhergestellt.

Nachdem ich jetzt angefangen habe die alten Berechtigungen wiederherzustellen fängt es wieder an.
Ich muss jedes mal bestätigen wenn ich wieder in ein Verzeichnis rein will.

Lustigerweise kann ich aber über eine als Administrator ausgeführte Kommandozeile an alles dran. Leider funktioniert der Trick mit ausführen als nicht mit dem Windows-Explorer.

Es passiert aber auch nicht bei allen Verzeichnissen.
Das ist echt komisch. SO ein Dreck.

Ich hab keine Idee was ich noch versuchen könnte ?

Jemand hier noch eine Idee ?

Gruß
Beowulf
Bitte warten ..
Mitglied: beowulf1980
18.10.2011 um 02:20 Uhr
Ok also ich bin schonmal soweit das ich festgestellt habe wenn ich die lokale Benutzer-Gruppe hinzufüge komme ich auch wieder als Admin dran.

Das liegt wohl irgendwie daran das ich keine Chance haben den WIndows-Explorer als Admin zu starten. Weil der Explorer-Prozess schon beim Windows-Start geladen wird und alle Child-Prozesse die ich danach aufrufe mit den gleichen Berechtigungen laufen.

Abhilfe konnte ich mir jetzt schaffen in dem ich einen alternativen Dateibrowser installiert habe.
Den kann ich als Admin starten und dann durch die Verzeichnisse gehen. Ist zwar ein unschöner Umweg aber ne bessere Lösung kann ich nicht finden.

Gruß
Beowulf
Bitte warten ..
Ähnliche Inhalte
Windows Server
Problem beim Setzen von NTFS Sicherheitsberechtigungen bzw. Brett vorm Kopf
gelöst Frage von Kalma73Windows Server8 Kommentare

Hallo, ich habe ein kleines Problem beim setzen der NTFS Sicherheitsberechtigungen auf meinem File Server. Ich habe einen Ordnerstruktur ...

Windows Server
Ereignisanzeige: Ereignis 137, Ntfs (Ntfs)
gelöst Frage von rs-varelWindows Server12 Kommentare

Hallo, folgende Grundhardware / Installation Windows Hyper-V Server 2012 mit 2 Virtuellen Maschinen 1.) Terminal Server 2.) AD-Server Beide ...

Viren und Trojaner
Welche Schutzsoftware nach Neuinstallation?
Frage von Mr.HeisenbergViren und Trojaner10 Kommentare

Hey, ich habe soeben mein System mit Windows 10 neu aufgesetzt und nutze bis her nur den AntiVir als ...

Ubuntu
NTFS mit Mint
Frage von 122136Ubuntu

Moin, probier gerade Mint aus - irgendwie ganz nett aber man spürt das Ubuntu zu sehr. Da ist etwas ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 3 StundenWindows 101 Kommentar

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 4 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner2 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Brainstorming, einfachste Option 1 getrenntes LAN (mit WAN zugang)
Frage von 132954LAN, WAN, Wireless13 Kommentare

Hi, folgendes: Wir bekommen eine Glasfaser Leitung, Und das sollte Optional so aussehen: Ein Modem/Router für das WAN, ein ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...