Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

O2-Box mit Ubuntu und WLAN

Frage Netzwerke DSL, VDSL

Mitglied: franc

franc (Level 2) - Jetzt verbinden

14.02.2014, aktualisiert 12:43 Uhr, 6041 Aufrufe, 8 Kommentare, 2 Danke

Hallo

ein Freund (wohnt woanders), hat DSL von o2 bekommen.
Eine o2 Box mit WLAN.
Er hat einen Ubuntu PC und hat sich erfolgreich über den Befehl pppoeconf im Terminal mit den Internet verbunden.
Nun hat er noch ein iPhone, mit den er über WLAN ins Internet will.
Die WLAN Verbindung funktioniert wohl, aber das Internet darüber nicht.
Der Rechner läuft und ist verbunden, aber WLAN gibt anscheinend kein Internet.

Habe ich da einen Denkfehler, wenn ich glaube, dass der Router (die o2-Box) automatisch das Gateway wird, wenn der Ubuntu PC PPPoE macht?

Müsste das iPhone gar die IP des Rechners als Gateway eintragen?

Interessanterweise kommt man angeblich auch nicht auf die Web Oberfläche des Routers, also auf 192.168.1.1
Weder mit PC noch mit iPhone (wenn im WLAN).

Danke
franc
Mitglied: aqui
LÖSUNG 14.02.2014, aktualisiert um 12:43 Uhr
Eigentlich ist das Unsinn, denn die O2 Box ist ein simpler Router. Ggf. sogar gleich mit WLAN. PPPoE macht ja der Router zum Provider nicht aber das Endgerät, da ist es ja völlig unsinnig das der Ubuntu Rechner PPPoE macht.
Verwunderlich das das überhaupt geht, denn normalerweise blocken Router PPPoE Packete vom lokalen LAN. Irgendwie ist das alles Murks und konfus...?

Es sollte vollkommen reichen den Ubuntu Rechner am LAN Port auf normal DHCP Client stellen und mit dem LAN Port des Routers verbinden. Fertig ist der Lack !
So wie es millionenfach üblich ist bei allen Haushalten mit einem simplen DSL Router.
Kommt na auch von selber drauf zumal der Ubuntu im Default ja auch DHCP macht.

Sinnvoll wäre hier ein ifconfig und der Output der Datei /etc/network/interfaces und das Modell der "O2 Box" zu posten ansonsten bleibt uns ja nur die berühmte Kristallkugel.
Das ist eigentlich ein simpler Klassiker...warum dein Freund a PPPoE macht ist vollkommen unverständlich sofern die O2 Box kein Modem ist.
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 14.02.2014, aktualisiert um 12:43 Uhr
Zitat von franc:

Hallo

ein Freund (wohnt woanders), hat DSL von o2 bekommen.
Eine o2 Box mit WLAN.

Welche?

Er hat einen Ubuntu PC und hat sich erfolgreich über den Befehl pppoeconf im Terminal mit den Internet verbunden.

Warum pppoe udn nicht einfach die Box sich einwählen lassen?

Nun hat er noch ein iPhone, mit den er über WLAN ins Internet will.

Schön für Ihn.

Die WLAN Verbindung funktioniert wohl, aber das Internet darüber nicht.

Warum sollte sie auch, wenn die O2-Box kein Router spielen darf.

Der Rechner läuft und ist verbunden, aber WLAN gibt anscheinend kein Internet.

Ist das WLAn überhaupt korrekt konfiguriert?

Habe ich da einen Denkfehler, wenn ich glaube, dass der Router (die o2-Box) automatisch das Gateway wird, wenn der Ubuntu PC PPPoE
macht?

ja. (das mit dem denkfehler udn nicht das mit dem automatischen gateway).

Automatisch wird das mal gar nichts, wenn Du es nicht entsprechend konfigurierst. einfache grundregel: Die Kiste die die Verbindung zum Provider herstellt, soltel das Routing übernehmen und somit auch zum gateway werden.


Müsste das iPhone gar die IP des Rechners als Gateway eintragen?

Wenn der rechner routing macht, ja. Ansonsten muß das iPhone selbst pppoe machen.


Interessanterweise kommt man angeblich auch nicht auf die Web Oberfläche des Routers, also auf 192.168.1.1
Weder mit PC noch mit iPhone (wenn im WLAN).

Vilelicht ist der Router ja auch anders konfiguriert?

Also:

Ip-Adressen und Modell des Modems/Routers posten udn dann braucht unsereins nicht die kristallkugel zu bemühen.


lks
Bitte warten ..
Mitglied: franc
14.02.2014 um 12:30 Uhr
Ich weiß nicht, was für eine o2-Box der Freund hat, er hat sich bisher nicht mehr gemeldet.
Ich will ihn auch nicht zu seinem "Glück" zwingen.

Er hat pppoe gemacht, weil das das einzige ist, das er mal beigebracht bekommen hatte, als er noch ein simples Modem hatte.

Aber dann ist es mir jetzt klar, warum die Internetverbindung über WLAN nicht geht. Die Verbindung zum WLAN AP steht offensichtlich, aber der Router ist ja gar nicht das Gateway. Es kann so nicht gehen.

Es ist noch zu klären, warum er nicht mal mit dem iPhone per 192.168.1.1 (das sei die o2 Box Standard IP) auf den Router kommt. Ich kann mir nicht vorstellen, dass er es verstellt hat und angeblich (laut meiner eigenen Glaskugel) ist das die IP.

Vielen Dank, dann werde ich ihm das mal erklären, wenn er sich noch mal meldet und überhaupt gewillt ist, das zu reparieren.

franc
Bitte warten ..
Mitglied: Lochkartenstanzer
14.02.2014 um 12:37 Uhr
Zitat von franc:

Es ist noch zu klären, warum er nicht mal mit dem iPhone per 192.168.1.1 (das sei die o2 Box Standard IP) auf den Router
kommt. Ich kann mir nicht vorstellen, dass er es verstellt hat und angeblich (laut meiner eigenen Glaskugel) ist das die IP.

Es muß ja nicht verstellt sin, sondern dieses Modell kan auch durchaus mal eine andere Standardkonfiguration haben (192.168.0.1 oder 192.168.3.1 oder irgendein anderes aus den 192-er RFC-1918-Netzen.).

Ein einfaches Ifconfig -a soltel da auskunft geben können.

lks

PS: Wenn er den "Router" mit PPPOE-Paßthrough betreibt, kann es sogar sein, daß der gar keine IP-Adressen verteilt und damt auch nicht über die RCFC-1918-Adresse erreichbar ist, weil man die erst manuell einem interface zuweisen muß.
Bitte warten ..
Mitglied: aqui
14.02.2014 um 20:45 Uhr
Es ist noch zu klären, warum er nicht mal mit dem iPhone per 192.168.1.1 (das sei die o2 Box Standard IP) auf den Router kommt. Ich kann mir nicht vorstellen, dass er es verstellt hat und angeblich (laut meiner eigenen Glaskugel) ist das die IP.
Sorry aber du rätst hier nur rum ohne Fakten zu wissen.
Der Freund soll erstmal im iPhone nachsehen ob er eine gültige IP vom Router bekommen hat. Anhand der IP kannst du dann auch gleich sehen ob er richtig mit dem WLAN verbunden ist !
Er sollte die O2 Box immer mit einem persönlichen WLAN Namen versehen wie Bitschleuder oder Wurstsemmel und NIEMLS die Hersteller Default SSID (WLAN Name) verwenden.
Noch sinnvoller ist es mit einem WLAN Scanner wie dem inSSIDer checken ob Nachbar WLANs da sind und auch die Kanaleinstellung zu optimieren.
Sein WLAN muss mindesten 4 Kanäle Abstand zu diesen haben.
Ist das sauber eingerichtet klappt das auch sofort.
Bitte warten ..
Mitglied: franc
13.05.2014, aktualisiert 14.05.2014
Zitat von aqui:
...
Es sollte vollkommen reichen den Ubuntu Rechner am LAN Port auf normal DHCP Client stellen und mit dem LAN Port des Routers
verbinden.

Nun war ich endlich mal vor Ort und habe stundenlang rumprobiert. Durch das pppoeconf ist es anscheinend alles verdreht.
Ohne PPPoE konnte ich durch manuelle Einstellung zwar den Router endlich erreichen und die Zugangsdaten dort hinterlegen, so dass das iPhone (nur gelegenltich) per WLAN ins Netz kommt und mein SGS2 zuverlässig, aber der Rechner kommt nach Neustart nicht mehr auf den Router. Das Netzwerk GUI Programm von Ubuntu (NetworkManager) funktioniert irgendwie nicht. Dort kann ich zwar eine LAN Verbindung mit DHCP einrichten, aber das wird nicht angewendet.

Ich habe dann den pppoeconf-Eintrag in der /etc/network/interfaces entfernt (auskommentiert) und auf dhcp gestellt, aber dann fährt der Ubuntu nicht mehr hoch.
Dann noch testweise auf static (mit der entsprechenden IP für PC und GW) aber auch dann fährt er nicht hoch und ich musste es wieder zurück setzen.
Das Ende vom Lied war, dass ich wieder pppoeconf ausgeführt habe und im Router die CheckBox mit PassThrough PPPoE gecheckt.
Jetzt geht der Rechner über PPPoE ins Netz, kommt zwar nicht auf den Router aber wenigstens ins Internet.

Das iPhone kommt allerdings nicht zuverlässig ins Internet und auch nicht auf den Router (192.168.1.1). Das habe ich aber erst danach erfahren, wo ich schon wieder fort bin. Da scheint nun der Hase im Pfeffer.
Mal geht es über WLAN, mal nicht, und wenn dann langsam. Mit meinem S2 kam ich auch auf den Router.

Sinnvoll wäre hier ein ifconfig und der Output der Datei /etc/network/interfaces und das Modell der "O2 Box"

Das ist eine o2 Box 4421
interfaces steht auf manual (static und dhcp gingen ja nicht, s.o.):
...
iface eth0 inet manual

ifconfig zeigt eth0 nicht an, wenn man PPPoE weg lässt (und versucht, das im NetworkManager einzustellen).

Das ist eigentlich ein simpler Klassiker...warum dein Freund a PPPoE macht ist vollkommen unverständlich sofern die O2 Box
kein Modem ist.

Vermutlich wäre es ganz einfach gewesen, wenn er nur das Kabel rein gesteckt und 192.168.1.1 aufgerufen hätte, anstatt das System mit pppoeconf zu verkonfigurieren.
Jetzt weiß ich aber nicht, wie man das wieder auf den normalen Zustand (dhcp) kriegen kann.
Ich kenne mich mit der Ubuntu GUI (ich glaube es ist Uno) nicht gut aus.
Bitte warten ..
Mitglied: Lochkartenstanzer
14.05.2014 um 08:38 Uhr
Zitat von franc:

Das Netzwerk GUI Programm von Ubuntu (NetworkManager) funktioniert irgendwie nicht. Dort kann ich zwar eine
LAN Verbindung mit DHCP einrichten, aber das wird nicht angewendet.

Die GUI-Networkmanager sind der größte Murks, den sich hat jemand einfallen lassen. Die funken einem nur in die Konfiguration dazwischen und ändern diese unmotiviert. Am besten deinstallieren udn alles nur mit /etc/network/interfaces konfigurieren. Ist zwar nicht so schön klickibunti, aber dafür ha man bessere kontrolle üebr sein netzwerk.


Ich habe dann den pppoeconf-Eintrag in der /etc/network/interfaces entfernt (auskommentiert) und auf dhcp gestellt, aber dann
fährt der Ubuntu nicht mehr hoch.
Dann noch testweise auf static (mit der entsprechenden IP für PC und GW) aber auch dann fährt er nicht hoch und ich
musste es wieder zurück setzen.
Das Ende vom Lied war, dass ich wieder pppoeconf ausgeführt habe und im Router die CheckBox mit PassThrough PPPoE gecheckt.
Jetzt geht der Rechner über PPPoE ins Netz, kommt zwar nicht auf den Router aber wenigstens ins Internet.

Das iPhone kommt allerdings nicht zuverlässig ins Internet und auch nicht auf den Router (192.168.1.1). Das habe ich aber
erst danach erfahren, wo ich schon wieder fort bin. Da scheint nun der Hase im Pfeffer.
Mal geht es über WLAN, mal nicht, und wenn dann langsam. Mit meinem S2 kam ich auch auf den Router.




disable ppoe manually.

Ansonsten:

Poste doch einfach mal, was in /etc/network/interfaces steht und was ifconfig -a sagt.

lks

PS. Du solltest die Networkmanager wirklich deinstalieren (apt-get remove network-manager)
Bitte warten ..
Mitglied: franc
14.05.2014, aktualisiert um 21:24 Uhr

Das hatte ich ja probiert, allerdings zwar nicht mit network restart, sondern mit dem Neustarten des Rechners, aber das ging ja nicht.
Mit dhcp (genau wie in dem Link auch beschrieben) fuhr die Kiste nicht hoch. Erst mit manual dann wieder.
Auch hatte ich die dsl-provider Datei nicht gelöscht, aber wenn sie referenziert wird, dürfte das ja auch egal sein.

Poste doch einfach mal, was in /etc/network/interfaces steht und was ifconfig -a sagt.

Die interfaces enthält jetzt wieder die Passage für ppoe und das manual. Auswendig kann ich es nicht mehr sagen.

PS. Du solltest die Networkmanager wirklich deinstalieren (apt-get remove network-manager)

Das nächste Mal gerne

EDIT: ich erfahre gerade, dass es was geholfen hat, dass er auf die WLAN Taste des Routers gedrückt hat. Die WLAN-LED war zwar vorher auch an. Jetzt hat er anscheinend wieder eine Verbindung über WLAN mit dem iPhone, auch wenn sie ihm zu langsam erscheint. Am Sonntag (vor Ort) hatte ich mit einem Speedtest gut 3 Mbs gemessen, also zwar nicht Highspeed, aber doch zum Surfen schon akzeptabel.
Immerhin scheint es also zu gehen auf die Weise, das ist die Hauptsache.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
LAN, WAN, Wireless
Drucker an O2 Box - kein Druck möglich (4)

Frage von pdiddo zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Hat On Networks PL500PS WLAN-Funktion? (4)

Frage von Andy1987 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...