Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Internet E-Mail

Octopus Open IT meldet 421 invalid sender domain LinuxServer.firma.loc (misconfigured dns?)

Mitglied: xennor

xennor (Level 1) - Jetzt verbinden

03.01.2012, aktualisiert 09:04 Uhr, 4088 Aufrufe, 7 Kommentare

Guten Morgen! Mein erster Beitrag hier und ich hoffe hier einen guten Rat zu bekommen wie mein Problem zu beheben ist!
Ich muss auch noch klarstellen, dass ich nur als IT-Systemkaufmann ausgebildet bin, ich aber schon etwas mehr Praxis in der Administrationsebene sammeln konnte.

In unserer kleinen Firma wird ein eine Telekom Octopus OpenIT Appliance eingesetzt.
Da uns nur 2x2 Mbit DSL Leitungen zur verfügung stehen, wurde es vor einiger Zeit so konfiguriert, dass alle Clients im Netzwerk über eine Leitung gehen, der Server(inkl. Appliance) und Uploadloadegschichten über die andere.
Vorher hat jeder Client seine Mails selbst abgerufen und verschickt. Jetzt habe ich es so konfiguriert, dass ich auf der Appliance Konten angelegt habe, und dort die 1&1 Logindaten für die Mailkonten hinterlegt habe.
D.h. das jetzt die Appliance über ihre eigene Leitung die Mails abholt/verschickt und über das Intranet an die Clients verteilt, was auch relativ gut zu funktionieren scheint.

Nun zum Problem:

Ich bekomme täglich mehrere Mails mit dem Titel "Delayed Mail (still being retried)" bzw "Undelivered Mail Returned to Sender".

Als Meldung steht in der Mail:

Reporting-MTA: dns; LinuxServer.firma.loc
X-Postfix-Queue-ID: 7EA177E09
X-Postfix-Sender: rfc822; root@LinuxServer.firma.loc
Arrival-Date: Thu, 29 Dec 2011 03:37:39 +0100 (CET)

Final-Recipient: rfc822; ch@firma.com
Action: failed
Status: 4.0.0
Diagnostic-Code: X-Postfix; host smtp.1und1.de[212.227.15.167] said: 421
invalid sender domain 'LinuxServer.firma.loc' (misconfigured dns?) (in
reply to MAIL FROM command)



// Firmenname durch 'firma' ersetzt


Was ich online dazu gefunden habe ist, dass hier bei einigen Empfängern wohl ein Reverse DNS Lookup gemacht wird
und, da die Absenderdomain anscheinend der lokale Name unserer Appliance ist ( root@LinuxServer.firma.loc ), es hier zu einem Fehler kommt.

Ich habe schon einmal versucht, die lokale domain der Appliance auf die unserer 1&1 Domain zu ändern (firma.com), jedoch kamen dann interne Mails nicht mehr an...

Eigentlich sind wir uns auch ziemlich sicher, dass alle Mails ankommen. Zumindest gab es noch keine konkreten Fall wo eine Mail erwartet wurde und nicht ankam, aber die Meldungen lassen mir keine Ruhe ;)

Kann mir jemand dabei helfen? Habe schon einige Stunden im Netz gesucht und nichts gefunden


Grüße
Christian
Mitglied: Luie86
03.01.2012 um 09:45 Uhr
Hallo,

änder doch einfach den lokalen Name der Appliance.
Habe ich bei unserem MTA auch gemacht und dann funktioniert es.
Achja und einen PTR solltest du auch noch anlegen lassen

Gruß Daniel
Bitte warten ..
Mitglied: xennor
03.01.2012 um 10:03 Uhr
Hey, wie bereits geschrieben, habe ich die Appliance schon einmal wie unsere Domain genannt. Versand und Empfang von externen Mails ist damit kein Problem, jedoch kommen die internen nicht mehr bzw erst sehr sehr spät an.
Bitte warten ..
Mitglied: Luie86
03.01.2012 um 10:56 Uhr
Re,

sorry dachte das sind bei dir vielleicht auch 2. Einstellungen.

Wo hängen denn dann deine Mails wenn du die Appliance umbennenst?
Normalerweise müssten die ja dann über deinen Smarthost (1un1) rausgeschickt werden.
Bitte warten ..
Mitglied: xennor
04.01.2012 um 08:37 Uhr
Die bleiben in der Appliance hängen.

Eigentlich läuft es so:

Clients senden die Mails zur Appliance
Appliance dann zum Smarthost

Der Empfang läuft genau andersrum
Bitte warten ..
Mitglied: Luie86
04.01.2012 um 09:50 Uhr
Zitat von xennor:
Clients senden die Mails zur Appliance
Appliance dann zum Smarthost

Dachte ich mir schon fast
Hast du in der Appliance die Möglichkeit eine Art "Standard-Smarthost" einzurichten der
sozusagen immer zum rausschicken genutzt wird?
Bitte warten ..
Mitglied: xennor
04.01.2012 um 11:13 Uhr
Joar, habe in der SMTP-Basiskonfiguration beim Sendemodus den Haken bei "Betrieb nur im Weiterleitungsmodus" gesetzt und dort die Daten angegeben.
Bitte warten ..
Mitglied: Luie86
04.01.2012 um 17:17 Uhr
Ok, wenn du den Namen änderst, was für einen Fehler bekommst du dann beim Mailversand?
Versucht die Appliance dann die Mail´s lokal zuzustellen und findet die MBoxen nicht?
Bitte warten ..
Ähnliche Inhalte
Entwicklung
Wordpress E-Mail Funktion - 421 invalid sender domain
Frage von BleifussEntwicklung5 Kommentare

Hallo, ich verwende Wordpress mit dem Plugin WP-Mail-SMTP. Ich habe ein bestehendes SMTP Postfach bei 1und1. Beim versenden einer ...

Windows Netzwerk
Software meldet "can not open port"
Frage von crack24Windows Netzwerk3 Kommentare

Hallo, ich habe hier eine Zeiterfassungsoftware mit 3 Terminals laufen. Ein Terminal wurde jetzt an einen anderen Platz gesetzt ...

Exchange Server
Senden mit Domain eines anderen Mail-Servers
Frage von JimPietExchange Server2 Kommentare

Moin, die User, die wir über Exchange 2010 mit Emails versorgen haben alle das Format "name@abteilung.domain.de". Es gibt aber ...

Windows Netzwerk
DNS - Weiterleitung zu DNS-Server in anderer Domain
gelöst Frage von SchauerWindows Netzwerk7 Kommentare

Hallo liebe Admins. Ich stehe vor einem Problem mit dem ich mich jetzt mitunter auch auf dieser Seite beschäftigt ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 1 TagLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Batch & Shell
Meltdown Microsoft Prüf Script - .zip Datei leider leer
gelöst Frage von MasterBlaster88Batch & Shell13 Kommentare

Hallo zusammen, ich patche gerade unsere Windows Server bzgl. der Meltdown Lücke. Patch vorhanden, Reg Keys gesetzt Um das ...

Batch & Shell
Shell-Skript - Syntax error: Unterminated quoted string
Frage von newit1Batch & Shell13 Kommentare

Hallo Ich schreibe ein Skript das eine CSV-Datei in eine mySQL Datenbank schieben soll. Bekomme nach start des Skrips ...

E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Windows Server
DNS Forwarding an andere Domäne
Frage von detox91Windows Server9 Kommentare

Hallo, für Testzwecke haben wir bei uns eine zweite Windows Domäne (B.local) aufgebaut, welche komplett unabhängig und isoliert der ...