Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ODBC Datenbank-Verbindung geht zumindest kurzzeitig verloren

Frage Microsoft Windows 7

Mitglied: fabs07

fabs07 (Level 1) - Jetzt verbinden

16.12.2013 um 20:00 Uhr, 1923 Aufrufe, 3 Kommentare

Hallo,

folgendes Szenario:
- Mini-Netzwerk mit Win7 64bit Rechnern, die alle an einem T-COM Router angeschlossen sind und der DHCP aktiviert hat
- eingesetzt wird eine Sybase Anywhere Version 8 auf einem der Rechner
- Rechner wurden alle getauscht (alt XP - neu Win7 64bit)
- seit diesem Tausch geht die ODBC-Verbindung vom Client zur DB verloren, irgendwelche Abfragen an die DB werden mit 'keine Verbindung zur Datenbank' bescheinigt
(meist nach 10-30 Minuten Inaktivität aber auch schon mal mitten drin)
- nach einem neustart der Anwendung (damit neue DB-Verbindung) geht es wieder

Was ich schon geprüft/geändert habe:
- es sind alle neuen Rechner, aber nie gleichzeitig alle betroffen: spricht für den Client als Problemquelle
- am DB-Server die offenen Verbindungen geprüft: die Verbindung ist am Server noch aufgeführt, die Trennung wurde also vom Client verursacht
- im Server und Client Energie sparen im Netzwerkadapter abgeschaltet

Kennt jemand dieses Problem?

Meine Vermutung geht nun dahin, dass der Netzwerkadapter zumindest kurzzeitig die Netzwerk-Verbindung verliert, dann aber gleich wieder aufbaut, so dass es der Benutzer nicht wirklich merkt. Aber die ODBC-Verbindung ist halt dennoch futsch.
Oder dass der T-Com Router das Problem ist und da irgendwas verursacht.
Wie könnte ich das denn testen? Welches Tool checkt, dass der Netzwerkadapter kurz mal weg ist?

Danke
Fabs
Mitglied: wiesi200
16.12.2013 um 20:03 Uhr
Hallo,

Ich hatte mal auch bei der Umstellung von XP zu Win7 so ein Problem mit ODBC.
Das hing mit der Namensauflösung zusammen. Trag mal beim ODBC Connector die IP des Servers ein, falls es nicht schon so ist. Und probiert mal.
Bitte warten ..
Mitglied: fabs07
16.12.2013 um 20:09 Uhr
Danke für den schnellen Tip. Werde ich gleich morgen ausprobieren!
Fabian
Bitte warten ..
Mitglied: fabs07
19.12.2013 um 10:06 Uhr
Hat leider nicht geholfen. Der Client verliert weiterhin irgendwann die Verbindung.
Fabian
Bitte warten ..
Neuester Wissensbeitrag
Microsoft Office

MS Office Excel - Formel wird angezeigt, aber nicht berechneter Wert!

Tipp von holli.zimmi zum Thema Microsoft Office ...

Ähnliche Inhalte
Microsoft Office
Access DB: ODBC-Verbindung zu Datenbank fehlgeschlagen (2)

Frage von potshock zum Thema Microsoft Office ...

Visual Studio
gelöst C-Sharp MVVM DataContext geht verloren (1)

Frage von mayho33 zum Thema Visual Studio ...

Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (15)

Frage von Winuser zum Thema Hyper-V ...

Windows Server
gelöst Rechte als Admin vergeben - Zugriff verweigert (14)

Frage von Ghost108 zum Thema Windows Server ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (12)

Frage von ProfessorZ zum Thema Router & Routing ...