Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Officeprodukte starten stark verzögert. Terminalserver 2008

Frage Microsoft Windows Server

Mitglied: mbrkmann

mbrkmann (Level 1) - Jetzt verbinden

13.01.2011 um 12:05 Uhr, 8962 Aufrufe, 11 Kommentare

Ein "Hallo" in die Runde.
Mein erster Post hier. Hoffe ihr könnt mir helfen.
Da ich nicht sicher bin wo die Ursache liegt....weiss ich auch net genau ob ich das richtige Themengebiet erwischt habe

Struktur:

AD - Server 2008 SP2
1 Server (AD Kontroller, Fileserver, Exchange)
1 Terminalserver

Alle User arbeiten über RDP auf dem Termserver.


Problem:

Bei vielen unserer User startet Office (Excel, Word) nur extrem langsam. Ich schätze mal 1-2 Minuten braucht jedes der Programme zum ersten Strart.
Es spielt keine Rolle ob man eine Datei öffnet oder eine leere Mappe bzw leeres Blatt.
Schliesst man das Dokument und lässt das Programm offen, lässt sich alles mit normaler geschwindigkeit öffnen. Das Prolem ist wohl User bzw Profilbezogen. Es spielt keine Rolle an welchem Rechner ich das Profil öffne, immer das gleiche Spiel.

Anfangs waren nur neue User betroffen. Nach dem Jahreswechseln betrifft das Problem nun aber eine deutlich größere Gruppe von Benutzern.

http://www.administrator.de/index.php?content=156818

Normal.dot schliesse ich mal aus, tritt ja auch bei Excel auf.
Drucker vielleicht. Bei uns ist die automatische Drucker "weiterleitung" (an den wts) aktiv und vermutlich sind nicht alle treiber der lokalen drucker auch auf dem term server installiert.

Allerdings verstehe ich den Zusammenhang mit den User dann nicht. Zuerst nur die neuen Profile und jetzt viele?
An den Druckern hat sich ja sonst nicht geändert.

Mein erster Versuch wäre die automatische Druckerweiterleitung rauszunehmen. Treiber für alle festeingerichteten Drucker sind ja logischerweise vorhanden.

Würdet ihr dem zustimmen oder hat noch jemand eine andere Idee?

könnte es was mit Lizenzen zu tun haben?

Mit freundlichen Grüßen ...und vielen Dank
Mitglied: St-Andreas
13.01.2011 um 12:14 Uhr
AddIns für Office deaktieren (Word/Excel ohne AddIns mal aurufen, näheres dazu unter google.de)

Das wäre mein erstes Ansatz.
Bitte warten ..
Mitglied: mbrkmann
13.01.2011 um 12:27 Uhr
Danke

Ich habs mir grade angeschaut. Es sind keine Addins geladen und/ oder installiert.

Außerdem gibt es ja eine deutliche Änderung...vor dem Jahreswechel waren ja weniger Accounts betroffen.
Meiner als Bsp. war bisher verschont. Seit dem Jahreswechsel aber bin ich auch betroffen und ich glaube kaum das plötzlich 15 User Add-Inns benutzen, die es vorher nicht getan haben.

Wobei sich "leider" auch an meinen Druckern nichts geändert hat.
Bitte warten ..
Mitglied: geTuemII
13.01.2011 um 13:43 Uhr
Hallo mbrkmann,

zunächst mal herzlich willkommen hier.

1. normal.dot:
Ich halte es nicht wirklich für ein Ausschlußkriterium, daß auch Excel betroffen ist, schließlich gibt es auch für Execl (und alle anderen Office-Programme) Vorlagedateien. Allerdings halte ich diese Ursache für wenig wahrscheinlich.

2. Drucker:
Office macht eine Druckeranfage wegen der richtigen Darstellung der Seitenvoransicht. Um das zu testen, sollte es reichen, einen lokalen Drucker des TS als Standarddrucker zu setzen und Office danach erstmalig in dieser TS-Session zu öffnen.

Weitere Ideen:
Sieh dir mal die Speicherorte in den jeweiligen Offie-Programm-Optionen an. Irgendwas, daß einen Netzwerkzugriff beim Start erklären würde? Hast Du sonst irgendwelche Netzwerkprobleme? Und ganz schräg: in letzter Zeit hat das löschen der Temporary Internet Files gegen die schrägsten Fehlersymptome geholfen, auch und vorrangig gegen solche, die zunächst nicht wirklich was mit IE zu tun hatten.

HTH geTuemII
Bitte warten ..
Mitglied: Ausserwoeger
13.01.2011 um 14:11 Uhr
Wieviel Hauptspeicher hat den dein Terminalserver ? Ist er 32 bit oder 64 bit ?

Beim ersten Start lädt der Server die benötigten daten für exel word usw. in den Hauptspeicher oder wenn keiner da ist swapt er auf die Festplatte. Wenn du zu wenig hast kann es sein das der start von den Programmen für alle langsam ist. Wieviel user arbeiten den auf dem Server ?

Je höher die belastung des Servers umso langsamer wird er.

LG Andreas Ausserwöger
Bitte warten ..
Mitglied: mbrkmann
13.01.2011 um 14:19 Uhr
hmm

ok, ich werde das alles mal testen und morgen berichten.
muss jetzt zur ner Aussenstelle (bluescreen beim betriebsleiter = große panik :D ).

zu 2.
Ja, es wird einen Netzzugriff geben. Alle Daten liegen ja auf dem AD-Kontroller/ Fileserver und dorthin will der WTS auch Standartm. speichern.
Aber müssten dann nicht alle Accounts betroffen sein?

naja, wie gesagt
ich berichte morgen ;)

Speicher WTS als auch DC -> 16 GB

ca. 30 User
Rund 10 User per VPN von Zweigestellen

..ich schätze Speicher ist nicht das Problem!



Danke schhon mal für die Hilfe!
Bitte warten ..
Mitglied: Ausserwoeger
13.01.2011 um 14:30 Uhr
Jo 16 GB Ram sollten schon reichen bei 30 usern. Und wie siehts mit der Swap datei aus is die von der grösse her richtig eingestellt?

Wenn das nicht bei allen ist gibt es irgendwelche unterschiede zwischen den usern so das problem auftauscht und wo nicht ? Hast du Roaming Profiles für deine user eingestellt ??

LG Andreas Ausserwöger
Bitte warten ..
Mitglied: geTuemII
13.01.2011 um 15:03 Uhr
zu 2.
Ja, es wird einen Netzzugriff geben. Alle Daten liegen ja auf dem AD-Kontroller/ Fileserver und dorthin will der WTS auch
Standartm. speichern.
Aber müssten dann nicht alle Accounts betroffen sein?

Du hast mich mißverstanden. Ich meinte, ob in den Optionen was drinsteht, das einen Netzwerkzugriff beim Start erklären würde. Also Benutzervorlagen, Gruppenvorlagen, Wiederherstellungsdateien usw. die auf einem anderen Server liegen. Achte dabei auch auf evtl. umgeleitete Eigene Dateien o.ä.

geTuemII
Bitte warten ..
Mitglied: mbrkmann
14.01.2011 um 07:56 Uhr
guten morgen.

also vielleicht sollte ich auch noch erwähnen das ich in der Thematik sicher noch Lernbedarf habe ;)

Muss mich dann auch gleich verbessern ....
Wenn der User sich am WTS anmeldet und zb. sein Word startet stehen unter
Extras -> Optionen -> Specherort fürDateien nur c:\ bzw. d:\
also geht das wohl alles lokal auf den WTS?!

Wenn ich Word oder Excel einmal gestartet habe und nur das Dokument bzw die leere Vorlage schliesse, Word also geöffnet bleibt. Geht alles im normalen Tempo, egal was ich, von wo öffne.

Server01 = DC

In der Profilen auf dem DC gibt es einen neuen Basisordner
\\server01\user\XXX

ein Terminaldienst Benutzerprofil
\\server01\windvsw1\profiles\xxxx

und ein Terminaldienst Basisordner
\\server01\windvsw1\userdirs\xxxx

ein Unterschied zwischen den Profilen ist mir nicht bekannt. Bisher war es auch so,
wenn ich ein Profil, wo das Problem nicht auftritt, kopiere und daraus einen neuen User mache.
Hat der neue User trotzdem das Problem.

Auch an meinem Profil hat sich nichts geändert.

Ich möchte noch mal auf die Lizenzen zurück kommen.
Die Struktur wurde von einem Dienstleister installiert.
Danach sind einige Rechner hinzugekommen und wir brauchten neue Cals.

Erst später ist mir klar geworden das wir auch neue Office Lizenzen brauchen, wenn neue Rechner an den WTS angeschloßen werden. Wir dürften also im so ca. 10 Officelizenzen zu wenig haben.
Werden natürlich neue kaufen aber ...könnte das nicht vielleicht das Problem sein?
Bitte warten ..
Mitglied: Ausserwoeger
14.01.2011 um 09:00 Uhr
Nein die officelizenzen sind sicha nicht das Problem

Schon eher der Speicherort des Office auf C:

Wenn du weniger erfahrung mit Terminalservern hast würde ich dir raten die gruppenrichtlinien für Office zu installieren und eine Terminalserver Gruppenrichtlinie Anzulegen. Wenn du alle einstellungen durchgehst und den Server so Richtig einstellst könnte es sein das dein Problem von selbst verschwindet durch die Einstellungen.

LG Andreas Ausserwöger
Bitte warten ..
Mitglied: mbrkmann
18.01.2011 um 14:46 Uhr
hey ...

so ein wochenende vergangen. leider keine spontane selbstheilung :D

@Ausserwoeger

Danke aber es wiederstrebt mir einfach mal so gpo´s zu installieren - ohne wirklich zu verstehen wo das Problem liegt. Ich halte es mal in der Hinterhand - wenn ich keine andere Lösung finden kann.

Ich habe mal alle Speicherorte unter Word auf D: geändert. Leider gibt es keine Veränderung.

Was mir noch aufgefallen ist:

der Admin Account ist nicht betroffen.

Startet man Excel zum erstenmal - öffnet es sich, man sieht die Arbeitsmappe, kann aber nichts machen (Eieruhr)

Startet man Word - baut es sich erst nach 30-60 Sec. auf. Man sieht also das leere Blatt nicht bzw erst nach der Wartezeit. Ausserdem schliesst Word sich auch lnagsam. Also es gibt noch mal eine deutliche Wartezeit beim beenden.
Das ist bei Excel nicht so.

Powerpoint ist von dem Problem gar nicht betroffen!

Morgen Abend teste ich mal die Druckertheorie.

sonst noch Ideen? ^^
Bitte warten ..
Mitglied: Ausserwoeger
19.01.2011 um 09:07 Uhr
Bei den GPOs meinte ich nicht einfach einstellen sondern die einstellungen ausprobieren und schauen welche das Problem behebt.
Also die Regeln durchgehen.

LG Andreas Ausserwöger
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...