Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Open Suse 11.4 Plesk 10.2 Probleme mit Zeichensatz beim Apache

Frage Linux Apache Server

Mitglied: MaxTPayne

MaxTPayne (Level 1) - Jetzt verbinden

21.04.2011 um 17:30 Uhr, 6524 Aufrufe, 4 Kommentare

Hallo,

ich habe die Open Suse 11.4 installiert als minimalinstallation. Anschließend ist die aktuelle Version von Plesk mit dem Autoinstaller installiert worden.

Nun hab ich das Problem das meine Daten die im ISO Format vorliegen im UTF-8 Format aber ausgegeben werden. Über google hab ich schon Einträge bezüglich dem AddDefaultCharset gefunden. Leider wirkt keiner der Einträge in der httpd.conf oder mod_mime-defaults.conf.

Weiß einer evtl. wie man das umstellen kann?

Vielen Dank!

Gruß
Max
Mitglied: infowars
22.04.2011 um 09:57 Uhr
Hm, i stehe etwas auf dem Schlauch.
Welche Daten werden wo in UTF-8 ausgegeben ?
Im Browser ?
Bitte warten ..
Mitglied: MaxTPayne
23.04.2011 um 11:58 Uhr
Kurze Ergänzung. Wir haben die Daten von einem SUSE 11.2 auf einem SUSE 11.4 kopiert.

Meine Daten sind alle im ISO-8859-1 Format in der Datenbank. Wenn ich jetzt aber die Webseite aufrufe werden die Umlaute nicht korrekt dargestellt. Wenn ich im Firefox auf Ansicht -> Zeichenkodierung -> UTF-8 klicke wird alles korrekt angezeigt.

Daher versuche ich im Apache das AddDefaultCharset zu setzen.
Bitte warten ..
Mitglied: infowars
24.04.2011 um 09:44 Uhr
Sonst einfach im Quelltext

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">

in

<meta http-equiv="content-type" content="text/html; charset=UTF-8">

ändern. Oder umgekehrt.
Bitte warten ..
Mitglied: MaxTPayne
26.04.2011 um 13:15 Uhr
Damit wäre zwar die Anzeige in Ordnung gewesen aber leider nicht die Adminoberfläche. Hab jetzt den ganzen Server neu mit Debain installiert. Jetzt funktioniert es auch

Vielen Dank für deine Hilfe!

Gruß
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Installation Open xchange Plesk Onyx 17
gelöst Frage von educationUbuntu5 Kommentare

Hallo, Ist: VServer mit ‪Ubuntu 14 Was gemacht wurde: Tools & Einstellungen -> Anwendungen & Datenbanken -> Open xchange ...

Server
Probleme bei der Konfiguration von Apache mit IPv6
gelöst Frage von DarkShadowServer2 Kommentare

Hallo, ich möchte gerne meinen Apache Webserver, der auf einem Windows 7 Enterprise PC läuft, IPv6 kompatibel machen. Zu ...

Apache Server
Apache 2.2 und SSL Probleme auf Webserver
gelöst Frage von atomiqueApache Server16 Kommentare

Guten Abend zusammen! Es geht hier um meinen Webserver der unter Debian 7 und mit Apache 2.2 läuft. Um ...

Server
Plesk - Webmail
Frage von ZockervogelServer8 Kommentare

Hallo, ich habe mir, obwohl ich keine Ahnung habe, einen dedizierter Server geholt. Installiert habe ich mit Linux Plesk ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 24 MinutenVerschlüsselung & Zertifikate

Interessant SSH-Kommando in CMD.exe und PowerShell

Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement17 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...