Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Open Suse 11.4 Plesk 10.2 Probleme mit Zeichensatz beim Apache

Frage Linux Apache Server

Mitglied: MaxTPayne

MaxTPayne (Level 1) - Jetzt verbinden

21.04.2011 um 17:30 Uhr, 6503 Aufrufe, 4 Kommentare

Hallo,

ich habe die Open Suse 11.4 installiert als minimalinstallation. Anschließend ist die aktuelle Version von Plesk mit dem Autoinstaller installiert worden.

Nun hab ich das Problem das meine Daten die im ISO Format vorliegen im UTF-8 Format aber ausgegeben werden. Über google hab ich schon Einträge bezüglich dem AddDefaultCharset gefunden. Leider wirkt keiner der Einträge in der httpd.conf oder mod_mime-defaults.conf.

Weiß einer evtl. wie man das umstellen kann?

Vielen Dank!

Gruß
Max
Mitglied: infowars
22.04.2011 um 09:57 Uhr
Hm, i stehe etwas auf dem Schlauch.
Welche Daten werden wo in UTF-8 ausgegeben ?
Im Browser ?
Bitte warten ..
Mitglied: MaxTPayne
23.04.2011 um 11:58 Uhr
Kurze Ergänzung. Wir haben die Daten von einem SUSE 11.2 auf einem SUSE 11.4 kopiert.

Meine Daten sind alle im ISO-8859-1 Format in der Datenbank. Wenn ich jetzt aber die Webseite aufrufe werden die Umlaute nicht korrekt dargestellt. Wenn ich im Firefox auf Ansicht -> Zeichenkodierung -> UTF-8 klicke wird alles korrekt angezeigt.

Daher versuche ich im Apache das AddDefaultCharset zu setzen.
Bitte warten ..
Mitglied: infowars
24.04.2011 um 09:44 Uhr
Sonst einfach im Quelltext

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">

in

<meta http-equiv="content-type" content="text/html; charset=UTF-8">

ändern. Oder umgekehrt.
Bitte warten ..
Mitglied: MaxTPayne
26.04.2011 um 13:15 Uhr
Damit wäre zwar die Anzeige in Ordnung gewesen aber leider nicht die Adminoberfläche. Hab jetzt den ganzen Server neu mit Debain installiert. Jetzt funktioniert es auch

Vielen Dank für deine Hilfe!

Gruß
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows 10
gelöst Windows 10 Start-Probleme - Hilfe (10)

Frage von clragon zum Thema Windows 10 ...

Windows 10
10 Creators Update coming April 11 (1)

Link von BassFishFox zum Thema Windows 10 ...

Ubuntu
gelöst Installation Open xchange Plesk Onyx 17 (4)

Frage von education zum Thema Ubuntu ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Virtualisierung
Von ESXi migrieren auf HyperV (SBS11) (23)

Frage von PixL86 zum Thema Virtualisierung ...

Netzwerke
gelöst Standartgateway für Clients (21)

Frage von itsk-robert zum Thema Netzwerke ...

Windows Server
Server-Ersteinrichtung für Dummies (20)

Frage von Olf1980 zum Thema Windows Server ...

Firewall
Welche Firewall ? (18)

Frage von Cyberurmel zum Thema Firewall ...