Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Open VPN macht VPN Verbindung , aber kein Ping auf die Maschinen dann möglich

Frage Netzwerke Netzwerkmanagement

Mitglied: 116480

116480 (Level 2)

26.01.2015, aktualisiert 15:41 Uhr, 3346 Aufrufe, 8 Kommentare

Hallo,

ich habe folgendes Problem. Logge ich als Administrator auf einen Client , dann kommt der OPENVPN Zugriff zustande ohne Fehler .
Logge ich als User ein kommt die Verbindung zustande, aber es ist kein Ping auf die Maschinen möglich.

Mon Jan 26 12:13:38 2015 TAP-WIN32 device [LAN-Verbindung 3] opened: \\.\Global\{659C3770-D3AA-4F17-B32E-B486B6A2B8D8}.tap
Mon Jan 26 12:13:38 2015 TAP-Windows Driver Version 9.21
Mon Jan 26 12:13:38 2015 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.242.2.10/255.255.255.252 on interface {659C3770-D3AA-4F17-B32E-B486B6A2B8D8} [DHCP-serv: 10.242.2.9, lease-time: 31536000]
Mon Jan 26 12:13:38 2015 NOTE: FlushIpNetTable failed on interface [23] {659C3770-D3AA-4F17-B32E-B486B6A2B8D8} (status=5) : Zugriff verweigert
Mon Jan 26 12:13:42 2015 TEST ROUTES: 3/3 succeeded len=3 ret=1 a=0 u/d=up
Mon Jan 26 12:13:42 2015 MANAGEMENT: >STATE:1422270822,ADD_ROUTES,,,
Mon Jan 26 12:13:42 2015 C:\Windows\system32\route.exe ADD 62.2.200.230 MASK 255.255.255.255 172.23.54.1
Mon Jan 26 12:13:42 2015 ROUTE: route addition failed using CreateIpForwardEntry: Zugriff verweigert [status=5 if_index=10]
Mon Jan 26 12:13:42 2015 Route addition via IPAPI failed [adaptive]
Mon Jan 26 12:13:42 2015 Route addition fallback to route.exe
Mon Jan 26 12:13:42 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Mon Jan 26 12:13:42 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Mon Jan 26 12:13:42 2015 C:\Windows\system32\route.exe ADD 10.242.2.1 MASK 255.255.255.255 10.242.2.9
Mon Jan 26 12:13:42 2015 ROUTE: route addition failed using CreateIpForwardEntry: Zugriff verweigert [status=5 if_index=23]
Mon Jan 26 12:13:42 2015 Route addition via IPAPI failed [adaptive]
Mon Jan 26 12:13:42 2015 Route addition fallback to route.exe
Mon Jan 26 12:13:42 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Mon Jan 26 12:13:42 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Mon Jan 26 12:13:42 2015 C:\Windows\system32\route.exe ADD 10.63.80.0 MASK 255.255.254.0 10.242.2.9
Mon Jan 26 12:13:42 2015 ROUTE: route addition failed using CreateIpForwardEntry: Zugriff verweigert [status=5 if_index=23]
Mon Jan 26 12:13:42 2015 Route addition via IPAPI failed [adaptive]
Mon Jan 26 12:13:42 2015 Route addition fallback to route.exe
Mon Jan 26 12:13:42 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Mon Jan 26 12:13:42 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Mon Jan 26 12:13:42 2015 Initialization Sequence Completed
Mon Jan 26 12:13:42 2015 MANAGEMENT: >STATE:1422270822,CONNECTED,SUCCESS,10.242.2.10,62.2.200.230
Es kommten verschiedene Fehler.
Diese Lösung hat leider nicht funktioniert http://serverfault.com/questions/326619/vpn-cant-connect-properly
Auch habe ich "Als Administrator ausführen" eingestellt. Aber als normaler User kommen eben die FEhler.
Ich habe auch Testhalber eine ältere Version von Open VPN installiert, da es ja früher lief. Fehler kam nun ohne Aenderung.

Gruss
Ralf
Mitglied: 114757
LÖSUNG 26.01.2015, aktualisiert um 15:41 Uhr
Ohne Administrator-Rechte kann der OpenVPN-Client in Windows keine Route setzen ! OpenVPN muss auf dem Client deshalb mit Adminrechten laufen...
Siehst du ja auch am Log:
ROUTE: route Addition failed using CreateIpForwardEntry: Zugriff verweigert 
ERROR: Windows route add command failed [adaptive]: returned error code 1
Gruß jodel32
Bitte warten ..
Mitglied: 116480
26.01.2015 um 13:40 Uhr
Hallo,

ja das ist genau das Problem. Ich habe wie oben beschrieben :
http://serverfault.com/questions/326619/vpn-cant-connect-properly

Die Open-vpngui.exe bei Kompatibilität mit "Ausführen als Administrator" angewählt. Aber trotzdem lauft es nicht !

Gruss
Ralf
Bitte warten ..
Mitglied: bigzorro
LÖSUNG 26.01.2015, aktualisiert um 15:41 Uhr
Wie soll ein Nicht-Administrator ein Programm als Admin ausführen?

Wer VPN nutzen soll, muss da als lokaler Admin angelegt sein.
Bitte warten ..
Mitglied: 116480
26.01.2015 um 13:51 Uhr
Hallo,

vorher ging es immer. Unter c:\Programme (X86\Sophos\Sophos SSL VPN Client\bin\openvpn-gui.exe Rechte Maustaste \ Eigenschaften \ Kompaibilität "Programm als Administrator" ausführen einstellen.

Gruss
Ralf
Bitte warten ..
Mitglied: bigzorro
LÖSUNG 26.01.2015, aktualisiert um 15:41 Uhr
Es muss dafür gesorgt werden dass das Programm (evtl. durch ein Startscript) von einer Instanz mit Adminrechten gestartet wird.

Gerade heute hatte ich einen Fall (Benutzer war sogar Admin) indem das Programm automatisch gestartet wurde, durch die fehlende Benutzerkontensteuerungsabfrage aber gleiches Problem.

Lasse den Nutzer das Programm jetzt manuell starten, Abfrage kommt, ja klicken - geht...
Bitte warten ..
Mitglied: 114757
LÖSUNG 26.01.2015, aktualisiert um 15:41 Uhr
Zitat von 116480:
vorher ging es immer. Unter c:\Programme (X86\Sophos\Sophos SSL VPN Client\bin\openvpn-gui.exe Rechte Maustaste \ Eigenschaften \
Kompaibilität "Programm als Administrator" ausführen einstellen.
Wenn der User keine Rechte hat Programme als Administrator auszuführen geht das nicht ...
Es müsste ja dann entweder eine Eingabeaufforderung zur Eingabe von Admin-Credentials kommen oder eine UAC-Box (die, falls der User Admin-rechte auf dem Client besitzt) bestätigt werden muss.)
Wenn du das über eine Verknüpfung machst stelle das auch in der Verknüpfung ein !
Bitte warten ..
Mitglied: 116480
26.01.2015 um 14:07 Uhr
Hallo,

ok. Das ist schlecht. Dann müsste jeder Adminrechte erhalten. Wir haben einen Pool. Also das sind Xendesktop Virtuelle Maschinen, da ist noch ein ältere Open VPN Client installiert. Der lauft sogar komplett ohne Adminrechte.

Gruss
Ralf
Bitte warten ..
Mitglied: 116480
26.01.2015 um 15:41 Uhr
Hallo,

ja danke. Habe nun mal die neuste Version installiert und alle Gruppen die bei uns OpenVPN verwenden als Lokal Admin auf den Xendesktop Pool berechtigt.
Geht nun.

Gruss
Ralf
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Fritzbox Fernzugang VPN ping nicht möglich (16)

Frage von Yannosch zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Keine wlan verbindung mit bestimmtes netzwerk möglich (4)

Frage von VerruecktesPferd zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (44)

Frage von sabines zum Thema Internet ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

LAN, WAN, Wireless
gelöst Eintägige Netzwerkunterbrechung trotz Backupleitung (15)

Frage von iAmbricksta zum Thema LAN, WAN, Wireless ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (13)

Frage von aschmid zum Thema Router & Routing ...