Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Openfire 3.7.1 AD-Anbindung

Frage Internet

Mitglied: Chonta

Chonta (Level 3) - Jetzt verbinden

04.06.2012, aktualisiert 17:48 Uhr, 5545 Aufrufe, 7 Kommentare

Problem bei AD Integration

Hallo,

hier im Forum bin ich auf einen Tip zur ersetzung von Skype im Firmenumfeld gestoßen.
Als Alternative für eine selbst gehostete Lösung wurde Openfire genannt.

Nun habe ich Openfire installiert, aber die AD-Anbindung haut nicht hin.
Ich habe es endlich soweit, das ein User Mapping funktioniert (juhu), das Problem ist, er findet nur eine Handvoll benutzer von 60.

UserFilter: (&(memberOf=CN=GRUPPENNAME,OU=OU,DC=DOMAIN,DC=NAME)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))

Der test verbindet gut und zeigt auch einen Benutzer der passt, aber insgesammt werden nur 8 Benutzerkonten gefunden.
Die Gruppe selber hat 174 Benutzer und 60 Aktive Benutzer.
Beim Gruppensetup ist (&(distinguishedName=CN=GGRUPPENNAME,OU=OU,DC=DOMAIN,DC=NAME))

Der Secure Port für die Adminconsole geht auch nicht, aber ein Problem nach dem anderen.

Gruß

Chonta
Mitglied: catachan
04.06.2012 um 19:51 Uhr
Hi

kannst du den LDAP String mal bei einer "normalen" AD Abfrage mittels Active Directory Users and Computers => Saved Query oder per dsquery machen ? Kommt das zu dem gleichen Ergebnis ?

Ist bei den anderen Konten die nicht gefunden werden was spezielles ? Umlaute, Leerzeichen etc.. im Anmeldenamen ?

LG
Bitte warten ..
Mitglied: Chonta
05.06.2012, aktualisiert um 09:48 Uhr
Hallo,

das AD zeigt genau das was erwartet wird an. Alle Benutzer.
Ich habe auch wie bei der Eingabe im AD bei gespeicherte Abfragen das (& wegzulassen (wird im AD automatisch hinzugefügt), aber Problem bleibt.

Es wird nur eine Handvoll Benutzer angezeig...

Gruß

Chonta

PS: Nachtrag:

System ist ein Debian 6 mit installiertem Samba 3.5, welches mit Winbind gegen das AD autentifiziert (geht sehr gut) Im Moment ist das ganze nur eine TestVM.
Bitte warten ..
Mitglied: catachan
05.06.2012 um 10:04 Uhr
Hi

hast du schon versucht ein Debugging aufzudrehen ?

LG
Bitte warten ..
Mitglied: Chonta
05.06.2012, aktualisiert um 11:03 Uhr
Hallo,

und wo sollte ich ansetzen?
Da das Program noch im Installationsprozess ist gibt es nicht wirklich logfiles und ne Option, das mir das Tool mal sagt was es macht und was schief geht ...

Wie es ausschaut kommt Openfire mit den Filtern nicht klar. Wenn ich einen Filter mache wie:

(&(objectCategory=person)(objectClass=user)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))
Der alst alle Aktiven Benutzer vom AD anzeigen soll, zeigt de rmir dennoch deaktivierte Benutzer.
Mit der Verschachetelung von Gruppen kommt der auch nicht klar und mit memberOf anscheinend auch nicht. Ich habe eine Neue Gruppe angelegt dann meine Hauptgruppe hinzugefügt, die Gruppe wurde dann angezeigt.
Gruppe entfernt und alle Benutzer direkt hinzugefügt > Openfire hat nix mehr gefunden??
Kurze Zeit später hat er mir wide rnur die Handvoll Benutzer angezeigt.
(!(userAccountControl:1.2.840.113556.1.4.803:=2)) scheint Openfire nicht zu mögen oder es wird ignoriert, denn es werden auch deaktivierte Benutzer angezeigt.
Aber (userAccountControl:1.2.840.113556.1.4.803:=2) zeigt dann nur noch deaktivierte Benutzer...
Wäre interesannt gewesen das Tool zu verwenden, aber solange die Auflösung vom LDAP nicht funktioniert nicht wirklich hilfreich.

Gruß

Chonta
Bitte warten ..
Mitglied: ColdZero89
25.07.2012, aktualisiert um 11:16 Uhr
Moin,

hast du Gruppen in Gruppen? Das kann Openfire so überhaupt nicht ab x) weiß nicht ob dies mittlerweile gefixed haben, aber in Version 3.6 konnte Openfire Gruppen in Gruppen nicht ab und hat die benutzer einfach nicht angezeigt.

Wir haben dann eine Gruppe Erstellt und dort alle Mitarbeiter reingepackt. Zack wurden auch alle angezeigt.

Ich schau - sofern ich dran denk - heute abend mal mein altes Script zur Abfrage des ADs durch, gucken wie ich diese gestaltet habe.

Gruß Zero
Bitte warten ..
Mitglied: Chonta
25.07.2012 um 12:28 Uhr
Hallo,

ich hatte extra eine eigene Gruppe eingerichtet.
Aber im Moment liegt das Projekt auf Eis

Gruß

Chonta
Bitte warten ..
Mitglied: ColdZero89
25.07.2012 um 16:10 Uhr
Moin,

wenn du auf der Weboberfläche dann in die Gruppenverwaltung gehst musst du noch eisntellen das ALLE diese sehen dürfen.
Dann sollte eigentlich alles Chiko sein und funktionieren.

Ich guck nachhermal irgendwo hab ich meine Doku sicherlich und stell dir meine openfire config mal rein, dann kannste dir das angucken.

Gruß zero
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Passwort Manager mit AD anbindung (6)

Frage von dakoerry zum Thema Windows Server ...

Windows Server
Schemaerweiterung - Office 365 - Exchange Online mit lokalem AD

Frage von chb1982 zum Thema Windows Server ...

Windows Server
Windows Server 2012 R2 Benutzerkonto für Zugriff auf AD Benutzer (1)

Frage von JulianOhm zum Thema Windows Server ...

Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...