Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenSUSE MySQL oder Perl Fehler

Frage Linux Suse

Mitglied: narthan

narthan (Level 1) - Jetzt verbinden

21.03.2013 um 13:44 Uhr, 2868 Aufrufe, 16 Kommentare, 5 Danke

Hallo,

ich habe eine VM mit KDE openSUSE 12.1 und wollt aus Testgründen ein Ticketsystem installieren. In dem Installationspaket waren MySQL und Perl enthalten, allerdings kommen bei der Installation via Terminal ständig Fehler, meist der gleiche:


01.
Writing Makefile for DBI 
02.
  TIMB/DBI-1.623.tar.gz 
03.
  make -- NOT OK 
04.
'YAML' not installed, will not store persistent state
Das trifft fast immer auf, wenn ich mit Hilfe von Perl ein Modul installieren will, z.B. DNS, DBI, DBD::mysql etc.
Da ich von Linux keine Ahnung hab, wäre ich über eine hilfreiche Antwort sehr dankbar

Grüß,
narthan
Mitglied: flow.ryan
21.03.2013 um 15:53 Uhr
Hallo,

scheint mir, als würde dir 'make' fehlen.
Hast du das installiert?

Gruß,
Florian
Bitte warten ..
Mitglied: hmarkus
21.03.2013 um 16:46 Uhr
Hallo,

wie installierst Du das Paket? Wo hast Du es her?

Wenn Du aus dem Repository von Suse installierst, dann sollte der Paketmanager die Abhängigkeiten auflösen und die eventuell fehlenden Pakete in der richtigen Reihenfolge installieren.

Welches Ticketsystem ist es?

Beschreib mal bitte genau Dein vorgehen.

Markus
Bitte warten ..
Mitglied: narthan
22.03.2013 um 08:08 Uhr
Hallo,

kann ich mit einem Befehl überprüfen ob "make" installiert ist? Ich bin mir ehrlich gesagt nicht so sicher weil ich noch 2 andere Projekte nebenbei laufen habe.

Ich hab das Paket heruntergeladen und installiere es über das Terminal im root Modus. Das Ticketsystem ist von OTRS.
Also ich habe die VM aufgesetzt und openSUSE 12.1 installiert. Dann hab ich die Internet Verbindung hergestellt und erstmal Updates laufen lassen über SUSE. Dann das entsprechende OTRS Paket von der Homepage für SUSE geladen und dessen Installationsbeschreibung (http://doc.otrs.org/3.2/en/html/) befolgt.

Grüße,
narthan
Bitte warten ..
Mitglied: hmarkus
22.03.2013 um 08:11 Uhr
Guten Morgen,
Zitat von narthan:
Hallo,

kann ich mit einem Befehl überprüfen ob "make" installiert ist?
make -v
Markus
Bitte warten ..
Mitglied: hmarkus
22.03.2013, aktualisiert um 08:32 Uhr
Also, auf der Website findet man folgendes
For Perl, we recommend using at least version 5.8.8. You will need some additional modules which can be installed either with the Perl shell and CPAN, or via the package manager of your operating system (rpm, yast, apt-get).
Außerdem werden mindestens 2GB RAM empfohlen.....

Die Perl-Version findest Du mit
perl -v
Module nachinstallieren geht mittels cpan. Erst die Shell aufrufen
perl -MCPAN -e shell
und dann kannst Du die Module installieren
install xxxx::xxxx
cpan installiert automatisch die Abhängigkeiten. Du kannst natürlich auch Yast verwenden. Leider sehe ich im Moment nicht, welche Module installiert werden müssen.
Hier die Tabelle mit den erforderlichen Modulen:
Tabelle 3.1. Die folgenden Perl-Module werden von OTRS benötigt.

Name Beschreibung
DBI Dieses Modul wird von OTRS für die Verbindung zum Datenbank-Backend benötigt.
DBD::mysql Modul zum Verbindungsaufbau zum MySQL-Datenbank-Backend (nur benötigt bei Verwendung von MySQL).
DBD::pg Modul zum Verbindungsaufbau zum PostgreSQL-Datenbank-Backend (nur benötigt bei Verwendung von PostgreSQL).
Digest::MD5 Ermöglicht die Verwendung des md5-Algorithmus.
CSS::Minifier Komprimiert eine CSS-Datei und schreibt das Ergebnis in eine andere Datei.
Crypt::PasswdMD5 Stellt MD5-basierte kryptographische Funktionen bereit.
MIME::Base64 Kodiert / dekodiert Zeichenketten in Base64, z. B. für E-Mail-Anhänge.
JavaScript:Minifier Komprimiert eine JavaScript-Datei und schreibt das Ergebnis in eine andere Datei.
Net::DNS Perl-Interface zum DNS-System.
LWP::UserAgent Verarbeitet HTTP-Anfragen.
Net::LDAP LDAP-Schnittstelle für Perl (nur benötigt, wenn LDAP verwendet wird).
GD Schnittstelle zur Gd Graphics Library. Wird nur benötigt, wenn das Statistikmodul von OTRS verwendet werden soll.
GD::Text, GD::Graph, GD::Graph::lines, GD::Text::Align Text- und Grafikwerkzeuge für die Benutzung zusammen mit der GD Graphics Library. Diese Komponenten werden nur benötigt, wenn das Statistikmodul von OTRS verwendet werden soll.
PDF::API2, Compress::Zlib

http://doc.otrs.org/3.0/de/html/manual-installation-of-otrs.html

Markus
Bitte warten ..
Mitglied: narthan
22.03.2013 um 08:30 Uhr
Hallo,

wow danke für die schnelle und ausführliche Antwort!
Sobald ich im Büro bin, werde ich mich gleich mal damit auseinandersetzen und mich dann wieder melden.
Perl hab ich eigentlich separat bereits installiert, aber ich bin mir gerade über die Version nicht sicher, und 2GB RAM ist vorhanden.
Die Tabelle mit den Modulen hatte ich auch, auch bereits versucht diese mittels MCPAN zu installieren, allerdings kam dann jedesmal dieser Fehler (wie im 1.Post angegeben) mit "make".

Gruß,
narthan
Bitte warten ..
Mitglied: hmarkus
22.03.2013 um 08:43 Uhr
Zitat von narthan:
...
vorhanden.
Die Tabelle mit den Modulen hatte ich auch, auch bereits versucht diese mittels MCPAN zu installieren, allerdings kam dann
jedesmal dieser Fehler (wie im 1.Post angegeben) mit "make".
Vermutlich solltest Du mal YAML installieren und es dann nochmal probieren.

Bitte checke die Perl-Version.

Markus
Bitte warten ..
Mitglied: narthan
22.03.2013 um 10:20 Uhr
Hallo,

also Perl hab ich 5.14.2 wenn ich "perl -v" eingebe.
Allerdings kommt, wenn ich "make -v" eingebe, folgende Meldung:

If 'make' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf make

Also muss ich 'make' nun installieren, dann YAML und dann die Module?

Gruß,
narthan
Bitte warten ..
Mitglied: hmarkus
22.03.2013 um 10:23 Uhr
Ja, also make solltest Du installieren, ich bin zwar nicht sicher, ob Perl darauf zugreift, aber es schadet nicht. Und mit YAML genauso.

Markus
Bitte warten ..
Mitglied: narthan
22.03.2013 um 13:36 Uhr
Hallo,

ich habe nun (endlich) die Installation und die Updates abgeschlossen. "make" ist installiert, allerdings kommt bei der Installation von YAML wieder der gleiche Fehler, auch wenn der Fehler diesmal deutlich später kam!

Fehler:

... 
Appending installation info to /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/perllocal.pod 
  MSCHWERN/ExtUtils-MakeMaker-6.64.tar.gz 
  make install  -- OK 
Running make for I/IN/INGY/YAML-LibYAML-0.41.tar.gz 
 
  CPAN.pm: Going to build I/IN/INGY/YAML-LibYAML-0.41.tar.gz 
 
Checking if your kit is complete... 
Looks good 
Prototype mismatch: sub main::prompt: none vs ($;$) at /usr/lib/perl5/5.14.2/ExtUtils/MakeMaker.pm line 220 
Writing Makefile for YAML::XS::LibYAML 
Writing MYMETA.yml and MYMETA.json 
Writing Makefile for YAML::LibYAML 
Writing MYMETA.yml and MYMETA.json 
cp lib/YAML/LibYAML.pm blib/lib/YAML/LibYAML.pm 
cp lib/YAML/XS.pm blib/lib/YAML/XS.pm 
make[1]: Entering directory `/root/.cpan/build/YAML-LibYAML-0.41-chzi9g/LibYAML' 
cp lib/YAML/XS/LibYAML.pm ../blib/lib/YAML/XS/LibYAML.pm 
cc -c  -I. -D_REENTRANT -D_GNU_SOURCE -DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -Wall -pipe   -DVERSION=\"\" -DXS_VERSION=\"\" -fPIC "-I/usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE"  -DHAVE_CONFIG_H api.c 
/bin/sh: cc: command not found 
make[1]: *** [api.o] Error 127 
make[1]: Leaving directory `/root/.cpan/build/YAML-LibYAML-0.41-chzi9g/LibYAML' 
make: *** [subdirs] Error 2 
  INGY/YAML-LibYAML-0.41.tar.gz 
  make -- NOT OK 
Running make test 
  Can't test without successful make 
Running make install 
  Make had returned bad status, install seems impossible
Also lag es wohl nicht nur an "make"... Wisst ihr vlt weiter?

Grüße (und schonmal schönes Wochenende),
narthan
Bitte warten ..
Mitglied: hmarkus
22.03.2013, aktualisiert um 14:40 Uhr
/bin/sh: cc: command not found

Du hast auch den gcc nicht installiert. Bei Suse ist es so, dass standardmäßig die Entwicklerwerkzeuge nicht installiert werden, die brauchst Du aber. Ich weiß nicht, ob die Installation des gcc reicht, oder ob dann sonst noch was fehlt. In diesem Thread Posting #2 hilft Dir wahrscheinlich weiter.

Markus
Bitte warten ..
Mitglied: narthan
25.03.2013 um 08:23 Uhr
Hallo,

genau nach dem Thread hatte ich es sogar installiert... :D
Dann gabs dabei wohl schon ein paar Fehler...ich lass die Installation nochmal laufen. Sonst versuch ich gcc mal so zu installieren und meld mich dann wieder.

Gruß,
narthan
Bitte warten ..
Mitglied: hmarkus
25.03.2013 um 08:32 Uhr
Zitat von narthan:
Hallo,

genau nach dem Thread hatte ich es sogar installiert... :D
Dann gabs dabei wohl schon ein paar Fehler...ich lass die Installation nochmal laufen. Sonst versuch ich gcc mal so zu
installieren und meld mich dann wieder.

Gruß,
narthan
Der gcc allein nutzt nix. Du musst die kompletten Entwicklungswerkzeuge (ich weiß nicht, wie das bei Suse heißt) installieren, sonst kann der gcc nicht arbeiten. Also es gehören die C/C++ Bibliotheken dazu, make, evtl. cmake usw.

Markus
Bitte warten ..
Mitglied: narthan
25.03.2013 um 09:40 Uhr
Hey , es hat geklappt! Vielen Dank Markus

Gruß,
narthan
Bitte warten ..
Mitglied: hmarkus
25.03.2013, aktualisiert um 10:14 Uhr
Zitat von narthan:
Hey , es hat geklappt! Vielen Dank Markus

Gruß,
narthan
Das ist erfreulich. Aber beschreib bitte mal was Du nun installiert hast und wie das bei Suse heißt, damit andere, die diesen Thread finden von der Lösung profitieren können.

Markus
Bitte warten ..
Mitglied: narthan
25.03.2013 um 10:22 Uhr
Ich habe den Befehl vom User martin_helm aus deinem Link

Zitat von hmarkus:
In diesem Thread http://forums.opensuse.org/english/get-technical-help-here/install-boot ... Posting #2 hilft Dir wahrscheinlich weiter.

also "zypper install -t pattern devel_basis" ausgeführt und dort wird eine Reihe von Paketen (gcc, make, binutils..etc.) automatisch installiert.


Gruß,
narthan
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
CMS
gelöst MySQL Import Access denied Fehler 1044 (1)

Frage von the-buccaneer zum Thema CMS ...

Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (34)

Frage von JayyyH zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...