Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenSUSE Routing

Frage Linux Suse

Mitglied: MisterExpulso

MisterExpulso (Level 1) - Jetzt verbinden

16.02.2012 um 21:29 Uhr, 3872 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe mir hier zu Testzwecken zwei virtuelle Netze in der VirtualBox aufgebaut.

Das erste Netz ist ein homogenes Windows Netzwerk:
Adaptername Virtualbox: windows (Internes Netz)
IP: 192.168.11.0 /24
Router: 192.168.11.2

Das zweite Netz ist ein homogenes Linux (openSUSE) Netzwerk (Internes Netz):
Adaptername Virtualbox: linux
IP: 192.168.111.0 /24
Router: 192.168.111.1 eth0

Die beiden Router sind über das Backbone-Netz (Internes Netzwerk) miteinander verbunden (192.168.254.0).
Dort hat
Router1 die IP: 192.168.254.11
Router2 die IP: 192.168.254.111 eth1

Ich habe auf dem Windows Router eine statische Route eingerichtet:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
192.168.111.0 255.255.255.0 192.168.254.11 192.168.254.11 1
Hier ist es auch kein Problem den Linux Router zu pingen.

Also müsste es auf dem Linux Router doch auch funktionieren:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
192.168.11.0 255.255.255.0 192.168.254.111 192.168.254.111 1
Zusätzlich habe ich IP Forwarding und Masquerading aktiviert.
Hier kann ich alllerdings nicht den Windows Router pingen.

Weiß jemand Rat?


Gruß,
DB
Mitglied: aqui
LÖSUNG 17.02.2012, aktualisiert 28.03.2014
Dein Prinzipschaubild zu diesem Netz sieht so aus:

caa9f1d63ec7aed53b786ce420644dfd - Klicke auf das Bild, um es zu vergrößern

Wenn du nicht dynamisch routest z.B. mit Quagga auf dem Linux dann musst du auf beiden Router zwingend 2 statische Routen eintragen, damit die Netze sich "sehen" !
Die Clients in den Windows oder Linux Segmenten haben dann das Default Gateway immer auf die Router IP in ihren jeweiligen Netzen.
Damit funktioniert das dann fehlerlos.
Wenn nicht hast du wie immer ein Firewall Problem ! Bedenke das das FW profil auch auf virtuelle VM Adapter greift !!
Bitte warten ..
Mitglied: MisterExpulso
23.02.2012 um 00:41 Uhr
Vielen Dank,
ich hatte bei meiner Lösung immer die Gateways verkehrt herum eingetragen. *facepalm*


MfG,
DB
Bitte warten ..
Mitglied: aqui
23.02.2012 um 10:48 Uhr
Kann in der Hektik ja mal passieren. (Hoffentlich aber nicht bei deiner Company im Sturm )
Klasse wenn nun alles rennt wie es soll !
Bitte warten ..
Ähnliche Inhalte
Suse
OpenSUSE 13.2 upgraden?
gelöst Frage von QQR700Suse2 Kommentare

Hallo, bin in der SUSE Welt gerade nicht so uptodate: wird die OpenSUSE 13.2er Version noch mit Aktualisierungen versorgt? ...

Suse
OpenSUSE 13.1 lässt sich nicht installieren
Frage von fuguSuse3 Kommentare

Moin ihr Linuxer! Ich wollte meinen neuen PC endlich mal mit 'ner SUSE bestücken. Leider komme ich direkt vom ...

Linux Netzwerk
OpenSuse 13.1 und XRP v0.6.1
gelöst Frage von Torsten2010Linux Netzwerk6 Kommentare

Hallo liebe Gemeinde, ich versuche die obige XRDP Version zu installieren. Einige Pakete habe ich nachinstalliert, make, gcc, usw. ...

Suse
Opensuse 13.1 und VNC
gelöst Frage von Torsten2010Suse4 Kommentare

Hallo, wie kann ich clientseitig die Auflösung ändern? Ich habe schon Ultravnc (mit Autoskalierung), tightvnc versucht. Immer passt er ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...