Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenType msi Paket

Frage Multimedia Schriftarten

Mitglied: Rubberduck81

Rubberduck81 (Level 1) - Jetzt verbinden

10.07.2013 um 10:24 Uhr, 1784 Aufrufe, 10 Kommentare, 1 Danke

Hi,

ich habe folgendes Problem, ich habe mittels WinINSTALL LE ein msi Paket erstellt, in dem zwei TrueType und eine OpenType Datei enthalten sind.
Führe ich die msi unter Win 7 aus, werden die beiden TrueType Dateien installiert und auch in die Registry eingetragen, von der OpenType Datei fehlt jedoch jede Spur. Hat jemand eine Idee wie man das Problem lösen kann ?
Mitglied: DerWoWusste
10.07.2013 um 10:27 Uhr
Hi.

Hast Du in wininstall LE schon mal das Paket geöffnet? Wird dort alles korrrekt angezeigt, sind also die Pfade richtig?
Bitte warten ..
Mitglied: Rubberduck81
10.07.2013 um 10:35 Uhr
Jup, habe ich.
WinINSTALL LE ist ja nur unter XP ausführbar, daher habe ich dort auch das Paket erstellt. Es lässt sich auch unter XP komplett installieren, nur unter Win7 eben nicht.
Bitte warten ..
Mitglied: DerWoWusste
10.07.2013 um 10:43 Uhr
Wininstall LE kannst Du von scalable Software in einer freien Version auch für Win7 runterladen, mach das mal damit, das andere ist uralt.
Bitte warten ..
Mitglied: departure69
10.07.2013, aktualisiert um 10:52 Uhr
Zitat von Rubberduck81:

Hallo.

----
Jup, habe ich.
WinINSTALL LE ist ja nur unter XP ausführbar,

Wenn man die völlig veraltete Version, die auf der W2K-Server-CD drauf war nimmt, schon. Nimm die neueste (http://www.scalable.com/wininstall-le), ist ebenfalls Freeware und funktioniert auch unter Windows 7 (sowohl 32- als auch 64-Bit). Einzige Einschränkung, wie schon bei der alten Version: Das zu paketierende Setup darf nicht schon selber ein msi sein, und auch nicht in der exe verpackt sein, muß also ein reiner exe-Installer sein. Spielt aber in Deinem Fall keine Rolle, weil Du nur ein paar Schriftarten installierst und msi-paketierst.

Edit: @DerWoWusste war schneller

Grüße

von

departure
Bitte warten ..
Mitglied: Rubberduck81
10.07.2013 um 11:37 Uhr
Hat jemand zufällig die .exe der neuen WinINSTALL Version für Win7 ? Will mich da jetzt nicht auch schon wieder registrieren.
Bitte warten ..
Mitglied: DerWoWusste
10.07.2013 um 12:49 Uhr
Dann nimm eine Wegwerf-Mailadresse: https://www.guerrillamail.com/de/
Bitte warten ..
Mitglied: Rubberduck81
10.07.2013 um 13:22 Uhr
Hab schon, aber Danke !

Habs auch installiert und die msi neu erstellt. Die Registry Einträge funktionieren soweit, aber die Fonts werden trotzdem nicht installiert !
Bitte warten ..
Mitglied: Rubberduck81
10.07.2013 um 13:35 Uhr
Die Registry Einträge sind vom Type auf SZ gesetzt und bei Data habe ich die Name der originalen datei eingefügt (bsp. lte50922.ttf).

Hat jemand eine Idee woran der Fehler liegt ?
Bitte warten ..
Mitglied: departure69
10.07.2013 um 13:41 Uhr
Hallo.

Warum mußt Du dazu in der Registry was tun (oder meinst, dort etwas tun zu müssen)?

WinInstall arbeitet doch mit einem Vorher/Nachher-Discovery. Und alles, was dazwischen geschieht, wird als Delta aufgezeichnet und ergibt beim Packaging die MSI. Man sollte allerdings mit einem "sauberen" System (neu installiert, kein Virenscanner, kein Windows-Update und keine andere Software , die im Discovery dazwischenfunkt) arbeiten.

Ansonsten würde ich an dem Paket nicht mehr rumfummeln.

Grüße

von

departure
Bitte warten ..
Mitglied: Rubberduck81
10.07.2013 um 14:48 Uhr
Wenn ich bei der Registry den Pfad SOFTWARE\Microsoft\Windows NT\CurrenVersion\Fonts nicht angebe, dann werden auch die Registry Einträge nicht vorgenommen !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Userverwaltung
Neue Version (msi Paket) lässt sich nicht über GPO ausrollen? (5)

Frage von ordi303 zum Thema Windows Userverwaltung ...

Windows Netzwerk
Installation von MSI Paket über GPO nicht möglich: Fehler 1602 (1)

Frage von patriwag zum Thema Windows Netzwerk ...

Informationsdienste
gelöst Aktuelle Firefox MSI Datei!? (8)

Frage von Hendrik2586 zum Thema Informationsdienste ...

Windows 7
Windows 7 Client zieht sich keine MSI Pakete (6)

Frage von Ghost108 zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...