Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN Access Server - Routing in ein anderes Netz

Frage Netzwerke Router & Routing

Mitglied: Holle1991

Holle1991 (Level 1) - Jetzt verbinden

07.12.2014 um 12:30 Uhr, 1151 Aufrufe, 9 Kommentare

Hallo erstmal zusammen!

Ich bin neu hier und hoffe, dass ich alles richtig mache.


Kämpfe nun seit über einer Woche mit einem Routing Problem.


Folgendes Szenario:

Ich habe auf meinem Windows Server 2012 über Hypes-V die OpenVPN Appliance importiert.
Beim ersten hochfahren musste ich das Netz konfigurieren, damit ich übers Webinterface den Rest konfigurieren kann.

Mein Netz sieht wie folgt aus:


Router1 (DHCP 192.168.1.100-200)
192.168.1.1
Ports für den OpenVPN Server sind eingetragen.

Router2 (nur Switchfunktion)
192.168.1.2

Windows Server (HP Proliant N54l - statisch)
192.168.1.120

OpenVPN Access Server (statisch)
192.168.1.100


Der OpenVPN Server verteilt an die Clients Adressen aus dem 10.10.10.0 Netz. Habe auch schon ein anderes Netz probiert - leider auch ohne Erfolg.

Ich kann mich erfolgreich mit meinem iPhone über die OpenVPN App verbinden und erhalte auch eine IP aus dem richtigen Netz.
Nun möchte ich aber auf die Freigaben des Windows Servers zugreifen können. Dafür habe ich auf dem OpenVPN Server das Routing eingestellt.
Sowohl über NAT, als auch über Routing komme ich nicht in mein 192.168.1.0 Netz. Ich kann auch nicht den Router1 pingen.


Habe ich irgendetwas vergessen einzustellen? Alle Berechtigungen über den OpenVPN Server sind gesetzt und ich finde auch über google keine passende Lösung.
Alles was dort geschrieben bzw. in Videos erklärt wird, habe ich auch so durchgeführt. Finde leider auch keine Kommandos, um über die Konsole des OpenVPN Servers händisch eine Route einzutragen.


Vielleicht hat ja einer von Euch einen Tipp.

Vielen Dank erstmal!


Liebe Grüße

Holger


Mitglied: orcape
07.12.2014 um 13:08 Uhr
Hi,
...und hoffe, dass ich alles richtig mache.
Wenn das so wäre, brauchtest Du nicht zu posten.
Router1 (DHCP 192.168.1.100-200)
Wenn Du einen DHCP-Range wie oben genannt hast, wieso vergibst Du dann in diesem Bereich statische IP´s ?
Windows Server (HP Proliant N54l - statisch)
192.168.1.120
OpenVPN Access Server (statisch)
192.168.1.100
Was OpenVPN betrifft hat @aqui hier ein paar nette Tutorials geschrieben, die Du problemlos über die Suchfunktion findest.
Um Dein Problem dann genauer zu beurteilen, solltest Du schon etwas mehr zu Deinen VPN-Einstellungen und Routingtabellen posten.
Ein kleines Bild Deines Netzwerk-Aufbaus wäre auch hilfreich.
Gruß orcape
Bitte warten ..
Mitglied: aqui
07.12.2014, aktualisiert um 13:48 Uhr
Vermutlich hast du wie so oft das "push route" Kommando in der Server Setup Datei vergessen ?!
Dieses Forumstutorial beschreibt die Details dazu:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Da bei Openvpn die Konfig immer HW unabhängig gleich ist gelten die o.a. Settings auch für deine Plattform.
Bitte warten ..
Mitglied: BernhardMeierrose
07.12.2014 um 18:56 Uhr
Moin,

kennen Deine Server und Router im lokalen Netz den Weg ins 10er-Netz ?
Sprich : route add 10.10.10.0 mask 255.0.0.0 192.168.1.100 (bzw die von Dir genutzte Subnet-Mask)

Gruß
Bernhard
Bitte warten ..
Mitglied: orcape
07.12.2014 um 19:11 Uhr
kennen Deine Server und Router im lokalen Netz den Weg ins 10er-Netz ?
So lange wie der TO keine weiteren Infos zu seiner Config postet bleibt das nur Rätsel raten.
Das Routing, OpenVPN betreffend, wird alles in der Server.config geklärt und wird ersichtlich, wenn der TO sich denn mal dazu entscheidet dazu etwas zu posten.
Gruß orcape
Bitte warten ..
Mitglied: aqui
08.12.2014 um 18:23 Uhr
kennen Deine Server und Router im lokalen Netz den Weg ins 10er-Netz ?
Das ist auch Unsinn mit der statischen Route, denn die Server haben ja den Router als Default Gateway !!
Dieser bekommt dann mit dem VPN Verbindungsaufbau die Routen automatisch in die Routing Table gepusht wie es üblich ist. Solche statischen Routen sind damit dann überflüssiger Unsinn, die eher Probleme bereiten als helfen !
Zu 98% liegt das an einer fehlkonfig der Server Konf Datei.
Das kann aber einzig und allein nur der TO klären wie der Kollege orcape schon richtig angemerkt hat !
Bitte warten ..
Mitglied: BernhardMeierrose
08.12.2014 um 20:06 Uhr
Ich glaube nicht, dass der OpenVPN-Server auf der 192.168.1.100 den wie auch immer gearteten Router auf der 192.168.1.1 automatisch konfigurieren wird, daher muss man schon entweder dem Router 192.168.1.1 oder dem Server die Route ins 10er Netz mitteilen.
Das Restrisoko, dass da RIP konfiguriert ist nehm ich mal in Kauf
Bitte warten ..
Mitglied: aqui
09.12.2014 um 10:35 Uhr
Da hast du natürlich Recht aber es war jetzt so zu verstehen das der Router selber der OVPN Server ist wie es z.B. in diesem_Tutorial beschrieben ist !
Nur darauf war das bezogen. Sollte das nicht der Fall sein und der OVPN Traffic (UDP 1194) den Router nur einfach passieren, dann wird dort natürlich nichts automatisch konfiguriert, das ist logisch. Wie sollte das auch gehen ?!
Der Server braucht die Route nicht ins 10er netz wenn ER der VPN Server ist, denn dort ist das 10er Netz ja direkt angeschlossen. Klar das dann eine Route dort vollkommen überflüssig ist (und auch kontraproduktiv).
Nicht aber am Router ! Dort muss natürlich eine statische Route eingetragen werden, klar ! Steht auch im o.a. Tutorial wenn der VPN Server hinter einem NAT Router betrieben wird !
Bitte warten ..
Mitglied: BernhardMeierrose
09.12.2014 um 10:50 Uhr
Also laut Eingangs-Thread läuft der OVPN als Appliance im Hyper-V, der Server "drunter" kennt also das 10er Netz nicht.
Ob man jetzt dem Router1 (DG) das Routing ins 10er Netz beibringt oder dem Server (oder beiden) ist ein Stück weit Geschmachssache.
Für die Server-Route würde z.B. sprechen, dass der Traffic zwischen OVPN-Server und dem Windows-Server drunter dann OS-Intern abgefackelt wird und nicht mehr über das LAN geht (klar, die Bremse ist die WAN-Leitung)
Für die Route am DG spricht natürlich, dass man alles Routing dort zentralisiert hat.
Bitte warten ..
Mitglied: aqui
09.12.2014 um 11:02 Uhr
Also laut Eingangs-Thread läuft der OVPN als Appliance im Hyper-V, der Server "drunter" kennt also das 10er Netz nicht.
Die Aussag eist nur seh bedingt richtig denn das hängt einzig und allein davon ab WIE die Appliance (VM) an den Host angebunden ist !!
Per Bridge, ber Host oder per NAT ?!?
Im Bridge und Host Modus erkennt der Host das 10er Netz sehr wohl !
oder dem Server (oder beiden) ist ein Stück weit Geschmachssache.
Nein, ist es nicht. Ein Router soll routen ein Server soll "serven". Infrastruktur Aufgaben sollte niemals ein Server ausführen um die Infrastruktur unabhängig von Servern und Endgeräten sicher betreiben zu können.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Verschlüsselung & Zertifikate
gelöst OpenVPN Access Server und x.509 PKI (4)

Frage von H4rdQu0r3 zum Thema Verschlüsselung & Zertifikate ...

Windows Netzwerk
IIS - anderes Netz zulassen (3)

Frage von survial555 zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...