Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OPENVPN Client bekommt keine Serververbindung!

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Ben2703

Ben2703 (Level 1) - Jetzt verbinden

01.09.2013 um 00:03 Uhr, 4692 Aufrufe, 12 Kommentare

mein OPENVPN Client bleibt bei der IP-Adresse stehen....und bekommt somit keinen Kontakt zum Server...
Der Server basiert auf SuseLinux10 und hängt hinter einem LinkSysRouter
Vielleicht weiß jemand Rat was da an den Einstellungen auf dem Server flasch sein kann
Danke für eine Antwort
Ben
Mitglied: Robobob
01.09.2013 um 00:12 Uhr
Hallo,

zu erst: Wie wäre es mit einer Begrüßung?

Dann: Überdenke um Himmels Willen deinen Beitrag nochmal.
Es fehlen sämtliche Informationen die zu einer möglichen Lösung beitragen könnten.

Lies dir die FAQ mal durch.

Besonders den Teil: http://www.administrator.de/faq/19

Danke und Schönen Abend.

Gruß

Max
Bitte warten ..
Mitglied: Dobby
01.09.2013 um 01:11 Uhr
Auch kein Hallo,

Das Forum hat auch eine Suchfunktion!
Und darüber ist folgendes zu finden, das muss man nur abtippen und
es ist egal auf welchen OS OpenVPN installiert ist die Konfiguration ist jedes mal das selbe.

OpenWRT Low Cost Router für LAN bzw. VLAN Routing inklusive OpenVPN Server
OpenVPN Server installieren auf DD-WRT Router oder pfSense Firewall

OpenVPN - Teil 1 - Installation, Konfiguration und erstellung der Zertifikate
OpenVPN - Teil 2 - OpenVPN Konfiguration

Der Server basiert auf SuseLinux10 und hängt hinter einem LinkSysRouter
Kannst Du auf dem LinkSys Router nicht einfach DD-WRT installieren und dort den OpenVPN Router benutzen?

Gruß
Dobby
Bitte warten ..
Mitglied: orcape
01.09.2013, aktualisiert um 10:47 Uhr
Hi Ben,

wenn schon mal die Begrüßung fehlt, so hast Du Dich wenigstens im Voraus für die Antworten bedankt.
Das ist ja schon mal ein Anfang.
Wie Robobob schon richtig angedeutet hat, fehlt hier schon noch ein "wenig Input" um Dir sinnvoll helfen zu können.
Mit....
mein OPENVPN Client bleibt bei der IP-Adresse stehen
....kann wohl keiner was anfangen.
Denn mein OPENVPN Client bleibt stehen (Laptop), wo ich Ihn gerade hinstelle...
Ein kleines Bild vom Netzwerkaufbau nebst Adressvergabe, wäre dann ebenfalls noch recht hilfreich.

Gruß orcape
Bitte warten ..
Mitglied: Ben2703
12.09.2013 um 13:23 Uhr
Hallo Zusammen
leider ist die Begrüßung das letzte mal beim kopieren verloren gegangen.
dafür bitte ich um entschuldigung...
Ich habe hier einmal den Ablauf des Clients kopiert.
Der Server lief bis Dato problemlos.
Da aber das Board den Geist aufgegeben hat, musst ich ein neues Board installieren.
Beim Starten zeigt SuseLinux keinen Fehler und läuft bis zum Login durch.
Wenn noch mehr Daten benötigt werden so bitte ich darum mir mitzuteilen welche das dann sind

Besten Dank für eine Antwort
Ben


OpenVPN(Connection......
Thu Sep 12 13:14:20 2013 OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011
Thu Sep 12 13:14:20 2013 WARNING: Make sure you understand the semantics of --tls-remote before using it (see the man page).
Thu Sep 12 13:14:20 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Sep 12 13:14:20 2013 LZO compression initialized
Thu Sep 12 13:14:20 2013 Control Channel MTU parms [ L:1562 D:138 EF:38 EB:0 ET:0 EL:0 ]
Thu Sep 12 13:14:20 2013 Data Channel MTU parms [ L:1562 D:1400 EF:62 EB:135 ET:0 EL:0 AF:3/1 ]
Thu Sep 12 13:14:20 2013 Fragmentation MTU parms [ L:1562 D:1400 EF:61 EB:135 ET:1 EL:0 AF:3/1 ]
Thu Sep 12 13:14:20 2013 Local Options hash (VER=V4): 'caff5189'
Thu Sep 12 13:14:20 2013 Expected Remote Options hash (VER=V4): '43a81564'
Thu Sep 12 13:14:20 2013 UDPv4 link local: [undef]
Thu Sep 12 13:14:20 2013 UDPv4 link remote: 212.xxx.xxx.xxx:1194
Thu Sep 12 13:15:20 2013 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Sep 12 13:15:20 2013 TLS Error: TLS handshake failed
Thu Sep 12 13:15:20 2013 TCP/UDP: Closing socket
Thu Sep 12 13:15:20 2013 SIGUSR1[soft,tls-error] received, process restarting
Bitte warten ..
Mitglied: Dobby
12.09.2013 um 13:55 Uhr
Thu Sep 12 13:15:20 2013 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Also so wie ich das sehe Ist irgend etwas bei Deiner Schlüsselübretragung bzw. Aushandlung nicht in Ordnung...
Thu Sep 12 13:15:20 2013 TLS Error: TLS handshake failed
Dadurch kommt es dann zu keiner Verbindung...
Thu Sep 12 13:15:20 2013 TCP/UDP: Closing socket
und die Verbindung wird geschlossen bzw. deren Aushandlung. (Drei Wege Handshake)

Das gute bei OpnVPN ist doch folgendes, dass die Einrichtung immer gleich bleibt und das auch
noch auf allen OS, egal ob man nun OpenSUSE oder sonst etwas verwendet!

Also tippe doch einfach eine der obigen Anleitungen ab und gut ist es.

Gruß
Dobby
Bitte warten ..
Mitglied: Ben2703
12.09.2013 um 15:08 Uhr
Hallo Dobby
Danke für die schnelle Antwort.
ich habe das System sozusagen geerbt und mein Problem ist, dass ich von Linux so gar keinen Plan habe.
Der Router hat z.B. zwei IP-Adressen, die auf den gleichen Port (1194) verweisen. Das geht mit dem neuen Router (ebenfalls ein Linksys R042) z.B. nicht.
Da ich nur das Board getauscht habe, hat sich ja an der Schlüsselübertragung nichts geändert.
Aber OK, welche der Anleigungen würdest du empfehlen.
Gruß
Ben
Bitte warten ..
Mitglied: Dobby
12.09.2013 um 15:21 Uhr
nimm doch ein der obigen 4 Links und dann schau mal was Dir besser zusagt.
Das ist eben der Vorteil von OpenVPN die Konfigurationsdateien sind immer gleich, egal ob nun auf einem
DD-WRT Router, einem Linux Server oder sonst wo.

Der Server basiert auf SuseLinux10 und hängt hinter einem LinkSysRouter
Viele Linksys Router lassen sich mit der alternativen Firmware DD-WRT flashen und dort kann
man dann auch einen OpenVPN Server direkt auf dem Router betreiben und dazu sind auch weiter oben
die ersten beiden Links!

Also wenn sich da nicht 150 Leute auf dem Server einwählen wollen/müssen würde ich das sogar bevorzugen
denn dann muss man keine Ports vorne am Router öffnen.

Ist man erst einmal via VPN mit dem Router verbunden, dann steht einem das gesamte Netzwerk dahinter zur
Verfügung!

Gruß
Dobby
Bitte warten ..
Mitglied: Ben2703
12.09.2013 um 15:34 Uhr
Hi Dobby
doch, auf dem Server loggen sich so derzeit insgesamt ca 280 Leute ein, nicht alle gleichzeitig aber halt zum Abholen von Dokumenten.
Wie gesagt ich habe das System geerbt und muss mich da erst mal richtig schlau machen.
Leider hab ich bis dato, da das System ja fehlerfrei lief keinen Handlungsbedarf gesehen.
Gruß
Ben
Bitte warten ..
Mitglied: Dobby
12.09.2013 um 16:02 Uhr
Leider hab ich bis dato, da das System ja fehlerfrei lief keinen Handlungsbedarf gesehen.
Aha, na wenn schon fehlerfrei lief könnte es sich ja auch um ein Update handeln was den VPN Server
zum erliegen gebracht hat!

Gruß
Dobby
Bitte warten ..
Mitglied: Ben2703
12.09.2013 um 19:05 Uhr
Hallo Dobby
ein Update hat er bestimmt nicht gezogen, zumindest lässt darauf nichts schließen
Daher meine Frage, wie kann es sein, dass das aushandeln der Zertifikate nur durch den Tausch des Boards nicht mehr funktioniert, da der Client ja bei der IPAdresse nicht weiter springt?
Gruß
Ben
Bitte warten ..
Mitglied: Dobby
13.09.2013, aktualisiert um 03:16 Uhr
Hallo,

ich glaube ich habe es jetzt, wenn Du das Mainboard getauscht hast,
sind natürlich auch eine oder mehrere andere MAC Adresse der
Onboard LAN Karten bzw. Onboard LAN Ports verändert worden!!!

Und wenn dort nun MAC / IP Adressbindungen vorhanden waren wird
die Kommunikation gestört respektive kommt erst gar nicht
zu Stande! Also Du solltest jetzt wirklich einmal in die
Konfigurationsdateien des OpenVPN Servers schauen
und explizit danach Ausschau halten.

Gruß
Dobby
Bitte warten ..
Mitglied: Ben2703
23.09.2013 um 00:55 Uhr
Hallo zusammen und danke für die ausführlichen Antworten
ich haben den Server jetzt soweit wieder zum Laufen gebraucht
aber bekomme trotzdem noch keinen Kontakt vom client

der Server scheint, obwohl er startet nicht am Port zu lauschen.

xxxvpn:/etc/openvpn # netstat -lnp --ip
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 4913/master
udp 0 0 xxx.xxx.xxx.xxx:1194 0.0.0.0:* 6500/openvpn

das wird augegeben wenn ich netstart aufrufe.
vielleicht weiß jemand warum bei der IP:1194 keine LISTEN steht.
was muss ich noch aufrufen.

viele Grüße
ben
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Router & Routing
Eine Steuerung hinter dem OpenVPN Client erreichen (15)

Frage von cannonball zum Thema Router & Routing ...

Router & Routing
Router für OpenVPN (Client) und VLAN (24)

Frage von damnbx zum Thema Router & Routing ...

Linux Netzwerk
Openvpn client Netz ereichbar machen (33)

Frage von schlamp zum Thema Linux Netzwerk ...

LAN, WAN, Wireless
gelöst VPN Tunnel - Client bekommt falsche IP Adresse (16)

Frage von Markowitsch zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...