Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN Client kann OpenVPN Server nicht anpingen.

Frage Netzwerke LAN, WAN, Wireless

Mitglied: steve007

steve007 (Level 1) - Jetzt verbinden

18.07.2013, aktualisiert 14.08.2013, 5847 Aufrufe, 39 Kommentare

Hallo Ihr

möchte mir eine VPN - Verbindung zwischen zwei Notebooks aufbauen, sind beides Windows 7 Home Premium-Rechner.
Habe das Problem nach Installation von OpenVPN V2.2.2, dass der Client den Server nicht pingen kann aber der Server den Client und somit kann ich auch auf die Freigaben zugreifen. der Client der den Server nicht anpingen kann, kann dann eben auch die Freigaben vom Server nicht sehen.
Ich bekomme beim Connect vom Client auch eine IP-Adresse im VPN zugewiesen, also soweit alles in Ordnung.
Da ich aber nicht viel Ahnung von VPN habe, habe ich auch mal die View Log vom Client wo eine Warnung erscheint mit aufgeführt, allerdings weis ich nicht ob das etwas damit zu tun hat. Die Meldung lautet:

WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Das ist die einzige Fehlermeldung die erscheint.

Hier die server.ovpn

01.
# Zertifikate 
02.
ca "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\ca.crt" 
03.
cert "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\server01.crt" 
04.
key "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\server01.key" 
05.
dh "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\dh1024.pem" 
06.
 
07.
# Server und Netzwerk 
08.
local 192.168.100.122 #LAN-Adresse des Servers 
09.
port 1194 
10.
proto udp 
11.
dev tap 
12.
server 192.168.10.0 255.255.255.0 #Subnetz 
13.
ifconfig-pool-persist ipp.txt 
14.
comp-lzo 
15.
persist-key 
16.
persist-tun 
17.
keepalive 10 120 
18.
 
19.
# Log 
20.
status "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn-status.log"  
21.
log "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn.log"  
22.
log-append "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn.log"  
23.
verb 3
Hier die client.ovpn

01.
# Zertifikate 
02.
ca "C:\\Program Files (x86)\\OpenVPN\\config\\ca.crt"  
03.
cert "C:\\Program Files (x86)\\OpenVPN\\config\\client01.crt"  
04.
key "C:\\Program Files (x86)\\OpenVPN\\config\\client01.key"  
05.
 
06.
# Client-Setup 
07.
client 
08.
dev tap 
09.
proto udp 
10.
remote meinedomain.dyndns-free.com 1194 #Hostname anpassen 
11.
resolv-retry infinite 
12.
nobind 
13.
persist-key 
14.
persist-tun 
15.
route-metric 512 
16.
route 0.0.0.0 0.0.0.0 
17.
comp-lzo 
18.
verb 3
Ich hoffe ich habe soweit erst mal alles nötige beschrieben und würde mich freuen wenn mir jemand helfen könnte.
Danke im Voraus!

steve007
39 Antworten
Mitglied: Dobby
18.07.2013 um 19:41 Uhr
Hallo Steve,

hast Du mal bei der Windows Firewall nachgeschaut ob dort auch der Dienst nebst den Ports erlaubt ist, also sprich ob
dort auf dem Notebook wo der Server läuft die Firewall das auch erlaubt und nicht unterdrückt?

No server certificate verification method has been enabled
Das heißt auf gut deutsch; dass keine Methode vergeben wurde wie das Zertifikat beim Server überprüft werden soll.
Also so etwas wie TLS denke ich mir, aber von OpenVPN habe ich echt null Plan, aber das mit der Firewall wird halt gerne und
oft vergessen.

Gruß
Dobby
Bitte warten ..
Mitglied: orcape
18.07.2013 um 20:08 Uhr
Hi,

Du hast erst mal ein Zertifikatsproblem, wie Dobby schon sagt.
Wenn der Tunnel aber steht, was zu erwarten ist, sonst würde die Verbindung in eine Richtung nicht klappen, liegt das sicher nicht mehr an OpenVPN.
Leider verrätst Du uns weder, wie Dein Client, noch wie Dein Server ins Netz kommt.
Hängt da noch ein Router zwischen, gehst Du einseitig per UMTS ins Netz ?
Ich hoffe ich habe soweit erst mal alles nötige beschrieben
Antwort....
Klares Nein....

Gruß orcape
Bitte warten ..
Mitglied: orcape
18.07.2013 um 20:13 Uhr
...kleiner Nachtrag.
In Deiner config, sowohl beim Server wie auch beim Client, dürfte.....
dev tap
persist-tun
...nicht so richtig zusammenpassen.

Gruß orcape
Bitte warten ..
Mitglied: steve007
18.07.2013 um 23:26 Uhr
Hallo D.o.b.b.y

an die Firewall habe ich schon gedacht, die habe ich gleich vor der Installation beendet.
Stand in der Anleitung schon so drin, dass die nicht kompatibel ist mit OpenVPN.

ciao
steve007
Bitte warten ..
Mitglied: steve007
18.07.2013 um 23:43 Uhr
Hallo orcape

ich habe aus der Anleitung in der PC-Welt-Site, siehe http://www.pcwelt.de/ratgeber/OpenVPN-mit-Windows-4984324.html diese Configurationsdateien so eingerichtet und eben nach der Anleitung. Hier steht das auch mit tun und tap so drin.
leider habe ich jetzt zum Test nur einen DSL-Router wo ich das Tunneling testen kann, vielleicht liegt es da dran, weil ich mit dem Client wirklich von aussen mit einen zweiten DSL-Anschluss an dem Server connecten sollte. Es ist aber ja so, dass er den Tunnel ja aufbaut, also habe ich gedacht ich kann das an einem DSL-Router schon mal testen bevor ich das bei meinen Kollegen installiere.
Portforwarding auf Port UDP 1194 habe ich auch im DSL-Router eingestellt wie in der Anleitung beschrieben.
Ich habe ja schon viel gegoogelt und fand hier auch schon solche Configurationsdateien und hier war auch meist immer nur das tun-Protokoll aktiviert. Mich wundert das auch was die in der PC-Welt beschreiben, denke aber auch das ich das ganze vielleicht doch erst mal trotzdem mit einen zweiten DSL-Anschluss für den Client testen sollte.
Meinst Du, dass das mit den Verschiedenen Protokollen, also tun und tap, grundsätzlich nicht funktionieren kann und die sich da in der PC-Welt verschrieben haben?

ciao
steve007
Bitte warten ..
Mitglied: Dobby
19.07.2013 um 00:39 Uhr
DSL-Router wo ich das Tunneling testen kann, vielleicht liegt es da dran, weil ich mit dem Client wirklich von aussen mit einen zweiten DSL-Anschluss an dem Server connecten sollte.
Jo das wäre was.

Gruß
Dobby
Bitte warten ..
Mitglied: orcape
19.07.2013 um 15:56 Uhr
Hi,

Jo das wäre was.
.... ...sehe ich auch so.
Nicht vergessen die FW.Rules entsprechend anzupassen.
Siehe Tutorial Aqui....
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Meinst Du, dass das mit den Verschiedenen Protokollen, also tun und tap, grundsätzlich nicht funktionieren kann und die sich da in der PC-Welt verschrieben haben?
Wenn Du nicht unbedingt bridgen willst, das heißt auf beiden OpenVPN-Seiten gleiches Netz, solltest Du das tun-Device benutzen.
Also in der Server-, Client config "dev tun" eintragen.

Gruß orcape
Bitte warten ..
Mitglied: steve007
19.07.2013 um 17:06 Uhr
Hallo Dobby, hallo orcape

ich war jetzt bei meinen Kollegen der eben den zweiten DSL-Anschluss hat, (macht DHCP wie die meisten).
ich komme ins Internet, denn das muss ja reichen, weil wenn ich woanders bin, z.B. Hotel etc. muss das ja auch gehen.
Ich habe also nichts Verstellt am Rechner. Der Witz von Client to Client-Verbindung durch Tunneling ist ja genau das.
Meinen Notebook-OpenVPN-Client habe ich bei Ihm angeschlossen und genau das gleiche Problem, kein Ping auf dem OpenVPN Server.
Ich habe den Client nur auf DHCP eingestellt, weil ich bei mir statische IP´s setze.
Jetzt kann ich sagen es liegt für die Testinstanz nicht an dem einen Router wo Client und Server daran hängen.
Mir ist eine Website beim Googeln aufgefallen wo ich mal meine Configuration anpassen werde, gebe wieder Bescheid. http://wiki.openvpn.eu/index.php/Erster_Tunnel

ciao
steve007
Bitte warten ..
Mitglied: steve007
19.07.2013 um 17:09 Uhr
>Noch ein Nachtrag, kann dass mit der Warnung die ich im View Log bekomme auch damit zusammenhängen?
ciao
steve007
----
Hallo Dobby, hallo orcape

ich war jetzt bei meinen Kollegen der eben den zweiten DSL-Anschluss hat, (macht DHCP wie die meisten).
ich komme ins Internet, denn das muss ja reichen, weil wenn ich woanders bin, z.B. Hotel etc. muss das ja auch gehen.
Ich habe also nichts Verstellt am Rechner. Der Witz von Client to Client-Verbindung durch Tunneling ist ja genau das.
Meinen Notebook-OpenVPN-Client habe ich bei Ihm angeschlossen und genau das gleiche Problem, kein Ping auf dem OpenVPN Server.
Ich habe den Client nur auf DHCP eingestellt, weil ich bei mir statische IP´s setze.
Jetzt kann ich sagen es liegt für die Testinstanz nicht an dem einen Router wo Client und Server daran hängen.
Mir ist eine Website beim Googeln aufgefallen wo ich mal meine Configuration anpassen werde, gebe wieder Bescheid.
http://wiki.openvpn.eu/index.php/Erster_Tunnel

ciao
steve007
Bitte warten ..
Mitglied: steve007
19.07.2013 um 21:55 Uhr
Hallo Ihr

gibt es denn nirgends wo eine Anleitung mit Server.ovpn und config.ovpn die schon mal einer zum laufen gebracht hat. Wo man einfach zwei PC´s miteinander tunneln will unter Windowsl, frage ich mich. die Anleitung die ich vorhin beschrieben habe, geht ja überhaupt nichts.
Kann mir jemand da helfen, oder gibt es da auch eine kostenpflichtige Version, wo so ein Theater nicht notwendig ist,
oder gibt es wirklich irgend wo eine Website, wo man das einfach nachvollziehen kann. Das kann doch nicht sein, dass dieses Produkt noch nie Funktioniert hat. Es gibt ja massig bei Google Anleitungen, aber keine geht aufs ganze, und eigentlich will ich ja nur das einfachste, also zwei Rechner miteinander im Internet ein Tunnel aufbauen, die zwei ganz normale Router haben die ins Internet kommen und am Server habe ich ja auch schon die Firewall abgeschaltet und das Portforwarding eingetragen am OpenVPN Server PC.
Und wie schon gesagt, am Client muss ich überhaupt nichts ändern, denn das kann ein Router sein der meinen Notebook ins Internet lässt wie er heisen will, er muss nur einen Internet - Zugang haben. Viele Artikel beschreiben vom Router auf der Client-Site, es muss das und das im Router configuriert werden, dass ist einfach EDV zu Fuss.
Wenn einer von Euch weis was es da noch gibt, währe ich sehr dankbar!

ciao
steve007
----
>Noch ein Nachtrag, kann dass mit der Warnung die ich im View Log bekomme auch damit zusammenhängen?
ciao
steve007
> ----
> Hallo Dobby, hallo orcape
>
> ich war jetzt bei meinen Kollegen der eben den zweiten DSL-Anschluss hat, (macht DHCP wie die meisten).
> ich komme ins Internet, denn das muss ja reichen, weil wenn ich woanders bin, z.B. Hotel etc. muss das ja auch gehen.
> Ich habe also nichts Verstellt am Rechner. Der Witz von Client to Client-Verbindung durch Tunneling ist ja genau das.
> Meinen Notebook-OpenVPN-Client habe ich bei Ihm angeschlossen und genau das gleiche Problem, kein Ping auf dem OpenVPN
Server.
> Ich habe den Client nur auf DHCP eingestellt, weil ich bei mir statische IP´s setze.
> Jetzt kann ich sagen es liegt für die Testinstanz nicht an dem einen Router wo Client und Server daran hängen.
> Mir ist eine Website beim Googeln aufgefallen wo ich mal meine Configuration anpassen werde, gebe wieder Bescheid.
> http://wiki.openvpn.eu/index.php/Erster_Tunnel
>
> ciao
> steve007
Bitte warten ..
Mitglied: steve007
19.07.2013 um 23:35 Uhr
Hallo orcape

ich glaube ich habe in dem Thread eine Fehler gemacht, aber was solls.
Kannst Du mir helfen mit meinem Problem, ich bin verzweifelt was ich schon alles versucht habe.
Es gibt einfach keine Configuration die funktioniert.
Jetzt mit der letzten configuration findet er die DNS, also meine DynDNS-Adresse nicht mehr.
Habe jetzt alles wieder auf dem Stand wo ich von Anfang war zurückgesetzt.
Also wie schon gesagt, kann nur den Server nicht pingen.

ciao
steve007
Bitte warten ..
Mitglied: orcape
20.07.2013 um 09:20 Uhr
Hi,

Jetzt mit der letzten configuration findet er die DNS, also meine DynDNS-Adresse nicht mehr
Nun das sollte erst mal die Bedingung sein, das der Tunnel überhaupt funktioniert.
Die DynDNS-Adresse funktioniert aber noch, nicht das Dich der Provider in der Zwischenzeit rausgekickt hat, weil Du den Account nach Aufforderung nicht aktualisiert hast.
Was den OpenVPN-Server betrifft, der am DSL hängt, wäre es sowieso sinnvoller diesen auf dem Router zu installieren.
Was sagt denn die Routingtabelle auf dem Client ?

Gruß orcape
Bitte warten ..
Mitglied: steve007
20.07.2013 um 09:54 Uhr
Hallo orcape

die DynDns funktioniert noch, ausserdem habe ich ja jetzt wieder meine erste Configuration die ich mit PC-Welt gemacht habe wieder drauf, und siehe da, dass Tunnel geht ja, nur wie schon gesagt, den Server kann ich nicht anpingen.
Ich kann auch meine Domain bei DynDns anpingen, also ping meinedomain.dyndns-free.com, habe darüber auch einen internen Webserver laufen.
Aber danke erst mal das Du Dich so schnell gemeldet hast.
Soll ich die route print am Client vor dem den Connect oder nach dem Connect ausdrucken?
Was meinst Du eigentlich mit OpenVpn auf Router installieren, da stehe ich auf dem Schlauch, denn mein Router (DSL) ist ein D-Link und kann doch hier die Software nicht installieren. Was meinst Du da genau?

ciao
steve007
Bitte warten ..
Mitglied: orcape
20.07.2013 um 10:37 Uhr
Hi,

wenn der OVPN-Server auf dem Router wäre, könntest Du das komplette Netz über den Tunnel von remote erreichen.
Wenn das aber nicht geht....
Soll ich die route print am Client vor dem den Connect oder nach dem Connect ausdrucken?
..zumindest mal posten.
Wenn Du den Server (Tunnel-IP 192.168.10.1) nicht pingen kannst, dann könnte es auch ein Problem mit dem Provider sein. (NAPT)
local 192.168.100.122 #LAN-Adresse des Servers
Netzmaske 255.255.255.0 ?
server 192.168.10.0 255.255.255.0 #Subnetz
OpenVPN- Netz ?
Wenn Deine IP-EInstellungen so aussehen, würde ich mal was ändern.
Ich vergebe da schon der Übersichtlichkeit halber für den Tunnel keine 192.168.xxx.xxx/24 Netz, sondern ein 10.10.X.X/24 oder 172.16.x.x/24.
Ob das nun etwas damit zu tun hat oder nicht, Du hast es zumindest bei einer eventuellen Fehlersuche einfacher und übersichtlicher.

Gruß orcape
Bitte warten ..
Mitglied: steve007
20.07.2013 um 10:55 Uhr
Hallo orcape

mit dem Netz 10.10.X.X/24 habe ich das auch schon versucht, alles geht nur ich kann nicht auf dem Server zugreifen oder eben erst mal pingen.
Ich stelle es jetzt trotzdem nochmal um und sende Dir die route print.

ciao steve007
Bitte warten ..
Mitglied: steve007
20.07.2013 um 11:09 Uhr
Hallo orcape

hier die route print

ac813c2bfc975401682b1a1433ce788a - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: steve007
20.07.2013 um 11:32 Uhr
Hallo orcape

hier nochmal die Ipconfig vom Client, hat auch das Standard-Gateway.

988c3cc299098ba050d396e757e1340d - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: orcape
20.07.2013, aktualisiert um 11:49 Uhr
10.18.14.2 lässt sich pingen ?
10.18.14.1 nicht ?
Der Tunnel steht und sollte auch Richtung Server eigentlich pingbar sein.
Wenn Du auf dem Win7-Client Laptop noch kein "nmap" installiert hast, solltest Du das mal tun.
Dann mal "nmap -v -sn 192.168.100.0/24" eingeben.
Dort sollte dann Dein Win7 Serverrechner mit IP als "up" erscheinen.

Gruß orcape

PS: Du versuchst aber jetzt nicht von Deinem eigenen LAN aus das zu testen ?
Weil Client und LAN-IP 192.168.100.123 ?
Bitte warten ..
Mitglied: steve007
20.07.2013 um 11:42 Uhr
Hallo orcape

ich kenne ja mitweilen die Configurationsdateien auswendig, hat das vielleicht was mit dem Eintrag: push "route 192.x.y.0 255.255.255.0", oder push "route 10.x.y.0 255.255.255.0"
zu tun ? In der Server.ovpn.
Vielleicht fällt Dir da was ein.

ciao
steve007
Bitte warten ..
Mitglied: orcape
20.07.2013 um 11:59 Uhr
..mit push "route 192.x.y.0 255.255.255.0" wird dem Client vom Server nur mitgeteilt, welches Netz hinter dem Server erreichbar ist.
Mit "route" welches Netz hinter dem Client.
Das ist eigentlich nur für eine LAN-to-LAN config interessant.
Bitte warten ..
Mitglied: steve007
20.07.2013 um 12:14 Uhr
Hallo orcape

die nmap-Auszug:

d8e2dd03ff00203cdcb66f3bffba6cc3 - Klicke auf das Bild, um es zu vergrößern

ciao steve007
Bitte warten ..
Mitglied: steve007
20.07.2013 um 12:22 Uhr
Hallo orcape

wie meinst Du das?
PS: Du versuchst aber jetzt nicht von Deinem eigenen LAN aus das zu testen ?
Weil Client und LAN-IP 192.168.100.123 ?


Ich pinge halt vom Client aus der die lokale Adresse hat 192.168.100.123 auf 10.18.14.1 und das geht nicht.
ich bin mit meinem Client jetzt nicht beim Kollegen. Also am anderen DSL-Anschluss, also Router.

ciao steve007
Bitte warten ..
Mitglied: orcape
20.07.2013 um 12:38 Uhr
Hi steve,

lt.nmap ist host 192.168.100.123 up, d.h. Du hast Verbindung.
ich bin mit meinem Client jetzt nicht beim Kollegen. Also am anderen DSL-Anschluss, also Router.
Du versuchst also von zu Hause, aus dem gleichen Netz den anderen Rechner zu erreichen, über dyndns.
Das solltest Du vergessen.....

Gruß orcape
Bitte warten ..
Mitglied: steve007
20.07.2013 um 12:40 Uhr
Hallo orcape

mir ist aufgefallen das der Server keinen Standard-Gateway Eintrag auf 10.18.14.1 auf Server hat, ist die OpenVpn Netzkarte.
Also mit ipconfig-Befehl.
ciao
steve007
Bitte warten ..
Mitglied: steve007
20.07.2013 um 12:54 Uhr
Hallo orcape

ich habe doch gestern von meinen Kollegen das auch gemacht und wir hatten keinen Ping auf dem Server, also wie Zuhause auf meinen Router. Das einzige was sich jetzt geändert hat ist, dass ich das 10.18.14.0 Netz eingetragen habe, sonst haben wir ja an der Configuration nichts verändert.
Meinst Du ich soll nochmal zum Kollegen fahren und es mit der jetzigen Configuration, also dem 10.18.14.0 Netz versuchen.
Ich hatte auch schon immer meine bedenken, ob das einfach mit nur meinen Router Zuhause funktioniert.
Du meinst also ich kann niemals einen Ping bekommen vom Client zum Server? Aber warum geht es umgedreht, verstehe ich nicht.
Aufgrund der nmap-befehls ist auf jeden fall sicher das der Portforwarding funktioniert.
Sonst würde sich der Client ja auch nicht anmelden können wenn ich einen connect mache.
Mir kommt das vor wie wenn der Server völlig abgeschottet ist, trotz Deaktivierung der Firewall, und dem Portforwardingeintrag.
Was meinst Du?
Aber wieso meldet sich der Client an und bekommt eine 10.18.14.x IP-Adresse.
ciao
steve007
Bitte warten ..
Mitglied: steve007
20.07.2013 um 13:02 Uhr
Hallo orcape

hat das vielleicht doch etwas mit der Warnung zu tun die im View Log erscheint die ich anfangs beschrieben habe im Client beim Connect?
WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

ciao
steve007
Bitte warten ..
Mitglied: orcape
20.07.2013 um 13:06 Uhr
Du musst das von remote versuchen, alles andere kannst Du vergessen.
Mit nmap dann die IP Deines Win7-Rechners sniffern.

Gruß orcape
Bitte warten ..
Mitglied: steve007
20.07.2013 um 13:15 Uhr
Hallo orcape

Wie genau?

Mit nmap dann die IP Deines Win7-Rechners sniffern.

meinst Du ich muss zum Kollegen gehen, logisch, und dort was für einen Befehl eingeben, verstehe ich nicht ganz.
Was soll dabei rauskommen?

ciao
steve
Bitte warten ..
Mitglied: orcape
20.07.2013, aktualisiert um 14:05 Uhr
Hi,

OpenVPN-Clientrechner zum anderen Netzwerk....
.von mir aus das Deines Kollegen.
..dort "nmap -v -sn 192.168.100.0/24" eingeben.
Dann sollte dort im Protokoll die IP Deines VPN-Serverrechners mit "up" auftauchen, wenn der Tunnel steht.
Es müsste sich dann Dein VPN-Serverrechner von da aus auch pingen lassen, unabhängig davon, ob jetzt irgendetwas die Tunnel-IP ( 10.18.14.1 ) blockt.

Gruß orcape
Bitte warten ..
Mitglied: steve007
21.07.2013 um 10:04 Uhr
Hallo orcape

ich komme am Mittwoch wieder zu meinen Kollegen, dann werde ich Dir berichten was dabei herausgekommen ist.
Erst mal danke für deine Mühe, bist echt gut drauf, muss man schon sagen.
Ich denke wir werden das Problem schon lösen, damit endlich mal eine klare Sicht im OpenVpn ist.
Wo ich mir noch Gedanken mache ist diese Warnung die ich schon in dem Thread beschrieben habe, aber da warten wir jetzt mal den Mittwoch ab.
Viele Grüße!

ciao
steve007
Bitte warten ..
Mitglied: steve007
21.07.2013 um 10:44 Uhr
Hallo orcape

Was den OpenVPN-Server betrifft, der am DSL hängt, wäre es sowieso sinnvoller diesen auf dem Router zu installieren.

Ich muss nochmal kurz auf deine Antwort zurückkommen.
Wie stellst Du Dir das vor den OpenVpn auf dem Router zu installieren, dass geht doch gar nicht.
Ich kenne die Fritz-Box, die neue, und die hat VPN in der Firmware und kann also als VPN-Router verwendet werden, oder ich nehme Lancom.
Aber installieren OpenVpn auf einen Router, ob der jetzt heist D-link oder AVM-Fritz ist nicht möglich.
Vielleich habe ich da falsch verstanden und Du meinst etwas anderes.

ciao
steve007
Bitte warten ..
Mitglied: orcape
21.07.2013 um 12:11 Uhr
Hi,

Wie stellst Du Dir das vor den OpenVpn auf dem Router zu installieren, dass geht doch gar nicht.
...und ob.
Hat Aqui hier im Forum schon super Tutorials geschrieben.......
diese.....
http://www.administrator.de/wissen/preiswerte-vpn-fähige-firewall- ...
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
...oder hier nach einem entsprechenden Router suchen.....
http://www.dd-wrt.com/site/support/router-database
...vielleicht ist Deiner auch dabei, falls ein WLAN-Gerät.
Aber Achtung, nicht jeder der da aufgeführten Router lässt sich auch mit einer OpenVPN-Software flashen.

Gruß orcape
Bitte warten ..
Mitglied: Dobby
21.07.2013 um 13:12 Uhr
Hallo,

am besten Du gehst direkt auf die DD-WRT Seite und wählst Die Routerdatabase oben in der Mitte aus und dann
gibst Du den Hersteller und den Namen Deines Routers ein (z.B. Netgear WNDR3800) und dann klickst Du auch die
Zeile die Dir dann angezeigt wird, dann kllappt ein Menü auf und Du kannst exakt die Version des DD-WRT Images
sehen die zu Deinem Router passt und ob er noch aktiviert werden muss (kostenpflichtig ~25 €) und dann ist gut

Der Router aus meinem Beispiel muss nicht aktiviert werden und geht auch flott zur Sache, wenn Du Dir nicht sicher bist kannst Du natürlich einen Buffalo WLAN Router mit GB LAN Ports und vorgeflashetem DD-WRT kaufen ca. 70 - 90 €
Da kann dann nichts mehr schief gehen und OenVPN ist da auch schon ganz sicher drauf.

Gruß
Dobby
Bitte warten ..
Mitglied: steve007
22.07.2013 um 12:34 Uhr
Hallo Dobby

die Site DD-WRT habe ich schon gefunden, ich habe einen D-Link D-615 Firmware B2, ist leider nicht dabei, also geht nicht.
Was ich nicht verstehe, warum keiner weis wie der OpenVpn - Server funktioniert.
Wenn ich jetzt angenommen diesen Buffalo WLAN Router bestelle, sagst Du ja es ist alles schon fertig konfiguriert.
Was muss ich denn dann auf der Client Seite machen. Ist da eine Software dabei?
Und wo kann ich den Buffalo-Router bestellen und welchen Typ?
Wenn Du mir das nochmal etwas genauer beschreiben könntest, währe ich Dir sehr dankbar.
Aber erst mal danke für die Info.
Aber ich habe auch gehört, die Fritz - Box kann VPN, währe das auch was?
Ich bestelle natürlich gerne den Buffalo WLAN Router, aber ich muss eben noch etwas mehr erfahren.
Am Mittwoch werde ich aber nochmal die OpenVPN-Lösung testen, was ich mit orcape ausgemacht habe.

ciao
steve007
Bitte warten ..
Mitglied: Dobby
22.07.2013 um 15:09 Uhr
die Site DD-WRT habe ich schon gefunden, ich habe einen D-Link D-615 Firmware B2, ist leider nicht dabei, also geht nicht. Was ich nicht verstehe, warum keiner weis wie der OpenVpn - Server funktioniert.
Da kann man dann eben nichts machen.

Wenn ich jetzt angenommen diesen Buffalo WLAN Router bestelle, sagst Du ja es ist alles schon fertig konfiguriert.
Nein das habe ich nicht! Ich habe lediglich geschrieben, dass dieser Router schon mit einem fertig installiertem
DD-WRT ausgeliefert wird, von der Konfiguration habe ich nichts geschrieben. Das musst Du immer selber erledigen,
das Konfigurieren meine ich jetzt. Aber zum glück ist es nicht weiter schlimm denn alle Konfigurationsdateien sehen
immer gleich aus, die von OpenVPN meine ich jetzt, egal ob auf Unix, BSD, Windows oder linux installiert wurde, oder eben auch auf einem Router!

Was muss ich denn dann auf der Client Seite machen. Ist da eine Software dabei?
Wichtig sind erst einmal drei Sachen:

Erstens:
- Wer und vor allem mit welchem Equipment sitzt denn auf der anderen Seite?
- Welche Methode soll denn zum Einsatz kommen? Und wofür?
- Welche Protokolle oder Doenste sollen darüber laufen

Zweitens:
- Bitte nur die Verbindung testen wenn beide Leute vor Ort sind!
- Also bis Samstag warten, die andere Seite anrufen und los geht es!
- Anleitungen suchen die genau Dein Szenario wieder spiegeln!!!!
Dann braucht man nur noch abtippen und hat ergo auch weniger Fehler

Drittens:
- Es sollte schon auf beiden OpenVPN eingesetzt werden
- Es sollte Hardware verwendet werden die auch eine VPN Beschleunigung Hardware seitig mitbringt um einen
ordentlichen Durchsatz zu gewährleisten.
- Es sollte bekannt sein welche Internetzugänge auf jeder Seite vorhanden sind.

Hier sind mal ein paar Anleitungen aus dem Forum von @aqui:
OpenVPN Server installieren auf DD-WRT Router oder pfSense Firewall
VPNs einrichten mit PPTP
OpenWRT Low Cost Router für LAN bzw. VLAN Routing inklusive OpenVPN Server
VPN Einrichtung (PPTP) mit DSL Routern und DD-WRT Firmware
VPNs mit DD-WRT, M0n0wall oder pFsense auf Basis von PPTP

Die Methode mit dem PPTP würde ich heute nicht mehr nehmen wollen, da sie bereits als kompromittiert gilt.


Und wo kann ich den Buffalo-Router bestellen und welchen Typ?
Hier ich selber würde zu Nr. 2 oder Nr. 3 tendieren aber wenn es eine Budgetfrage ist dann wird es Nr.1 auch tun.
Nr.1 Buffalo WHR-HP-G300N AirStation Nfiniti Wireless-N High Power Broadband Router und Access Point
Nr.2 Buffalo AirStation WZR-HP-G300NH2EU NFINITI HighPower Gigabit Wireless-LAN Router 300Mbps
Nr.3 Buffalo AirStation WZR-HP-G450H-EU Nfiniti HighPower Giga Wireless-N Router und Access Point (450Mbps, 4-Port)


Wenn Du mir das nochmal etwas genauer beschreiben könntest, währe ich Dir sehr dankbar.
Das steht alles in den Anleitungen von dem Nutzer @aqui drinnen, ließ das bitte einmal durch und dann wird da auch was draus, ich gebe Dir auch gerne mal ein Beispiel: Man testet nicht die VPN Verbindung aus seinem LAN heraus
und denkt dann das kann ja dann auch nicht von außerhalb funktionieren! Eine Straßenbahn testet man ja auch auf Schienen und nicht auf dem Flugplatz. Klingt ein wenig gehässig, soll Dich aber nur animieren auch bei dem schönen Wetter Dich hinzusetzen und es auch durchzulesen, sehr vieles wird dann nicht nur für Dich verständlicher, sondern auch für uns, nämlich dann wenn Du wieder etwas nachfragen musst!

Aber erst mal danke für die Info.
Kein Thema.

Aber ich habe auch gehört, die Fritz - Box kann VPN, währe das auch was?
Entweder Du machst das VPN mit der Fritz!Box zu einer anderen Fritz!Box oder eben mit OpenVPN zu OpenVPN
bzw. einer OpenVPN kompatiblen Software. Man kann einiges aber eben nicht alles mit einander bzw. untereinander
mischen.

Ich bestelle natürlich gerne den Buffalo WLAN Router, aber ich muss eben noch etwas mehr erfahren.
Du solltest Dir einmal die Anleitungen von qui ansehen und auch durchlesen, denn die sind zum einen gut bebildert und
zum anderen auch einfach gehalten und wenn dann etwas nicht funktioniert und Du auch weißt wovon Du redest dann macht das auch alles ganz anders Sinn und man hilft auch richtig mit, denn ich denke da sind noch ein paar Lücken die Du bei Dir schließen solltest. Das war nicht bösartig gemeint.

Am Mittwoch werde ich aber nochmal die OpenVPN-Lösung testen, was ich mit orcape ausgemacht habe.
Viel Erfolg.

Gruß
Dobby
Bitte warten ..
Mitglied: steve007
22.07.2013 um 16:05 Uhr
Hallo Dobby

ich werde das jetzt alles mal durchlesen, und danke für die ausführliche Beschreibung.
Melde mich dann später wieder, denke dann nächste Woche eben.
Vielleicht geht ja auch alles gleich wie ich mir das vorstelle.
Gebe Euch auf jeden Fall Bescheid.
Gruß an orcape, er hat sich ja auch viel mühe gemacht.
Auf jeden Fall, danke erst mal Ihr zwei.
ciao
steve007
Bitte warten ..
Mitglied: steve007
11.08.2013 um 14:46 Uhr
Hallo

ich habe jetzt auch nochmal eine andere Konfiguration ausprobiert und habe natürlich die andere auch noch, aber bei beiden Konfigurationen ist das dasselbe.
Kein Ping auf Server vom Client, also von ausserhalb versteht sich, nicht über mein Netz (Router).
Nmap-Befehl habe ich wie Ihr gesagt habt auch auf dem Client ausgeführt, also "nmap -v -sn 192.168.100.0/24", kommt kein Server mit Up.
Der Client bekommt also von aussen eine DHCP-Adresse (habe mir extra noch einen zweiten Anschluß legen lassen, ist also vollkommen getrennt mit meinen anderen, als wie wenn ich von New York mit dem Client auf dem Server zugreifen würde.
Was kann denn das noch sein, bei beiden Konfigurationen der gleiche Fehler. Kein Ping auf Server und auch kein UP vom Nmap vom Client aus.

Währe dankbar wenn Ihr mir da nochmal helfen könntet.

ciao steve007
Bitte warten ..
Mitglied: orcape
14.08.2013 um 21:37 Uhr
Hi steve,

Kein Ping auf Server vom Client, also von ausserhalb versteht sich,
..und da existiert ein normaler DSL-Anschluß ?
Der Client bekommt also von aussen eine DHCP-Adresse (habe mir extra noch einen zweiten Anschluß legen lassen,
...hm, sicher ?
Wie sieht die aus???...die DHCP ?-Adresse...
Hast Du mal versucht den Server direkt mit dem Client zu verbinden, testweise.
Von den Tipps hier, hast Du wohl nichts so richtig in die Tat umgesetzt.
Da fehlen wohl noch etwas die Grundlagen.
Du wirst Dir das dann wohl machen lassen müssen.

Gruß orcape
Bitte warten ..
Mitglied: steve007
14.08.2013 um 22:12 Uhr
Hallo

heute Mittag habe ich das alles hinbekommen mit tun und tap, mit
Verschlüsselung und allen drum und dran. ich hatte bei meinem einen Router
ein Problem festgestellt.
Die Sache mit mehreren Clients über tap geht auch.
Der Router hatte einen Fehler den ich mit der Firmware die allerdings schon
vorhanden war beseitigt.
Er hatte zwar alle Ports weitergeleitet, aber irgend etwas war nicht IO mit
dem Gerät.
Übrigens, Ich habe zwei getrennte Anschlüsse.
Aber trotzdem danke für die ganze Mühe.

ciao steve007
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
MBAM 2.5 Client - Server Kommunikation

Frage von thatsright zum Thema Windows Server ...

Router & Routing
Eine Steuerung hinter dem OpenVPN Client erreichen (15)

Frage von cannonball zum Thema Router & Routing ...

Router & Routing
Router für OpenVPN (Client) und VLAN (24)

Frage von damnbx zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...