Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN Dienst startet mit falscher Config

Frage Linux Linux Netzwerk

Mitglied: Sniffer

Sniffer (Level 1) - Jetzt verbinden

26.01.2009, aktualisiert 14:11 Uhr, 3320 Aufrufe, 1 Kommentar

Hallo zusammen,

ich hab seit heute mal wieder ein Problem, und zwar setz ich grad nen OpenVPN Server auf. Die Verbindung an sich klappt wunderbar, jedoch muss ich die Serverdatei ständig mit dem Befehl openvpn --config server.conf starten.

Wenn ich den OpenVPN Server über den Dienst (/etc/init.de/openvpn start) starte bekomme ich als Rückmeldung nur failed. Wenn ich dann in die Log Datei sehe, sieht man dass er einige Dateien oder Zertifikate nicht findet die in meiner Config nicht verwendet werden, daher gehe ich davon aus, dass der Server mit der falschen server.conf startet. Jedoch weiß ich jetzt nicht wo ich den entsprechenden Eintrag ändern kann.

Um Hilfe wäre ich sehr dankbar

Gruß Christian
Mitglied: TB-Master
21.02.2009 um 13:12 Uhr
Hallo Christian,

ich weiß nicht welche Distri du verwendest, aber unter gentoo arbeitet das init script mit symlinks.
Also wenn deine Config server.conf heißt müsstest du in /etc/init.d einen symblink mit dem gleichen namen auf /etc/init.d/openvpn anlegen. (ln -s openvpn server). Dann sollte die richtige config verwendet werden. Ansonsten wird versucht die standardconfig openvpn.conf zu verwenden.

Toni
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 7
gelöst Windows Dienst startet Programm nicht bzw. nur im Hintergrund (5)

Frage von Juergen42 zum Thema Windows 7 ...

Netzwerkprotokolle
gelöst OpenVPN selbe config funktioniert an einem Rechner nicht (4)

Frage von PharIT zum Thema Netzwerkprotokolle ...

Ubuntu
Kerio Mailserver Startet nicht (5)

Frage von Patrick2017 zum Thema Ubuntu ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...