Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN- GUI lässt sich nicht per runas- Befehl starten

Frage Microsoft

Mitglied: kingkong

kingkong (Level 2) - Jetzt verbinden

23.08.2008, aktualisiert 22.10.2008, 7633 Aufrufe, 5 Kommentare

Hallo,

ich habe das Problem, dass sich die OpenVPN- GUI 1.03 unter Windows XP Pro SP3 nicht per runas-Befehl starten lässt. Ich habe den Befehl folgendermaßen eingegeben:

01.
 C:\WINDOWS\system32\runas.exe /user:administrator /savecred "C:\Programme\OpenVPN\bin\OpenVPN GUI 1.03.exe" 
Danach werde ich nach dem Passwort gefragt, gebe es richtig ein ... und es passiert gar nichts. Ich habe das Gefühl, das Programm wird kurz ausgeführt, aber dann gleich wieder beendet.
Mit anderen Programmen funktioniert dieser Befehl ausgezeichnet.

Kann es daran liegen, dass die GUI nicht wirklich installiert ist, sondern einfach nur in das Verzeichnis kopiert wurde?



Gruß und Danke im Voraus,
kingkong
Mitglied: HubertN
23.08.2008 um 16:02 Uhr
Warum gehst du das Problem nicht einfach von der anderen Seite an ??!! Wozu das mit erweiterten Rechten überhaupt starten, wenn es auch ohne geht !?

Google lässt da grüßen... Eingabe von "openvpn administrator" liefert gleich als erstes das gewünschte Ergebnis !


Lesen musst Du selber...

Gruß

Hubert
Bitte warten ..
Mitglied: kingkong
23.08.2008 um 16:49 Uhr
Nun gut, ich hatte das gleich wieder verworfen, weil ich dachte, das sei nicht das richtige für mich - aber da du ja sagst, das sei das richtige Ergebnis, musst du mir auch erklären, wie ich dem OpenVPN-Service mitteile, dass er nur eine bestimmte von 4 verschiedenen Verbindungen startet. In der Beschreibung steht ausdrücklich
[...] This service simply starts all configuration files it finds in the OpenVPN\config folder [...].
Ich habe eine VPN-Verbindung zu meinen Eltern, eine in die Arbeit, eine für meine Firewall (IPCop), wenn ich per WLAN rein gehe, und eine, die ich verwende, wenn ich von außen (also über das Internet) zugreife...
Die Verbindungen brauche ich nicht jeden Tag, und die Rechner sind logischerweise auch nicht immer an...

Gruß
kingkong
Bitte warten ..
Mitglied: gutitm
21.10.2008 um 13:49 Uhr
@kingkong

Hast du bis jetzt eine Lösung gefunden? Habe hier das gleiche Problem mehrerer Konfigfiles?

Einzige Lösung bis jetzt für mich OVPN per Softwarelösung runaspc starten. Ist ähnlich wie /savecred, ABER das Passwort wird nur anwendungsbezogen und verschlüsselt gespeichert.

Alle anderen Lösungen:
--> Dienst für eingeschränke Nutzer --> laut Manual nicht mehrere Configfiles möglich, keine Passwörter für Zertifikate möglich
Bitte warten ..
Mitglied: kingkong
21.10.2008 um 20:08 Uhr
Bisher leider nicht... Ich starte die GUI jetzt eben immer per Kontextmenü, aber da muss ich natürlich jedes Mal das Passwort eingeben...
Bitte warten ..
Mitglied: gutitm
22.10.2008 um 09:31 Uhr
Hm...naja, das bedeutet ja, dass du das Adminpasswort benutzt ;)

Wie gesagt...einzige Lösung bis jetzt runasspc
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Cmd Befehle in Powershell GUI aufrufen (5)

Frage von Markus2016 zum Thema Batch & Shell ...

Netzwerkgrundlagen
gelöst Grundsätzliche Fragen zum Thema OpenVPN (Starter) (4)

Frage von JohnWorks zum Thema Netzwerkgrundlagen ...

Windows Netzwerk
OpenVPN als Service funktioniert nicht! (6)

Frage von mike7050 zum Thema Windows Netzwerk ...

Tipps & Tricks
OpenVPN Delegationen

Anleitung von agowa338 zum Thema Tipps & Tricks ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Vmware
VMware ESX - Start einer VM verhindern (18)

Frage von emeriks zum Thema Vmware ...

Rechtliche Fragen
gelöst Geschäftsführer Email gefaked (18)

Frage von xbast1x zum Thema Rechtliche Fragen ...

iOS
IPhone wird ferngesteuert Hacker? (17)

Frage von Akcent zum Thema iOS ...