Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN über die Kommandozeile

Frage Netzwerke Netzwerkprotokolle

Mitglied: Kirus22

Kirus22 (Level 1) - Jetzt verbinden

24.07.2008, aktualisiert 11:43 Uhr, 6361 Aufrufe, 1 Kommentar

Hallo zusammen,

ich möchte gerne OpenVPN über die Kommandozeile aufrufen. Nur leider findet er kein Device? Kann mir da jemand weiterhelfen?


openvpn.exe --remote x.x.x.x --nobind --dev tun --dev-type dt --tls-client --ns-cert-type server --ca ca.crt --cert Test.crt --key Test.key --pull --verb 4 --mute 50 --resolv-retry infinite --float

Hab auch schon --dev Tap, --dev tap0 usw ausprobiert. Nur leider ohne erfolg.

Anbei noch die Logfile:

Thu Jul 24 09:21:51 2008 us=713725 NOTE: --mute triggered...
Thu Jul 24 09:21:51 2008 us=713797 138 variation(s) on previous 50 message(s) suppressed by --mute
Thu Jul 24 09:21:51 2008 us=713954 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct 1 2006
Thu Jul 24 09:21:51 2008 us=714172 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA. OpenVPN
2.0-beta16 and earlier used 5000 as the default port.
Thu Jul 24 09:21:51 2008 us=720078 Control Channel MTU parms [ L:1541 D:138 EF:38 EB:0 ET:0 EL:0 ]
Thu Jul 24 09:21:51 2008 us=721173 Data Channel MTU parms [ L:1541 D:1450 EF:41 EB:4 ET:0 EL:0 ]
Thu Jul 24 09:21:51 2008 us=721259 Local Options String: 'V4,dev-type [unknown-dev-type],link-mtu 1541,tun-mtu 1500,proto UDPv4,cipher BF-CBC,auth SHA
1,keysize 128,key-method 2,tls-client'
Thu Jul 24 09:21:51 2008 us=721394 Expected Remote Options String: 'V4,dev-type [unknown-dev-type],link-mtu 1541,tun-mtu 1500,proto UDPv4,cipher BF-CB
C,auth SHA1,keysize 128,key-method 2,tls-server'
Thu Jul 24 09:21:51 2008 us=721530 Local Options hash (VER=V4): '1462e8e3'
Thu Jul 24 09:21:51 2008 us=721644 Expected Remote Options hash (VER=V4): 'fde5e740'
Thu Jul 24 09:21:51 2008 us=721808 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Jul 24 09:21:51 2008 us=722084 UDPv4 link local: [undef]
Thu Jul 24 09:21:51 2008 us=722150 UDPv4 link remote: 217.x.x.x:1194
Thu Jul 24 09:21:51 2008 us=745167 TLS: Initial packet from 217.x.x.x:1194, sid=9b6a5b91 4c806bbb
Thu Jul 24 09:21:51 2008 us=915027 VERIFY OK: depth=1, /C=DE/ST=GE/L=CE/O=CE/OU=Server-Zertifikat/CN=Server/emailAddress=mail@xx.de
Thu Jul 24 09:21:51 2008 us=915511 VERIFY OK: nsCertType=SERVER
Thu Jul 24 09:21:51 2008 us=915561 VERIFY OK: depth=0, /C=DE/ST=GE/O=CE/OU=Zertifikat-Server/CN=Server1/emailAddress=mail@xxx.de
Thu Jul 24 09:21:52 2008 us=171098 WARNING: 'dev-type' is used inconsistently, local='dev-type [unknown-dev-type]', remote='dev-type tap'
Thu Jul 24 09:21:52 2008 us=171225 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1541', remote='link-mtu 1573'
Thu Jul 24 09:21:52 2008 us=171319 WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'
Thu Jul 24 09:21:52 2008 us=171681 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Thu Jul 24 09:21:52 2008 us=171743 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Jul 24 09:21:52 2008 us=171857 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Thu Jul 24 09:21:52 2008 us=171915 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Jul 24 09:21:52 2008 us=172033 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Thu Jul 24 09:21:52 2008 us=172106 [Server1] Peer Connection Initiated with 217.x.x.x:1194
Thu Jul 24 09:21:53 2008 us=415748 SENT CONTROL [Server1]: 'PUSH_REQUEST' (status=1)
Thu Jul 24 09:21:53 2008 us=439884 PUSH: Received control message: 'PUSH_REPLY,route 217.x.x.0 255.255.255.255,ping 10,ping-restart 60,ifconfig 10
.1.1.2 255.255.255.0'
Thu Jul 24 09:21:53 2008 us=440037 OPTIONS IMPORT: timers and/or timeouts modified
Thu Jul 24 09:21:53 2008 us=440089 OPTIONS IMPORT: --ifconfig/up options modified
Thu Jul 24 09:21:53 2008 us=440150 OPTIONS IMPORT: route options modified
Thu Jul 24 09:21:53 2008 us=440211 'tap' is not a TUN/TAP device. The --ifconfig option works only for TUN/TAP devices.
Thu Jul 24 09:21:53 2008 us=440271 Exiting

Vielleicht hat ja jemand ein Tipp für mich.

Gruß Kirus22
Mitglied: Kirus22
24.07.2008 um 11:43 Uhr
Die Lösung lautet: --dev-type dt weg lassen...

openvpn.exe --remote x.x.x.x --nobind --dev tap --tls-client --ns-cert-type server --ca ca.crt --cert Test.crt --key Test.key --pull --verb 4 --mute 50 --resolv-retry infinite --float

Dann funktioniert es.

Gruß Kirus
Bitte warten ..
Ähnliche Inhalte
Windows Server
Flexlm aus Kommandozeile als Service starten (3)

Frage von rodgerwilco zum Thema Windows Server ...

Sicherheits-Tools
OpenVPN für Standarduser (9)

Frage von geocast zum Thema Sicherheits-Tools ...

Netzwerkgrundlagen
OpenVPN mit IPv6 (2)

Frage von Moddry zum Thema Netzwerkgrundlagen ...

Router & Routing
gelöst OpenVPN pfsense (5)

Frage von sebastian2608 zum Thema Router & Routing ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (21)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (12)

Frage von alemanne21 zum Thema Webentwicklung ...