Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Openvpn Konfiguration Fehler

Frage Microsoft Windows Server

Mitglied: soldier185

soldier185 (Level 1) - Jetzt verbinden

31.12.2012, aktualisiert 01.01.2013, 2830 Aufrufe, 5 Kommentare

Guten Tag,
Ich bin gerade dabei ein Openvpn Server zu mmeinem windows server 2008 aufzusetzen jedoch ist irgend etwas schiefgelaufen laut den logs ist der service am laufen, Jedoch bekomme ich von meinem client nur gelbe bildschirme und das ist mein client log:
Mon Dec 31 17:35:55 2012 OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011
Mon Dec 31 17:35:55 2012 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Mon Dec 31 17:35:55 2012 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Mon Dec 31 17:35:55 2012 LZO compression initialized
Mon Dec 31 17:35:55 2012 Control Channel MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
Mon Dec 31 17:35:55 2012 Socket Buffers: R=[8192->8192] S=[8192->8192]
Mon Dec 31 17:35:55 2012 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
Mon Dec 31 17:35:55 2012 Local Options hash (VER=V4): 'd79ca330'
Mon Dec 31 17:35:55 2012 Expected Remote Options hash (VER=V4): 'f7df56b8'
Mon Dec 31 17:35:55 2012 UDPv4 link local: [undef]
Mon Dec 31 17:35:55 2012 UDPv4 link remote: 134.255.246.161:1194

ich kann auch den server nicht mit der Internen Adresse pingen (192.168.10.1) ich musste eig die 192.168.10.2 bekommen ich weiß nicht warum.
wenn Ihr fragen habt poste gerne weitere logs etc.

gerne poste ich die client config:
  1. Zertifikate
ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\s4hclient.crt"
key "C:\\Program Files\\OpenVPN\\config\\s4hclient.key"

  1. Client-Setup
client
dev tap
proto udp
remote 134.255.246.161 1194 #Hostname anpassen
resolv-retry infinite
nobind
persist-key
persist-tun
route-metric 512
route 0.0.0.0 0.0.0.0
comp-lzo
verb 3

und meine server Config:
  1. Zertifakte
ca "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\ca.crt"
cert "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\space4host.crt"
key "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\space4host.key"
dh "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\dh1024.pem"

  1. Server und Netzwerk
local 134.255.246.161
port 1194
proto udp
dev tap
server 192.168.10.0 255.255.255.0 #Subnetz
ifconfig-pool-persist ipp.txt
comp-lzo
persist-key
persist-tun
keepalive 10 120


  1. Log
status "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn-status.log"
log "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn.log"
log-append "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn.log"
verb 3

meine logs weisen nichts besonders auf dennoch den inhalt:

status Log:
OpenVPN CLIENT LIST
Updated,Tue Jan 01 03:13:19 2013
Common Name,Real Address,Bytes Received,Bytes Sent,Connected Since
ROUTING TABLE
Virtual Address,Common Name,Real Address,Last Ref
GLOBAL STATS
Max bcast/mcast queue length,0
END

server.log:
ist leer


openvpn.log
Tue Jan 01 03:13:09 2013 OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011
Tue Jan 01 03:13:09 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Jan 01 03:13:09 2013 Diffie-Hellman initialized with 1024 bit key
Tue Jan 01 03:13:09 2013 TLS-Auth MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
Tue Jan 01 03:13:09 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Jan 01 03:13:09 2013 TAP-WIN32 device [LAN-Verbindung 2] opened: \\.\Global\{D3AFBB4D-9C02-4C3C-AC4D-3730B86B9BC4}.tap
Tue Jan 01 03:13:09 2013 TAP-Win32 Driver Version 9.9
Tue Jan 01 03:13:09 2013 TAP-Win32 MTU=1500
Tue Jan 01 03:13:09 2013 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.10.1/255.255.255.0 on interface {D3AFBB4D-9C02-4C3C-AC4D-3730B86B9BC4} [DHCP-serv: 192.168.10.0, lease-time: 31536000]
Tue Jan 01 03:13:09 2013 Sleeping for 10 seconds...
Tue Jan 01 03:13:19 2013 Successful ARP Flush on interface [18] {D3AFBB4D-9C02-4C3C-AC4D-3730B86B9BC4}
Tue Jan 01 03:13:19 2013 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
Tue Jan 01 03:13:19 2013 UDPv4 link local (bound): 134.255.246.161:1194
Tue Jan 01 03:13:19 2013 UDPv4 link remote: [undef]
Tue Jan 01 03:13:19 2013 MULTI: multi_init called, r=256 v=256
Tue Jan 01 03:13:19 2013 IFCONFIG POOL: base=192.168.10.2 size=253
Tue Jan 01 03:13:19 2013 IFCONFIG POOL LIST
Tue Jan 01 03:13:19 2013 Initialization Sequence Completed

icch habe verscht mit auth eine Autentifizierungsmethode client und server mit zu geben ohne erfolg.
Mitglied: aqui
31.12.2012, aktualisiert um 17:57 Uhr
Dein VPN Tunnel kommt gar nicht erst zustande weil du in der Konfig Datei vermutlich die Authentisierungsmethode vergessen hast. Sie dir den Log Output an, da steht alles drin !
Ohne aktiven VPN Tunnel natürlich auch nix Ping der Server IP ...logisch, oder ?! ipconfig /all auf dem Client und auch ein route print würde dir sonst ein aktives Tunnel Interface zeigen inklusive IP was bei dir sicher nicht der Fall ist !

Folge diesem Tutorial Schritt für Schritt, das dir die Konfiguration im Detail erklärt:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Es spielt keinen Rolle welche HW Plattform du hast, da die OVPN Konfig immer gleich ist.
Wenns dennoch nicht funktionieren sollte (was wir hier nicht hoffen !) dann musst du deine Server Konfig und auch die Client Konfig Datei mal posten, denn nur mit den spärlichen Infos von oben ist eine zielführende Hilfe nicht möglich !
Bitte warten ..
Mitglied: soldier185
01.01.2013, aktualisiert um 12:54 Uhr
gerne poste ich die client config:

Zertifikate

ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\s4hclient.crt"
key "C:\\Program Files\\OpenVPN\\config\\s4hclient.key"

Client-Setup

client
dev tap
proto udp
remote 134.255.246.161 1194 #Hostname anpassen
resolv-retry infinite
nobind
persist-key
persist-tun
route-metric 512
route 0.0.0.0 0.0.0.0
comp-lzo
verb 3

und meine server Config:

Zertifakte

ca "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\ca.crt"
cert "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\space4host.crt"
key "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\space4host.key"
dh "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\dh1024.pem"

Server und Netzwerk

local 134.255.246.161
port 1194
proto udp
dev tap
server 192.168.10.0 255.255.255.0 #Subnetz
ifconfig-pool-persist ipp.txt
comp-lzo
persist-key
persist-tun
keepalive 10 120


Log

status "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn-status.log"
log "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn.log"
log-append "C:\\Program Files (x86)\\OpenVPN\\log\\openvpn.log"
verb 3

meine logs weisen nichts besonders auf dennoch den inhalt:

status Log:
OpenVPN CLIENT LIST
Updated,Tue Jan 01 03:13:19 2013
Common Name,Real Address,Bytes Received,Bytes Sent,Connected Since
ROUTING TABLE
Virtual Address,Common Name,Real Address,Last Ref
GLOBAL STATS
Max bcast/mcast queue length,0
END

server.log:
ist leer


openvpn.log
Tue Jan 01 03:13:09 2013 OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011
Tue Jan 01 03:13:09 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Jan 01 03:13:09 2013 Diffie-Hellman initialized with 1024 bit key
Tue Jan 01 03:13:09 2013 TLS-Auth MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
Tue Jan 01 03:13:09 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Jan 01 03:13:09 2013 TAP-WIN32 device [LAN-Verbindung 2] opened: \\.\Global\{D3AFBB4D-9C02-4C3C-AC4D-3730B86B9BC4}.tap
Tue Jan 01 03:13:09 2013 TAP-Win32 Driver Version 9.9
Tue Jan 01 03:13:09 2013 TAP-Win32 MTU=1500
Tue Jan 01 03:13:09 2013 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.10.1/255.255.255.0 on interface {D3AFBB4D-9C02-4C3C-AC4D-3730B86B9BC4} [DHCP-serv: 192.168.10.0, lease-time: 31536000]
Tue Jan 01 03:13:09 2013 Sleeping for 10 seconds...
Tue Jan 01 03:13:19 2013 Successful ARP Flush on interface [18] {D3AFBB4D-9C02-4C3C-AC4D-3730B86B9BC4}
Tue Jan 01 03:13:19 2013 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
Tue Jan 01 03:13:19 2013 UDPv4 link local (bound): 134.255.246.161:1194
Tue Jan 01 03:13:19 2013 UDPv4 link remote: [undef]
Tue Jan 01 03:13:19 2013 MULTI: multi_init called, r=256 v=256
Tue Jan 01 03:13:19 2013 IFCONFIG POOL: base=192.168.10.2 size=253
Tue Jan 01 03:13:19 2013 IFCONFIG POOL LIST
Tue Jan 01 03:13:19 2013 Initialization Sequence Completed

ich habe verscht mit auth eine Autentifizierungsmethode client und server mit zu geben ohne erfolg.
muss ich auth wo bestimmtes anbingen?
Bitte warten ..
Mitglied: aqui
01.01.2013, aktualisiert um 15:13 Uhr
In deiner Client Konfig fehlt das Kommando:
remote-cert-tls server
Das löst die obige Fehlermeldung im Client aus. Das solltest du dazukonfigurieren und dann sollte es klappen.
Der Abschnitt ist HIER:
http://openvpn.net/index.php/open-source/documentation/howto.html#mitm
in der OVPN Online Doku genau beschrieben !
Bitte warten ..
Mitglied: soldier185
01.01.2013, aktualisiert um 17:20 Uhr
bekomme jetzt in meinem client log den fehler das er nicht handshaken kann:
Tue Jan 01 16:59:23 2013 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Jan 01 16:59:23 2013 TLS Error: TLS handshake failed und es geht immer noch nicht.
Noch ne idee?
hier noch ma meine client Log:
Tue Jan 01 17:19:00 2013 OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011
Tue Jan 01 17:19:00 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Jan 01 17:19:00 2013 LZO compression initialized
Tue Jan 01 17:19:00 2013 Control Channel MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
Tue Jan 01 17:19:00 2013 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Jan 01 17:19:00 2013 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
Tue Jan 01 17:19:00 2013 Local Options hash (VER=V4): 'd79ca330'
Tue Jan 01 17:19:00 2013 Expected Remote Options hash (VER=V4): 'f7df56b8'
Tue Jan 01 17:19:00 2013 UDPv4 link local: [undef]
Tue Jan 01 17:19:00 2013 UDPv4 link remote: 134.255.246.161:1194
Bitte warten ..
Mitglied: aqui
02.01.2013, aktualisiert um 12:43 Uhr
Its all on the web !!!
Guckst du hier:
http://openvpn.net/index.php/open-source/faq/79-client/253-tls-error-tl ...
Vermutlich also wie immer Lokale Firewall oder NAT Firewall...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
SAN, NAS, DAS
Iomega ix2-200 fehler konfiguration

Frage von Asker06 zum Thema SAN, NAS, DAS ...

Router & Routing
OpenVpn Verbindung Synology NAS hinter Zywall USG 40 (2)

Frage von Tirgel zum Thema Router & Routing ...

Windows Server
Windows Firewall Einstellungen für OpenVPN Tunnel (3)

Frage von Aubanan zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...