Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN läuft, doch ich komme nicht dadrüber ins Internet

Frage Netzwerke Router & Routing

Mitglied: SunDalf

SunDalf (Level 1) - Jetzt verbinden

02.05.2014, aktualisiert 03.05.2014, 2513 Aufrufe, 6 Kommentare

Hallo,

ich habe pfSense version 2.1.2 auf einem Alix 2D13 mit einer 4GB CF Card installiert. PfSense macht über pppoe die Einwahl beim ISP. Dieses funktioniert auch. Nun möchte ich aber via openVPN ins Internet, dafür habe alles haargenau nach dieser Anleitung gemacht: https://forum.pfsense.org/index.php?topic=29944.0

Der Service Status vom openVPN Client ist auch grün, läuft also und die Client Instance Statistics sehen auch gut aus:

Name/Time Remote/Virtual IP
openVPN UDP:1194 80.x.80.x
Fri May 2 18:35:24 2014 46.x.46.x


Das Problem ist bloß, ich gehe weiterhin mit der ISP IP-Adresse ins Internet.

Das Gateway ist wie in der Anleitung eingerichtet

Hat jemand den entscheidenen Tipp?

Viele Grüße
Mario

Update: Nach einem Reboot komme ich nun nur noch online, wenn ich den openVPN Client stoppe. Ist er gestartet, zieht er sich auch eine IP des Anbieters und ein Traceroute mit Source Address 'any' geht auch über den openVPN Tunnel, von einem Rechner im Netzwerk komme ich aber nicht online.
Mitglied: aqui
03.05.2014, aktualisiert um 08:59 Uhr
Das Forumstutorial zu dem Thema hast du gelesen ??
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Dort steht alles haarklein drin wie es richtig zu machen ist !!

Deine Aussage "Nun möchte ich aber via openVPN ins Internet" ist ziemlich verwirrend und auch unsinnig, denn OpenVPN ist keine Technik um "ins Internet" zu kommen wie jeder weiss.
Man kann jetzt mal im freien Fall raten was du meinst oder in unsere berühmte Kristllkugel hier sehen und evtl. daraus schliessen das du mit einem remoten Client von überall her wie z.B. öffentliche Hotspots eine gesicherten VPN Tunnel nach Hause aufbauen willst um über deinen Internet Zugang ins Internet zu gelangen ??
Das entspricht ebenso der oben im Tutorial geschilterten Anleitung allerdings musst du dann das Default Gateway für den Client auf den VPN Tunnel legen so das der gesamte Client Traffic bei aktivem Client in den Tunnel geroutet wird.
Dazu muss das Push Kommando in deine OVPN Konfig Datei auf dem Server lauten:
push "redirect-gateway def1"
(Siehe auch hier: https://openvpn.net/index.php/open-source/documentation/howto.html#redir ... )
Vermutlich wie so oft hier Doku nicht gelesen und das Push Kommando vergessen... ?!

Wie gesagt fraglich ist ob du das mit der komischen Äußerung von oben auch meinst...???
Im Grunde ist das ein simpler Klassiker im VPN Umfeld.
Bitte warten ..
Mitglied: orcape
03.05.2014 um 09:47 Uhr
Hi SunDalf,
ich gehe mal davon aus, das Dich Aqui hier nicht wirklich richtig verstanden hat, Du hast das zwar mit dem Strong-VPN geschrieben, sonst sind Deine Angaben aber leider etwas dürftig und zweideutig.
Um das mal aufzuklären, Strong-VPN ist der Provider den Du Deine Daten anvertrauen willst und der hoffentlich nicht seine Daten an die NSA weiterleitet...
Dieser stellt Dir einen OpenVPN-Server zur Verfügung, über den Du mit einem OpenVPN-Client zugreifen und über diesen ins Internet gelangen willst.
Das Problem ist bloß, ich gehe weiterhin mit der ISP IP-Adresse ins Internet.
Nun ohne Deinen eigentlichen Provider würde es keinen Tunnel geben, logisch das dessen IP irgendwie auftaucht.
Was bei Dir nur nicht funktioniert, ist das Routing und darüber kann sich hier keiner eine Meinung bilden, weil Du dazu einfach viel zu wenig Angaben gemacht hast.
Das es ein reines Routing-Problem ist, bestätigt Dein Update....
Update: Nach einem Reboot komme ich nun nur noch online, wenn ich den openVPN Client stoppe. Ist er gestartet, zieht er sich auch eine IP des
Anbieters und ein Traceroute mit Source Address 'any' geht auch über den openVPN Tunnel, von einem Rechner im Netzwerk komme ich aber nicht
online.
Gruß orcape
Bitte warten ..
Mitglied: SunDalf
03.05.2014 um 15:20 Uhr
Hallo Aqui,
hallo Orcape,

sorry, wenn ich mich ein wenig verwirred oder gar unsinnig ausgedrückt habe. Ja, ein openVPN Anbieter stellt mir ein Server zu Verfügung, welcher aber nicht StrongVPN ist, sondern ein schwedischer Anbieter. Ich habe eben alles nur nach dieser Anleitung konfiguriert.

Natürlich ist mit klar, das ich in erster Linie eine Verbindung zu meinem ISP benötige. Ist diese erstmal zustande gekommen, wird darüber dann die openVPN Verbindung aufgebaut. Diese kann ich auch aufbauen, denn ich sehe in den openVPN Logs auch den Eintrag 'Initialization Sequence Completed' und erhalte, wie oben beschrieben auch eine IP des Anbieters.

Ich denke auch, das ich ein Routing Problem habe, das Push Kommando habe ich aber gesetzt.

Gruss SunDalf
Bitte warten ..
Mitglied: orcape
LÖSUNG 03.05.2014, aktualisiert um 19:26 Uhr
Wie wäre es dann mal mit einer Routingtabelle vom ALIX.
Was hast Du für Firewallregeln für WAN-, LAN- und OpenVPN-Interface erstellt?
Gruß orcape
Bitte warten ..
Mitglied: SunDalf
03.05.2014 um 17:44 Uhr
Hallo orcape,

ich habe es soeben hin bekommen. Es fehlte noch eine Firewallregel auf dem Bridge Interface:

ID Proto Source Port Destination Port Gateway Queue
IPv4 * BRIDGE net * * * * none


Vielen Dank und ein schönes Wochenende
Bitte warten ..
Mitglied: aqui
03.05.2014, aktualisiert um 22:36 Uhr
Ein Bridge Interface gibt es gar nicht in einer OVPN Konfig mit der pfSense....aber egal wenns jetzt rennt ist ja alles gut !
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

Webbrowser
Internet Explorer schliesst direkt bei Start (10)

Frage von gabeBU zum Thema Webbrowser ...

LAN, WAN, Wireless
Basiswissen CiscoVPN: Internet nicht über den Tunnel (5)

Frage von PharIT zum Thema LAN, WAN, Wireless ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (25)

Frage von aschmid zum Thema Router & Routing ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(6)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Windows 10
gelöst Windows 10 Home "Netzlaufwerk nicht bereit" (19)

Frage von Oggy01 zum Thema Windows 10 ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (18)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Exchange Server
Exchange Postfach leeren - nicht löschen (11)

Frage von AndreasOC zum Thema Exchange Server ...