Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

openvpn problem

Frage Sicherheit Firewall

Mitglied: Closed

Closed (Level 1) - Jetzt verbinden

20.12.2006, aktualisiert 11:40 Uhr, 7002 Aufrufe, 2 Kommentare

hallo erstmal. also ich hab so ziemlich alle tuts und auch das openvpn buch durchgelesen, aber hab trotzdem noch ein paar probleme:

also hier erstmal die config dateien

server
[quote]

mode server
tls-server

  1. Port
port 1194

  1. TCP oder UDP?
#proto tcp-server
proto udp


#tls-auth c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ta.key 0


  1. tun oder tap?
  2. Das tun Device erstellt einen IP Tunnel,
  3. während das tap Device einen Ethernet Tunnel erstellt.
#tun or tap device
#tun is an IP tunnel,
#tap an ethernet tunnel
dev tap
dev-node openvpn

#Our Server IP
ifconfig 10.0.0.1 255.255.255.0

#dynamic clients from 10.0.0.2-10.0.0.254
ifconfig-pool 10.0.0.2 10.0.0.254

#Die pakete werden auf dieser größe gekapselt
#tap-mtu 1500
#tap-mtu-extra 32
#fragment 1300
mssfix

#Paths to the certs
ca c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ca.crt
cert c:\\Programme\\OpenVPN\\easy-rsa\\keys\\Server.crt
key c:\\Programme\\OpenVPN\\easy-rsa\\keys\\Server.key
dh c:\\Programme\\OpenVPN\\easy-rsa\\keys\\dh1024.pem

#Tests the connection with a ping like paket. (wait=120sec)
keepalive 10 120

#Authenication
auth SHA1

#Our encryption algorithm
#cipher aes-256-ecb
#openvpn --show-ciphers for testing

#comp
comp-lzo

#Logging
status openvpn-status.log
verb 3
persist-key
persist-tun
[/quote]


Client
[quote]

tls-client
float
dev tap
dev-node openvpn
nobind

#MTU
#tun-mtu 1500
#fragment 1300

#tcp oder udp
proto udp

#Server IP
remote ca.homeftp.org 1194

#force authentication
#WICHTIG: hier den COMMON Name vom Server Zertifikat nehmen!
tls-remote Server
ns-cert-type server

ca c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ca.crt
cert c:\\Programme\\OpenVPN\\easy-rsa\\keys\\client.crt
key c:\\Programme\\OpenVPN\\easy-rsa\\keys\\client.key

#tls-auth c:\\Programme\\OpenVPN\\easy-rsa\\keys\\ta.key 1

auth SHA1
#cipher aes-256-cbc
comp-lzo
resolv-retry infinite


verb 3
persist-key
persist-tun
[/quote]


so nun die log file
[quote]

Tue Dec 19 19:26:50 2006 192.168.2.7:1227 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Dec 19 19:26:50 2006 192.168.2.7:1227 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Tue Dec 19 19:26:50 2006 192.168.2.7:1227 [Client] Peer Connection Initiated with 192.168.2.7:1227
Tue Dec 19 19:26:53 2006 Client/192.168.2.7:1227 MULTI: Learn: 00:ff:4f:92:48:3f -> Client/192.168.2.7:1227
Tue Dec 19 19:26:55 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:06 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:16 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:26 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:36 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
Tue Dec 19 19:27:46 2006 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)
[/quote]


das connection reset by peer verstehe ich nicht. merkwürdig ist halt dass ich das ganze derzeit auf einer virtuellen Maschine teste. es funktioniet auch alles. kann also beide rechner pingen. sowohl vom client aus den client und server. vom server aus auch jeweils client und server.
die monitore im system tray sind grün.

teste ich nun dieselbe config übers inet, so sind die monitore beim client gelb. kann das daran liegen dass ein port nicht korrekt freigeschaltet wurde? das ist das was ich vermute. hab die einstellungen allerdings richtig auf dem router eingestllt. habe auch ma sämtliche firewalls deinstalliert zu testzwecken. kein erfolg.

hatte in einer quelle noch gefunden dass die fehlermeldung eventuell an udp liegen kann. hab das ganze auf txp umgestellt und da erhalte ich dann dass der tcp-handshake fehlschlägt.

bitte helft mir. das kann ja eigentlich nur an der config liegen. was mache ich da falsch? bin für jede anregung und hilfe sehr dankbar. hab dieselbe frage auch schon im openvpn forum gepostet. falls dort eine antwort kommt, werde ich die lösung hier auch reinposten für diejenigen die es interessiert
Mitglied: Andynix
20.12.2006 um 10:34 Uhr
1.) Versuchs mal hiermit (es geht)
http://a-sawicki.de/cms/index.php?option=com_content&task=category& ...
2.) Portweiterleitung am Router auch eingestellt ?
3.) Ich habe schon mir am einen Speedport 700W (Telekom) 2 Stunden den Kopf zerbrochen und nicht geschaft ! (es wurde nicht benötigt und ich habe es sein lassen)
Bitte warten ..
Mitglied: Closed
20.12.2006 um 11:40 Uhr
jo port weiterleitung ist aktiviert. gucke mir die page ma an, aber hab wirklich schon sau viel jetz gelesen. hab auch alles mögliche an configs ausprobiert und die zertifikate auch nochmal neu erstellt. kanne s mir nicht erklären.

hab jetz ma auf tcp umgestellt. merkwürdig ist hier dass der dhcp des openvpnservers anscheinend nciht funktioniert. vergebe ich dem tap device eine netzip klappt es.

das ist alles wirklich sehr sehr merkwürdig

danke aber schonmal
Bitte warten ..
Ähnliche Inhalte
Sicherheits-Tools
OpenVPN für Standarduser (9)

Frage von geocast zum Thema Sicherheits-Tools ...

Netzwerkgrundlagen
OpenVPN mit IPv6 (2)

Frage von Moddry zum Thema Netzwerkgrundlagen ...

Router & Routing
gelöst OpenVPN pfsense (5)

Frage von sebastian2608 zum Thema Router & Routing ...

Tipps & Tricks
OpenVPN Delegationen

Anleitung von agowa338 zum Thema Tipps & Tricks ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (16)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Windows 7
Bluesreens unternehmensweit (15)

Frage von SYS64738 zum Thema Windows 7 ...

Windows 10
Programm Installation bei Win 10 Fehlerhaft (12)

Frage von Keineahnungvonnix zum Thema Windows 10 ...

SAN, NAS, DAS
gelöst Synology DS213j (11)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...