Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN-Problem: Linux zu Win7 geht nicht, Linux zu Linux geht

Frage Microsoft Windows Netzwerk

Mitglied: michaelkrauth

michaelkrauth (Level 1) - Jetzt verbinden

04.04.2014, aktualisiert 17:57 Uhr, 1646 Aufrufe, 3 Kommentare, 1 Danke

Hallo zusammen,

ich habe mal wieder ein OpenVPN-Problem. Da es unter Windows 7/64 Bit auftritt schreibe ich mal im MS-Netzwerkbereich. Bitte verschieben, falls es einen besseren Bereich gibt

Auf einem Debian-Rechner läuft OpenVPN in folgender Konfiguration:
01.
port 1194 
02.
proto udp 
03.
dev tun 
04.
ca ca.crt 
05.
cert server.crt 
06.
key server.key 
07.
dh dh1024.pem 
08.
server 10.8.0.0 255.255.255.0 
09.
ifconfig-pool-persist ip.txt 
10.
client-to-client 
11.
keepalive 10 120 
12.
comp-lzo 
13.
user nobody 
14.
group nogroup 
15.
persist-key 
16.
persist-tun 
17.
status openvpn-status.log 
18.
log openvpn.log 
19.
verb 3 
20.
push "route 192.168.1.0" 
21.
push "route-gateway 192.168.1.1" 
22.
push "dhcp-option DNS 192.168.1.2" 
23.
push "dhcp-option DNS 192.168.1.200" 
24.
push "dhcp-option WINS 192.168.1.2" 
25.
push "dhcp-option DOMAIN <SNIP>.local"
Per iptables-Regel wird der Verkehr vom tun-Device ins lokale Netz (192.168.1.0/255.255.255.0) weitergeleitet.
Verbinde ich mit von einem Linuxrechner habe ich Zugriff auf das VPN-Gateway (auch unter seiner tatsächlichen IP im lokalen Netz) und auf die Rechner dahinter.

Mache ich das Ganze von einem Windowsrechner aus wird zwar der Tunnel aufgebaut, ich bekomme aber kein Default-Gateway zugewiesen und kann auch nicht auf die Rechner zugreifen.

Ich vermute ganz stark ein Konfigurationsproblem unter Windows, sehe aber den Wald vor lauter Bäumen nicht mehr.
Aktuell bin ich bei folgender Konfiguration:
01.
client 
02.
remote <SNIP>.no-ip.org 1194 
03.
pull 
04.
dev tun 
05.
proto udp 
06.
ca buero_ca.crt 
07.
cert mk.crt 
08.
key mk.key 
09.
resolv-retry infinite 
10.
nobind 
11.
persist-key 
12.
persist-tun 
13.
ns-cert-type server 
14.
comp-lzo 
15.
verb 3 
16.
route-method exe 
17.
route-delay 2 
18.
route-metric 1 
19.
redirect-gateway def1
Es kann aber gut sein, daß ich da während des Ausprobierens der verschiedenen Tipps einen noch größeren Bock geschossen habe ...

Die Firewall ist testweise komplett aus, OpenVPN GUI läuft mit Adminrechten und ich weiß jetzt überhaupt nicht mehr, was ich da machen kann. Beide Clients (Windows und Linux) hängen im gleichen Netz, einen Knoten in der Routereinstellung schließe ich deshalb aus.

Könnt Ihr mich erleuchten?

Danke schon mal,

42m
Mitglied: aqui
LÖSUNG 04.04.2014, aktualisiert um 17:57 Uhr
Die Firewall ist vermutlich nicht aus ! Das problem ist das Firewall Profil was Win 7 auf das OVPN Tunnelinterface setzt (tun/tap) das ist immer das öffentliche Profil und damit blockt Win7 den kompletten VPN Traffic.
Um das zu fixen guckst du hier:
http://asktheoracle.com/blog/how-to-make-openvpn-work-with-the-windows- ...
hier
http://social.technet.microsoft.com/Forums/windows/en-US/6f5eb33b-e048- ...
und hier speziell zu Windows:
http://social.technet.microsoft.com/Forums/windows/en-US/b9cd4de4-274e- ...

Letzteres sollte dein Problem sofort lösen !
Die Winblows Firewall ist das was dich zu Fall bringt...
Bitte warten ..
Mitglied: michaelkrauth
04.04.2014, aktualisiert um 18:04 Uhr
Vielen Dank für die Antwort.

Ich habe, vor allem mit W2K3 schon einigen Blödsinn erlebt, was Firewalls angeht, aber in dem Fall bin ich mir ziemlich sicher, daß die aus ist resp. war.

Spassigerweise hat das ausschalten erst mal nichts geholfen, das zurücksetzen auf Standard und dann nochmal ausschalten hat mich allerdings einen Schritt weiter gebracht, ich weiß nur nicht, in welche Richtung :D

[...] Stimme aus dem Off: Es vergehen einige Minuten, in denen unser Held noch einmal in sich geht.

So, Ergänzung: Es ging erst mal nicht weiter, bis ich auf dem Server OpenVPN gestoppt und die ip.txt und die ipp.txt gelöscht habe.

Warum auch immer, jetzt geht es. Wenn es jetzt unter Linux noch klappt mache ich Luftsprünge

Ich sage schon mal artig Danke,

Nachtrag:

Auf dem Server habe ich den ganzen "push route" und "push route-gateway" Kram auskommentiert, das tut der Funktion keinen Abbruch, im Gegenteil, jetzt geht es auch mit Windows (und Linux weiterhin)
Ob es auch daran lag oder alleine am löschen der beiden .txt Files kann ich jetzt nicht sagen, vor dem löschen der Files ging es allerdings nicht.

Wie dem auch sei, es scheint jetzt zu funktionieren, damit belasse ich es so wie es ist.

42m
Bitte warten ..
Mitglied: aqui
05.04.2014, aktualisiert um 17:23 Uhr
Auf dem Server habe ich den ganzen "push route" und "push route-gateway" Kram auskommentiert, das tut der Funktion keinen Abbruch,
Sorry aber das ist völliger Unsinn. Mit dem Push Route Kommando wird das lokale LAN in die Routing Tabelle des Clients propabiert. Ohne das Push Route Kommando würde der VPN Client das lokale LAN nicht kennen !
Wenn du ein route print eingibst (netstat -r bei Linux und OS-X) in der Eingebeaufforderung des Clients kannst du das reproduzierbar sehen.
Diese Aussage ist also technisch falsch außer push route gateway und push dhcp... denn das braucht man wirklich nicht, jedenfalls nicht in einem solchen Banalszenario wie deinem.
Das push route <lokales LAN> also push "route 192.168.1.0 255.255.255.0" bei dir (du hast hier auch einen Fehler in der conf datei da du die Subnetzmaske vergessen hast !) muss aber zwingend drinbleiben.
Das hiesige OVPN Tutorial beschreibt dieses Szenario genau:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Wobei die Plattform hier keinerlei Rolle spielt das die Setup Konfig Dateien von OVPN über alle Hardware identisch ist !
Geh also nochmal in dich und checke deine server.conf Datei oder die client.conf.
Eine ip.txt oder sowas gibt es bei OVPN nicht.
Wenns aber trotzdem geht auch gut....irgendwo ist aber trotzdem ein Fehler !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...