Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN-Server leitet Pakete nicht ins Internet

Frage Microsoft Windows Netzwerk

Mitglied: RT2014

RT2014 (Level 1) - Jetzt verbinden

06.05.2014 um 18:18 Uhr, 3271 Aufrufe, 11 Kommentare

Hallo,

nach tagelangem Probieren und Googlen gebe ich auf und brauche Hilfe. Für Linux habe ich viele Tipps im Internet gefunden... inzwischen vermute ich, dass das, was ich benötige mit "Windows Server" vielleicht sogar gar nicht geht...

Was will ich? Ich habe zwei Windows Server, einen direkt hier vor Ort (Standort 2) und einem im Ausland (Standort 1).

Meine Konfiguration:
Standort 1 (OpenVPN-SERVER): Windows Server 2008 R2
IP-Adresse: 141.XX.XX.11
Gateway: 141.XX.XX.1

Standort 2 (OpenVPN-CLIENT): Windows Server 2003
IP-Adresse: 85.XX.XX.242
Gateway: 85.XX.XX.254

Ich möchte, dass der eingehend Traffic vom OpenVPN-SERVER zum OpenVPN-CLIENT geleitet wird. Umgekehrt soll der abgehende Traffic über das VPN vom CLIENT zu SERVER geschickt werden und von dort weiter in Internet.

Was bereits funktioniert:
Die Verbindung zwischen Server und Client wird hergestellt als TUN-Verbindung. Vom Client aus kann ich den Server mit PING 10.8.0.1 erreichen. Vom Server aus ebenso den Client mit PING 10.8.0.2. Auch Dienste wie SMTP funktionieren über die VPN-Verbindung.

* Problem 1 *
Externe Server im Internet z.B. 8.8.8.8 lassen sich am Client NICHT pingen! Das Client-OpenVPN-Log zeigt an, dass bei PING 8.8.8.8 tatsächlich je Ping ein Datenpaket an der Server geschickt wird und das Server-Log zeigt den Empfang der Ping-Pakete an. Auch Tracert zeigt an, dass die Datenpaket über die VPN-Verbindung laufen.

Ich habe den Eindruck, dass der Server die Daten nicht ins Internet weiterleitet oder die Rückleitung der Antwortpakete zum Client nicht funktioniert. Beim Server habe ich mit REGEDIT "IPEnableRouter" auf "1" geändert! Ich habe viel in Google gesucht, aber keine Lösung gefunden. Unter Linux muss beim Server wohl der Befehl iptables ausgeführt werden. Ich verwende aber Windows. Ich habe außerdem auf den Server (und Client) den Windows-Dienst "Routing und RAS" / bzw. bei engl. Windows "Routing and Remote Access" gestartet, was aber auch keinen Erfolg bringt.

* Problem 2 *
Eingehend Traffic beim OpenVPN-Server kann ich mit dem Befehl:
netsh interface portproxy add v4tov4 listenport=80 listenaddress=141.XX.XX.11 connectport=80 connectaddress=10.8.0.2
an den Client weiterleiten und zurück via OpenVPN-Server ins Internet. Der Client erhält dabei aber nicht die IP-Adresse des Internetsurfers, sondern 10.8.0.1 übermittelt! Kann man das ändern?

Frage: Oder geht das alles nur, wenn ich Server und Client nicht per TUN-VPN sondern TAP-VPN, also per LAN-Bridge verbinde.

Danke für eure Hilfe,
Ralf.


Hier noch die Konfigurationsdateien von OpenVPN:

OpenVPN-Server:
01.
local 141.XX.XX.11 
02.
port 1194 
03.
proto udp 
04.
dev tun 
05.
ca ca.crt 
06.
cert server.crt 
07.
key server.key 
08.
tls-server 
09.
key-method 2 
10.
dh dh1024.pem 
11.
server 10.8.0.0 255.255.255.0 
12.
client-config-dir ccd 
13.
push "redirect-gateway def1 bypass-dhcp bypass-dns" 
14.
push "dhcp-option DNS 8.8.8.8" 
15.
push "route 10.8.0.0 255.255.255.0" 
16.
keepalive 20 120 
17.
comp-lzo 
18.
persist-key 
19.
persist-tun 
20.
verb 3
OpenVPN-Client:
01.
tls-client 
02.
dev tun 
03.
proto udp 
04.
remote 141.XX.XX.11 1194 
05.
resolv-retry infinite 
06.
keepalive 20 60 
07.
nobind 
08.
persist-key 
09.
persist-tun 
10.
comp-lzo 
11.
ca ca.crt 
12.
cert client.crt 
13.
key client.key 
14.
verb 3 
15.
tun-mtu 1500 
16.
pull
Client-CCD-Datei:
01.
ifconfig-push 10.8.0.2 10.8.0.1
Mitglied: aqui
06.05.2014, aktualisiert um 20:44 Uhr
Die Frage bekommen wir wöchentlich hier....
Dein Push Kommando am Server ist falsch ! Wenn du wie von dir gewünscht jeglichen Client Traffic in den Tunnel leiten willst muss das Client Default Gateway auf die Tunnel IP "umgebogen" werden !
Das erledigt das Konfig Kommando:
push "redirect-gateway def1"
Siehe auch: https://openvpn.net/index.php/open-source/documentation/howto.html#redir ...

Frage 2 ist eigentlich obsolet wenn man die Konfig richtig macht. So ein Redirect muss man nicht machen. Grundlagen zur Einrichtung findest du auch hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
HW kannst du ignorieren. Die Einrichtung bei OVPN ist immer gleich und HW unabhängig !
Bitte warten ..
Mitglied: RT2014
07.05.2014 um 14:34 Uhr
Danke für Deine Antwort.

Ich habe den Befehl push "redirect-gateway def1" schon in meiner Server-Konfiguration, d.h. der Client-Traffic wird bereits zum Server geschick! Das "bypass-dhcp bypass-dns" sagt nur, dass die DNS-Auflösung über die Internetverbindung des Clients laufen soll, sonst würde das nämlich gar nicht funktionieren derzeit, weil ja der Server den Traffic des Clients nicht weiter ins Internet leitet.

Zu Frage 2: Doch, so einen Redirekt am Server muss man machen, steht sogar in dem ersten Link von Dir. Unter Linux gibt es dafür den Befehl iptables. Diesen Fehler gibt es aber nicht unter Windows.
Bitte warten ..
Mitglied: aqui
08.05.2014 um 16:48 Uhr
weil ja der Server den Traffic des Clients nicht weiter ins Internet leitet.
Ooops ja das ist dann aber Unsinn, denn kann er ja auch den gesamten Traffic den du in den Tunnel sendest mit dem Default Gateway nicht weiterleiten und damit wird dann dein gesamter Thread hier bzw. die Fragestellung ja komplett blödsinnig ?!
Denn du willst ja genau sämtlichen Traffic über den Tunnel via Server ins Internet routen...was denn also nun ??

2.) Nein, das ist Unsinn mit dem Redirect ? Das machst du ja mit dem Default Gateway was du definierst. Damit sendet der Client alles in den Tunnel zum Server, der wiederum hat ein Default gateway zu seinem Router ins Internet und gut iss...
Wie kommst du auch so einen Unsinn mit dem Redirect ??
Nimm dir ein Traceroute oder Pathping zum Ziel dann kannst du das auch Hop für Hop schwarz auf weiss selber sehen..!
Bitte warten ..
Mitglied: RT2014
08.05.2014 um 20:03 Uhr
Was soll ich sagen, fakt ist, die Verbindung zwischen Server und Client steht, pingen und Dienste wie SMTP/POP3 gehen durch den Tunnel, Traffic ins Internet wird vom Client ebenfalls an den Server geschickt und dort passiert dann damit nichts mehr.

Ich habe inzwischen versucht mit den Windows-RAS-Dienst eine PPTP/L2TP-Verbindung zwischen zwei Windows-Servern aufzubauen. Auch das klappt, ebenso ping und Dienste wie SMTP/POP3, aber auch hier wird kein Client-Traffic vom Server in Internet weitergeleitet. Bei den Windows-RAS-Dienst kann man zumindest NAT-aktivieren, aber es funktioniert einfach nicht.

Seit über 2 Wochen beschäftige ich mich jetzt damit, dies hier ist das 4. Forum wo ich frage, ... tja. Was soll ich noch sagen?
Bitte warten ..
Mitglied: orcape
08.05.2014 um 20:43 Uhr
Hi,
was sagen denn die Routing-Protokolle ?
Wie sehen die Netze aus ? Firewall-Hardware vorgeschaltet ? ...wirst die Server ja wohl kaum direkt am Netz haben.
Allein mit den Config-Dateien kann man wenig dazu beitragen, hier "Licht ins Dunkel" zu bringen.
Gruß orcape
Bitte warten ..
Mitglied: RT2014
09.05.2014 um 20:38 Uhr
Danke für Deine Bemühungen. Hier die Routing-Tabellen, nachdem zwischen Client und Server die OpenVPN-Verbindung aufgebaut wurde. In der Server-Konfiguration haben ich die Zeile push "redirect-gateway def1" eingefügt:

"ipconfig /all" vom Server:
01.
Windows IP Configuration 
02.
 
03.
   Host Name . . . . . . . . . . . . : XXX 
04.
   Primary Dns Suffix  . . . . . . . :  
05.
   Node Type . . . . . . . . . . . . : Hybrid 
06.
   IP Routing Enabled. . . . . . . . : Yes 
07.
   WINS Proxy Enabled. . . . . . . . : No 
08.
 
09.
Ethernet adapter Local Area Connection 2: 
10.
 
11.
   Connection-specific DNS Suffix  . :  
12.
   Description . . . . . . . . . . . : TAP-Windows Adapter V9 
13.
   Physical Address. . . . . . . . . : 00-FF-28-FD-9F-58 
14.
   DHCP Enabled. . . . . . . . . . . : Yes 
15.
   Autoconfiguration Enabled . . . . : Yes 
16.
   Link-local IPv6 Address . . . . . : xxx::xx:xx:xx(Preferred) 
17.
   IPv4 Address. . . . . . . . . . . : 10.8.0.1(Preferred)  
18.
   Subnet Mask . . . . . . . . . . . : 255.255.255.252 
19.
   Lease Obtained. . . . . . . . . . : Freitag, 9. Mai 2014 19:41:55 
20.
   Lease Expires . . . . . . . . . . : Samstag, 9. Mai 2015 19:41:56 
21.
   Default Gateway . . . . . . . . . :  
22.
   DHCP Server . . . . . . . . . . . : 10.8.0.2 
23.
   DHCPv6 IAID . . . . . . . . . . . : 335609640 
24.
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-E1-08-B2-00-15-5D-0B-0B-A0 
25.
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1 
26.
                                       fec0:0:0:ffff::2%1 
27.
                                       fec0:0:0:ffff::3%1 
28.
   NetBIOS over Tcpip. . . . . . . . : Enabled 
29.
 
30.
Ethernet adapter Local Area Connection: 
31.
 
32.
   Connection-specific DNS Suffix  . :  
33.
   Description . . . . . . . . . . . : Microsoft Hyper-V Network Adapter 
34.
   Physical Address. . . . . . . . . : 00-15-5D-0B-0B-A0 
35.
   DHCP Enabled. . . . . . . . . . . : No 
36.
   Autoconfiguration Enabled . . . . : Yes 
37.
   Link-local IPv6 Address . . . . . : xxx::xx:xx:xx(Preferred) 
38.
   IPv4 Address. . . . . . . . . . . : 141.XX.XX.11(Preferred)  
39.
   Subnet Mask . . . . . . . . . . . : 255.255.255.0 
40.
   Default Gateway . . . . . . . . . : 141.XX.XX.1 
41.
   DHCPv6 IAID . . . . . . . . . . . : 234886493 
42.
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-E1-08-B2-00-15-5D-0B-0B-A0 
43.
   DNS Servers . . . . . . . . . . . : 8.8.8.8 
44.
                                       8.8.4.4 
45.
   NetBIOS over Tcpip. . . . . . . . : Enabled 
46.
 
47.
Tunnel adapter isatap.{6B7310B3-7B97-4D8A-B7B5-529A85A2C705}: 
48.
 
49.
   Media State . . . . . . . . . . . : Media disconnected 
50.
   Connection-specific DNS Suffix  . :  
51.
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter 
52.
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 
53.
   DHCP Enabled. . . . . . . . . . . : No 
54.
   Autoconfiguration Enabled . . . . : Yes 
55.
 
56.
Tunnel adapter Teredo Tunneling Pseudo-Interface: 
57.
 
58.
   Connection-specific DNS Suffix  . :  
59.
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface 
60.
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 
61.
   DHCP Enabled. . . . . . . . . . . : No 
62.
   Autoconfiguration Enabled . . . . : Yes 
63.
   IPv6 Address. . . . . . . . . . . : xxx::xx:xx:xx(Preferred) 
64.
   Link-local IPv6 Address . . . . . : xxx::xx:xx:xx(Preferred) 
65.
   Default Gateway . . . . . . . . . :  
66.
   NetBIOS over Tcpip. . . . . . . . : Disabled 
67.
 
68.
Tunnel adapter 6TO4 Adapter: 
69.
 
70.
   Connection-specific DNS Suffix  . :  
71.
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter 
72.
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 
73.
   DHCP Enabled. . . . . . . . . . . : No 
74.
   Autoconfiguration Enabled . . . . : Yes 
75.
   IPv6 Address. . . . . . . . . . . : xxx::xx:xx:xx(Preferred) 
76.
   Default Gateway . . . . . . . . . :  
77.
   DNS Servers . . . . . . . . . . . : 8.8.8.8 
78.
                                       8.8.4.4 
79.
   NetBIOS over Tcpip. . . . . . . . : Disabled 
80.
 
81.
Tunnel adapter isatap.{28FD9F58-5B30-4115-9CA5-C47C7E7FBCF3}: 
82.
 
83.
   Media State . . . . . . . . . . . : Media disconnected 
84.
   Connection-specific DNS Suffix  . :  
85.
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3 
86.
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 
87.
   DHCP Enabled. . . . . . . . . . . : No 
88.
   Autoconfiguration Enabled . . . . : Yes
"route print" vom Server:
01.
IPv4 Route Table 
02.
=========================================================================== 
03.
Active Routes: 
04.
Network Destination        Netmask          Gateway       Interface  Metric 
05.
          0.0.0.0          0.0.0.0      141.XX.XX.1     141.XX.XX.11    261 
06.
         10.8.0.0    255.255.255.0         10.8.0.2         10.8.0.1     30 
07.
         10.8.0.0  255.255.255.252         On-link          10.8.0.1    286 
08.
         10.8.0.1  255.255.255.255         On-link          10.8.0.1    286 
09.
         10.8.0.3  255.255.255.255         On-link          10.8.0.1    286 
10.
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306 
11.
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306 
12.
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306 
13.
      141.XX.XX.0    255.255.255.0         On-link      141.XX.XX.11    261 
14.
     141.XX.XX.11  255.255.255.255         On-link      141.XX.XX.11    261 
15.
    141.XX.XX.255  255.255.255.255         On-link      141.XX.XX.11    261 
16.
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306 
17.
        224.0.0.0        240.0.0.0         On-link      141.XX.XX.11    261 
18.
        224.0.0.0        240.0.0.0         On-link          10.8.0.1    286 
19.
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306 
20.
  255.255.255.255  255.255.255.255         On-link      141.XX.XX.11    261 
21.
  255.255.255.255  255.255.255.255         On-link          10.8.0.1    286 
22.
=========================================================================== 
23.
Persistent Routes: 
24.
  Network Address          Netmask  Gateway Address  Metric 
25.
          0.0.0.0          0.0.0.0      141.XX.XX.1  Default  
26.
===========================================================================
"ipconfig /all" vom Client:
01.
Windows-IP-Konfiguration 
02.
 
03.
   Hostname  . . . . . . . . . . . . : YYYYY 
04.
   Primäres DNS-Suffix . . . . . . . :  
05.
   Knotentyp . . . . . . . . . . . . : Unbekannt 
06.
   IP-Routing aktiviert  . . . . . . : Nein 
07.
   WINS-Proxy aktiviert  . . . . . . : Nein 
08.
 
09.
Ethernet-Adapter LAN-Verbindung: 
10.
 
11.
   Verbindungsspezifisches DNS-Suffix: 
12.
   Beschreibung  . . . . . . . . . . : Intel(R) PRO/1000 MT-Netzwerkverbindung 
13.
   Physikalische Adresse . . . . . . : 00-0C-29-B1-1A-F7 
14.
   DHCP aktiviert  . . . . . . . . . : Nein 
15.
   IP-Adresse. . . . . . . . . . . . : 85.XX.XX.242 
16.
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0 
17.
   IP-Adresse. . . . . . . . . . . . : 10.1.1.242 
18.
   Subnetzmaske  . . . . . . . . . . : 255.0.0.0 
19.
   Standardgateway . . . . . . . . . : 85.XX.XX.254 
20.
   DNS-Server  . . . . . . . . . . . : 212.XX.XX.12 
21.
                                       85.XX.XX.8 
22.
									    
23.
Ethernet-Adapter OpenVPN-Verbindung: 
24.
 
25.
   Verbindungsspezifisches DNS-Suffix:  
26.
   Beschreibung  . . . . . . . . . . : TAP-Windows Adapter V9 
27.
   Physikalische Adresse . . . . . . : 00-FF-FB-A6-B9-4F 
28.
   DHCP aktiviert  . . . . . . . . . : Ja 
29.
   Autokonfiguration aktiviert . . . : Ja 
30.
   IP-Adresse. . . . . . . . . . . . : 10.8.0.2 
31.
   Subnetzmaske  . . . . . . . . . . : 255.255.255.252 
32.
   Standardgateway . . . . . . . . . : 10.8.0.1 
33.
   DHCP-Server . . . . . . . . . . . : 10.8.0.1 
34.
   DNS-Server  . . . . . . . . . . . : 8.8.8.8 
35.
   Lease erhalten  . . . . . . . . . : Freitag, 9. Mai 2014 19:42:12 
36.
   Lease läuft ab  . . . . . . . . . : Samstag, 9. Mai 2015 19:42:12 
"route print" vom Client:
01.
IPv4-Routentabelle 
02.
=========================================================================== 
03.
Schnittstellenliste 
04.
0x1 ........................... MS TCP Loopback interface 
05.
0x2 ...00 0c 29 b1 1a f7 ...... Intel(R) PRO/1000 MT-Netzwerkverbindung - Paketplaner-Miniport 
06.
0x3 ...00 ff fb a6 b9 4f ...... TAP-Windows Adapter V9 - Paketplaner-Miniport 
07.
=========================================================================== 
08.
=========================================================================== 
09.
Aktive Routen: 
10.
     Netzwerkziel    Netzwerkmaske          Gateway    Schnittstelle Metrik 
11.
          0.0.0.0        128.0.0.0         10.8.0.1         10.8.0.2      1 
12.
          0.0.0.0          0.0.0.0     85.XX.XX.254       10.1.1.242     10 
13.
         10.0.0.0        255.0.0.0       10.1.1.242       10.1.1.242     10 
14.
       10.1.1.242  255.255.255.255        127.0.0.1        127.0.0.1     10 
15.
         10.8.0.0  255.255.255.252         10.8.0.2         10.8.0.2     30 
16.
         10.8.0.0    255.255.255.0         10.8.0.1         10.8.0.2      1 
17.
         10.8.0.1  255.255.255.255         10.8.0.2         10.8.0.2      1 
18.
         10.8.0.2  255.255.255.255        127.0.0.1        127.0.0.1     30 
19.
   10.255.255.255  255.255.255.255       10.1.1.242       10.1.1.242     10 
20.
   10.255.255.255  255.255.255.255         10.8.0.2         10.8.0.2     30 
21.
       85.XX.XX.0    255.255.255.0     85.XX.XX.242       10.1.1.242     10 
22.
     85.XX.XX.242  255.255.255.255        127.0.0.1        127.0.0.1     10 
23.
   85.255.255.255  255.255.255.255       10.1.1.242       10.1.1.242     10 
24.
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1 
25.
        128.0.0.0        128.0.0.0         10.8.0.1         10.8.0.2      1 
26.
     141.XX.XX.11  255.255.255.255     85.XX.XX.254       10.1.1.242      1 
27.
        224.0.0.0        240.0.0.0       10.1.1.242       10.1.1.242     10 
28.
        224.0.0.0        240.0.0.0         10.8.0.2         10.8.0.2     30 
29.
  255.255.255.255  255.255.255.255       10.1.1.242       10.1.1.242      1 
30.
  255.255.255.255  255.255.255.255         10.8.0.2         10.8.0.2      1 
31.
Standardgateway:          10.8.0.1 
32.
=========================================================================== 
33.
St„ndige Routen: 
34.
  Keine
Bitte warten ..
Mitglied: aqui
10.05.2014 um 12:07 Uhr
Ein Traceroute oder Pathping wäre nochmal interessant vom Client zu 8.8.8.8 oder www.heise.de z.B.
Da kann man dann mal sehen wo es direkt hakt.

Der server hat scheinbar keine Route ins Internet für das VPN IP Netzwerk.
Das musst du fixen, dann klappt das auch.
Bitte warten ..
Mitglied: RT2014
10.05.2014 um 15:18 Uhr
Hier der pathping 8.8.8.8:

01.
Routenverfolgung zu 8.8.8.8 ber maximal 30 Abschnitte 
02.
 
03.
  0  CLIENT1 [10.8.0.2]  
04.
  1  SERVER1 [10.8.0.1]  
05.
  2     *        *        * 
06.
 
07.
	Berechnung der Statistiken dauert ca. 50 Sekunden... 
08.
            Quelle zum Abs.  Knoten/Verbindung 
09.
Abs. Zeit   Verl./Ges.=   %  Verl./Ges.=   %  Adresse 
10.
  0                                           CLIENT1 [10.8.0.2]  
11.
                                0/ 100 =  0%   | 
12.
  1   76ms     0/ 100 =  0%     0/ 100 =  0%  SERVER1 [10.8.0.1]  
13.
                              100/ 100 =100%   | 
14.
  2  ---     100/ 100 =100%     0/ 100 =  0%  CLIENT1 [0.0.0.0] 
15.
 
16.
Ablaufverfolgung beendet.
Was wohl das "CLIENT1 [0.0.0.0]" an letzter Position heißt. Vermutlich weiß der OpenVPN-Server nicht wohin mit dem Paket!?

Kannst Du mir verraten, wie diese Route am Server heißen soll? Route-Befehl?
(Sorry, nach fast 3 Wochen rumprobieren mit OpenVPN und RAS bin ich am Ende!)
Bitte warten ..
Mitglied: orcape
11.05.2014 um 11:17 Uhr
Hi,
z.B.
route add 10.8.0.0 mask 255.255.255.0 192.168.0.1 metric 2
..wobei hier 192.168.0.1 das Gateway zum Internet wäre.
Das musst Du natürlich entsprechend anpassen.
Gruß orcape
Bitte warten ..
Mitglied: RT2014
11.05.2014 um 20:44 Uhr
Habe die Route am OpenVPN-Server gesetzt (Gateway ist 141.XX.XX.1), ohne Erfolg:

01.
route add 10.8.0.0 mask 255.255.255.0 141.XX.XX.1 metric 2
Ping 8.8.8.8 am OpenVPN-Server geht mit dieser Route (wie vorher), am OpenVPN-Client aber nicht.

Aber sagt diese Anweisung doch nicht nur, dass Paket an das Subnetz 10.8.0.? an das Gateway geschickt werden sollen? Richtig müsste es doch heißen, dass Paket VON DEM Subnetz 10.8.0.? AN das Gateway geschickt werden?
Bitte warten ..
Mitglied: RT2014
12.05.2014 um 20:24 Uhr
Habe nun mit dem "RAS- & Routing-Dienst" herumgespielt. Aber leider ebenfalls erfolglos.

Aufgefallen ist mir, dass der Befehl
01.
pathping -i 10.8.0.2 8.8.8.8

am OpenVPN-Server, der ja eigentlich 10.8.0.1 als IP hat, funktioniert Er funktioniert aber auch mit jeder anderen 10.8.0.x IP!

Es bleibt also bei meinem Eindruck, dass der Windows-Server Pakete die er vom Client 10.8.0.2 per OpenVPN erhält nicht über das Gateway 141.XX.XX.1 weiterleitet oder ggf. nur noch die Antwortpaket zurück. Die Paket müssten also so laufen: 10.8.0.2 -> 10.8.0.1 -> 141.XX.XX.1 -> 8.8.8.8 und zurück.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
gelöst OpenVPN Server - Kein Zugriff auf Server LAN (2)

Frage von PeterH96 zum Thema Router & Routing ...

Netzwerkgrundlagen
OpenVPN-Server über br0 ins Netzwerk routen klappt nicht (7)

Frage von Aileron zum Thema Netzwerkgrundlagen ...

Router & Routing
Routing Windows OpenVPN Server mit Teltonika RUT500 als Client (1)

Frage von ahenngee zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...