Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

OpenVPN trägt falsches Gateway ein!?

Frage Netzwerke

Mitglied: a-Lele

a-Lele (Level 1) - Jetzt verbinden

10.02.2011, aktualisiert 18.10.2012, 5617 Aufrufe, 2 Kommentare

Hallo Leute, habe mich mal mit VPN (Windowsbasis) befasst und habe da ein Problem.

Ich habe laut dieser zwei Anleitungen alles konfiguriert:
http://www.administrator.de/OpenVPN_-_Teil_1_-_Installation%2C_Konfigur ...
http://www.administrator.de/OpenVPN_-_Teil_2_-_OpenVPN_Konfiguration.ht ...

Im grunde funktioniert auch die Verbindung.
- Zertifikate werden erkannt und akzeptiert
- Verbindung wird aufgebaut und Client<->Server erreichen sich.
Das ist meine Server config:
01.
server 10.0.0.0 255.255.255.0 
02.
port 1194 
03.
proto udp 
04.
dev tun 
05.
dh C:\\OpenVPN\\server-keys\\dh1024.pem 
06.
ca C:\\OpenVPN\\server-keys\\ca.crt 
07.
cert C:\\OpenVPN\\server-keys\\butterbrot.crt 
08.
key C:\\OpenVPN\\server-keys\\butterbrot.key 
09.
ifconfig-pool-persist ipp.txt 
10.
push "route 192.168.178.0 255.255.255.0" 
11.
push "redirect-gateway" 
12.
push "DISABLE-NBT" 
13.
push "dhcp-option DNS 192.168.178.1" 
14.
push "dhcp-option WINS 192.168.178.1" 
15.
keepalive 15 60 
16.
persist-key 
17.
persist-tun 
18.
verb 4 
19.
mute 15
und das Client:
01.
client 
02.
port 1194 
03.
proto udp 
04.
dev tun 
05.
ca ca.crt 
06.
cert client1.crt 
07.
key client1.key 
08.
remote "--IP--" 
09.
resolv-retry infinite 
10.
nobind 
11.
persist-key 
12.
persist-tun 
13.
mute-replay-warnings 
14.
verb 3 
15.
mute 20
Der Server kriegt immer die 10.0.0.1 in der log steht:
Notified TAP-Win32 driver to set a DHCP IP/netmask of 10.0.0.1/255.255.255.252 on interface {B858955C-0683-40EB-B1C8-A185BBF085EF} [DHCP-serv: 10.0.0.2, lease-time: 31536000]

Das würde mich ja net stören wenn er beim Client auch die 10.0.0.1 als default Gateway bzw. als Gateway für die Route eintragen würde.
Dort trägt er aber 10.0.0.5 ein, diese gibt es garnicht...

Den Server erreiche ich unter 10.0.0.1 und der client wird unter 10.0.06 auch erreicht.
Nur wieso tuaucht da aufeinmal die 10.0.0.5 auf?

Habe allg auch mal ein ipconfig-pool eingesetzt drauf wurde auch net reagiert.
Frage mich e wieso der Client ausgerechnet die 6 bekommt und net die 2?

Die Grundfrage lautet wieso er auf 10.0.0.5 kommt und wie ich diese evt. dem Server geben kann?

Bin ratlos habe zahlreiche TUTs druchgelesen aber immer das gleiche Problem.

bin für jeden Tipp dankbar.

EDIT: Hier noch ein Bild von der Übersicht:
Links vor der VPN verbindung / rechts danach.
http://imageupload.org/?di=8129734118510

gruß
Mitglied: aqui
10.02.2011, aktualisiert 18.10.2012
OpenVPN benutzt zwischen dem Server und den Client P2P Verbindungen mit einer Hostroute. Vedes "Pärchen" bekommt also immer eine individuelle 2er Kombination. Das ist auch bei anderen Protokollen wie z.B. PPTP so üblich und steht auch en Detail so in den OpenVPN Dokumenten beschrieben. Ist also absolut normal und "works as designed" !
Hier wird auch nochmal drauf eingegangen:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Bitte warten ..
Mitglied: a-Lele
10.02.2011 um 15:54 Uhr
Hab nach bissel suche herausgefunden was der Unterschied zwischen
dev tun
und
dev tap
ist..
und das war das Problem.. ;)

http://de.wikipedia.org/wiki/TUN/TAP
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
OpenVPN Client einen Gateway zuweisen (5)

Frage von pinnacle zum Thema Router & Routing ...

Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

UMTS, EDGE & GPRS
PC als Gateway mit zentralem Internetanschluss via Mobilfunk (6)

Frage von donnyS73lb zum Thema UMTS, EDGE & GPRS ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...